seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/12/06, 21:08:05


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: gcc-update  (Read 6844 times)

0 Members and 1 Guest are viewing this topic.

Offline agaida

  • User
  • Posts: 1.760
    • http://g-com.eu
gcc-update
« on: 2012/09/20, 23:20:18 »
For all multiarch-users: there is a new version of gcc partly in sid. Wait till tomorrow.
There's this special biologist word we use for "stable". It's "dead". ~ Jack Cohen

Offline agaida

  • User
  • Posts: 1.760
    • http://g-com.eu
gcc-update
« Reply #1 on: 2012/09/21, 10:23:02 »
Missing packages are now in sid.
There's this special biologist word we use for "stable". It's "dead". ~ Jack Cohen

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.931
    • Land of the Buckeye
RE: gcc-update
« Reply #2 on: 2012/09/21, 15:11:54 »
Well ... most of them, apparently.

Code: [Select]
root@imerabox:/home/don# dpkg --configure -a
dpkg: error processing gcc-4.7-base:amd64 (--configure):
 package gcc-4.7-base:amd64 4.7.2-1 cannot be configured because gcc-4.7-base:i386 is at a different version (4.7.1-9)
Errors were encountered while processing:
 gcc-4.7-base:amd64
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.723
  • we are the priests ... of the temples of syrinx
RE: gcc-update
« Reply #3 on: 2012/09/21, 18:14:45 »
Maybe later today or tomorrow
Code: [Select]
The following packages have unmet dependencies:
 cpp-4.7 : Depends: gcc-4.7-base (= 4.7.1-9) but 4.7.2-1 is installed
 g++-4.7 : Depends: gcc-4.7-base (= 4.7.1-9) but 4.7.2-1 is installed
 g++-4.7-multilib : Depends: gcc-4.7-base (= 4.7.1-9) but 4.7.2-1 is installed
 gcc-4.7 : Depends: gcc-4.7-base (= 4.7.1-9) but 4.7.2-1 is installed
 gcc-4.7-base : Breaks: gcc-4.7-base:i386 (!= 4.7.2-1) but 4.7.1-9 is installed
 gcc-4.7-base:i386 : Breaks: gcc-4.7-base (!= 4.7.1-9) but 4.7.2-1 is installed
 gcc-4.7-multilib : Depends: gcc-4.7-base (= 4.7.1-9) but 4.7.2-1 is installed
 lib32gcc1 : Depends: gcc-4.7-base (= 4.7.1-9) but 4.7.2-1 is installed
 lib32gomp1 : Depends: gcc-4.7-base (= 4.7.1-9) but 4.7.2-1 is installed
 lib32itm1 : Depends: gcc-4.7-base (= 4.7.1-9) but 4.7.2-1 is installed
 lib32quadmath0 : Depends: gcc-4.7-base (= 4.7.1-9) but 4.7.2-1 is installed
 lib32stdc++6 : Depends: gcc-4.7-base (= 4.7.1-9) but 4.7.2-1 is installed
 libgcc1 : Depends: gcc-4.7-base (= 4.7.1-9) but 4.7.2-1 is installed
 libgfortran3 : Depends: gcc-4.7-base (= 4.7.1-9) but 4.7.2-1 is installed
 libgomp1 : Depends: gcc-4.7-base (= 4.7.1-9) but 4.7.2-1 is installed
 libitm1 : Depends: gcc-4.7-base (= 4.7.1-9) but 4.7.2-1 is installed
 libquadmath0 : Depends: gcc-4.7-base (= 4.7.1-9) but 4.7.2-1 is installed
 libstdc++6 : Depends: gcc-4.7-base (= 4.7.1-9) but 4.7.2-1 is installed
 libstdc++6-4.7-dev : Depends: gcc-4.7-base (= 4.7.1-9) but 4.7.2-1 is installed
I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.931
    • Land of the Buckeye
RE: gcc-update
« Reply #4 on: 2012/09/21, 19:35:42 »
I am trying hard to love multiarch -- I am sure when we look back from 3 years in the future, it will seem like a great transition ....

No googleearth for Nvidia driver users yet, either.  :(
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline agaida

  • User
  • Posts: 1.760
    • http://g-com.eu
RE: gcc-update
« Reply #5 on: 2012/09/21, 20:11:11 »
Before i wrote, that the missing packages are in sid, a update work for me™.
Quote

[Donnerstag, 20. September 2012] [23:10:09] <agaida> und Vorsicht, doko versucht grade wieder mit einem gcc-Update alle multiarch-Installationen weltweit in Schutt und Trümmer zu legen.
[Donnerstag, 20. September 2012] [23:10:43] <devil> der weiss halt wie man spass hat


Google translator: and caution, doko just trying again with a gcc update multiarch put all installations around the world to rubble and debris.

:twisted:
There's this special biologist word we use for "stable". It's "dead". ~ Jack Cohen

Offline agaida

  • User
  • Posts: 1.760
    • http://g-com.eu
RE: gcc-update
« Reply #6 on: 2012/09/21, 20:39:16 »
dibl: ups. ;)

the needed packages should be in sid now. But now there is another problem.

Long version: http://pastebin.com/kqnqpeGF

Short version: d-u and run into an error about some changelog. delete this file. start d-u again :twisted:

Code: [Select]

Errors were encountered while processing:
 /var/cache/apt/archives/gcc-4.7-base_4.7.2-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
~$
~$ # get rid of the changelog
~$
~$ sudo rm /usr/share/doc/gcc-4.7-base/changelog.Debian.gz
~$
~$ # try it again
There's this special biologist word we use for "stable". It's "dead". ~ Jack Cohen

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.931
    • Land of the Buckeye
RE: gcc-update
« Reply #7 on: 2012/09/21, 21:34:06 »
Here, it looks like piper's output, then if I try it with -f, I see this:

Code: [Select]
E: Unmet dependencies. Try using -f.
root@imerabox:/home/don# apt-get -f install
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  cpp-4.7 g++-4.7 gcc-4.7 gcc-4.7-base:i386 lib32gcc1 lib32stdc++6 libgcc1 libgcc1:i386 libgfortran3 libgomp1 libitm1 libquadmath0
  libstdc++6 libstdc++6:i386 libstdc++6-4.7-dev
Suggested packages:
  gcc-4.7-locales g++-4.7-multilib gcc-4.7-doc libstdc++6-4.7-dbg gcc-4.7-multilib libmudflap0-4.7-dev libgcc1-dbg libgomp1-dbg
  libitm1-dbg libquadmath0-dbg libmudflap0-dbg binutils-gold libstdc++6-4.7-doc
The following packages will be upgraded:
  cpp-4.7 g++-4.7 gcc-4.7 gcc-4.7-base:i386 lib32gcc1 lib32stdc++6 libgcc1 libgcc1:i386 libgfortran3 libgomp1 libitm1 libquadmath0
  libstdc++6 libstdc++6:i386 libstdc++6-4.7-dev
15 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.
1 not fully installed or removed.
Need to get 0 B/25.2 MB of archives.
After this operation, 115 kB disk space will be freed.
Do you want to continue [Y/n]?
Retrieving bug reports... Done
Parsing Found/Fixed information... Done
serious bugs of gcc-4.7-base (4.7.1-9 -> 4.7.2-1) <marked>
 #688330 - gcc-4.7-base: WTF are you doing to the binary packages? (Fixed: gcc-4.7/4.7.2-2)
   Merged with: 688277 688278
Summary:
 gcc-4.7-base(1 bug)
Are you sure you want to install/upgrade the above packages? [Y/n/?/...]
Reading changelogs... Done
dpkg: warning: files list file for package 'openssh-blacklist' missing; assuming package has no files currently installed
(Reading database ... 236136 files and directories currently installed.)
Preparing to replace gcc-4.7-base:i386 4.7.1-9 (using .../gcc-4.7-base_4.7.2-1_i386.deb) ...
Unpacking replacement gcc-4.7-base:i386 ...
dpkg: error processing /var/cache/apt/archives/gcc-4.7-base_4.7.2-1_i386.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/gcc-4.7-base/changelog.Debian.gz', which is different from other instances of package gcc-4.7-base:i386
Errors were encountered while processing:
 /var/cache/apt/archives/gcc-4.7-base_4.7.2-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


I guess I'll wait some more.
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline agaida

  • User
  • Posts: 1.760
    • http://g-com.eu
gcc-update
« Reply #8 on: 2012/09/21, 22:23:18 »
look at those lines in your post:

Code: [Select]
1_i386.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/gcc-4.7-base/changelog.Debian.gz', which is different from other instances of


look at my post above: There is your solution! :twisted:
There's this special biologist word we use for "stable". It's "dead". ~ Jack Cohen

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.931
    • Land of the Buckeye
gcc-update
« Reply #9 on: 2012/09/21, 22:29:59 »
Aha!  I was too dense to see that line among all the noise.  Yes, the d-u completed after I removed the offender file.

Vielen dank, agaida!
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline agaida

  • User
  • Posts: 1.760
    • http://g-com.eu
gcc-update
« Reply #10 on: 2012/09/21, 22:43:27 »
There's this special biologist word we use for "stable". It's "dead". ~ Jack Cohen

Offline agaida

  • User
  • Posts: 1.760
    • http://g-com.eu
gcc-update
« Reply #11 on: 2012/09/21, 23:20:39 »
There's this special biologist word we use for "stable". It's "dead". ~ Jack Cohen

Offline agaida

  • User
  • Posts: 1.760
    • http://g-com.eu
gcc-update
« Reply #12 on: 2012/09/22, 02:47:38 »
As expected, please wait few hours again, the i386 part is in incoming ;) :

Code: [Select]

~$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  bcompare freeglut3:i386 gcc-4.7-base:i386 ia32-libs ia32-libs-i386:i386
  lesstif2:i386 libacl1:i386 libasound2:i386 libasyncns0:i386 libattr1:i386
  libaudio2:i386 libaudiofile1:i386 libavahi-client3:i386 libavahi-common3:i386
  libbsd0:i386 libc6:i386 libcaca0:i386 libcap2:i386 libcomerr2:i386 libcups2:i386
  libcurl3:i386 libdb5.1:i386 libdbus-1-3:i386 libdirectfb-1.2-9:i386
  libdrm-intel1:i386 libdrm-nouveau1a:i386 libdrm-radeon1:i386 libdrm2:i386
  libedit2:i386 libesd0:i386 libexif12:i386 libexpat1:i386 libffi5:i386
  libflac8:i386 libfltk1.1:i386 libfontconfig1:i386 libfreetype6:i386 libgcc1:i386
  libgcrypt11:i386 libgd2-xpm:i386 libgdbm3:i386 libgl1-mesa-dri:i386
  libgl1-mesa-glx:i386 libglapi-mesa:i386 libglu1-mesa:i386 libgnutls26:i386
  libgpg-error0:i386 libgphoto2-2:i386 libgphoto2-port0:i386 libgssapi-krb5-2:i386
  libice6:i386 libidn11:i386 libieee1284-3:i386 libjack0:i386 libjbig0:i386
  libjpeg62:i386 libjpeg8:i386 libjson0:i386 libk5crypto3:i386 libkeyutils1:i386
  libkrb5-3:i386 libkrb5support0:i386 liblcms1:i386 libldap-2.4-2:i386 libltdl7:i386
  liblzma5:i386 liblzo2-2:i386 libmpg123-0:i386 libncursesw5:i386 libnspr4:i386
  libnspr4-0d:i386 libnss-ldap:i386 libnss3:i386 libnss3-1d:i386 libodbc1:i386
  libogg0:i386 libopenal1:i386 libp11-kit0:i386 libpam-ldap:i386 libpam0g:i386
  libpciaccess0:i386 libpng12-0:i386 libpopt0:i386 libpulse0:i386 librtmp0:i386
  libsamplerate0:i386 libsane:i386 libsasl2-2:i386 libsdl1.2debian:i386
  libselinux1:i386 libsigc++-2.0-0c2a:i386 libslang2:i386 libsm6:i386
  libsndfile1:i386 libsqlite3-0:i386 libssh2-1:i386 libssl1.0.0:i386 libstdc++5:i386
  libstdc++6:i386 libsvga1:i386 libsysfs2:i386 libtasn1-3:i386 libtdb1:i386
  libtiff4:i386 libtinfo5:i386 libts-0.0-0:i386 libusb-0.1-4:i386 libuuid1:i386
  libv4l-0:i386 libv4lconvert0:i386 libvorbis0a:i386 libvorbisenc2:i386
  libvorbisfile3:i386 libwrap0:i386 libx11-6:i386 libx11-xcb1:i386 libx86-1:i386
  libxau6:i386 libxaw7:i386 libxcb-glx0:i386 libxcb-render-util0:i386
  libxcb-render0:i386 libxcb1:i386 libxcomposite1:i386 libxcursor1:i386
  libxdamage1:i386 libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxft2:i386
  libxi6:i386 libxinerama1:i386 libxml2:i386 libxmu6:i386 libxmuu1:i386 libxp6:i386
  libxpm4:i386 libxrandr2:i386 libxrender1:i386 libxslt1.1:i386 libxss1:i386
  libxt6:i386 libxtst6:i386 libxv1:i386 libxxf86vm1:i386 odbcinst1debian2:i386
  teamviewer7 xaw3dg:i386 zlib1g:i386
The following packages will be upgraded:
  cpp-4.7 fuse fuse-utils g++-4.7 g++-4.7-multilib gcc-4.7 gcc-4.7-base
  gcc-4.7-multilib gir1.2-gtk-3.0 lib32gcc1 lib32gomp1 lib32itm1 lib32quadmath0
  lib32stdc++6 libfuse-dev libfuse2 libgail-3-0 libgcc1 libgfortran3 libgomp1
  libgtk-3-0 libgtk-3-common libgtk-3-dev libitm1 libquadmath0 libstdc++6
  libstdc++6-4.7-dev ntfs-3g xkb-data
29 upgraded, 0 newly installed, 149 to remove and 0 not upgraded.
Need to get 35.8 MB of archives.
After this operation, 288 MB disk space will be freed.
Do you want to continue [Y/n]? n
Abort.
There's this special biologist word we use for "stable". It's "dead". ~ Jack Cohen

Offline agaida

  • User
  • Posts: 1.760
    • http://g-com.eu
gcc-update
« Reply #13 on: 2012/09/22, 12:01:24 »
i386 is in sid.
There's this special biologist word we use for "stable". It's "dead". ~ Jack Cohen

Offline DeepDayze

  • User
  • Posts: 409
gcc-update
« Reply #14 on: 2012/09/22, 16:03:00 »
So don't you all just love multi-arch? :D