seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/10/21, 07:48:19


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: dictionaries-common aspell broken  (Read 3160 times)

0 Members and 1 Guest are viewing this topic.

Offline anticapitalista

  • User
  • Posts: 11
    • http://antix.mepis.org/
dictionaries-common aspell broken
« on: 2013/06/07, 00:41:59 »
Hi there.

I'm not running siduction, but antiX sid and hope you good folks can help out.
Code: [Select]

apt-get install poedit
Reading package lists... Done
Building dependency tree      
Reading state information... Done
The following extra packages will be installed:
  aspell aspell-en dictionaries-common libdb5.1++ libenchant1c2a libgtkspell0
  libwxbase2.8-0 libwxgtk2.8-0
Suggested packages:
  aspell-doc spellutils ispell jed-extra libenchant-voikko
  libgnomeprintui2.2-0
Recommended packages:
  enchant
The following NEW packages will be installed:
  aspell aspell-en dictionaries-common libdb5.1++ libenchant1c2a libgtkspell0
  libwxbase2.8-0 libwxgtk2.8-0 poedit
0 upgraded, 9 newly installed, 0 to remove and 0 not upgraded.
Need to get 6,793 kB of archives.
After this operation, 21.1 MB of additional disk space will be used.
Do you want to continue [Y/n]?
Get:1 http://ftp.gr.debian.org/debian/ unstable/main libdb5.1++ amd64 5.1.29-5 [757 kB]
Get:2 http://ftp.gr.debian.org/debian/ unstable/main dictionaries-common all 1.20.1 [305 kB]
Get:3 http://ftp.gr.debian.org/debian/ unstable/main aspell amd64 0.60.7~20110707-1 [362 kB]
Get:4 http://ftp.gr.debian.org/debian/ unstable/main aspell-en all 7.1-0-1 [268 kB]                                                                          
Get:5 http://ftp.gr.debian.org/debian/ unstable/main libenchant1c2a amd64 1.6.0-10 [87.8 kB]                                                18.9 kB/s 4min 39s
Get:6 http://ftp.gr.debian.org/debian/ unstable/main libwxbase2.8-0 amd64 2.8.12.1-12 [678 kB]
Get:7 http://ftp.gr.debian.org/debian/ unstable/main libwxgtk2.8-0 amd64 2.8.12.1-12 [3,411 kB]
Get:8 http://ftp.gr.debian.org/debian/ unstable/main libgtkspell0 amd64 2.0.16-1 [28.9 kB]
Get:9 http://ftp.gr.debian.org/debian/ unstable/main poedit amd64 1.5.4-1 [895 kB]
Fetched 6,793 kB in 2min 21s (47.9 kB/s)                                      
Preconfiguring packages ...
Selecting previously unselected package libdb5.1++:amd64.
(Reading database ... 211763 files and directories currently installed.)
Unpacking libdb5.1++:amd64 (from .../libdb5.1++_5.1.29-5_amd64.deb) ...
Selecting previously unselected package dictionaries-common.
Unpacking dictionaries-common (from .../dictionaries-common_1.20.1_all.deb) ...
Adding 'diversion of /usr/share/dict/words to /usr/share/dict/words.pre-dictionaries-common by dictionaries-common'
Selecting previously unselected package aspell.
Unpacking aspell (from .../aspell_0.60.7~20110707-1_amd64.deb) ...
Selecting previously unselected package aspell-en.
Unpacking aspell-en (from .../aspell-en_7.1-0-1_all.deb) ...
Selecting previously unselected package libenchant1c2a:amd64.
Unpacking libenchant1c2a:amd64 (from .../libenchant1c2a_1.6.0-10_amd64.deb) ...
Selecting previously unselected package libwxbase2.8-0:amd64.
Unpacking libwxbase2.8-0:amd64 (from .../libwxbase2.8-0_2.8.12.1-12_amd64.deb) ...
Selecting previously unselected package libwxgtk2.8-0:amd64.
Unpacking libwxgtk2.8-0:amd64 (from .../libwxgtk2.8-0_2.8.12.1-12_amd64.deb) ...
Selecting previously unselected package libgtkspell0.
Unpacking libgtkspell0 (from .../libgtkspell0_2.0.16-1_amd64.deb) ...
Selecting previously unselected package poedit.
Unpacking poedit (from .../poedit_1.5.4-1_amd64.deb) ...
Processing triggers for man-db ...
Processing triggers for desktop-file-utils ...
Processing triggers for mime-support ...
Processing triggers for menu ...
Processing triggers for hicolor-icon-theme ...
Setting up libdb5.1++:amd64 (5.1.29-5) ...
Setting up dictionaries-common (1.20.1) ...
Can't locate Text/Iconv.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.14.2 /usr/local/share/perl/5.14.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.14 /usr/share/perl/5.14 /usr/local/lib/site_perl .) at /usr/share/perl5/Debian/DictionariesCommon.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl5/Debian/DictionariesCommon.pm line 7.
Compilation failed in require at /usr/sbin/update-dictcommon-aspell line 4.
BEGIN failed--compilation aborted at /usr/sbin/update-dictcommon-aspell line 4.
dpkg: error processing dictionaries-common (--configure):
 subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of aspell:
 aspell depends on dictionaries-common (>> 0.40); however:
  Package dictionaries-common is not configured yet.

dpkg: error processing aspell (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of aspell-en:
 aspell-en depends on aspell (>= 0.60.3-2); however:
  Package aspell is not configured yet.
 aspell-en depends on dictionaries-common (>= 0.49.2); however:
  Package dictionaries-common is not configured yet.

dpkg: error processing aspell-en (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libenchant1c2a:amd64:
 libenchant1c2a:amd64 depends on aspell-en | myspell-dictionary | aspell-dictionary | ispell-dictionary | hunspell-dictionary; however:
  Package aspell-en is not configured yet.
  Package myspell-dictionary is not installed.
  Package aspell-dictionary is not installed.
  Package aspell-en which provides aspell-dictionary is not configured yet.
  Package ispell-dictionary is not installed.
  Package hunspell-dictionary is not installed.

dpkg: error processing libenchant1c2a:amd64 (--configure):
 dependency problems - leaving unconfigured
Setting up libwxbase2.8-0:amd64 (2.8.12.1-12) ...
Setting up libwxgtk2.8-0:amd64 (2.8.12.1-12) ...
dpkg: dependency problems prevent configuration of libgtkspell0:
 libgtkspell0 depends on libenchant1c2a (>= 1.4.2); however:
  Package libenchant1c2a:amd64 is not configured yet.

dpkg: error processing libgtkspell0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of poedit:
 poedit depends on libgtkspell0 (>= 2.0.10); however:
  Package libgtkspell0 is not configured yet.

dpkg: error processing poedit (--configure):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin ...
Errors were encountered while processing:
 dictionaries-common
 aspell
 aspell-en
 libenchant1c2a:amd64
 libgtkspell0
 poedit
E: Sub-process /usr/bin/dpkg returned an error code (1)


Thanks for any info/help

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.922
    • Land of the Buckeye
RE: dictionaries-common aspell broken
« Reply #1 on: 2013/06/07, 01:31:22 »
Hmmmmmm.

Code: [Select]
root@imerabox:/# apt-get -s install poedit
Reading package lists... Done
Building dependency tree      
Reading state information... Done
The following extra packages will be installed:
  libdb5.1++ libgtkspell0
The following NEW packages will be installed:
  libdb5.1++ libgtkspell0 poedit
0 upgraded, 3 newly installed, 0 to remove and 31 not upgraded.
Inst libdb5.1++ (5.1.29-5 Debian:unstable [amd64])
Inst libgtkspell0 (2.0.16-1 Debian:unstable [amd64])
Inst poedit (1.5.4-1 Debian:unstable [amd64])
Conf libdb5.1++ (5.1.29-5 Debian:unstable [amd64])
Conf libgtkspell0 (2.0.16-1 Debian:unstable [amd64])
Conf poedit (1.5.4-1 Debian:unstable [amd64])


I have the following repos enabled:

- debian sid
- siduction
- siduction kdenext
- deb-multimedia

That is all.  So I would suppose it is a difference between what is in your repos.
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline DeepDayze

  • User
  • Posts: 409
RE: dictionaries-common aspell broken
« Reply #2 on: 2013/06/07, 01:39:23 »
What version of Perl and where did you get it from?

Try installing the missing Perl module via CPAN as I am not sure if this Perl module is in a separate package...perhaps someone knowledgeable can chime in.

Found this on another forum hopefully this might be a good dirty workaround.

As root:
Quote
Code: [Select]

# cpan
Terminal does not support AddHistory.

cpan shell -- CPAN exploration and modules installation (v1.7601)
ReadLine support available (try 'install Bundle::CPAN')

cpan> install Text::Iconv


....

You'll have to run through manual configuration of CPAN if you've never used it before, but that only takes a minute or two; it's easy. You can hit enter on pretty much any prompt you dont know the answer to (except when choosing the download server list). I suggest choosing "follow" instead of "ask" when deciding how to handle prerequisites.


As for AntiX, I have M11 installed on an older laptop and its quite nice.

Offline anticapitalista

  • User
  • Posts: 11
    • http://antix.mepis.org/
RE: dictionaries-common aspell broken
« Reply #3 on: 2013/06/07, 11:59:07 »
DeepDaze that did it.

Many thanks for the help.