seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/12/06, 19:07:13


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Please update flash player  (Read 7391 times)

0 Members and 1 Guest are viewing this topic.

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.377
Please update flash player
« on: 2013/12/11, 20:42:58 »
Adobe fixed 4 vulnerabilities in Flash Player and Shockwave Player.
flash Player can be updated by:
Code: [Select]
update-flashplugin-nonfree --install

New Version is: 11.2.202.332


Check version with:
Code: [Select]
update-flashplugin-nonfree --status |grep Fla

https://www.computerbase.de/news/2013-12/adobe-schliesst-sicherheitsluecken-in-flash-und-shockwave/
http://www.zdnet.com/adobe-patches-security-issues-in-flash-and-shockwave-players-7000024150/


greetz
devil
« Last Edit: 2013/12/11, 23:03:33 by devil »

Offline GoinEasy9

  • User
  • Posts: 461
Re: Please update flash player
« Reply #1 on: 2013/12/11, 22:37:58 »
Thanks for the info devil.  I need the reminders.
Linux Counter number 348347

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.931
    • Land of the Buckeye
Re: Please update flash player
« Reply #2 on: 2013/12/11, 23:41:41 »
Thanks for the info devil.  I need the reminders.


+1
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline absolut

  • User
  • Posts: 421
Re: Please update flash player
« Reply #3 on: 2013/12/11, 23:53:24 »
in this regard, i'd like to point out that you can also run flash-update via a cronjob, as described in this thread:

http://forum.siduction.org/index.php?topic=3449.30

thus, flash will be updated automatically

Offline michaa7

  • User
  • Posts: 2.126
Re: Please update flash player
« Reply #4 on: 2013/12/12, 03:28:04 »
yes, I have installed the cronjob, and it really seems to work as the installed version is 11.2.202.332.
But I wonder *when* it happend:
Quote
# ls -la /usr/lib/flashplugin-nonfree/libflashplayer.so
-rw-r--r-- 1 root root 17422820 Dez  1 10:12 /usr/lib/flashplugin-nonfree/libflashplayer.so
Does that mean the cronjob installed it 12 days ago?
No, it seems to show the time the file was created (compiled or packed). Anyway, I got it automatically via the cronjob.
« Last Edit: 2013/12/12, 04:04:55 by michaa7 »
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline ajavibp

  • User
  • Posts: 86
    • The website of the association where I collaborate.
Re: Please update flash player
« Reply #5 on: 2013/12/13, 10:14:18 »
Thanks!

Offline mylo

  • User
  • Posts: 921
Re: Please update flash player
« Reply #6 on: 2013/12/28, 21:47:24 »
Thanks for the info devil.  I need the reminders.


+1

+10 or can the update be incorporated in a apt-get update?
Regards mylo
____________________________________________ ____
"Die gefährlichste aller Weltanschauungen ist die Weltanschauung der Leute,
welche die Welt nicht angeschaut haben."               Alexander von Humboldt

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.377
Re: Please update flash player
« Reply #7 on: 2013/12/28, 22:03:16 »
You could run a cronjob.


greetz
devil

Offline HunkirDowne

  • User
  • Posts: 32
Re: Please update flash player
« Reply #8 on: 2013/12/29, 11:17:30 »
Don't know if this helps, but somehow I am getting updates automatically.  I can't find a cron job that would be making the call, so I think it might be somewhere in apt?


Offline michaa7

  • User
  • Posts: 2.126
Re: Please update flash player
« Reply #9 on: 2013/12/29, 11:29:11 »
If you see "flashplugin-nonfree" updated in apt-get, that's *not* the player but the updater!
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline HunkirDowne

  • User
  • Posts: 32
Re: Please update flash player
« Reply #10 on: 2013/12/29, 12:42:16 »
If you see "flashplugin-nonfree" updated in apt-get, that's *not* the player but the updater!

I think I'm OK, but check me out:

Code: [Select]
root@siductionbox:~# update-flashplugin-nonfree --status|grep Fla
Flash Player version installed on this system  : 11.2.202.332
Flash Player version available on upstream site: 11.2.202.332
root@siductionbox:~# dpkg --get-selections|grep flash
flashplugin-nonfree                             install
root@siductionbox:~# apt-cache policy flashplugin-nonfree
flashplugin-nonfree:
  Installed: 1:3.4
  Candidate: 1:3.4
  Version table:
 *** 1:3.4 0
        500 ftp://ftp.us.debian.org/debian/ unstable/contrib i386 Packages
        100 /var/lib/dpkg/status
root@siductionbox:~# apt-cache policy iceweasel
iceweasel:
  Installed: 24.2.0esr-1
  Candidate: 24.2.0esr-1
  Version table:
 *** 24.2.0esr-1 0
        500 ftp://ftp.us.debian.org/debian/ unstable/main i386 Packages
        100 /var/lib/dpkg/status
root@siductionbox:~# apt-cache policy google-chrome-stable
google-chrome-stable:
  Installed: 31.0.1650.63-1
  Candidate: 31.0.1650.63-1
  Version table:
 *** 31.0.1650.63-1 0
        500 http://dl.google.com/linux/chrome/deb/ stable/main i386 Packages
        100 /var/lib/dpkg/status
root@siductionbox:~# find $(find /etc -mindepth 1 -maxdepth 1 -type d -name '*cron*' -print) -depth -type f -not -empty -iname '*flash*'|wc
      0       0       0
root@siductionbox:~# find $(find /etc -mindepth 1 -maxdepth 1 -type d -name '*cron*' -print) -depth -type f -not -empty -print|xargs grep -il flash|wc
      0       0       0
root@siductionbox:~# find /etc/apt -depth -type f -name '*.list' -print|xargs cat|grep -v '#'|tr -s '\n'

deb http://packages.siduction.org/base unstable main
deb http://packages.siduction.org/extra unstable main
deb http://packages.siduction.org/fixes unstable main
deb ftp://ftp.us.debian.org/debian unstable main contrib non-free
deb http://dl.google.com/linux/chrome/deb/ stable main

Offline michaa7

  • User
  • Posts: 2.126
Re: Please update flash player
« Reply #11 on: 2013/12/29, 14:40:00 »
This tells you the version of the *updater*. If you want to know the version of the flashplugin-nonfree you need to go on a website where there is flash content. Then rightclick and see your version.


Or simply click here and compare the output to the newest linux version:
http://www.adobe.com/de/software/flash/about/


Edit: ok, didn't see the whole input, you are right, "update-flashplugin-nonfree --status" tells you what you need to know, too.
« Last Edit: 2013/12/29, 14:45:12 by michaa7 »
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline pjnsmb

  • User
  • Posts: 61
Re: Please update flash player
« Reply #12 on: 2014/02/21, 07:30:12 »
regards
pjnsmb

Offline michaaa62

  • User
  • Posts: 293
Re: Please update flash player
« Reply #13 on: 2014/02/21, 08:10:21 »
Thanks for the headup!
Once again the update-flashplayer-nonfree utility failed to download.
Quote
# update-flashplugin-nonfree -iv
options :  -i -v --
temporary directory: /tmp/flashplugin-nonfree.LOWfsvYe7d
importing public key ...
selected action = --install
installed version = 11.2.202.336
upstream version = 11.2.202.341
wgetoptions= -nd -P .   -v --progress=dot:default
downloading http://people.debian.org/~bartm/flashplugin-nonfree/fp.11.2.202.341.sha512.amd64.pgp.asc ...
--2014-02-21 07:49:34--  http://people.debian.org/~bartm/flashplugin-nonfree/fp.11.2.202.341.sha512.amd64.pgp.asc
Auflösen des Hostnamen »people.debian.org (people.debian.org)«... 206.12.19.5, 2607:f8f0:610:4000:214:38ff:feee:b65a
Verbindungsaufbau zu people.debian.org (people.debian.org)|206.12.19.5|:80... verbunden.
HTTP-Anforderung gesendet, warte auf Antwort... 404 Not Found
2014-02-21 07:49:34 FEHLER 404: Not Found.

wget failed to download http://people.debian.org/~bartm/flashplugin-nonfree/fp.11.2.202.341.sha512.amd64.pgp.asc
downloading http://people.debian.org/~bartm/flashplugin-nonfree/fp10.sha512.amd64.pgp.asc ...
--2014-02-21 07:49:34--  http://people.debian.org/~bartm/flashplugin-nonfree/fp10.sha512.amd64.pgp.asc
Auflösen des Hostnamen »people.debian.org (people.debian.org)«... 206.12.19.5, 2607:f8f0:610:4000:214:38ff:feee:b65a
Verbindungsaufbau zu people.debian.org (people.debian.org)|206.12.19.5|:80... verbunden.
HTTP-Anforderung gesendet, warte auf Antwort... 200 OK
Länge: 1273 (1,2K) [text/plain]
In »»./fp10.sha512.amd64.pgp.asc«« speichern.

     0K .                                                     100% 59,0M=0s

2014-02-21 07:49:35 (59,0 MB/s) - »»./fp10.sha512.amd64.pgp.asc«« gespeichert [1273/1273]

verifying PGP fp10.sha512.amd64.pgp.asc ...
copying /var/cache/flashplugin-nonfree/install_flash_player_11_linux.x86_64.tar.gz ...
verifying checksum install_flash_player_11_linux.x86_64.tar.gz ...
wgetoptions= -nd -P .   -v --progress=dot:default  -O /tmp/flashplugin-nonfree.LOWfsvYe7d/install_flash_player_11_linux.x86_64.tar.gz
downloading http://fpdownload.macromedia.com/get/flashplayer/pdc/11.2.202.336/install_flash_player_11_linux.x86_64.tar.gz ...
verifying checksum install_flash_player_11_linux.x86_64.tar.gz ...
unpacking install_flash_player_11_linux.x86_64.tar.gz ...
verifying checksum contents of install_flash_player_11_linux.x86_64.tar.gz ...
moving libflashplayer.so to /usr/lib/flashplugin-nonfree ...
setting permissions and ownership of /usr/lib/flashplugin-nonfree/libflashplayer.so ...
Flash Player version: 11.2.202.336
moving install_flash_player_11_linux.x86_64.tar.gz to /var/cache/flashplugin-nonfree ...
flash-mozilla.so - Auto-Modus
  Link verweist zur Zeit auf /usr/lib/flashplugin-nonfree/libflashplayer.so
/usr/lib/flashplugin-nonfree/libflashplayer.so - Priorität 50
Gegenwärtig »beste« Version ist »/usr/lib/flashplugin-nonfree/libflashplayer.so«.
calling update-alternatives ...
flash-mozilla.so - Auto-Modus
  Link verweist zur Zeit auf /usr/lib/flashplugin-nonfree/libflashplayer.so
/usr/lib/flashplugin-nonfree/libflashplayer.so - Priorität 50
Gegenwärtig »beste« Version ist »/usr/lib/flashplugin-nonfree/libflashplayer.so«.
removing /usr/bin/flash-player-properties
removing /usr/share/applications/flash-player-properties.desktop
removing /usr/share/icons/hicolor/16x16/apps/flash-player-properties.png
removing /usr/share/icons/hicolor/22x22/apps/flash-player-properties.png
removing /usr/share/icons/hicolor/24x24/apps/flash-player-properties.png
removing /usr/share/icons/hicolor/32x32/apps/flash-player-properties.png
removing /usr/share/icons/hicolor/48x48/apps/flash-player-properties.png
installing /usr/bin/flash-player-properties
installing /usr/share/applications/flash-player-properties.desktop
installing /usr/share/icons/hicolor/16x16/apps/flash-player-properties.png
installing /usr/share/icons/hicolor/22x22/apps/flash-player-properties.png
installing /usr/share/icons/hicolor/24x24/apps/flash-player-properties.png
installing /usr/share/icons/hicolor/32x32/apps/flash-player-properties.png
installing /usr/share/icons/hicolor/48x48/apps/flash-player-properties.png
already exists: /usr/share/pixmaps/flash-player-properties.png
end of action --install
cleaning up temporary directory /tmp/flashplugin-nonfree.LOWfsvYe7d ...
end of update-flashplugin-nonfree
The installer is as flawed as the plugin itself! Some bogus output, suggesting an install took place, when it did not download anything!
Please note the '404-not found'-error!

I ended up downloading the package http://get.adobe.com/de/flashplayer/download/?installer=Flash_Player_11.2_for_other_Linux_(.tar.gz)_64-bit&standalone=1 , extracting it and copying to the right places.
Code: [Select]
tar -xf install_flash_player_11_linux.x86_64.tar.gz
cp -r usr/* /usr
cp libflashplayer.so /usr/lib/flashplugin-nonfree/
After that
Quote
# update-flashplugin-nonfree -iv
options :  -i -v --
temporary directory: /tmp/flashplugin-nonfree.h8ZVmujst2
importing public key ...
selected action = --install
installed version = 11.2.202.341
upstream version = 11.2.202.341
upstream version 11.2.202.341 is already installed
end of action --install
cleaning up temporary directory /tmp/flashplugin-nonfree.h8ZVmujst2 ...
end of update-flashplugin-nonfree
« Last Edit: 2014/02/22, 07:54:14 by michaaa62 »

Offline drb

  • User
  • Posts: 156
Re: Please update flash player
« Reply #14 on: 2014/02/21, 10:48:31 »
Not happened here before . . . but has today