seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/12/06, 21:29:31


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Odd Video Effects After Dist-Upgrade on 03/19/2014  (Read 1590 times)

0 Members and 1 Guest are viewing this topic.

UP2L8

  • Guest
Some of my apps, for lack of better words, start washing downward when I open them from a minimized state.  This began happening after I d-u on 03/19/2014.  Any idea of what could be causing it and if it's fixable?


Since the problem appears to be video related, I looked in the pkgs that were upgraded and only saw xserver-xorg-video-qxl as a possible culprit, but reading the description of the package leads me to believe not.

Here's what it looks like:



The large image is PCManFM falling down.  Also note the streaks.
« Last Edit: 2014/03/29, 07:45:51 by UP2L8 »

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.377
Re: Odd Video Effects After Dist-Upgrade on 03/19/2014
« Reply #1 on: 2014/03/29, 09:05:40 »
We need some information on your graphics hardware. Please paste the output of
Code: [Select]
inxi -G

greetz
devil

UP2L8

  • Guest
Re: Odd Video Effects After Dist-Upgrade on 03/19/2014
« Reply #2 on: 2014/03/29, 22:43:11 »
I'm currently not at the machine having the issue, but following are the video specs according to ASUS:


Embedded Intel GMA 4500MHD

UP2L8

  • Guest
Re: Odd Video Effects After Dist-Upgrade on 03/19/2014
« Reply #3 on: 2014/04/01, 12:52:18 »
Output from inxi -G:

Card: Intel Mobile 4 Series Integrated Graphics Controller
X.Org: 1.15.0
drivers: intel (unloaded: fbdev, vesa)
Resolution: 1366x768@60.0hz
GLX Renderer: Mesa DRI Mobile Intel GM45 Express
GLX Version: 2.1 Mesa 9.2.2

Offline Crust

  • User
  • Posts: 33
Re: Odd Video Effects After Dist-Upgrade on 03/19/2014
« Reply #4 on: 2014/04/01, 18:59:57 »
I have some major graphics glitching as well.  My video card info is:

Graphics:  Card: Intel 3rd Gen Core processor Graphics Controller
           Display Server: X.Org 1.15.0.901 drivers: intel (unloaded: fbdev,vesa) Resolution: 1920x1080@59.9hz
           GLX Renderer: Mesa DRI Intel Ivybridge Mobile GLX Version: 3.0 Mesa 10.1.0

Offline Crust

  • User
  • Posts: 33
Re: Odd Video Effects After Dist-Upgrade on 03/19/2014
« Reply #5 on: 2014/04/01, 19:44:21 »
For me, forcing the accelmethod to UXA seems to have solved the issue.

UP2L8

  • Guest
Re: Odd Video Effects After Dist-Upgrade on 03/19/2014
« Reply #6 on: 2014/04/03, 04:39:45 »
Thanks for sharing your resolution method, Crust.  I'll give your method a try on my end to see if it will resolve my issue as well.

UP2L8

  • Guest
Re: Odd Video Effects After Dist-Upgrade on 03/19/2014
« Reply #7 on: 2014/04/05, 11:11:40 »
First, a d-u earlier today didn't resolve this issue.  Second, I tried setting up UXA accelmethod per the following:


http://askubuntu.com/questions/225356/how-can-i-enable-the-sna-acceleration-method-for-intel-cards-under-ubuntu-12-04


and then rebooted.  I was dumped to the command line.  I logged in as myself and was not able to start LXDE with the startx command.  I deleted everything done per the previous tip, rebooted, and started normally; e.g. lightdm and then LXDE.
« Last Edit: 2014/04/05, 11:24:07 by UP2L8 »

UP2L8

  • Guest
Re: Odd Video Effects After Dist-Upgrade on 03/19/2014
« Reply #8 on: 2014/04/30, 20:46:04 »
I decided to disable compton today to see if that might be the cause of the odd video effects.  Disabling compton resolves the issue with windows "washing down," but there's still a noticeable GUI anomaly when maximizing or minimizing windows.  Therefore, I do not think there's an issue with compton and it wasn't updated on 03/19/2014.  I'm now wondering if there's been a change in the kernel that could be causing the GUI issues.