seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/09/16, 02:09:04


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [solved] Keine Netzwerkverbindung nach Schließen von Notebookdeckel  (Read 3249 times)

0 Members and 1 Guest are viewing this topic.

Offline mxmehl

  • User
  • Posts: 33
Hallo zusammen,

anscheinend hat keiner außer mir dieses Problem seit dem letzten d-u [1], deswegen versuche ich hier mal, meinen Bug zu beschreiben.

Ich nutze Siduction Firestarter [2] auf meinem Lenovo Thinkpad E520 Notebook. Seit dem letzten d-u habe ich den absolut komischen Bug, dass sobald ich den Notebookdeckel schließe (Bildschirm wird gesperrt, keine Bereitschaft/Ruhezustand) keine Netzwerkverbindungen mehr vorhanden sind.
Eine Eingabe von ifconfig zeigt nur lo als Adapter, kein eth0, wlan0 oder ng mehr.

Ich kann auch danach machen, was ich will: Weder Ab- und Anmelden noch init 3 && init 5 helfen. Nur ein beherzter Neustart stellt die Netzwerkverbindungen wieder wie gewohnt her.

Was noch komischer ist: Schalte ich das Notebook in Bereitschaft und starte es wieder (Bildschirm ist wieder gesperrt), besteht das Problem nicht, auch wenn ich während der Bereitschaft den Deckel schließe und das Notebook durch Öffnen des Deckels wieder aufwecke.

Das Problem tritt nicht auf, wenn ich normal den Bildschirm sperre (mit xscreensaver [3]).

Ich habe gestern ein weiteres d-u gemacht in Hoffnung auf ein verbuggtes Paket, jedoch ohne Besserung.


Ich hoffe, Ihr könnt mir helfen! Danke im Voraus und sowieso für die ganze Arbeit :)

Viele Grüße
Max


[1] Ich bin sehr sicher, dass es bei diesem d-u geschehen ist: https://p.mehl.mx/?304a88c0ec13fe72#/ma3lFDRPCgBBq0f25KVgPgeLh9rVXP/bVZ0s5+qqy8=
[2] Linux heartofgold 3.14-0.towo.3-siduction-amd64 #1 SMP PREEMPT Mon Mar 31 16:34:46 UTC 2014 x86_64 GNU/Linux
[3] $ xscreensaver -v
xscreensaver 5.26
« Last Edit: 2014/04/17, 01:05:32 by mxmehl »
Use Study Share Improve.

FSFE, Blog, Homepage

System: Lenovo Thinkpad e520, Siduction 2013.2.0, x64, XFCE

Offline bluelupo

  • Global Moderator
  • User
  • *****
  • Posts: 2.065
    • http://bluelupo.net
Re: Keine Netzwerkverbindung nach Schließen von Notebookdeckel
« Reply #1 on: 2014/04/13, 16:12:17 »
Hi mxmehl,
du musst uns schon mehr Infos bzgl. deiner Netzwerkconfig liefern um dem Problem Herr zu werden. Hier mal ein paar Hinweise welche Infos wir brauchen:

* welcher Desktop
* NetworkManager oder konventionelle NW über die /etc/network/interfaces (ceni)
* Logfileeinträge
Ciao bluelupo
BlueLupo's Wiki - BlueLupo's Blog
BlueLupo bei GooglePlus
Bluelupo bei Diaspora*

Offline mxmehl

  • User
  • Posts: 33
Re: Keine Netzwerkverbindung nach Schließen von Notebookdeckel
« Reply #2 on: 2014/04/14, 10:00:36 »
Danke für den Hinweis, bluelupo.

Ich nutze XFCE 4.10.
Bei mir läuft der Network-Manager, alles über DHCP. network-manager-gnome ist installiert für das applet.

Nun zu den Logfiles. Ich habe durch 'tail -f /var/log/*.log' mal geschaut, wo sich was tut, wenn ich den Deckel schließe, wieder öffne und mich dann anmelde. Und da findet sich schon mal ein Hinweis (siehe Anhang).
So wie ich das interpretiere, wird ein "sleep requested", wodurch das Netzwerkgerät deaktiviert wird. Zum Schluss wird das Interface auch gelöscht.

Dadurch bin ich auf tlp bzw tlp-rdw gekommen, ein Launchpad-Programm, welches den Energieverbrauch auf Thinkpad-Geräten reduzieren soll. Dort wird auch erlaubt, dass Radio-Geräte in den Standby-Modus geschalten werden dürfen. Ich habe dies aber deaktiviert:

Code: [Select]
# WiFi power saving mode: 1=disable/5=enable
# (Linux 2.6.32 and later, some adapters only!)
WIFI_PWR_ON_AC=1
WIFI_PWR_ON_BAT=1

Die volle TLP-Config hab ich auch mal angehängt.

Wie man in dem history.log im ersten Post sehen kann, wurden tlp, tlp-rdw, network-manager und network-manager-gnome aktualisiert. Ich bin allerdings am Ende meines Lateins, wo der Fehler denn nun noch herkommen kann.
#Edit: Die Auswahl eines anderen Kernels beim Start hat leider auch nichts gebracht.


Hoffe auf Erleuchtung, danke ;
Use Study Share Improve.

FSFE, Blog, Homepage

System: Lenovo Thinkpad e520, Siduction 2013.2.0, x64, XFCE

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.356
Re: Keine Netzwerkverbindung nach Schließen von Notebookdeckel
« Reply #3 on: 2014/04/14, 10:43:14 »
Hast Du evtl. noch ein zweites Powrmanagement-Tool wie laptop-mode-tools  oder Powertop (was ich übrigens besser finde als TLP) installiert? Das geht nicht gut, die beißen sich. Ansonsten würde ich TLP mal entfernen, das macht bekanntermaßen Probleme. Du kannst hier auch mal tlp-stat (als root) anhängen.


greetz
devil

Offline der_bud

  • User
  • Posts: 883
  • member
Re: Keine Netzwerkverbindung nach Schließen von Notebookdeckel
« Reply #4 on: 2014/04/14, 11:11:57 »
Es gibt in der TLP FAQ einen Punkt Warum funktioniert das Wiederherstellen des Funkgerätezustands mit RESTORE_DEVICE_STATE_ON_STARTUP nicht?

In Deiner tlp.conf fällt mir auf das Du RESTORE_DEVICE_STATE_ON_STARTUP=0 stehen hast und gleichzeitig ist #DEVICES_TO_ENABLE_ON_STARTUP="wifi" auskommentiert ist, möglicherweise wird deshalb der Adapter nicht in den Zustand vorm Suspend zurückversetzt.
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline mxmehl

  • User
  • Posts: 33
Re: Keine Netzwerkverbindung nach Schließen von Notebookdeckel
« Reply #5 on: 2014/04/14, 13:17:25 »
Danke für Eure schnellen Antworten!

Hast Du evtl. noch ein zweites Powrmanagement-Tool wie laptop-mode-tools  oder Powertop (was ich übrigens besser finde als TLP) installiert?

(Leider) nein. Das einzige was irgendwie dazu passen könnte ist xfce4-power-manager oder upowerd, das läuft beides in der Prozessliste.

In Deiner tlp.conf fällt mir auf das Du RESTORE_DEVICE_STATE_ON_STARTUP=0 stehen hast und gleichzeitig ist #DEVICES_TO_ENABLE_ON_STARTUP="wifi" auskommentiert ist, möglicherweise wird deshalb der Adapter nicht in den Zustand vorm Suspend zurückversetzt.

Gute Idee. Ich hab's getestet, aber leider ohne Erfolg. Deswegen bin ich devils Rat gefolgt...

Ansonsten würde ich TLP mal entfernen, das macht bekanntermaßen Probleme. Du kannst hier auch mal tlp-stat (als root) anhängen.

Auch nach Purgen von TLP* besteht das Problem noch. Die Geräte werden quasi einfach gelöscht und sind auch nicht mehr zu aktivieren durch ein ifup wlan0 oder so. Bei jedem Mal (versehentlichen) Notebook-Schließen muss ich im Grunde neustarten...

# Edit: Ausgabe von tlp-stat noch angehängt, auch wenn's jetzt deinstalliert wurde.
Use Study Share Improve.

FSFE, Blog, Homepage

System: Lenovo Thinkpad e520, Siduction 2013.2.0, x64, XFCE

Offline mxmehl

  • User
  • Posts: 33
Re: Keine Netzwerkverbindung nach Schließen von Notebookdeckel
« Reply #6 on: 2014/04/17, 01:04:26 »
Kurzes Update:

Nach einem d-u gestern scheint das Problem behoben worden zu sein. Dort gab einen neuen Kernel 3.14-1 und der network-manager wurde auf 0.9.8.8-6 aktualisiert. Wahrscheinlich hat eines von denen die Sache gefixt.

Halleluja, ich hoffe, es bleibt so. Danke für die tatkräftige Hilfe hier!

# Edit: Es lag definitiv am NM. Hier der Bugreport bei Debian inkl Lösung: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=742933
« Last Edit: 2014/04/17, 01:10:48 by mxmehl »
Use Study Share Improve.

FSFE, Blog, Homepage

System: Lenovo Thinkpad e520, Siduction 2013.2.0, x64, XFCE

Offline bluelupo

  • Global Moderator
  • User
  • *****
  • Posts: 2.065
    • http://bluelupo.net
Hi mxmehl,
freut mich das wieder klappt. Manchmal kann es nicht schaden vor einem d-u bzgl. des Network-Managers hier Forum nachzulesen ob es Probleme gibt. Als Workaround kann man temporär den NM auf HOLD setzen bis das Problem gefixt ist.
Ciao bluelupo
BlueLupo's Wiki - BlueLupo's Blog
BlueLupo bei GooglePlus
Bluelupo bei Diaspora*