seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/10/21, 06:39:57


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Unmet dependencies for vlc  (Read 2905 times)

0 Members and 1 Guest are viewing this topic.

Offline oneself

  • User
  • Posts: 68
Unmet dependencies for vlc
« on: 2014/04/21, 17:37:12 »
Hi,


I'm trying to install vlc, but seem to be unable to do so because of some unmet dependencies.  I think vlc is pretty standard and I'm confused as to why I am not able to install it.  Can I install an older version?  What are my options?



Code: [Select]

$ apt-get install vlc
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:


The following packages have unmet dependencies:
 vlc : Depends: vlc-nox (= 1:2.1.4-dmo1) but it is not going to be installed
       Depends: libavcodec55 (>= 10:2.2) but 10:2.1.4-dmo1 is to be installed
       Depends: libva-x11-1 (> 1.2.0~) but it is not installable
       Depends: libxcb-xv0 (>= 1.2) but it is not installable
E: Unable to correct problems, you have held broken packages.
There are 10 types of people, those who know binary and those who don't.

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.756
    • g-com.eu
Re: Unmet dependencies for vlc
« Reply #1 on: 2014/04/21, 17:42:23 »
please answer your question yourself by studing the following line carefully:

Code: [Select]
vlc : Depends: vlc-nox (= 1:2.1.4-dmo1) but it is not going to be installed

and please note, that we don't support dmo - if you have problems with dmo, please ask marillat himself
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline oneself

  • User
  • Posts: 68
Re: Unmet dependencies for vlc
« Reply #2 on: 2014/04/21, 17:52:30 »
Hi,


I understand that vlc depends on vlc-nox.  I am not sure what "dmo" means.  Could you please explain?
Is there some other package in my system that's causing a weird version of that package to be used?


Thank you
There are 10 types of people, those who know binary and those who don't.

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.756
    • g-com.eu
Re: Unmet dependencies for vlc
« Reply #3 on: 2014/04/21, 18:13:08 »
http://deb-multimedia.org/ - if one use this repo - one should know how to handle this. nuff said.
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline oneself

  • User
  • Posts: 68
Re: Unmet dependencies for vlc
« Reply #4 on: 2014/04/21, 18:20:57 »
I would _really_ appreciate a little bit more help, and maybe a little bit less attitude.  I understand that I'm not an expert. This is exactly why I'm reaching out to get some help.


Could you elaborate on the bad interaction between siduction and deb-multimedia and how to fix it?
There are 10 types of people, those who know binary and those who don't.

Offline der_bud

  • User
  • Posts: 887
  • member
Re: Unmet dependencies for vlc
« Reply #5 on: 2014/04/21, 19:07:31 »
Hi oneself, as you probably know, deb-multimedia is not an official debian repo but driven by a single person, Christian Marillat. Some people think they need to use it because of special versions of packages or programs they cannot find elsewhere.
But as this repo is not maintained by siduction nor by debian, if something breaks or dependency mismatch occurs it is up to Marillat to solve this (or up to you to not mix his repo into your sources.lists).

As for siduction, all I can say is that vlc and vlc-nox are working here with stock siduction sources, meaning debian sid + siduction repositories:

Code: [Select]
# LANG=C apt-cache policy vlc
vlc:
  Installed: 2.1.2-2+b3
  Candidate: 2.1.2-2+b3
  Version table:
 *** 2.1.2-2+b3 0
        500 http://http.debian.net/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status
#LANG=C apt-cache policy vlc-nox
vlc-nox:
  Installed: 2.1.2-2+b3
  Candidate: 2.1.2-2+b3
  Version table:
 *** 2.1.2-2+b3 0
        500 http://http.debian.net/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status


As a first step, you could try if  " apt-get install -f " has a solution.
« Last Edit: 2014/04/21, 19:42:54 by der_bud »
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline oneself

  • User
  • Posts: 68
Re: Unmet dependencies for vlc
« Reply #6 on: 2014/04/22, 16:36:24 »
Hi,


Thank you very much for spelling it out.  I was not aware of that.  I think I will remove deb-multimedia from my repo list, and try to clean things out that way.


Thanks again.
There are 10 types of people, those who know binary and those who don't.

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.718
  • we are the priests ... of the temples of syrinx
Re: Unmet dependencies for vlc
« Reply #7 on: 2014/04/24, 04:17:56 »
From  "dmo"

Code: [Select]
piper@x1:~$ apt-cache policy vlc-nox
vlc-nox:
  Installed: 1:2.1.4-dmo1
  Candidate: 1:2.1.4-dmo1
  Version table:
 *** 1:2.1.4-dmo1 0
        500 http://www.deb-multimedia.org/ sid/main amd64 Packages
        100 /var/lib/dpkg/status
     2.1.2-2+b3 0
        500 http://mirror.cc.columbia.edu/debian/ unstable/main amd64 Packages
piper@x1:~$ apt-cache policy vlc
vlc:
  Installed: 1:2.1.4-dmo1
  Candidate: 1:2.1.4-dmo1
  Version table:
 *** 1:2.1.4-dmo1 0
        500 http://www.deb-multimedia.org/ sid/main amd64 Packages
        100 /var/lib/dpkg/status
     2.1.2-2+b3 0
        500 http://mirror.cc.columbia.edu/debian/ unstable/main amd64 Packages
piper@x1:~$ apt-cache policy libavcodec55
libavcodec55:
  Installed: 10:2.2.1-dmo1
  Candidate: 10:2.2.1-dmo1
  Version table:
 *** 10:2.2.1-dmo1 0
        500 http://www.deb-multimedia.org/ sid/main amd64 Packages
        100 /var/lib/dpkg/status
     6:10-2 0
          1 http://mirror.cc.columbia.edu/debian/ experimental/main amd64 Packages
piper@x1:~$ apt-cache policy libva-x11-1
libva-x11-1:
  Installed: 1.3.0-2
  Candidate: 1.3.0-2
  Version table:
 *** 1.3.0-2 0
        500 http://mirror.cc.columbia.edu/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status
piper@x1:~$ apt-cache policy libxcb-xv0
libxcb-xv0:
  Installed: 1.10-2
  Candidate: 1.10-2
  Version table:
 *** 1.10-2 0
        500 http://mirror.cc.columbia.edu/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status
piper@x1:~$

Yes, I need  "dmo"  for my media center (mythtv) which is awesome :) :)

Where you getting version  10:2.1.4-dmo1  of   libavcodec55  ?
« Last Edit: 2014/04/24, 04:24:57 by piper »
I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear