seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/12/06, 22:25:33


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: systemd upgrade makes the system unbootable (because of dbus ?)  (Read 7802 times)

0 Members and 1 Guest are viewing this topic.

Offline louispolaire

  • User
  • Posts: 21
@absolut : As I said in my last post the problem occurs at the start of systemd, there is no journaling at this point. If you prefer the error occurs with the start of PID=1. When I chroot into the unbootable system, the last item on the journal concerns the last working boot.

@der_bud : I find no way to start systemd, so no use of systemctl or journalctl.

The only way would be to be able to read those messages during boot to know exactly which services are inside this cycle. but as I explained earlier it goes too fast and I don't know the way to record the boot log before the start of systemd.

Any body have an idea ?


Offline louispolaire

  • User
  • Posts: 21
OK Solved !!

Thanks to this : https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=741528

it was cups,  I chrooted into the broken system and did a
Code: [Select]
#systemctl disable cups
which made the trick.

I have to say I am a little disapointed not having been able to read those bootlog messages.
what is the use of messages if you can't read them ?

but most important, problem solved... NEXT !

Offline der_bud

  • User
  • Posts: 896
  • member
Glad you solved your issues :).

For further reference, some info about debugging, emergency-boot, early-boot-logging with systemd you can possibly find here:

http://forum.siduction.org/index.php?topic=4566.0
http://freedesktop.org/wiki/Software/systemd/Debugging/#index2h2
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.