seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/11/18, 02:37:45


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: backintime-kde bzw. python-kde4 nicht installierbar  (Read 2496 times)

0 Members and 1 Guest are viewing this topic.

Offline Wonko

  • User
  • Posts: 25
Hallo,

ich habe ein Problem bei der Installation von backintime-kde. Im Grund lässt es sich darauf zurückführen, dass das Paket sip-api-10.1 installiert werden soll, aber nicht vorhanden ist.

Grüße,
Wonko

Code: [Select]
[✓]root@theta:~# apt-get install backintime-kde
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 backintime-kde : Depends: python-kde4 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


[✗]root@theta:~# apt-get install python-kde4
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python-kde4 : Depends: sip-api-10.1 but it is not installable
E: Unable to correct problems, you have held broken packages.


[✗]root@theta:~# apt-get install sip-api-10.1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package sip-api-10.1 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'sip-api-10.1' has no installation candidate


[✗]root@theta:~# apt-cache search sip-api
python-sip - Python/C++ bindings generator runtime library

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.765
    • g-com.eu
Re: backintime-kde bzw. python-kde4 nicht installierbar
« Reply #1 on: 2014/05/14, 16:02:08 »
das Paket gibt es schon, aber halt nicht mehr in sid. Zwei Möglichkeiten:
* das backintime-kde gegen die neuen Abhängigkeiten bauen
* einen Fehler in den debian bugtracker schreiben und das dann irgendwann erledigt bekommen
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline Wonko

  • User
  • Posts: 25
Re: backintime-kde bzw. python-kde4 nicht installierbar
« Reply #2 on: 2014/05/14, 17:23:38 »
Danke für die Antwort.

Wie baue ich das Paket gegen die neuen Abhängigkeiten? Ich habe es versucht mit

Code: [Select]
apt-get -b source backintime-kde
aber wenn ich das erzeugte Paket installieren will, dann kommt derselbe Fehler.

Wo wird denn der Bug gemeldet? Im Debian oder Siduction-Bugtracker? Oder kann ich das direkt über reportbug-ng machen?

Viele Grüße,
Wonko

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.373
Re: backintime-kde bzw. python-kde4 nicht installierbar
« Reply #3 on: 2014/05/14, 19:36:28 »
Du kannst Dir auch mal Obnam anschauen. Ist zwar CLI, aber in ner halben Stunde konfiguriert und läuft dann unauffällig im Hintergrund.  Luckybackup geht auch, die Sicherungen sind aber größer als bei Obnam.



greetz
devil

Offline der_bud

  • User
  • Posts: 893
  • member
Re: backintime-kde bzw. python-kde4 nicht installierbar
« Reply #4 on: 2014/05/14, 21:12:58 »
Im Thread Re: Does it seem safe to remove python-kde4? hat Santa die baldige Verfügbarkeit eines gefixten python-kde4 in Aussicht gestellt, vielleicht hilft ja einfach nur abwarten und Tee trinken  :).
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline Wonko

  • User
  • Posts: 25
Re: backintime-kde bzw. python-kde4 nicht installierbar
« Reply #5 on: 2014/05/14, 23:18:31 »
Hat sich erledigt. Python-kde4 ist wohl gerade korrigiert worden. :)

Ich wollte schon bei Backintime bleiben, da ich damit schon seit längerer Zeit meine Backups mache. Aber Danke für den Tipp.

Gruß,
Wonko