seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/02/28, 01:22:56


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [SOLVED] inkscape not installable: depends on libpoppler44 but it is not...  (Read 1689 times)

0 Members and 1 Guest are viewing this topic.

Offline orca

  • User
  • Posts: 27
Hi there

I just tried to install inkscape and had the following error:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 inkscape : Depends: libpoppler44 (>= 0.24.5) but it is not installable
E: Unable to correct problems, you have held broken packages.

I checked with packagesearch and the available versions of libpoppler are: qt4-4, 37, 43 and 46, all of them already installed. It seems 46 should be sufficient, doesn't it? Is this a misspecification in the package metadata?? My repos are the traditional ones: debian, base, kdenext, fixes, extra.

Thanks in advance!
« Last Edit: 2014/07/12, 20:13:06 by orca »

Offline GoinEasy9

  • User
  • Posts: 461
goineasy9@siduction64kdefx:~$ apt-cache policy inkscape
inkscape:
  Installed: 0.48.4.90+bzr13402.1
  Candidate: 0.48.4.90+bzr13402.1
  Version table:
     0.91~pre1-1 0
          1 http://http.debian.net/debian/ experimental/main amd64 Packages
 *** 0.48.4.90+bzr13402.1 0
        500 ftp://ftp.gtlib.gatech.edu/pub/siduction/extra/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status
     0.48.4-5+b1 0
        500 http://http.debian.net/debian/ unstable/main amd64 Packages

Inkscape installed with the siduction/extra/ unstable repo enabled.  Could we see what results from running apt-cache policy inkscape shows on your machine.  There's a different version in sid/ unstable, that may be causing the problem.
Linux Counter number 348347

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.795
    • g-com.eu
This is sid - some packages move to testing, while new versions appear in sid - thats life. And so is the story with libpoppler44.

Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline orca

  • User
  • Posts: 27
Hi GoinEasy,

After issuing apt-cache policy inkscape, I get

inkscape:
  Installed: (none)
  Candidate: 0.48.4.90+bzr13402.1
  Version table:
     0.48.4.90+bzr13402.1 0
        500 http://ftp.spline.de/pub/siduction/extra/ unstable/main amd64 Packages
     0.48.4-5+b1 0
        500 http://http.debian.net/debian/ unstable/main amd64 Packages

It looks somewhat similar to yours, as concerns the versions and the repos, doesn't it?

Cheers

Offline orca

  • User
  • Posts: 27
Hi

I have somehow managed to install inkscape, with help from musca and agaida in the #siduction chat channel.

Here is the step by step recipe:

1) include the testing (=jessie) suite in your debian.list source file

2) apt-get update

3) apt-get -t testing install libpoppler44

4) exclude the testing suite from your debian.list source file

5) apt-get update

6) apt-get install inkscape

Thanks folks

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.795
    • g-com.eu
in short
* add testing to debian.list
* update
* apt-get install inkscape

Thats all - and testing don't need to be deactivated - normaly the packages in sid are younger aka have higher numbers.
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)