seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/10/21, 07:26:54


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: (solved) network-manager 0.9.10.0-1.1, no paasword  (Read 2931 times)

0 Members and 1 Guest are viewing this topic.

Offline ayla

  • User
  • Posts: 1.697
Hi,

after d-u this morning network-manager did not find his wpa-password any more. I was asked again every reboot/login.
Installed version 0.9.10.0-1 from cache and it works again.

I set it on hold after then.

Had not used a wallet, stored pw in file.
greets
ayla

« Last Edit: 2015/01/04, 00:33:14 by piper »
Kernel: 4.18.11-towo.1-siduction-amd64 x86_64
Desktop: KDE Plasma 5.13.5
(mostly) kept current siduction "18.3.0 Patience"
HP EliteBook 8570p; MoBo: HP model: 17A7 v: KBC Version 42.35
Dual core  i5-3320M (-MT-MCP-)
Intel 3. Gen Graphics (Ivybridge) Driver:i915/ intel
 Wifi Intel Centrino N6205

Offline ayla

  • User
  • Posts: 1.697
Re: network-manager 0.9.10.0-1.1, no paasword
« Reply #1 on: 2014/08/20, 19:59:44 »
hmm... this is strange:

Setting up a laptop yesterday with the ssd from an old one, no updates for about 4 month.
Setting network-manager on hold before dist-upgrading.
NM version 0.9.8-somewhat, newest plasma-nm

The above mentioned fault occured. Downgraded plasma-nm to an older version. Works now, passwort is automatically insertet on bootup/login.

So I've the siituation that after  last d-u both machines with different NM versions stopt working as expextect but downgrading different files to different versions bring the correct working back, where the file I had to downgrade on one machine is the working one on the other ??

Will unset the hold on both machines tomorrow and see what happens...
Kernel: 4.18.11-towo.1-siduction-amd64 x86_64
Desktop: KDE Plasma 5.13.5
(mostly) kept current siduction "18.3.0 Patience"
HP EliteBook 8570p; MoBo: HP model: 17A7 v: KBC Version 42.35
Dual core  i5-3320M (-MT-MCP-)
Intel 3. Gen Graphics (Ivybridge) Driver:i915/ intel
 Wifi Intel Centrino N6205

Online GoinEasy9

  • User
  • Posts: 461
Re: network-manager 0.9.10.0-1.1, no paasword
« Reply #2 on: 2014/08/20, 23:17:02 »
After seeing your first post, I held off on updating my siduction laptop until last night.  I also use wpa, and, after the update, I had no problem with it finding the wpa password automatically.  Here are my current versions:

$ apt-cache policy network-manager
network-manager:
  Installed: 0.9.10.0-1.1
  Candidate: 0.9.10.0-1.1
  Version table:
 *** 0.9.10.0-1.1 0
        500 http://http.debian.net/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status

$ apt-cache policy plasma-nm
plasma-nm:
  Installed: 0.9.3.4-1
  Candidate: 0.9.3.4-1
  Version table:
 *** 0.9.3.4-1 0
        500 http://http.debian.net/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status

Linux Counter number 348347

Offline ayla

  • User
  • Posts: 1.697
Re: network-manager 0.9.10.0-1.1, no paasword
« Reply #3 on: 2014/08/21, 07:47:17 »
Very strange, unholdet NM on my desktop and upgradet to the same versions I had trouble the other day -which are the versions mentioned by GoingEasy9. No problem any more, NM gets its password automatically now.

Did the same on my laptop +unhold plasma-nm, where never before was the 0.9.10.0-1.1 version of NM installed and the problem reapeared there. I've simply no idea what's going on here...

tried then:

downgrade NM to version 0.9.8... again
reboot, it asks for the password, given, connected, logout/login, ask for passwort..., reboot, ask for password ...
Downgradet plasma-nm to version 0.9.3.3.3
reboot,  it asks for the password, given, connected,  logout/login, connectet automatically, reboot, connectet automatically.

d-u'd again, (in X, only NM and plasma-nm could be updatet, had to apply an apt-get -f install first) connection broken, but automatically restored
logout/login,takes a really long time to login, ask for passwort, given, connected,
logout/login,takes a really long time to login, ask for passwort, given, connected,
reboot, normal boot time, ask for password ..
reboot, normal boot time, ask for password ..

Downgradet plasma-nm to version 0.9.3.3.3
  logout/login, connectet automatically, reboot, connectet automatically.

Set plasma-nm on hold and gave up. Installed version of NM=0.9.10.0-1.1, same Version i had to downgrade before on my desktop and wich is now working there too, with plasma-nm 0.9.3.4-1

WTF??
« Last Edit: 2014/08/21, 08:01:05 by ayla »
Kernel: 4.18.11-towo.1-siduction-amd64 x86_64
Desktop: KDE Plasma 5.13.5
(mostly) kept current siduction "18.3.0 Patience"
HP EliteBook 8570p; MoBo: HP model: 17A7 v: KBC Version 42.35
Dual core  i5-3320M (-MT-MCP-)
Intel 3. Gen Graphics (Ivybridge) Driver:i915/ intel
 Wifi Intel Centrino N6205

Offline ayla

  • User
  • Posts: 1.697
Re: network-manager 0.9.10.0-1.1, no paasword
« Reply #4 on: 2015/01/01, 13:46:42 »
Hi,

the same problem, -allways asking for my wpa-password after each reboot/loggin- happend again after upgrading nm and plasma-nm again on my notebook.

I do not use kwallet.

The '##@@¬¬³³ thing is: It works without asking on my home station where I could use ceni insteed -same versions installed on both...

Comparing the files under /etc/NetworkManager/system-connections showed no difference in the wifi-security section:
Code: [Select]
[wifi-security]
key-mgmt=wpa-psk
psk-flags=1

I have found a workaround by searching a few ubuntu sides now for my notebook by adding a line with my psk key of my home network  there, so it looks like this:
Quote
[wifi-security]
key-mgmt=wpa-psk
psk-flags=1
psk=myverysecurewpakey

So it's working now as expexted but for me the questions remain: where is this key stored on my home station, why didn't I had need to store it there manually and is this the right way to store the key or will it be overwritten with the next upgrade??

greets
ayla
Kernel: 4.18.11-towo.1-siduction-amd64 x86_64
Desktop: KDE Plasma 5.13.5
(mostly) kept current siduction "18.3.0 Patience"
HP EliteBook 8570p; MoBo: HP model: 17A7 v: KBC Version 42.35
Dual core  i5-3320M (-MT-MCP-)
Intel 3. Gen Graphics (Ivybridge) Driver:i915/ intel
 Wifi Intel Centrino N6205

Offline der_bud

  • User
  • Posts: 887
  • member
Re: network-manager 0.9.10.0-1.1, no paasword
« Reply #5 on: 2015/01/02, 15:32:18 »
... It works without asking on my home station where I could use ceni insteed ...

...where is this key stored on my home station, why didn't I had need to store it there manually ...

I think you remember CENI stands for 'Configure /Etc/Network/Interfaces' ? So on my very simple setup laptop without any wpa-supplicant stuff or such, my password for wlan is exactly in that file, /etc/network/interfaces.

We had two perhaps similar issues about NM always asking for PW recently from users in a LUG meeting; as I have no network manager I try to remember the solutions from my memory. One user solved his issue by deleting the connections and when re-adding he explicitely set two switches: first, he had to set a mark in a field for that connection to be 'used by all users of the system', then when asked for wlan passphrase he had to set a mark explicitely in the field 'remember this password' [1].
 The other user's issue was different, he auto-logged-in to his desktop (no user password at login). In that case, when autologin is used in gdm/kdm/lightdm, the authentification module PAM does not allow some services that store passwords (NM was one of them)  without re-asking. So that users set a user-password at login or disabled autologin, afterwards NM connected without asking for wlan passphrase.

_
[1]:
Quote from: askubuntu
To fix this. Go to your network connections. From there click on wireless tab. Choose your connection and then click the edit button. Make sure your password is entered then click on the wireless security tab. Then check the box in the bottom left corner that says available to all users. This is what fixed the problem for me ...
 ... For me the problem was occuring with a particular network despite the "All users may connect to this network" checkbox being already checked. So what I did was to uncheck the box, save, check the box, then save again. I know this seems retarded, but it solved the problem for me.
« Last Edit: 2015/01/02, 15:37:02 by der_bud »
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline ayla

  • User
  • Posts: 1.697
Re: network-manager 0.9.10.0-1.1, no paasword
« Reply #6 on: 2015/01/02, 18:41:29 »
Code: [Select]
...So what I did was to uncheck the box, save, check the box, then save again....
Thanks, der_bud, that did the trick on my notebook.


Quote
...then when asked for wlan passphrase he had to set a mark explicitely in the field 'remember this password'...
Since updates a few month ago this field -and a field "store in file"- isn't in the "settings"  any more. What happens is that the first time one enters the passphrase, one is gettings asked to use kwallet to store it, which I do not like, so I say "store" there and  in the second window I do not choose kwallet.
This was working for a year or so and is still working on my desktop with no problem.

Just on the notebook -where I really need the nm, if I don't want to frickel with ceni and wvdial evry time I change location, it had not.  ::)

But: solved now, thanks again.
ayla

of course, can't mark this old thread as solved any more...
Kernel: 4.18.11-towo.1-siduction-amd64 x86_64
Desktop: KDE Plasma 5.13.5
(mostly) kept current siduction "18.3.0 Patience"
HP EliteBook 8570p; MoBo: HP model: 17A7 v: KBC Version 42.35
Dual core  i5-3320M (-MT-MCP-)
Intel 3. Gen Graphics (Ivybridge) Driver:i915/ intel
 Wifi Intel Centrino N6205

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.718
  • we are the priests ... of the temples of syrinx
Re: (solved) network-manager 0.9.10.0-1.1, no paasword
« Reply #7 on: 2015/01/04, 00:35:20 »
Marked it solved for you ;)
I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

Offline ayla

  • User
  • Posts: 1.697
Re: (solved) network-manager 0.9.10.0-1.1, no paasword
« Reply #8 on: 2015/01/04, 00:46:55 »
Thanks, piper
Kernel: 4.18.11-towo.1-siduction-amd64 x86_64
Desktop: KDE Plasma 5.13.5
(mostly) kept current siduction "18.3.0 Patience"
HP EliteBook 8570p; MoBo: HP model: 17A7 v: KBC Version 42.35
Dual core  i5-3320M (-MT-MCP-)
Intel 3. Gen Graphics (Ivybridge) Driver:i915/ intel
 Wifi Intel Centrino N6205

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.367
Re: (solved) network-manager 0.9.10.0-1.1, no paasword
« Reply #9 on: 2015/06/28, 09:25:19 »
Even though this is an old thread, this might be helpfull. Investigating on the perrils of autol login with lightdm I looked at the Arch-Linux-Wiki and found this line:
Code: [Select]
LightDM goes through PAM even when autologin is enabled. You must be part of the autologin group to be able to login without entering your password

and also:


Code: [Select]
Note: GNOME users, and by extension any gnome-keyring user will have to set up a blank password to their keyring for it to be unlocked automatically.

greetz
devil