seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/09/18, 00:41:21


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: broken dependencies  (Read 5058 times)

0 Members and 1 Guest are viewing this topic.

Offline dartex

  • User
  • Posts: 46
broken dependencies
« on: 2014/09/04, 13:41:22 »
Hi, I have a problem since a few days...

I tryed to do a du after a few weeks, and an error occurred.
Now, everything I try to do with apt (install, remove or update packages) the output is
Code: [Select]
libdevmapper1.02.1 : Dipende: dmsetup (>= 2:1.02.88-1)
libperl5.20 : Dipende: perl-base (= 5.20.0-6) ma la versione 5.18.2-7 è installata
systemd-sysv : Dipende: systemd (= 208-7) ma la versione 214-1 è installata
udev : Dipende: libudev1 (= 208-7) ma la versione 214-1 è installata

The last du installed "systemd=214" (from experimental? why?).
(reply #8 for more details)

I tryed apt-get -f install, but it want to remove 234 packages (all kde and xserver-xorg among others).

I can't upgrade or install any new package... how can I solve it?  :o
« Last Edit: 2014/09/04, 16:04:44 by dartex »

Offline michaa7

  • User
  • Posts: 2.126
Re: broken dependencies
« Reply #1 on: 2014/09/04, 13:47:40 »
Is it 32 or 64 bit (shouldn't matter, but anyway)

Are you sure there's nothing on hold? Your system didn't complete the perl transition (perl moved to 5.20, but you still have at least one 5.18 package installed). So I'd try to manually upgrade all perl packages to 5.20. Afterward we may see whether or not the d-u wents through.

And your systemd-sysv v214 is from experimental, but sid still is @ v208. I don't know whether or not this is a siduction thing or *you* did this  on purpose (the systemd-sysv from experimental). But after getting in sync perl this is the next construction area you have to care about.

And please provide the real commands you issue.
« Last Edit: 2014/09/04, 14:00:13 by michaa7 »
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline dartex

  • User
  • Posts: 46
Re: broken dependencies
« Reply #2 on: 2014/09/04, 14:30:50 »
thanks for the quickly answer! ;)

Is it 32 or 64 bit (shouldn't matter, but anyway)
64 bit.

Are you sure there's nothing on hold? Your system didn't complete the perl transition (perl moved to 5.20, but you still have at least one 5.18 package installed). So I'd try to manually upgrade all perl packages to 5.20. Afterward we may see whether or not the d-u wents through.
nothing on hold...
how can I manually upgrade? it let me update anything...

And your systemd-sysv v214 is from experimental, but sid still is @ v208. I don't know whether or not this is a siduction thing or *you* did this  on purpose (the systemd-sysv from experimental). But after getting in sync perl this is the next construction area you have to care about.
I don't know.  :o :o :o
I only installed libreoffice from experimental... but after that I disabled experimental.

Offline michaa7

  • User
  • Posts: 2.126
Re: broken dependencies
« Reply #3 on: 2014/09/04, 14:36:23 »
Code: [Select]
apt-get install perl-base should bring it to the newest version. But as I don't know which other packages may be affected you better *simulate* it first issuing
Code: [Select]
apt-get install perl-base -s and watch what happens.

I don't have systemd-sysv installed as i don't use it yet. But my systemd is 208. And you don't have to disable experimental as this repo has priority "1", whereas sid has "500". So you never pull anything from experimental except you explicitly require it.
« Last Edit: 2014/09/04, 14:45:58 by michaa7 »
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline dartex

  • User
  • Posts: 46
Re: broken dependencies
« Reply #4 on: 2014/09/04, 14:48:25 »
Code: [Select]
apt-get install perl-base should bring it to the newest version. But as I don't know which other packages may be affected you better *simulate* it first issuing
Code: [Select]
apt-get install perl-base -s and watch what happens.

I don't have systemd-sysv installed as i don't use it yet. But my systemd is 208. and You don't have to disable experimental as this repo has priority "1", whereas sid has "500". So you never pull anything from experimental except you explicitly require it.

I have it in italian, I think you'll understand. if not, ask me.
is it possible to have the output in english, just once?
Code: [Select]
apt-get install perl-base -s
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt-get -f install" per correggere questi problemi:
I seguenti pacchetti hanno dipendenze non soddisfatte:
 irssi : Dipende: perlapi-5.18.2
 libapt-pkg-perl : Dipende: perlapi-5.18.1
 libclass-methodmaker-perl : Dipende: perlapi-5.18.2
 libcurses-perl : Dipende: perlapi-5.18.2
 libdevmapper1.02.1 : Dipende: dmsetup (>= 2:1.02.88-1)
 libfile-fnmatch-perl : Dipende: perlapi-5.18.2
 libhtml-parser-perl : Dipende: perlapi-5.18.1
 libio-pty-perl : Dipende: perlapi-5.18.1
 liblist-moreutils-perl : Dipende: perlapi-5.18.2
 liblocale-gettext-perl : Pre-dipende: perlapi-5.18.2
 libmouse-perl : Dipende: perlapi-5.18.2
 libnet-idn-encode-perl : Dipende: perlapi-5.18.2
 libnet-ssleay-perl : Dipende: perlapi-5.18.2
 libparams-classify-perl : Dipende: perlapi-5.18.1
 libperl5.18 : Dipende: perl-base (= 5.18.2-7) ma la versione 5.20.0-6 sta per essere installata
 libpurple0 : Dipende: perlapi-5.18.2
 libterm-readkey-perl : Dipende: perlapi-5.18.2
 libtext-charwidth-perl : Dipende: perlapi-5.18.1
 libtext-iconv-perl : Dipende: perlapi-5.18.1
 libxml-libxml-perl : Dipende: perlapi-5.18.2
 perl : Dipende: perl-base (= 5.18.2-7) ma la versione 5.20.0-6 sta per essere installata
 pidgin : Dipende: perlapi-5.18.2
 systemd-sysv : Dipende: systemd (= 208-7) ma la versione 214-1 sta per essere installata                                                                                 
 udev : Dipende: libudev1 (= 208-7) ma la versione 214-1 sta per essere installata                                                                                         
E: Dipendenze non soddisfatte. Provare "apt-get -f install" senza pacchetti (o specificare una soluzione).


edit: just checked, exp repo is not disabled. but I really don't think I manually installed it!  :o :o :o
« Last Edit: 2014/09/04, 14:52:30 by dartex »

Offline michaa7

  • User
  • Posts: 2.126
Re: broken dependencies
« Reply #5 on: 2014/09/04, 15:10:41 »
Parlo italiano, ecco non c'est problema leggerlo ;-)

But as others don't, we'll continue to have this conversation in EN.

You my put "LANG=C" in front off a command, but it does not work in all circumscances. But no problem here.

The problem for me here is, that I don't know what happens when you let go  libapt-pkg-perl as it may prevent apt from working :( and I don't know why "apt-get -f install doesn't solve the problem.

Remove pidgin and irssi (at least for the moment), then install all those *perl* packages manually like
Code: [Select]
apt-get install perl-base  libapt-pkg-perl libclass-methodmaker-perl <and so on> -s
Don't care about systemd-sysv for the moment. Maybe someone else could step in an tell us whether it is safe to downgrade it to 208. It should work, but I am not sure ...

I have to go for now but will show up again in the evening.
« Last Edit: 2014/09/04, 15:19:49 by michaa7 »
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline dartex

  • User
  • Posts: 46
Re: broken dependencies
« Reply #6 on: 2014/09/04, 15:20:44 »
ok! ;)

as I told, it's impossible to update, install and (I forgot) remove ANY package!  ???

Code: [Select]
apt-get remove pidgin
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libdevmapper1.02.1 : Depends: dmsetup (>= 2:1.02.88-1)
 libperl5.20 : Depends: perl-base (= 5.20.0-6) but 5.18.2-7 is to be installed
 systemd-sysv : Depends: systemd (= 208-7) but 214-1 is to be installed
 udev : Depends: libudev1 (= 208-7) but 214-1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

it's always the same output, averything I try to do with apt-get....

Offline michaa7

  • User
  • Posts: 2.126
Re: broken dependencies
« Reply #7 on: 2014/09/04, 15:33:20 »
read "man dpkg". Carefully. There are "force" options, to be used with caution!!!

So, as a last resort you will use them. Make a written list on paper of all packages involved with their current version and the version to be installed. D/L all needed versions to your computer (because dpkg needs them on disk, not somewere in the net like apt). If you can't d/l them using "-d" with apt, then use your browser and browse the Debian sid repo, pick the packages manually. Then we'll see.

I now really have to leave ;-) for now.
« Last Edit: 2014/09/04, 15:38:46 by michaa7 »
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline dartex

  • User
  • Posts: 46
Re: broken dependencies
« Reply #8 on: 2014/09/04, 15:59:48 »
I think I found the log of the last update attempt.

I'll cut it because "The message exceeds the maximum allowed length". I let the packages with perl, udev and systemd.

Code: [Select]
Start-Date: 2014-08-30  15:34:52
Commandline: apt-get dist-upgrade
Install: ... libperl5.20:amd64 (5.20.0-6, automatic), ... libsystemd0:amd64 (214-1, automatic), ...
Upgrade: ... libclass-method-modifiers-perl:amd64 (2.10-1, 2.11-1), libmouse-perl:amd64 (2.3.0-1, 2.3.0-1+b1), ... libnet-idn-encode-perl:amd64 (2.200-1, 2.200-1+b1), ... libhttp-cookies-perl:amd64 (6.00-2, 6.01-1), ... libsystemd-login0:amd64 (208-7, 214-1), ... perl:amd64 (5.18.2-7, 5.20.0-6), ... libnet-ssleay-perl:amd64 (1.65-1, 1.65-1+b1), ... perl-base:amd64 (5.18.2-7, 5.20.0-6), ... libdevel-globaldestruction-perl:amd64 (0.12-1, 0.13-1), ... libtype-tiny-perl:amd64 (0.044-1, 1.000002-1), liblist-moreutils-perl:amd64 (0.33-2, 0.33-2+b1), ... libsystemd-daemon0:amd64 (208-7, 214-1), ... libgudev-1.0-0:amd64 (208-7, 214-1), ... libstrictures-perl:amd64 (1.005004-1, 1.005005-1), ... libclass-methodmaker-perl:amd64 (2.21-1, 2.21-1+b1), ... libpam-systemd:amd64 (208-7, 214-1), ... libsystemd-id128-0:amd64 (208-7, 214-1), ... libtext-charwidth-perl:amd64 (0.04-7+b2, 0.04-7+b3), ... udev:amd64 (208-7, 214-1), ... libhtml-parser-perl:amd64 (3.71-1+b1, 3.71-1+b2), ... libxml-libxml-perl:amd64 (2.0116+dfsg-1, 2.0116+dfsg-1+b1), ... libterm-readkey-perl:amd64 (2.32-1, 2.32-1+b1), libkpty4:amd64 (4.13.3-90r1, 4.14.0-90r1), ... libudev1:amd64 (208-7, 214-1), ... libmoox-late-perl:amd64 (0.014-1, 0.015-1), ... perl-modules:amd64 (5.18.2-7, 5.20.0-6), ... libtext-iconv-perl:amd64 (1.7-5+b1, 1.7-5+b2), ... libdpkg-perl:amd64 (1.17.10, 1.17.13), ... libcurses-perl:amd64 (1.31-1, 1.31-1+b1), ... libapt-pkg-perl:amd64 (0.1.29+b1, 0.1.29+b2), systemd-sysv:amd64 (208-7, 214-1), ... libsystemd-journal0:amd64 (208-7, 214-1), ... systemd:amd64 (208-7, 214-1), ... libdevperl-event1.02.1:amd64 (1.02.85-2, 1.02.88-1), ... liblocale-gettext-perl:amd64 (1.05-8, 1.05-8+b1), ... libdevperl1.02.1:amd64 (1.02.85-2, 1.02.88-1), ... libio-pty-perl:amd64 (1.08-1+b3, 1.08-1+b4), ... libparams-classify-perl:amd64 (0.013-4+b1, 0.013-4+b2), ... libfile-fnmatch-perl:amd64 (0.02-2, 0.02-2+b1),
Remove: ... libperl5.18:amd64 (5.18.2-7), ...
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2014-08-30  15:37:53
so, the last dist-upgrade installed the 214 version (from experimental?).  I don't know why...!  :-\

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.911
    • Land of the Buckeye
Re: broken dependencies
« Reply #9 on: 2014/09/04, 16:25:11 »
Yep, that system is a bit messed up.  On mine, which was updated this morning:


Code: [Select]
root@imerabox:/# apt-cache policy systemd
systemd:
  Installed: 208-8
  Candidate: 208-8
  Version table:
     214-1 0
          1 http://ftp.us.debian.org/debian/ experimental/main amd64 Packages
 *** 208-8 0
        500 http://ftp.us.debian.org/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status


Maybe if you comment out the experimental repo in your sources, then update it, you can put it back together.  Maybe.
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline dartex

  • User
  • Posts: 46
Re: broken dependencies
« Reply #10 on: 2014/09/04, 18:19:51 »
Maybe if you comment out the experimental repo in your sources, then update it, you can put it back together.  Maybe.

I tryed, it doesn't work.



I'm downloading from packages.debian.org every single package and installing them with dpkg -i.
it seems to work, for now...
solved the "systemd problem", I'll try with perl.



edit: for perl, synatic solved the problem. while apt-get didn't.  ???
« Last Edit: 2014/09/04, 18:27:00 by dartex »

Offline michaa7

  • User
  • Posts: 2.126
Re: broken dependencies
« Reply #11 on: 2014/09/04, 19:38:56 »
...
edit: for perl, synatic solved the problem.
Fine. Did you run "apt-get update && apt-get dist-upgrade" afterwards? If not then do so now to see whether or not all is in sync again. You may need to "apt-get -f install" agian.
while apt-get didn't.  ???

dpkg -i installs one or some package(s), it does not do a dist-upgrade (= building up the dependency tree over all installed packages) That's why you should d-u again (see above).
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline dartex

  • User
  • Posts: 46
Re: broken dependencies
« Reply #12 on: 2014/09/04, 22:25:06 »
...
edit: for perl, synatic solved the problem.
Fine. Did you run "apt-get update && apt-get dist-upgrade" afterwards? If not then do so now to see whether or not all is in sync again. You may need to "apt-get -f install" agian.
while apt-get didn't.  ???

dpkg -i installs one or some package(s), it does not do a dist-upgrade (= building up the dependency tree over all installed packages) That's why you should d-u again (see above).

I had 4 broken packages: libdevmapper1, systemd, udev, perl.
with "dpkg -i" I correctly installed all systmed and udev packages.
perl packages left.
I tryed "apt-get dist-upgrade" and "apt-get -f install" but it didn't work.

so, I tryed to update the broken perl package with synaptic, and it worked!!! ;)
(it also updated related packages, so I didn't had to manually download and install each)

now I have apt/synaptic working.

I'm now doing dist-upgrade...


edit: du done. pc rebooted. it seems it's all ok. 660 packages updated. :o
there are now other 10 packages, but I will wait... :)
« Last Edit: 2014/09/04, 23:05:47 by dartex »

Offline michaa7

  • User
  • Posts: 2.126
Re: broken dependencies
« Reply #13 on: 2014/09/04, 23:33:30 »
edit: du done. pc rebooted. it seems it's all ok. 660 packages updated. :o
there are now other 10 packages, but I will wait... :)

We often have this question and a discussion how often siduction user should d-u.

Your example shows what may happen when there is a transition involved. And as a rule of thumb I'd say: Don't wait much time after an ongoing transition is completed. D-u as fast as you can. It may become complicated if you don't.

OTAH, even if there are problems, they can be solved. But there is no garantie!


As to the 10 packages, if they are held back without your interference, than there is no problem.
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline dartex

  • User
  • Posts: 46
Re: broken dependencies
« Reply #14 on: 2014/09/05, 12:27:44 »
edit: du done. pc rebooted. it seems it's all ok. 660 packages updated. :o
there are now other 10 packages, but I will wait... :)

We often have this question and a discussion how often siduction user should d-u.

Your example shows what may happen when there is a transition involved. And as a rule of thumb I'd say: Don't wait much time after an ongoing transition is completed. D-u as fast as you can. It may become complicated if you don't.

OTAH, even if there are problems, they can be solved. But there is no garantie!


As to the 10 packages, if they are held back without your interference, than there is no problem.

I usually ugrade more often.
This time I waited about 3 weeks...
and there were hundreds of kde packages.

The 10 packages are not hold...
I did update and downloaded the packages in afternoon, while using pc.
Then did the "real" du some hours later, when not using it. ;)

So, then i did "apt-get update" again, and there were 10 new package. :)