seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/11/13, 08:58:10


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: du wants to downgrade extlinux syslinux syslinux-common?  (Read 903 times)

0 Members and 1 Guest are viewing this topic.

Offline vayu

  • User
  • Posts: 200
Does it seem ok to downgrade these packages?  extlinux syslinux syslinux-common

Code: [Select]
apt-get dist-upgrade -d
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  linux-headers-3.19.3-towo.2-siduction-amd64 linux-image-3.19.3-towo.2-siduction-amd64
The following packages will be upgraded:
  avr-libc binutils binutils-avr bsdutils bzip2 cabextract chkrootkit chromium chromium-inspector chromium-l10n
  console-setup console-setup-linux debconf debconf-i18n debconf-utils debsums devscripts firmware-atheros gcc-avr
  google-chrome-beta google-chrome-stable grub-common grub-efi-amd64-bin grub-pc grub-pc-bin grub2-common
  gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly gtk3-engines-oxygen icedtea-7-plugin icedtea-netx
  icedtea-netx-common iceweasel icu-devtools initscripts keyboard-configuration krb5-multidev libblkid1 libbz2-1.0
  libcap2 libcap2:i386 libcap2-bin libgssapi-krb5-2 libgssrpc4 libgstreamer-plugins-bad1.0-0 libgudev-1.0-0
  libibverbs-dev libibverbs1 libicu-dev libicu52 libicu52:i386 libjavascriptcoregtk-1.0-0 libjavascriptcoregtk-3.0-0
  libk5crypto3 libkadm5clnt-mit9 libkadm5srv-mit9 libkdb5-7 libkrb5-3 libkrb5-dev libkrb5support0 libmount1 libmpeg2-4
  libnm-glib4 libnm-util2 libnspr4 libopenconnect3 libpam-systemd libparted-fs-resize0 libparted2 libperl5.20
  libqt5webkit5 librtmp-dev librtmp1 libruby2.1 libsmartcols1 libssh2-1 libssl-dev libssl1.0.0 libsvn-dev libsvn1
  libsystemd-daemon0 libsystemd-id128-0 libsystemd-journal0 libsystemd-login0 libsystemd0 libsystemd0:i386 libtasn1-6
  libtasn1-6:i386 libtasn1-6-dev libtcl8.6 libteamdctl0 libtiff5 libtiff5:i386 libtiff5-dev libtiffxx5 libudev1
  libudev1:i386 libupower-glib3 libuuid1 libuuid1:i386 libvlc5 libvlccore8 libwebkitgtk-1.0-0 libwebkitgtk-1.0-common
  libwebkitgtk-3.0-0 libwebkitgtk-3.0-common libwebp-dev libwebp5 libwebpdemux1 libwebpmux1 libxerces-c3.1 libxfont1
  libzip-dev libzip2 linux-headers-siduction-amd64 linux-image-siduction-amd64 linux-libc-dev mount nano
  network-manager openssh-client openssh-server openssh-sftp-server openssl parted perl perl-base perl-modules
  php5-cgi php5-cli php5-common python-debian python-imaging python-pil python-pygments ruby2.1 ruby2.1-dev ssl-cert
  strace systemd systemd-sysv sysv-rc sysvinit sysvinit-utils tcl8.6 tzdata tzdata-java udev unrar upower util-linux
  uuid-dev vim vim-common vim-runtime virtualbox-guest-additions-iso vlc vlc-data vlc-nox vlc-plugin-pulse wget whois
The following packages will be DOWNGRADED:
  extlinux syslinux syslinux-common
162 upgraded, 2 newly installed, 3 downgraded, 0 to remove and 0 not upgraded.
Need to get 391 MB of archives.
After this operation, 164 MB of additional disk space will be used.
Do you want to continue? [Y/n] n

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.373
Re: du wants to downgrade extlinux syslinux syslinux-common?
« Reply #1 on: 2015/04/09, 17:43:53 »
I cannot see that behaviour on any box here. At the moment I have no clue why that would happen.


greetz
devil

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.765
    • g-com.eu
Re: du wants to downgrade extlinux syslinux syslinux-common?
« Reply #2 on: 2015/04/09, 18:02:19 »
apt-get purge   extlinux syslinux syslinux-common
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline seasons

  • User
  • Posts: 239
Re: du wants to downgrade extlinux syslinux syslinux-common?
« Reply #3 on: 2015/04/12, 16:34:05 »
So, this morning, the packages have returned to the siduction repo. Just to be sure, we want the siduction version (4.05), correct? Also, I assume the "epoch" (4:) override is still intended, correct?
Thanks in advance.

Code: [Select]
$ apt-cache policy syslinux
syslinux:
  Installed: 3:6.03+dfsg-5
  Candidate: 4:4.05+dfsg-6+deb8u1.2
  Version table:
     4:4.05+dfsg-6+deb8u1.2 0
        500 http://packages.siduction.org/extra/ unstable/main amd64 Packages
     3:6.03+dfsg-6 0
          1 http://ftp.debian.org/debian/ experimental/main amd64 Packages
 *** 3:6.03+dfsg-5 0
        500 http://ftp.us.debian.org/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.765
    • g-com.eu
Re: du wants to downgrade extlinux syslinux syslinux-common?
« Reply #4 on: 2015/04/12, 16:47:23 »
you want to purge this - its live only stuff

And yes - this epoch is only for siduction, because we want to have to old and (mostly) working version of syslinux in siduction. 6.03 is ok but don't play well with gfxboot  (or i'm to dumb to configure it right). As the older version has no disadvantages for us (all major distribution who use gfxboot use this version too) i decided to bring back our version with a new epoch back to our repo.
« Last Edit: 2015/04/12, 16:50:58 by melmarker »
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)