seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/09/18, 01:10:39


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Beim Runterfahren: A stop job is running for Session....  (Read 11385 times)

0 Members and 1 Guest are viewing this topic.

Offline spacepenguin

  • User
  • Posts: 863
    • spacepenguin.de
Ich hab hier ein Indian Summer, welches ich direkt nach Installation per d-u auf Plasma 5 mit sddm gebracht habe. Es gab keinerlei gravierende Probleme dabei.

Beim Runterfahren kommt jedoch in ich sag mal 8 von 10 Fällen eine Meckermeldung über einen stop job, siehe angehängtes Bild. Mal handelt es sich um Session 1, mal um Session 2 (wobei immer nur eine läuft - automatisches Login - und es auch nur einen User auf dem Rechner gibt).

Der "stop job" läuft dann auch die ganzen 1:30 durch, danach laufen jede Menge Meldungen über den Bildschirm wie früher beim Booten und der Rechner geht aus wie es sein soll.

Was könnte sowas verursachen, wie komme ich dem auf die Schliche? Und kann man die vorgegebenen 1:30 Minuten auf vielleicht 0:10 oder so setzen?

Susan | Hardware: SysProfile
Music-Profile: http://www.last.fm/de/user/spacepengu

Offline hsp

  • User
  • Posts: 500
Re: Beim Runterfahren: A stop job is running for Session....
« Reply #1 on: 2016/02/12, 07:45:06 »
Ich kann dir zwar nicht helfen, kann aber bestätigen das ich das auch hin und wieder um Zusammenhang mit meiner verschlüsselten (luks) Rootpartition habe. Beim schliessen des Container hängt er auch 90 Sekunden.

Du kannst das Timeout mit 7x drücken von stgr-alt-entf innerhalb von 2 sec. abbrechen.

...

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.360
Re: Beim Runterfahren: A stop job is running for Session....
« Reply #2 on: 2016/02/12, 07:53:42 »
Du kannst auch in /etc/systemd/system.conf den Wert für
Code: [Select]
DefaultTimeoutStopSec=90s
runterrsetzen

Offline musca

  • Global Moderator
  • User
  • *****
  • Posts: 725
  • sid, fly high!
Re: Beim Runterfahren: A stop job is running for Session....
« Reply #3 on: 2016/02/12, 10:23:52 »
Hallo spacepenguin,

Du kannst das Journal  des letzten Starts zu Rate ziehen:

Code: [Select]
export SYSTEMD_PAGER=less
journalctl -b -1


Man kann seitenweise blättern mit d(own) oder u(p).
Recht weit unten wird dort auch der Shutdown protokolliert.

Durch die starke Parallelisierung ist das Journal etwas unübersichtlich,
aber dort sollten theoretisch am Ende für jeden Dienst zwei (oder mehr) Zeilen stehen:
stopping servicename (~ Der Dienst erhält den Befehl sich zu beenden.)
stopped servicename  (~ Der Dienst hat sich beendet)

recht spät erscheinen dort:
Feb 12 00:09:05 sidbox systemd[1]: Unmounting /run/user/105...
Feb 12 00:09:05 sidbox systemd[1]: Unmounting /media/musca/USB DISK...
Feb 12 00:09:05 sidbox systemd[1]: Unmounting /run/user/1000...
 ...
Feb 12 00:09:05 sidbox systemd[1]: Unmounted /run/user/105.
Feb 12 00:09:05 sidbox systemd[1]: Unmounted /media/musca/USB DISK.
Feb 12 00:09:05 sidbox systemd[1]: Unmounted /run/user/1000.


Grüße
musca
„Es irrt der Mensch, solang er strebt.“  (Goethe, Faust)

Offline der_bud

  • User
  • Posts: 883
  • member
Re: Beim Runterfahren: A stop job is running for Session....
« Reply #4 on: 2016/02/12, 11:12:49 »
Wenn man an muscas journalctl-Zeile noch ein -e anhängt, springt man direkt zum Ende des Logs. Falls die letzten Shutdown-Meldungen nicht mehr ans Journal geschickt wurden, könnte dies hier helfen:  https://freedesktop.org/wiki/Software/systemd/Debugging/#shutdowncompleteseventually   (nicht selbst getestet).
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline spacepenguin

  • User
  • Posts: 863
    • spacepenguin.de
Re: Beim Runterfahren: A stop job is running for Session....
« Reply #5 on: 2016/02/12, 17:02:55 »
Danke euch :). Am Wochenende hab ich vermutlich wieder Zugriff auf den Rechner, dann werde ich das mal testen.
Susan | Hardware: SysProfile
Music-Profile: http://www.last.fm/de/user/spacepengu

Offline ralul

  • User
  • Posts: 1.809
Re: Beim Runterfahren: A stop job is running for Session....
« Reply #6 on: 2016/02/13, 20:35:49 »
Um die nicht quitierenden Tasks zu finden:
- nicht runterfahren, sondern melde dich nur ab
- Geh mit Strng+Alt+2 auf eine leere Console: melde dich an
- starte:   top -u DEIN_ANMELDENAME
---
Wenn man Lxqt als Desktop benutzt, dann hat man nach
dem ausloggen noch menu-cache am Laufen,
was leider auch die ganzen systemd --user
Sachen am Quitieren hindert.
experiencing siduction runs better than my gentoo makes me know I know nothing

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.731
    • g-com.eu
Re: Beim Runterfahren: A stop job is running for Session....
« Reply #7 on: 2016/02/13, 21:06:28 »
erm - ja
Wer hat eigentlich behauptet, dass kwin ne gute idee ist? Es kann natürlich auch sein, dass sddm mist baut - alles schon dagewesen - oder systemd ne macke hat. Vielleicht ist auch die lxqt-session mistig. Aber ganz eindeutig: ich glaube kaum, dass man menu-cache die schuld geben sollte, menu-cache wird erst in der Session gestartet - und soweit ich weiss, nur vom runner, dem Panel und eventuell pcmanfm-qt genutzt (bei dem müsste ich aber erst mal in die Sourcen schauen).

Fakt ist doch: Ich würde dem armen menu-cache nicht die schuld geben, wenn er noch da ist, wenn die session, die ihn erzeugt hat, schon lange tot ist - mein Vorschlag zu Güte: mal bite einen bug in https://github.com/lxde/lxqt - und bind den Fehler an lxqt-session - einfach ruhig erwähnen, dass das bei debian sid auftritt, aber auch bei gentoo, dann hat das ne höhere Dringlichkeit und man bindet das mir nicht ans Bein.

EDIT: Was sagen eigentlich die cgroups zu diesem Thema?
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline sunrat

  • User
  • Posts: 297
Re: Beim Runterfahren: A stop job is running for Session....
« Reply #8 on: 2016/02/22, 15:27:34 »
It may not be solely an LXQT issue. I have only Plasma5 and regularly get a 1m30s timeout for "A stop job is running for Session.... ". Not showing anything in journalctl so I will try the debugging soon.
Previously I had sometimes similar timeout for NetworkManager/wpasupplicant but sometimes would never stop. I recall aborting at 7m30s. I purged NM and configured with Ceni so that problem resolved. That also fixed a problem where KTorrent would crash networking/wlan0.

Quote
Du kannst das Timeout mit 7x drücken von stgr-alt-entf innerhalb von 2 sec. abbrechen.
This is useful to know.

Google translate -
Es kann nicht nur eine LXQT Problem sein. Ich habe nur Plasma5 und regelmäßig 1m30s Timeout für bekommen "Ein Stop-Job für Session läuft ....". Nicht alles, was in journalctl zeigen, damit ich die Fehlersuche  bald versuchen.
 Vorher hatte ich manchmal ähnliche Timeout für Networkmanager  / wpasupplicant aber manchmal würde nie aufhören. Ich erinnere mich an den Abbruch bei 7m30s. Ich gespült NM und konfiguriert mit Ceni, so dass Problem gelöst. Das Fest auch ein Problem, wo KTorrent würde Networking / wlan0 abstürzen.

Offline musca

  • Global Moderator
  • User
  • *****
  • Posts: 725
  • sid, fly high!
At shutdown: A stop job is running for Session....
« Reply #9 on: 2016/02/24, 18:38:59 »
hello,

holgerw pointed me to this thread and I talked to the systemd guys and got two remarks on the matter:

You could start debug-shell.service before the shutdown, then try `sudo -u musca systemctl --user list-jobs` in tty9 when it hangs

though "Session 1" isn't quite that, but `systemd-cgls` from the same debug shell would likely reveal it

greetings
musca

beware: if you permanently enable the debug-shell.service, this may be a security concern (local access to root shell)
„Es irrt der Mensch, solang er strebt.“  (Goethe, Faust)