seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/02/21, 04:41:40


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: lxqt - default application not setting  (Read 849 times)

0 Members and 1 Guest are viewing this topic.

Offline titan

  • User
  • Posts: 199
lxqt - default application not setting
« on: 2016/04/09, 18:39:04 »
I have just tried to set Chromium as my default browser in LXQT Configuration Centre - LXQT Session Settings - Default Applications - Web Browser  I can change it to Chromium but it just reverts to Firefox , changing the terminal works fine.

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.563
  • we are the priests ... of the temples of syrinx
Re: lxqt - default application not setting
« Reply #1 on: 2016/04/09, 20:19:25 »
I have my browsers in opt, so you would have to adjust accordingly and I don't use/like chromium

Code: [Select]
update-alternatives --install /usr/bin/x-www-browser x-www-browser /opt/firefox 90

update-alternatives --set x-www-browser /opt/firefox
"We're all grown up and don't freak out when a piece of text contains the word 'fuck'. I still don't understand why people think that the word 'fuck' is what would keep certain groups from contributing to the Linux kernel. In all seriousness, it doesn't."

John Paul Adrian Glaubitz

Offline titan

  • User
  • Posts: 199
Re: lxqt - default application not setting
« Reply #2 on: 2016/04/09, 22:54:10 »
I have set it with update-alternatives but it makes no difference. The problem is opening links, general use I just open the browser I want. I eventually found changing openbox config from Iceweasel back to x-www-browser fixed it which I though odd as I use kwin with LXQT and also had the problem with i3.

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.580
    • g-com.eu
Re: lxqt - default application not setting
« Reply #3 on: 2016/04/09, 23:43:23 »
there are many Applications out in the wild that use own settings for prefered browsers - one of these applications is thunderbird/frosted_duck or so

Edit: and before i forget - there are alternatives for x-www-browser, gnome-browser etc pp
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline titan

  • User
  • Posts: 199
Re: lxqt - default application not setting
« Reply #4 on: 2016/04/10, 12:18:03 »
The problem was actually highlighted when I opened a link in Signal (beta) messenger on i3 , Signal has no way to change preferred applications so I changed to LXQT to find the same problem with trying to set Chromium as my default browser.