seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2017/05/28, 10:33:47


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Unable to boot kernel 4.5.2-towo1  (Read 965 times)

0 Members and 1 Guest are viewing this topic.

Offline bokoto

  • User
  • Posts: 16
Unable to boot kernel 4.5.2-towo1
« on: 2016/04/22, 11:49:05 »
I upgraded manually to linux 4.5.2 yesterday from 4.4. but I cant get it to boot - I get a blank screen with no errors and it hangs there forever. I can go back and boot 4.4 fine. The initrd and vmlinuz files are in the boot directory as expected. Grub sees the new kernel and lists it in the boot menu. Grub.cfg seems pretty much standard and i haven't touched it. I have a UEFI setup running LXQT. Any ideas will be appreciated!

Offline samoht

  • User
  • Posts: 169
Re: Unable to boot kernel 4.5.2-towo1
« Reply #1 on: 2016/04/22, 12:49:34 »
Some additional info helpful (needed), for instance regarding graphics card:

Code: [Select]
hwinfo | grep -A 14 "VGA compatible controller (VGA)"or
Code: [Select]
inxi -Gor
Code: [Select]
lspci -v  | grep -A 1 "VGA compatible controller"
Greetings
Tom
« Last Edit: 2016/04/22, 13:01:47 by samoht »

Offline bokoto

  • User
  • Posts: 16
Re: Unable to boot kernel 4.5.2-towo1
« Reply #2 on: 2016/04/22, 12:58:17 »
Some additional info helpful (needed), for instance regarding graphics card:

Code: [Select]
hwinfo | grep -A 14 "VGA compatible controller (VGA)"
Greetings
Tom

Hello,thanks for your response -  here is the graphic info :

11: PCI 02.0: 0300 VGA compatible controller (VGA)
  [Created at pci.366]
  Unique ID: _Znp.jIM9UTIoqKE
  SysFS ID: /devices/pci0000:00/0000:00:02.0
  SysFS BusID: 0000:00:02.0
  Hardware Class: graphics card
  Model: "Intel Mobile 4 Series Chipset Integrated Graphics Controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x2a42 "Mobile 4 Series Chipset Integrated Graphics Controller"
  SubVendor: pci 0x103c "Hewlett-Packard Company"
  SubDevice: pci 0x30e1
  Revision: 0x07
  Driver: "i915"
  Driver Modules: "drm"
  Memory Range: 0xd0000000-0xd03fffff (rw,non-prefetchable)

However I have had no graphic  issues with it so far, running 4.4.1. I also have Gnome 3.20 on the same disk running on 4.5 with no problems.

Offline samoht

  • User
  • Posts: 169
Re: Unable to boot kernel 4.5.2-towo1
« Reply #3 on: 2016/04/22, 13:15:20 »
Had such an idea, pls look at (in German, unfortunately)

http://forum.siduction.org/index.php?topic=6088.msg50179#msg50179
and
http://forum.siduction.org/index.php?topic=6075.msg50057#msg50057

Perhaps, try also grub start parameters

Code: [Select]
i915.modeset=0
or
nomodeset


In my case it was a computer of a friend of mine with the same (?) Intel Corporation 4 Series Chipset Integrated Graphics Controller, which booted into a black screen after installing a new kernel.
DE: KDE Plasma5

« Last Edit: 2016/04/22, 13:48:17 by samoht »

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.065
Re: Unable to boot kernel 4.5.2-towo1
« Reply #4 on: 2016/04/22, 13:47:04 »
Can you try


apt purge xserver-xorg-video-intel


and reboot?


And please, do not disable KMS for that.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline bokoto

  • User
  • Posts: 16
Re: Unable to boot kernel 4.5.2-towo1
« Reply #5 on: 2016/04/22, 14:16:36 »
Can you try


apt purge xserver-xorg-video-intel


and reboot?


And please, do not disable KMS for that.


Hello, Thanks for the suggestion - however removing the xorg video intel did not solve the issue. I still get the blank screen after grub. On the other hand, I tried the clearlinux 4.5 kernel and it booted ok but then it comes up with some warnings about powerclamp intel not supported on my cpu ,and subsequently turns off lxqt power management so I have no battery detection at all. Apart from that I still have not been able to boot any 4.5 siduction kernel.

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.065
Re: Unable to boot kernel 4.5.2-towo1
« Reply #6 on: 2016/04/22, 14:21:15 »
Please boot again with 4.5 and hit "e" at grub-screen, then navigat to the line which begins with linux and remove quiet from that line, hit ctrl +x to boot up now. Hopefully you see some relevant messages without the "quiet" which helps to investigate, whatÄs going wrong.
« Last Edit: 2016/04/22, 14:26:19 by towo »
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline bokoto

  • User
  • Posts: 16
Re: Unable to boot kernel 4.5.2-towo1
« Reply #7 on: 2016/04/22, 14:57:32 »
Please boot again with 4.5 and hit "e" at grub-screen, then navigat to the line which begins with linux and remove quiet from that line, hit ctrl +x to boot up now. Hopefully you see some relevant messages without the "quiet" which helps to investigate, whatÄs going wrong.


I have removed the quiet from the grub linux line - nothing happens - normally there would be some disk activity but here nothing - just a blank screen with the backlight on, no cursor. and It just doesn't progress from here. No warning no errors, nothing.

Offline bokoto

  • User
  • Posts: 16
Re: Unable to boot kernel 4.5.2-towo1
« Reply #8 on: 2016/04/22, 15:22:08 »
Had such an idea, pls look at (in German, unfortunately)

http://forum.siduction.org/index.php?topic=6088.msg50179#msg50179
and
http://forum.siduction.org/index.php?topic=6075.msg50057#msg50057

Perhaps, try also grub start parameters

Code: [Select]
i915.modeset=0
or
nomodeset


In my case it was a computer of a friend of mine with the same (?) Intel Corporation 4 Series Chipset Integrated Graphics Controller, which booted into a black screen after installing a new kernel.
DE: KDE Plasma5


Hi, thanks for your response
 i915.modeset=0 results in non-bootable system - so I guess it is not KMS that is causing the problem

Offline bokoto

  • User
  • Posts: 16
Re: Unable to boot kernel 4.5.2-towo1
« Reply #9 on: 2016/04/22, 15:47:36 »
Ok so far just a summary - 4.4.0/1 boots always ok - no errors, 4.5 clearlinux boots ok with no power management , 4.5.1/4.5.2 siduction does not boot at all - no errors no warnings - <i tend to believe there must be something unrelated to the video driver since if this was the case, i would normally get some artifacts at boot screen.


Ok finally something  - I installed
4.5.0-1-amd64 #1 SMP Debian 4.5.1-1 (2016-04-14) x86_64 GNU/Linux


and it booted just fine - i will stick to it for now and possibly continue with the towo - siduction kernels when i get the time .

« Last Edit: 2016/04/22, 16:12:32 by bokoto »