seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2017/02/25, 19:16:31


Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [solved] linux-headers-3.19.3 missing  (Read 623 times)

0 Members and 1 Guest are viewing this topic.

Offline paxmark2

  • User
  • Posts: 67
[solved] linux-headers-3.19.3 missing
« on: 2016/05/22, 18:22:52 »
My / on my ssd  is smaller than optimal.  I keep deleting things when it gets too big.  In /var I  deleted) some linux-headers-3.xx that I thought was old old invalid headers after I installed a new kernel.  Silly me.


On an apt-get dist-upgrade I got some warnings, and they continue

Code: [Select]
sudo apt-get install libdatetime-perl
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be upgraded:
  libdatetime-perl
1 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.     
[size=78%]                                                                                                                      [/size]
                                                     
####     a little skipped here, the update went well
                                                                             
Code: [Select]
Retrieving bug reports... Done                                                                                                                                                                                                               
Parsing Found/Fixed information... Done                                                                                                                                                                                                     
Reading changelogs... Done                                                                                                                                                                                                                   
dpkg: warning: files list file for package 'linux-headers-3.19.3-towo.3-siduction-amd64' missing; assuming package has no files currently installed                                                                                         
dpkg: warning: files list file for package 'linux-headers-3.18-5.towo.3-siduction-amd64' missing; assuming package has no files currently installed                                                                                         
dpkg: warning: files list file for package 'linux-headers-3.17-5.towo-siduction-amd64' missing; assuming package has no files currently installed                                                                                           
(Reading database ... 184912 files and directories currently installed.)     


I saw elsewhere - something similar on Ubuntu 13.04 and did (I have used these commands before)
 
Code: [Select]
sudo dpkg --configure -a
sudo apt-get -f install
sudo rm /var/lib/apt/lists/* -rf
sudo apt-get update   
Then I tried "apt-get remove ncdu"  followed by "apt-get install ncdu.  It still comlains about missing headers


So I did and apt-get install of the three linux-headers-3 ...   the important lines were


Code: [Select]
linux-headers-3.19.3-towo.3-siduction-amd64 is already the newest version (3.19-12).
linux-headers-3.19.3-towo.3-siduction-amd64 is already the newest version (3.19-12).
linux-headers-3.17-5.towo-siduction-amd64 is already the newest version (3.17-13).


It still continues with further updates, but causes no problems.  I do not have these headers listed as available on 2 Debian testing installs -  searched via aptitude search.  In siduction


Code: [Select]
apt-cache search linux-headers-3
linux-headers-3.18-6.towo-siduction-amd64 - Header files for Linux 3.18-6.towo-siduction-amd64
linux-headers-3.19-0.towo-siduction-amd64 - Header files for Linux 3.19-0.towo-siduction-amd64
linux-headers-3.19-0.towo.2-siduction-amd64 - Header files for Linux 3.19-0.towo.2-siduction-amd64
linux-headers-3.19.0-0.towo.3-siduction-amd64 - Header files for Linux 3.19.0-0.towo.3-siduction-amd64
linux-headers-3.19.1-towo.1-siduction-amd64 - Header files for Linux 3.19.1-towo.1-siduction-amd64
linux-headers-3.19.1-towo.2-siduction-amd64 - Header files for Linux 3.19.1-towo.2-siduction-amd64
linux-headers-3.19.1-towo.3-siduction-amd64 - Header files for Linux 3.19.1-towo.3-siduction-amd64
linux-headers-3.19.2-towo.1-siduction-amd64 - Header files for Linux 3.19.2-towo.1-siduction-amd64
linux-headers-3.19.2-towo.2-siduction-amd64 - Header files for Linux 3.19.2-towo.2-siduction-amd64
linux-headers-3.19.3-towo.1-siduction-amd64 - Header files for Linux 3.19.3-towo.1-siduction-amd64
linux-headers-3.19.3-towo.2-siduction-amd64 - Header files for Linux 3.19.3-towo.2-siduction-amd64
linux-headers-3.19.3-towo.3-siduction-amd64 - Header files for Linux 3.19.3-towo.3-siduction-amd64
linux-headers-3.7-3.7-10.towo-siduction-amd64 - Header files for Linux 3.7-10.towo-siduction-amd64
linux-headers-3.7-siduction-amd64 - Linux header for siduction on 64-bit PCs
linux-headers-35-3.5-6.towo-siduction-amd64 - Header files for Linux 3.5-6.towo-siduction-amd64
linux-headers-35-siduction-amd64 - Linux header for siduction on 64-bit PCs
linux-headers-3.18-5.towo.3-siduction-amd64 - Header files for Linux 3.18-5.towo.3-siduction-amd64
linux-headers-3.17-5.towo-siduction-amd64 - Header files for Linux 3.17-5.towo-siduction-amd64
 


Beautiful day, enjoy.
« Last Edit: 2016/06/06, 01:32:45 by musca »

Offline absolut

  • User
  • Posts: 307
on my workstation uname -a tells me
Code: [Select]
Linux sidbox 4.5.5-towo.1-siduction-amd64 #1 SMP PREEMPT siduction 4.5-11 (2016-05-19) x86_64 GNU/Linux
when is it that you ran apt dist-upgrade; when was your last kernel update?

for kernel / header removal please use the dedicated application "kernel-remover"

Offline paxmark2

  • User
  • Posts: 67
Code: [Select]
uname -a
Linux rauneseee 4.5.5-towo.1-siduction-amd64 #1 SMP PREEMPT siduction 4.5-11 (2016-05-19) x86_64 GNU/Linux


I added the new kernel maybe 2 days ago.  journalct -b -0 after reboot into new kernel showed no new flaws  And as I was getting over 90% full on / I did a little pruning on /var/cache/apt/ archives and stumbled upon some linux-headers-3.xx elsewhere and deleted them.  "kernel-remove" was done prior to the deleing, I let kernel 4.3 go and now have the above and 4.5.1-towo.3 as a backup.   

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 3.849
If you use apt install instead of apt-get install, you do not need to worry about /var/cache/apt/archives anymore. apt does not keep debs of installed packages anymore, apt-get does. That also goes for apt-get dist-upgrade vs. apt dist-upgrade.


greetz
devil

Offline paxmark2

  • User
  • Posts: 67
Devil, yes, thanks.  On a new testing install on new computer, I have moved to apt.  I am using apt more on my siduction box here. 


Next thing for me to do is look more at apt-cache of the old linux-headers-3.xx that I have only in Siduction.  But I am getting paid overtime to spend 12 hours with a friend in the hospital., and it is just warnings. 

Offline paxmark2

  • User
  • Posts: 67
Trying to add solved to the top, oh well.

I finally got rid of the warning messages via going to the 4.6.1. kernel, removing all the linuxheaders 3.17 3.18 and 3.19 and dpkg-reconfigure linux-image-4.6.1-towo.1-siduction-amd64
« Last Edit: 2016/06/05, 21:22:19 by paxmark2 »