seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2017/12/15, 11:13:53


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Problems with bumblebee / nvidia driver  (Read 1347 times)

0 Members and 1 Guest are viewing this topic.

Offline Pergola

  • User
  • Posts: 9
Problems with bumblebee / nvidia driver
« on: 2016/11/21, 20:07:47 »
Hello everybody,

I have these two gpus:

Code: [Select]
>lspci | egrep -i "3D|vga|video"
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06)
01:00.0 VGA compatible controller: NVIDIA Corporation GM206M [GeForce GTX 965M] (rev a1)

If I set update-alternatives to nvidia or bumblebee, everything freezes in the middle of booting, probably at the attempt to start X. If I set it to the mesa driver, the system boots normally. I can change back to the bumblebee driver, do

Code: [Select]
>service bumblebeed restart
and successfully use optirun for SOME applications, e.g. glxgears. However, other applications won't run (steam, some exe-files with wine...)


Examples:

Code: [Select]
>optirun steam
Running Steam on debian  64-bit
STEAM_RUNTIME is enabled automatically
[2016-11-21 20:02:11] Startup - updater built Oct 13 2016 00:47:16
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)

(or is this a 32bit vs. 64bit problem?? How to solve that?)

Code: [Select]
>optirun wine daorigins.exe
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object 'libvglfaker.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object 'libvglfaker.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object 'libvglfaker.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object 'libvglfaker.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object 'libvglfaker.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object 'libvglfaker.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object 'libvglfaker.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object 'libvglfaker.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object 'libvglfaker.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object 'libvglfaker.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
err:module:import_dll Library fmod_event.dll (which is needed by L"Z:\\Programme\\Dragon Age\\daorigins.exe") not found
err:module:import_dll Library fmodex.dll (which is needed by L"Z:\\Programme\\Dragon Age\\daorigins.exe") not found
err:module:import_dll Library NxCharacter.dll (which is needed by L"Z:\\Programme\\Dragon Age\\daorigins.exe") not found
err:module:import_dll Library NxCooking.dll (which is needed by L"Z:\\Programme\\Dragon Age\\daorigins.exe") not found
err:module:import_dll Library SpeedTreeRT.dll (which is needed by L"Z:\\Programme\\Dragon Age\\daorigins.exe") not found
err:module:import_dll Library binkw32.dll (which is needed by L"Z:\\Programme\\Dragon Age\\daorigins.exe") not found
err:module:import_dll Library umbra.dll (which is needed by L"Z:\\Programme\\Dragon Age\\daorigins.exe") not found
err:module:LdrInitializeThunk Main exe initialization for L"Z:\\Programme\\Dragon Age\\daorigins.exe" failed, status c0000135

Can someone please help me? What is wrong with the libraries? Why does X not start with nvidia / bumblebee set in update-alternatives for glx? (I also tried to configure the nvidia card in xorg.conf - result: still no complete booting plus strange flickering)
« Last Edit: 2016/11/21, 21:00:52 by musca »

Offline whistler_mb

  • User
  • Posts: 120
Re: Problems with bumblebee / nvidia driver
« Reply #1 on: 2016/11/22, 10:08:16 »
For 32bit applications you have to use primusrun with the 32bit primus-libs.
Code: [Select]
$ apt-cache policy primus
primus:
  Installiert:           0~20150328-4
  Installationskandidat: 0~20150328-4
  Versionstabelle:
 *** 0~20150328-4 500
        500 http://ftp.de.debian.org/debian unstable/main amd64 Packages
        500 http://ftp.de.debian.org/debian testing/main amd64 Packages
        100 /var/lib/dpkg/status
     0~20140711-1 500
        500 http://ftp.de.debian.org/debian stable/main amd64 Packages
Code: [Select]
$ apt-cache policy primus-libs:i386
primus-libs:i386:
  Installiert:           0~20150328-4
  Installationskandidat: 0~20150328-4
  Versionstabelle:
 *** 0~20150328-4 500
        500 http://ftp.de.debian.org/debian unstable/main i386 Packages
        500 http://ftp.de.debian.org/debian testing/main i386 Packages
        100 /var/lib/dpkg/status
     0~20140711-1 500
        500 http://ftp.de.debian.org/debian stable/main i386 Packages

Offline Pergola

  • User
  • Posts: 9
Re: Problems with bumblebee / nvidia driver
« Reply #2 on: 2016/11/22, 18:01:13 »
Thanks, this solves at least the problem with steam!

Is anybody out there who uses bumblebee? Probably you don't have to change the glx-driver all the time from mesa to bumblebee and back in order to boot properly?

Offline whistler_mb

  • User
  • Posts: 120
Re: Problems with bumblebee / nvidia driver
« Reply #3 on: 2016/11/22, 18:44:44 »
I use bumblebee  ;)

X runs with the intel/mesa driver. For games (win und Linux) I use primusrun.

Code: [Select]
$ inxi -G
Graphics:  Card-1: Intel 4th Gen Core Processor Integrated Graphics Controller
           Card-2: NVIDIA GK106M [GeForce GTX 765M]
           Display Server: X.Org 1.18.4 driver: intel Resolution: 1920x1080@60.00hz, 1920x1080@60.00hz
           GLX Renderer: Mesa DRI Intel Haswell Mobile GLX Version: 3.0 Mesa 12.0.4

Code: [Select]
$ optirun inxi -G
Graphics:  Card-1: Intel 4th Gen Core Processor Integrated Graphics Controller
           Card-2: NVIDIA GK106M [GeForce GTX 765M]
           Display Server: X.Org 1.18.4 driver: intel Resolution: 1920x1080@60.00hz, 1920x1080@60.00hz
           GLX Renderer: GeForce GTX 765M/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 367.57

Offline Pergola

  • User
  • Posts: 9
Re: Problems with bumblebee / nvidia driver
« Reply #4 on: 2016/11/22, 22:15:57 »
Mine right after start (update-alternatives=mesa):

Code: [Select]
$ inxi -G
Graphics:  Card-1: Intel HD Graphics 530
           Card-2: NVIDIA GM206M [GeForce GTX 965M]
           Display Server: X.Org 1.18.4 driver: N/A Resolution: 1920x1080@60.02hz
           GLX Renderer: Mesa DRI Intel HD Graphics 530 (Skylake GT2)
           GLX Version: 3.0 Mesa 12.0.4
$ optirun inxi -G
[  804.076734] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
[  804.076787] [ERROR]Could not connect to bumblebee daemon - is it running?

If I then set update-alternatives to bumblebee and attempt to start inxi - G again, everything instantly freezes and I have to force-reboot...


P.S. I also solved the problem with wine daorigins.exe. It had nothing to do with the bumblebee issue, I just had to move dlls. Still, the other problem remains: I have to switch the glx driver every time I want to use bumbebee and then change it back when I shutdown in order to boot correctly again.
« Last Edit: 2016/11/23, 00:50:17 by Pergola »

Offline whistler_mb

  • User
  • Posts: 120
Re: Problems with bumblebee / nvidia driver
« Reply #5 on: 2016/11/23, 14:19:32 »
I think your bumblebee installation is borked.

You should remove everything with bumblebee. And probably also the whole nvidia staff.
Look in /etc/X11/xorg.d.conf/ if there are conf-files for intel or nvidia and move them to another directory.
Delete the bumblebee folder in /etc/.

Reboot. Your system should now runs fine, hopefully  ;)

Now you can install the nvidia-driver. Then install bumblebee and primusrun (incl. 32bit libs). Don't make any changes to config-files. Check if your user is in the group bumblebee.

Now, the alternatives should be set to bumblebee
Code: [Select]
# LANG=C update-alternatives --config glx
There are 3 choices for the alternative glx (providing /usr/lib/glx).

  Selection    Path                       Priority   Status
------------------------------------------------------------
* 0            /usr/lib/nvidia/bumblebee   125       auto modehttps://forum.siduction.org/Smileys/default/rolleyes.gif
  1            /usr/lib/mesa-diverted      5         manual mode
  2            /usr/lib/nvidia             100       manual mode
  3            /usr/lib/nvidia/bumblebee   125       manual mode

Press <enter> to keep the current choice[*], or type selection number:

After a reboot you should now able to use primusrun (or optirun)
« Last Edit: 2016/11/23, 15:32:08 by whistler_mb »

Offline Pergola

  • User
  • Posts: 9
Re: Problems with bumblebee / nvidia driver
« Reply #6 on: 2016/11/24, 20:42:02 »
I followed your steps, but  unfortunately the screen still freezes at boot.

Offline Pergola

  • User
  • Posts: 9
Re: Problems with bumblebee / nvidia driver
« Reply #7 on: 2016/11/29, 23:26:10 »
OK... today I did an update and it works! I don't really know why, but I saw that xserver-packages were upgraded. Maybe they were responsible for the problem...?

Offline whistler_mb

  • User
  • Posts: 120
Re: Problems with bumblebee / nvidia driver
« Reply #8 on: 2016/12/01, 11:25:54 »
This is SID! Everything is possible  ;)

Offline Pergola

  • User
  • Posts: 9
Re: Problems with bumblebee / nvidia driver
« Reply #9 on: 2016/12/03, 12:12:57 »
Hmm... it's not solved completely. If I do

Code: [Select]
ssystemctl enable bumblebeed.service
my old problem is back. As long as the service is disabled, booting and shutdown works with bumblebee being set in update-alternatives. However, before I could use primusrun, I had to perform

Code: [Select]
service bumblebeed start.

Now I put this line into /etc/rc.local, which works fine. However, now I get a freeze during shutdown. Stoping the service in rc0.d does not work. I assume it is called to late. Is there a way to execute a script automatically as root before X is terminated?