seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/12/06, 21:29:46


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [solved] Warnig: No dist-upgrade  (Read 10768 times)

0 Members and 1 Guest are viewing this topic.

Offline harley-peter

  • User
  • Posts: 798
Re: Warnig: No dist-upgrade
« Reply #75 on: 2016/12/09, 10:54:49 »
@devil:
danke, da hätte ich auch selbst drauf kommen können.  ???

@geier0815:
Thank you for the link. I think it is better to wait yet.  :(

Offline dsat

  • User
  • Posts: 98
Re: Warnig: No dist-upgrade
« Reply #76 on: 2016/12/09, 12:32:02 »
Hi,

I am running a pure debian sid and since days d-u wants to remove nvidia-driver and xserver-xorg-video-nvidia. Yesterday I let it go and found myself on a console on reboot. I opened experimental in the sources list and installed nvidia-driver and xserver-xorg-video-nvidia from experimental. That worked for me.

Regards dsat

Offline seasons

  • User
  • Posts: 239
Re: Warnig: No dist-upgrade
« Reply #77 on: 2016/12/09, 13:45:54 »
@dsat: If you had just waited another day or two, you wouldn't have needed to install anything from experimental: https://packages.qa.debian.org/n/nvidia-graphics-drivers/news/20161208T165034Z.html

@harley-peter: Debian is waiting on Nvidia to update their proprietary legacy drivers:

Nvidia 340.xx bug:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=845640

Nvidia 304.xx bug:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=845639

Offline OppaErich

  • OLE
  • User
  • Posts: 375
Re: Warnig: No dist-upgrade
« Reply #78 on: 2016/12/09, 16:20:25 »
Seems the wait is over
Code: [Select]
root@oppa-hex-ssd:~# apt full-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  nvidia-egl-common nvidia-egl-icd
The following packages will be upgraded:
  gir1.2-clutter-gst-3.0 gstreamer1.0-clutter-3.0 libclutter-gst-3.0-0 libegl-nvidia0 libegl1-glvnd-nvidia libfdt1 libgl1-nvidia-glx libgl1-nvidia-glx:i386 libgldispatch0-nvidia libinput-bin libinput10
  libjs-angularjs liblirc-client0 liblircclient0 libmozjs-24-0 libmozjs185-1.0 libnvidia-eglcore libnvidia-glcore libnvidia-glcore:i386 libnvidia-ml1 libpng16-16 libpng16-16:i386 libservlet3.1-java
  libsmbclient libtomcat8-java libwbclient0 nvidia-alternative nvidia-driver nvidia-driver-bin nvidia-driver-libs nvidia-kernel-dkms nvidia-kernel-support nvidia-legacy-check nvidia-vdpau-driver
  preview-latex-style samba-common samba-libs xserver-xorg-video-nvidia
38 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 49.7 MB of archives.
After this operation, 424 kB of additional disk space will be used.
Does this glue the GPU to the bus ? My GPU has a habit of falling off it.  :-\

Offline terroreek

  • User
  • Posts: 169
Re: Warnig: No dist-upgrade
« Reply #79 on: 2016/12/10, 00:36:30 »
Hmm ... I just upgraded this what my dist-upgrade looks like

Code: [Select]
The following NEW packages will be installed:
  libgnutls-dane0 libunbound2 linux-headers-4.8.12-towo.2-siduction-amd64 linux-image-4.8.12-towo.2-siduction-amd64
  nvidia-egl-common nvidia-egl-icd
The following packages will be upgraded:
  conky conky-all coreutils crda cryptsetup cryptsetup-bin cups-browsed cups-filters cups-filters-core-drivers
  exfat-utils ffmpeg gir1.2-clutter-gst-3.0 glances grep gstreamer1.0-clutter-3.0 guile-2.0-libs iso-codes libaprutil1
  libaprutil1-dbd-sqlite3 libaprutil1-ldap libav-tools libavcodec-extra libavcodec-extra57 libavdevice57 libavfilter6
  libavformat57 libavresample3 libavutil55 libclutter-gst-3.0-0 libcryptsetup4 libcupsfilters1 libegl-nvidia0
  libegl1-glvnd-nvidia libfontembed1 libgl1-nvidia-glx libgl1-nvidia-glx:i386 libgldispatch0-nvidia libgles-nvidia1
  libgles-nvidia2 libgles1-glvnd-nvidia libgles1-nvidia libgles2-glvnd-nvidia libgles2-nvidia libgnutls-openssl27
  libgnutls28-dev libgnutls30 libgnutls30:i386 libgnutlsxx28 libgraphicsmagick-q16-3 libinput-bin libinput10
  libjs-angularjs liblcms2-2 liblcms2-2:i386 liblcms2-utils liblirc-client0 liblircclient0 libmozjs-24-0
  libmozjs185-1.0 libnvidia-eglcore libnvidia-glcore libnvidia-glcore:i386 libnvidia-ml1 libopenconnect5
  libparted-fs-resize0 libparted2 libpcsclite1 libpcsclite1:i386 libpkcs11-helper1 libpng-dev libpng16-16
  libpng16-16:i386 libpostproc54 libsmbclient libswresample2 libswscale4 libtiff5 libtiff5:i386 libwayland-bin
  libwayland-client0 libwayland-client0:i386 libwayland-cursor0 libwayland-cursor0:i386 libwayland-dev
  libwayland-server0 libwayland-server0:i386 libwbclient0 libwnck-common libwnck22 libxkbcommon-dev libxkbcommon-x11-0
  libxkbcommon0 libxkbcommon0:i386 libxrandr-dev libxrandr2 libxrandr2:i386 links linux-headers-siduction-amd64
  linux-image-siduction-amd64 network-manager-openconnect network-manager-openconnect-gnome nvidia-alternative
  nvidia-driver nvidia-driver-bin nvidia-driver-libs nvidia-kernel-dkms nvidia-kernel-support nvidia-legacy-check
  nvidia-smi nvidia-vdpau-driver nvidia-xconfig openconnect parted python-samba samba samba-common samba-common-bin
  samba-dsdb-modules samba-libs xserver-xorg-video-nvidia zlib1g zlib1g:i386 zlib1g-dev

Gnome is barfing after the upgrade. 

Offline CCarpenter

  • User
  • Posts: 195
    • http://www.greenvalleyranchschwand.de
Re: Warnig: No dist-upgrade
« Reply #80 on: 2016/12/10, 02:33:13 »
apt full-upgrade worked fine here ...

Offline OppaErich

  • OLE
  • User
  • Posts: 375
Re: Warnig: No dist-upgrade
« Reply #81 on: 2016/12/10, 11:58:58 »
Yeah, I knew this - why did I upgrade anyway ? Black screen and a working mouse pointer is all I get from this.  ::)

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.377
Re: Warnig: No dist-upgrade
« Reply #82 on: 2016/12/10, 13:52:05 »
Paste the output of
Code: [Select]
dpkg -l | grep xorg

Offline OppaErich

  • OLE
  • User
  • Posts: 375
Re: Warnig: No dist-upgrade
« Reply #83 on: 2016/12/10, 14:35:14 »
Hmm, there were no removals. I'll boot and join irc...

Offline DuckHunting

  • User
  • Posts: 11
Re: Warnig: No dist-upgrade
« Reply #84 on: 2016/12/10, 18:21:07 »
Yeah, I knew this - why did I upgrade anyway ? Black screen and a working mouse pointer is all I get from this.  ::)

Just wanted to say that Oppa Erich is not alone: I seem to have the same issues with a NVIDIA GPU as Oppa Erich. Mine is a GTX 970. Some time ago, with a kernel and/or nvidia-driver upgrade, I lost my sddm login screen, getting only a black screen. Nouveau was not working either with the 4K resolution of my Dell and produced flickering screens with 1024*768 goodness. At least, I got a working konsole.

Be it as it may, with the recent update of the kernel and the nvidia-driver, I directly boot into a black screen with no way out. The display goes into standby. Boot into recovery produces the same result, even with older kernels.

Nvidia-driver is from debian sid, kernel is standard siduction.

So, in case of a boot into darkness, is there any alternative to a new install? If not, could you please let me know when the new release will be available?

Thank you and kind regards
Duck Hunting
« Last Edit: 2016/12/10, 18:24:58 by DuckHunting »

Offline OppaErich

  • OLE
  • User
  • Posts: 375
Re: Warnig: No dist-upgrade
« Reply #85 on: 2016/12/10, 18:37:26 »
It seems it's not nvidia this time. I can't find any errors about it, the modules are loaded and I get the graphical mouse pointer and can move it around. I have to [Alt][Ctrl][F2] to get to a console. I do see "unrecoverable" errors about libclutter in journal and libclutter was updated too. looks like this a Gnome issue this time.

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.377
Re: Warnig: No dist-upgrade
« Reply #86 on: 2016/12/10, 19:57:58 »

Offline terroreek

  • User
  • Posts: 169
Re: Warnig: No dist-upgrade
« Reply #87 on: 2016/12/11, 04:56:48 »
thanks @devil

Looks like libmozjs-24-0 was updated and gnome is working fine again.  Version 24.2.0-5 confirmed working.

Offline OppaErich

  • OLE
  • User
  • Posts: 375
Re: Warnig: No dist-upgrade
« Reply #88 on: 2016/12/11, 11:02:48 »
Yeah, same here. Gnome up again.


Thanks devil

Offline musca

  • Global Moderator
  • User
  • *****
  • Posts: 725
  • sid, fly high!
Re: Warning: No dist-upgrade
« Reply #89 on: 2016/12/11, 14:40:35 »
Hello,
I'm happily closing the thread as it has reached the chinese lucky number of 88 replies.

Please feel free to open a new thread.

greetings
musca
« Last Edit: 2016/12/11, 15:47:10 by musca »
„Es irrt der Mensch, solang er strebt.“  (Goethe, Faust)