seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/12/01, 06:55:53


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [solved] problems with emacs  (Read 1081 times)

0 Members and 1 Guest are viewing this topic.

Offline cas

  • User
  • Posts: 401
[solved] problems with emacs
« on: 2016/12/30, 21:47:32 »
Code: [Select]
$ LANG=C apt-get dist-upgrade -s
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Error!
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 emacs : Depends: emacs24 or
                  emacs24-lucid but it is not going to be installed or
                  emacs24-nox but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

$ dpkg --get-selections | grep hold
$
« Last Edit: 2017/01/02, 23:18:34 by cas »

Offline cas

  • User
  • Posts: 401
Re: problems with emacs
« Reply #1 on: 2016/12/30, 22:08:37 »
after I purged meta package 'emacs' other packages are to be removed and some get newly installed.

Code: [Select]
LANG=C apt-get dist-upgrade -s
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  converseen emacs24 libmagick++-6.q16-5v5 libmagick++-6.q16-6v6 libmagickwand-6.q16-2
The following NEW packages will be installed:
  libmagickcore-6.q16-3 libmagickwand-6.q16-3 linux-headers-4.9.0-towo.2-siduction-amd64 linux-image-4.9.0-towo.2-siduction-amd64
The following packages will be upgraded:


Offline musca

  • Global Moderator
  • User
  • *****
  • Posts: 725
  • sid, fly high!
Re: problems with emacs
« Reply #2 on: 2016/12/31, 00:04:17 »
the dependency chain goes here:
emacs ▶ emacs24 ▶ libmagickwand-6.q16-2


but libmagickwand-6.q16-2 is to be replaced by libmagickwand-6.q16-3.

Just don't call it transition during the transition freeze.

greetings
musca
„Es irrt der Mensch, solang er strebt.“  (Goethe, Faust)

Offline cas

  • User
  • Posts: 401
Re: problems with emacs
« Reply #3 on: 2016/12/31, 00:25:09 »
I assume waiting will be just enough to get this resolved (automatically)

Offline cas

  • User
  • Posts: 401
Re: problems with emacs
« Reply #4 on: 2017/01/02, 23:17:40 »
waiting sufficed to solve it

Code: [Select]
$ LANG=C apt-get dist-upgrade -s
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  libmagick++-6.q16-5v5 libmagick++-6.q16-6v6 libmagickwand-6.q16-2
The following NEW packages will be installed:
  libmagick++-6.q16-7 libmagickcore-6.q16-3 libmagickwand-6.q16-3 linux-headers-4.9.0-towo.2-siduction-amd64 linux-image-4.9.0-towo.2-siduction-amd64
The following packages will be upgraded: