seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/09/20, 06:20:21


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: iwlwifi problems  (Read 1826 times)

0 Members and 1 Guest are viewing this topic.

Offline finotti

  • User
  • Posts: 99
iwlwifi problems
« on: 2017/01/30, 01:49:14 »
I'm having problems with the wifi of my Dell Latitude E7440.  It often loses internect connection (it says it is still connected to the network)  and then to reconnect I have to disconnect to the network and then reconnect (using the default widget in KDE -- Network Manager, maybe?).

Here are some of the errors I see:

Code: [Select]
$ journalctl -p err
[snitp]
Jan 29 17:04:04 e7440 kernel: iwlwifi 0000:02:00.0: Failed to wake NIC for hcmd
Jan 29 17:04:04 e7440 kernel: iwlwifi 0000:02:00.0: Error sending TXPATH_FLUSH: enqueue_hcmd failed: -5
Jan 29 17:04:04 e7440 kernel: iwlwifi 0000:02:00.0: Failed to send flush command (-5)
Jan 29 17:04:04 e7440 kernel: iwlwifi 0000:02:00.0: Failed to wake NIC for hcmd
Jan 29 17:04:04 e7440 kernel: iwlwifi 0000:02:00.0: Error sending REMOVE_STA: enqueue_hcmd failed: -5
Jan 29 17:04:04 e7440 kernel: iwlwifi 0000:02:00.0: Failed to remove station. Id=2
Jan 29 17:04:09 e7440 kernel: Bluetooth: hci0 command 0x0c03 tx timeout
Jan 29 17:04:17 e7440 kernel: Bluetooth: hci0 sending initial HCI reset command failed (-110)

Here is some information about the system:

Code: [Select]
$ inxi -v3
System:    Host: e7440 Kernel: 4.9.1-towo.1-siduction-amd64 x86_64 (64 bit gcc: 6.3.0)
           Desktop: KDE Plasma 5.8.4 (Qt 5.7.1) Distro: siduction 15.1.0 Paint It Black - kde - (201601162135)
Machine:   Device: laptop System: Dell product: Latitude E7440 v: 00
           Mobo: Dell model: 07F3F4 v: A00 BIOS: Dell v: A17 date: 12/01/2015
Battery    BAT0: charge: 64.4 Wh 134.3% condition: 48.0/64.4 Wh (74%) model: SMP DELL 909H538 status: Full
CPU:       Dual core Intel Core i7-4600U (-HT-MCP-) cache: 4096 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10778
           clock speeds: max: 3300 MHz 1: 2776 MHz 2: 2700 MHz 3: 2709 MHz 4: 2769 MHz
Graphics:  Card: Intel Haswell-ULT Integrated Graphics Controller bus-ID: 00:02.0
           Display Server: X.Org 1.19.0 driver: intel Resolution: 1920x1080@60.02hz
           GLX Renderer: Mesa DRI Intel Haswell Mobile GLX Version: 3.0 Mesa 13.0.2 Direct Rendering: Yes
Network:   Card-1: Intel Ethernet Connection I218-LM driver: e1000e v: 3.2.6-k port: f080 bus-ID: 00:19.0
           IF: eno1 state: down mac: 34:e6:d7:19:d5:4d
           Card-2: Intel Wireless 7260 driver: iwlwifi bus-ID: 02:00.0
           IF: wlp2s0 state: up mac: 48:51:b7:67:5b:a1
Drives:    HDD Total Size: 256.1GB (43.6% used)
           ID-1: model: SAMSUNG_SSD_PM85
Info:      Processes: 230 Uptime: 17 days Memory: 5209.8/7895.6MB Init: systemd runlevel: 5 Gcc sys: 6.3.0
           Client: Shell (bash 4.4.51) inxi: 2.3.5

Code: [Select]
$ inxi -Nn
Network:   Card-1: Intel Ethernet Connection I218-LM driver: e1000e
           IF: eno1 state: down mac: 34:e6:d7:19:d5:4d
           Card-2: Intel Wireless 7260 driver: iwlwifi
           IF: wlp2s0 state: up mac: 48:51:b7:67:5b:a1

Any help would be greatly appreciated.

Offline unklarer

  • User
  • Posts: 474
Re: iwlwifi problems
« Reply #1 on: 2017/01/30, 21:06:59 »
The error message is "standard" on the Internet.   ;)

I have here only the German explanation and find the link no more:
Quote
Es kann gut sein, dass du aufgrund von AMPDU gedrosselst wirst.

Bei manchen Nutzern tritt in Zusammenhang mit AMPDU ein Bug auf, der die Verbindung trennt. Intel's Treiberentwickler haben sich entschieden, AMPDU einfach für alle abzuschalten, um dies zu umgehen. Das verkrüppelt jedoch die Bandbreite. Ist natürlich Blödsinn, aber naja...

Mach mal folgende Zeile in /etc/modprobe.d/ampdu.conf, und reboote dann:
Code: [Select]
Code:
options iwlwifi 11n_disable=8

This is also referred to herein
https://wiki.archlinux.org/index.php/Wireless_network_configuration#iwlwifi


Offline finotti

  • User
  • Posts: 99
Re: iwlwifi problems
« Reply #2 on: 2017/01/30, 21:15:04 »
Thanks!  I will try that.