seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/02/28, 00:33:10


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: UEFI Patience USB  (Read 2390 times)

0 Members and 1 Guest are viewing this topic.

Offline MintChip

  • User
  • Posts: 6
UEFI Patience USB
« on: 2017/03/24, 05:14:44 »
Hello everyone. I am having issues getting a usb to boot from UEFI and I was hoping someone could help. I can easily create a mint 18.1 UEFI USB using Rufus in windows (GPT - UEFI Only setting) that boots but when I do the same thing with Siduction (same usb) I get a red box saying it is an invalid operating system. I also tried using the manual and a post from this site by formatted the USB using FAT32, dragged the files from the ISO on, and then tried the syslinux command (after unmounting) and it failed with invalid target outputs. I know I used the right device in the command too. Also ISO MD5 checked out. Am I missing something? Any help would be greatly appreciated. Thank you.
« Last Edit: 2017/03/24, 06:47:34 by MintChip »

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.331
Re: UEFI Patience USB
« Reply #1 on: 2017/03/24, 11:37:08 »
Don't use Rufus!
Don't try useless things like copy iso to fat32!


If you only have Windows, use win32diskimager or etcher.
On linux use dd, cat or cp and read our release notes!
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline cas

  • User
  • Posts: 401
Re: UEFI Patience USB
« Reply #2 on: 2017/03/24, 12:19:37 »
an usb-stick with siduction-ISO  works for me always using "dd" as described here:
https://manual.siduction.org/hd-ins-opts-oos

In some circumstances (but not siduction) I also have problems in creating working USB-sticks with an ISO. Could you therefore please elaborate on the why of your claims ?

Don't use Rufus!
Don't try useless things like copy iso to fat32!



Offline MintChip

  • User
  • Posts: 6
Re: UEFI Patience USB
« Reply #3 on: 2017/03/25, 03:33:42 »
Don't use Rufus!
Don't try useless things like copy iso to fat32!


If you only have Windows, use win32diskimager or etcher.
On linux use dd, cat or cp and read our release notes!

Thank you for your response. The copying/extracting the iso to fat32 came from this post. Rufus was a recommendation through internet searching. Why do you not recommend Rufus? It worked for linux mint and another distro. I am not sure why you have an adverse opinion of GUI applications. I am learning the command line but don't have a ton of time to dive into it fully and they are a big time time saver. Also, I am a little hesitant of doing formatting in the command line until I am fairly comfortable with the commands and options. Using my car as an analogy, I am willing to change spark plugs and the oil but I am still not comfortable enough changing the brake pads. Getting back on track, I will take your recommendation for windows formatting tools and give it a try.

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.395
Re: UEFI Patience USB
« Reply #4 on: 2017/03/25, 09:46:40 »
We are not generaly against the use of GUI apps. But in case where something goes wrong, we recommend those, because they are known to work. In this case, as we have negative experience witrh tools like UnetBootin and we don't know if Rufus works,  dd is a good example, so is apt vs. Synaptics e.g.


dd is quite simple:
Code: [Select]
dd if=/path_to_your_image of=/dev/sdX syncwhere X is your usb-stick.

Offline MintChip

  • User
  • Posts: 6
Re: UEFI Patience USB
« Reply #5 on: 2017/03/25, 22:14:04 »
We are not generaly against the use of GUI apps. But in case where something goes wrong, we recommend those, because they are known to work. In this case, as we have negative experience witrh tools like UnetBootin and we don't know if Rufus works,  dd is a good example, so is apt vs. Synaptics e.g.


dd is quite simple:
Code: [Select]
dd if=/path_to_your_image of=/dev/sdX syncwhere X is your usb-stick.

Thank you Devil. I was having the same issue with the recommended GUI apps as well (disk imager and etcher). I get a redbox at boot saying I have a secure boot violation when I select the usb device with UEFI in the name from the boot section of my BIOS. If I select the one without UEFI, I make it to the grub screen but when I go further the boot process freezes part way through. I will check where it freezes next time and put the information up here just in case that is my problem. With patience do we still use the syslinux command? I get an invalid target output when I use it so I am thinking not, but I wanted to check. Lastly, I tried the DD command and I hit the same issues as the GUI apps. A quick note, I am guessing you meant not to put 'sync' at the end of the DD command because I get an error that says "unrecognized operand 'sync'" output when that is added. It is strange because other distributions work using the GUI apps and they boot.

Edit - When I try to boot from the usb device without the UEFI in the name, I select From stock/HDD from the grub menu and the boot process freezes with 4 lines at the top of the screen. They are: Created slice User and Session Slice; Listening on udev Control Socket; Listing on Journal Socket, and Started Dispatch Password Requests... They all have a green "Ok".
« Last Edit: 2017/03/25, 22:48:05 by MintChip »

Offline MintChip

  • User
  • Posts: 6
Re: UEFI Patience USB
« Reply #6 on: 2017/03/25, 22:47:22 »
I listed below my secure boot settings in my BIOS just in case they help fix the issue.

Under Secure boot:
Secure Boot State: Enabled
Platform Key (PK) State: Loaded
OS Type: Windows UEFI mode

Under Compatibility Support Module
Launch CSM: Enabled
Boot Device Control: UEFI and Legacy OPROM
Boot from Network Devices: Legacy OPROM first
Boot from Storage Devices: Legacy OPROM first
Boot from PCI-E/PCI Expansion Devices: Legacy OPROM first
« Last Edit: 2017/03/26, 04:53:07 by MintChip »

Offline sunrat

  • User
  • Posts: 321
Re: UEFI Patience USB
« Reply #7 on: 2017/03/26, 01:35:28 »
You will never install most Linux with those settings.
Quote
Under Secure boot:
Secure Boot State: Enabled Disable this!
Platform Key (PK) State: Loaded
OS Type: Windows UEFI mode Change to Other OS or something like it

Under Compatibility Support Module
Launch CSM: Enabled Disable this (may work either way but may not)
Also disable "Fast Boot'.

Offline MintChip

  • User
  • Posts: 6
Re: UEFI Patience USB
« Reply #8 on: 2017/03/26, 05:02:39 »
You will never install most Linux with those settings.
Quote
Under Secure boot:
Secure Boot State: Enabled Disable this!
Platform Key (PK) State: Loaded
OS Type: Windows UEFI mode Change to Other OS or something like it

Under Compatibility Support Module
Launch CSM: Enabled Disable this (may work either way but may not)
Also disable "Fast Boot'.

Thank you Sunrat. I wasn't able to disable the secure boot state because it is greyed out in my BIOS. What I was able to do was change the OS Type to "Other OS" and disable CSM. That seemed to allow me to get to the Grub menu for the UEFI device. Unfortunately, the boot froze part way through. Basically tweaked out on my screen and then froze with either 3 or 4 lines at the top of the screen.

Offline sunrat

  • User
  • Posts: 321
Re: UEFI Patience USB
« Reply #9 on: 2017/03/26, 05:08:06 »
Disabling Secure Boot is essential. Did you try it again after changing OS Type?

Offline MintChip

  • User
  • Posts: 6
Re: UEFI Patience USB
« Reply #10 on: 2017/03/29, 04:53:58 »
Disabling Secure Boot is essential. Did you try it again after changing OS Type?
It appears there is no way to disable secure boot in my BIOS. What did change is the Boot section of the BIOS shows the keys for secure boot are unloaded when they were loaded before I changed the OS type. Since I was having so much trouble with getting the USB to boot, I just decided to use a distribution that is based on debian testing and change the repositories to Sid. Everything worked. I will try Siduction another time.

Offline LRC1962

  • User
  • Posts: 67
Re: UEFI Patience USB
« Reply #11 on: 2017/04/15, 13:25:35 »
On personal experience. Rufus only comes up with a no device found at boot no matter what you do. UnetBootin does not even recognize latest iso as valid boot iso. Ended up using ImageUSB which works fine. WARNING: Be very careful!!!!! Oneof the options it gives is your operating system drives. Stupid option but it is there.
Booted just fine and about three hours later had almost everything in place including Firefox with same profile setup as Windows.
PS: many thanks for 2017 iso!!!!!  ;D ;D Runs on Uefi boot with no tweaking. Am somewhat good at breaking and fixing OS's but Uefi still bugs me on the tweaking side.

Offline LRC1962

  • User
  • Posts: 67
Re: UEFI Patience USB
« Reply #12 on: 2017/04/15, 13:34:02 »
Disabling Secure Boot is essential. Did you try it again after changing OS Type?
It appears there is no way to disable secure boot in my BIOS. What did change is the Boot section of the BIOS shows the keys for secure boot are unloaded when they were loaded before I changed the OS type. Since I was having so much trouble with getting the USB to boot, I just decided to use a distribution that is based on debian testing and change the repositories to Sid. Everything worked. I will try Siduction another time.
I have an Acer laptop which has it greyed out. need to add password for bios then change the secure boot setting, then you can go back and change password to blank. Security boot will then be greyed out again, but the nonsecure boot option still holds. Note: For getting bios advice you need to get exact model of computer your are using as there are a thousand different versions out there. And trust me getting advice by Googling it is very hit and miss. Mostly miss.