seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/12/05, 18:40:29


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [Solved] WARNING: udisk2 is broken!  (Read 2819 times)

0 Members and 1 Guest are viewing this topic.

Online pjnsmb

  • User
  • Posts: 61
[Solved] WARNING: udisk2 is broken!
« on: 2017/08/29, 20:04:31 »
Debian Bug report logs - #873634


I updated to udisks2 2.7.2-1 and had delayed desktop opening and lost the use of gnome-disk-utility .


I had to resore a full back up before I saw this reported bug


Be warned about updating udisks2 which wants to install libblockdev-utils2 and  libblockdev2  as well
« Last Edit: 2017/09/05, 13:23:40 by devil »
regards
pjnsmb

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.308
Re: udisk2 bug report
« Reply #1 on: 2017/08/29, 21:06:16 »
Code: [Select]
apt install libblockdev-crypto2 libblockdev-mdraid2 libblockdev-part2 libblockdev-fs2 libblockdev-loop2 libblockdev-swap2
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline clubex

  • User
  • Posts: 265
Re: udisk2 bug report
« Reply #2 on: 2017/08/29, 22:56:15 »
Big thanks towo

Offline amdgoon

  • Newbie
  • Posts: 2
Re: udisk2 bug report
« Reply #3 on: 2017/08/29, 23:32:17 »
Thanks towo!

Offline drooghead

  • User
  • Posts: 19
Re: udisk2 bug report
« Reply #4 on: 2017/08/30, 06:09:36 »
Many thanks towo you saved my day and my urgent university project. I have to curb my addiction to upgrading.  :)

Offline sepps

  • User
  • Posts: 15
Re: WARNING: udisk2 is broken!
« Reply #5 on: 2017/08/30, 19:27:03 »
 8) thanks towo

Offline terroreek

  • User
  • Posts: 169
Re: WARNING: udisk2 is broken!
« Reply #6 on: 2017/08/31, 01:08:50 »
Thanks towo

If anyone is using gnome,  when you log in you see see this. 


Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.308
Re: WARNING: udisk2 is broken!
« Reply #7 on: 2017/08/31, 07:04:44 »
With todays update of libblockdev this problem is also history.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline Harakiri

  • User
  • Posts: 13
Re: WARNING: udisk2 is broken!
« Reply #8 on: 2017/08/31, 11:31:58 »
With todays update of libblockdev this problem is also history.

Unfortunately there is a problem with liblockdev-part2 which has become uninstallable. There is an obsolete(?) dependency missing.

Mentioned here:
https://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg1544602.html

https://www.mail-archive.com/debian-bugs-rc@lists.debian.org/msg472507.html

Offline Harakiri

  • User
  • Posts: 13
Re: WARNING: udisk2 is broken!
« Reply #9 on: 2017/09/01, 09:32:21 »
I'm happy again, today's libblockdev 2.12-2 got fixed.

Offline lexruee

  • User
  • Posts: 5
Re: WARNING: udisk2 is broken!
« Reply #10 on: 2017/09/04, 21:31:42 »
@terroreek:
Do you still have the issue? I'm using GNOME as well but I have "apt-marked" udisks2 to avoid the bug.


Offline DeepDayze

  • User
  • Posts: 409
Re: WARNING: udisk2 is broken!
« Reply #11 on: 2017/09/05, 04:16:18 »
Everything is working fine here so far :)

Offline Harakiri

  • User
  • Posts: 13
Re: WARNING: udisk2 is broken!
« Reply #12 on: 2017/09/05, 08:37:05 »
@lexruee
Since the latest libblock-files update, udisks2 is upgradable again.

Offline tommy2

  • User
  • Posts: 120
Re: WARNING: udisk2 is broken!
« Reply #13 on: 2017/09/05, 10:44:52 »
I'm new at this, but since everything works or is back to normal shouldn't this WARNING: be marked as resolved. Which brings up a question, who is responsible for doing that the originator or a moderator?  :-[


t2

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.377
Re: WARNING: udisk2 is broken!
« Reply #14 on: 2017/09/05, 13:23:15 »
If the thread-starter does not take care of this, at some point a team member will do that. I'll take care of it now.