seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/04/04, 18:39:40


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Boot-Fehler bei 4.15.x-Kerneln mit AMDGPU-Treiber  (Read 2013 times)

0 Members and 1 Guest are viewing this topic.

Offline DuckHunting

  • User
  • Posts: 11
Boot-Fehler bei 4.15.x-Kerneln mit AMDGPU-Treiber
« on: 2018/02/22, 22:17:54 »
Liebe Experten,

ich habe leider bei sämtlichen 4.15.x-Kerneln das Problem, dass der Bildschirm vor dem Start des Windowmanagers einfriert.

Hier ein paar Hintergrundinfos:

Code: [Select]
axel@linux:~$ inxi -v1
System:    Host: linux Kernel: 4.14.15-towo.1-siduction-amd64 x86_64 bits: 64 Desktop: KDE Plasma 5.12.1
           Distro: siduction 17.1.0 Patience - kde - (201703051755)
CPU:       Quad core Intel Core i7-7700 (-MT-MCP-) speed/max: 1400/3601 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480]
           Display Server: x11 (X.Org 1.19.6 ) drivers: ati,amdgpu (unloaded: modesetting,fbdev,vesa,radeon)
           Resolution: 3840x2160@60.00hz
           OpenGL: renderer: AMD Radeon RX 480 Graphics (POLARIS10 / DRM 3.19.0 / 4.14.15-towo.1-siduction-amd64, LLVM 5.0.
           version: 4.5 Mesa 17.3.5
Drives:    HDD Total Size: 4506.9GB (4.5% used)
Info:      Processes: 250 Uptime: 3 min Memory: 1772.0/16005.6MB Client: Shell (bash) inxi: 2.3.56

Das Journal enthält bei 4.15.x-Kerneln folgende Fehlermeldung, die bei der 4.14.x-Reihe nicht auftritt:

Code: [Select]
Feb 22 22:04:52 linux kernel: amdgpu 0000:01:00.0: firmware: failed to load amdgpu/polaris10_pfp_2.bin (-2)
Die aktuelle Version des Pakets amd-firmware-graphics ist installiert, stellt die fehlende Datei jedoch wohl nicht bereit:

Code: [Select]
axel@linux:~$ apt policy firmware-amd-graphics
firmware-amd-graphics:
  Installiert:           20170823-1
  Installationskandidat: 20170823-1
  Versionstabelle:
 *** 20170823-1 500
        500 http://deb.debian.org/debian unstable/non-free amd64 Packages
        100 /var/lib/dpkg/status

Code: [Select]
axel@linux:~$ apt show firmware-amd-graphics
Package: firmware-amd-graphics
Version: 20170823-1
Priority: optional
Section: non-free/kernel
Source: firmware-nonfree
Maintainer: Debian Kernel Team <debian-kernel@lists.debian.org>
Installed-Size: 18,8 MB
Suggests: initramfs-tools
Breaks: firmware-linux-nonfree (<< 20151018-1~)
Replaces: firmware-linux-nonfree (<< 20151018-1~)
Homepage: http://git.kernel.org/?p=linux/kernel/git/firmware/linux-firmware.git
Tag: admin::hardware, hardware::video, role::app-data, use::driver
Download-Size: 1.913 kB
APT-Manual-Installed: yes
APT-Sources: http://deb.debian.org/debian unstable/non-free amd64 Packages
Description: Binary firmware for AMD/ATI graphics chips
 This package contains the binary firmware for AMD/ATI graphics chips
 supported by the radeon, amdgpu and r128 drivers.
 .
 Contents:
  * amdgpu/carrizo_ce.bin
  * amdgpu/carrizo_me.bin
  * amdgpu/carrizo_mec.bin
  * amdgpu/carrizo_mec2.bin
  * amdgpu/carrizo_pfp.bin
  * amdgpu/carrizo_rlc.bin
  * amdgpu/carrizo_sdma.bin
  * amdgpu/carrizo_sdma1.bin
  * amdgpu/carrizo_uvd.bin
  * amdgpu/carrizo_vce.bin
  * amdgpu/fiji_ce.bin
  * amdgpu/fiji_mc.bin
  * amdgpu/fiji_me.bin
  * amdgpu/fiji_mec.bin
  * amdgpu/fiji_mec2.bin
  * amdgpu/fiji_pfp.bin
  * amdgpu/fiji_rlc.bin
  * amdgpu/fiji_sdma.bin
  * amdgpu/fiji_sdma1.bin
  * amdgpu/fiji_smc.bin
  * amdgpu/fiji_uvd.bin
  * amdgpu/fiji_vce.bin
  * amdgpu/polaris10_ce.bin
  * amdgpu/polaris10_k_smc.bin
  * amdgpu/polaris10_mc.bin
  * amdgpu/polaris10_me.bin
  * amdgpu/polaris10_mec.bin
  * amdgpu/polaris10_mec2.bin
  * amdgpu/polaris10_pfp.bin
  * amdgpu/polaris10_rlc.bin
  * amdgpu/polaris10_sdma.bin
  * amdgpu/polaris10_sdma1.bin
  * amdgpu/polaris10_smc.bin
  * amdgpu/polaris10_smc_sk.bin
  * amdgpu/polaris10_uvd.bin
  * amdgpu/polaris10_vce.bin
  * amdgpu/polaris11_ce.bin
  * amdgpu/polaris11_k_smc.bin
  * amdgpu/polaris11_mc.bin
  * amdgpu/polaris11_me.bin
  * amdgpu/polaris11_mec.bin
  * amdgpu/polaris11_mec2.bin
  * amdgpu/polaris11_pfp.bin
  * amdgpu/polaris11_rlc.bin
  * amdgpu/polaris11_sdma.bin
  * amdgpu/polaris11_sdma1.bin
  * amdgpu/polaris11_smc.bin
  * amdgpu/polaris11_smc_sk.bin
  * amdgpu/polaris11_uvd.bin
  * amdgpu/polaris11_vce.bin
  * amdgpu/polaris12_ce.bin
  * amdgpu/polaris12_mc.bin
  * amdgpu/polaris12_me.bin
  * amdgpu/polaris12_mec.bin
  * amdgpu/polaris12_mec2.bin
  * amdgpu/polaris12_pfp.bin
  * amdgpu/polaris12_rlc.bin
  * amdgpu/polaris12_sdma.bin
  * amdgpu/polaris12_sdma1.bin
  * amdgpu/polaris12_smc.bin
  * amdgpu/polaris12_uvd.bin
  * amdgpu/polaris12_vce.bin
 [...] 

Könntet Ihr mir einen Tipp geben?

Danke und LG

Axel
« Last Edit: 2018/02/22, 22:21:53 by DuckHunting »

Online towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.333
Re: Boot-Fehler bei 4.15.x-Kerneln mit AMDGPU-Treiber
« Reply #1 on: 2018/02/23, 10:05:33 »
Allse was polaris im Namen hat von hier downloaden:

https://github.com/wkennington/linux-firmware/tree/master/amdgpu

und entsprechend nach /lib/firmware/amdgpu/ kopieren.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline DuckHunting

  • User
  • Posts: 11
Re: Boot-Fehler bei 4.15.x-Kerneln mit AMDGPU-Treiber
« Reply #2 on: 2018/02/23, 11:54:59 »
Danke für die rasche Hilfe!

Quote
Alles was polaris im Namen hat von hier downloaden

Also auch die Polaris11 und Polaris12-Dateien?

Online towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.333
Re: Boot-Fehler bei 4.15.x-Kerneln mit AMDGPU-Treiber
« Reply #3 on: 2018/02/23, 13:07:14 »
Nein, nur die polaris10_, auch wenn es absolut nichts machen würde, Alles von dort zu kopieren.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline DuckHunting

  • User
  • Posts: 11
Re: Boot-Fehler bei 4.15.x-Kerneln mit AMDGPU-Treiber
« Reply #4 on: 2018/02/25, 13:00:31 »
Bitte entschuldige, wenn ich mich etwas dämlich anstelle:

Im Verzeichnis /lib/firmware/amdgpu sind ja schon ein paar polaris-10-Dateien. Muss ich diese vorher löschen? Falls ja: vollständig oder nur, soweit eine neuere Version vorhanden ist?

Danke und LG

Axel

Update:

Ich habe testweise sämtliche neuen polaris_10-Dateien (19) in /lib/firmware/amdgpu kopiert und die alten Dateien, soweit vorhanden, überschrieben. Die Folge ist, dass sich kein einziger Kernel booten lässt (auch die 4.14.*-Versionen nicht).

Hier die Fehlermeldung aus dem Journal:

Code: [Select]
Feb 25 11:44:23 linux kernel: mc: Failed to load firmware "amdgpu/polaris10_mc.bin"
Feb 25 11:44:23 linux kernel: [drm:gmc_v8_0_sw_init [amdgpu]] *ERROR* Failed to load mc firmware!
Feb 25 11:44:23 linux kernel: [drm:amdgpu_device_init [amdgpu]] *ERROR* sw_init of IP block <gmc_v8_0> failed -22
Feb 25 11:44:23 linux kernel: amdgpu 0000:01:00.0: amdgpu_init failed
Feb 25 11:44:23 linux kernel: amdgpu 0000:01:00.0: Fatal error during GPU init
Feb 25 11:44:23 linux kernel: [TTM] Memory type 2 has not been initialized
Feb 25 11:44:24 linux sddm[1174]: Display server failed to start. Exiting
Feb 25 11:44:25 linux systemd-coredump[2733]: Process 1174 (sddm) of user 0 dumped core.
                                             
                                              Stack trace of thread 1174:
                                              #0  0x00007efe37ce66a0 raise (libc.so.6)
                                              #1  0x00007efe37ce7cf7 abort (libc.so.6)
                                              #2  0x00007efe389e70c7 _ZNK14QMessageLogger5fatalEPKcz (libQt5Core.so.5)
                                              #3  0x000055fda105a998 _ZN4SDDM7Display5startEv (sddm)
                                              #4  0x000055fda106b480 _ZN4SDDM4Seat13createDisplayEi (sddm)
                                              #5  0x000055fda106b6d0 _ZN4SDDM4SeatC2ERK7QStringP7QObject (sddm)
                                              #6  0x000055fda106c50d _ZN4SDDM11SeatManager10createSeatERK7QString (sddm)
                                              #7  0x000055fda1059996 _ZN4SDDM9DaemonAppC1ERiPPc (sddm)
                                              #8  0x000055fda1038f0b main (sddm)
                                              #9  0x00007efe37cd2f2a __libc_start_main (libc.so.6)
                                              #10 0x000055fda10391ca _start (sddm)

Könnt Ihr damit etwas anfangen?

Danke und LG

Axel
« Last Edit: 2018/02/25, 17:06:58 by DuckHunting »

Offline Volker

  • Newbie
  • Posts: 1
Re: Boot-Fehler bei 4.15.x-Kerneln mit AMDGPU-Treiber
« Reply #5 on: 2018/02/26, 11:17:52 »
Hallo,

rm -rf /var/lib/sddm/.cache/

und

 rm -rf ~/.cache

hat bei mir geholfen.

Siehe:  https://forums.opensuse.org/showthread.php/529550-tumbleweed-sddm-greeter-segfaulting-with-new-AMD-Mesa-drivers-18-0-0-X

Viele Grüße
Volker


Offline DuckHunting

  • User
  • Posts: 11
Re: Boot-Fehler bei 4.15.x-Kerneln mit AMDGPU-Treiber
« Reply #6 on: 2018/02/26, 11:35:15 »
Vielen Dank für den Tipp, Volker.

Ich werde gerne probieren, ob das weiterhilft, und wäre froh, wenn es so wäre. Ich habe allerdings etwas Zweifel, ob das Problem dasselbe ist: Debian Sid nutzt noch die Version 17.3.5 von Mesa.

Danke und LG

Axel

Offline DuckHunting

  • User
  • Posts: 11
Re: Boot-Fehler bei 4.15.x-Kerneln mit AMDGPU-Treiber
« Reply #7 on: 2018/02/27, 10:22:23 »
Towo, darf ich Dich diesbezüglich noch einmal um Hilfe bitten? Mir scheint, es handelt sich eher um ein Kernel-Problem im Zusammenhang mit meiner Grafikkarte.

Im Gentoo-Forum (https://forums.gentoo.org/viewtopic-t-1074902-postdays-0-postorder-asc-start-25.html?sid=b7c37e9056e7e2599863cf4debdd0ae4) heisst es scheinbar zu diesem Fehler:

Quote
After disabling SME (CONFIG_AMD_MEM_ENCRYPT=y but CONFIG_AMD_MEM_ENCRYPT_ACTIVE_BY_DEFAULT not set or mem_encrypt=off as kernel commandline option) everything works now. I'm very pleased, although I hope that AMDGPU+DC will work with SME in the future...

Danke und LG

Axel



Online towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.333
Re: Boot-Fehler bei 4.15.x-Kerneln mit AMDGPU-Treiber
« Reply #8 on: 2018/02/27, 12:03:08 »
Hast Du mem_encrypt=off getestet?


Ich habe keine Hardware, wo ich das testen kann, ich habe weder Polaris noch Vega Hardware verfügbar.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline DuckHunting

  • User
  • Posts: 11
Re: Boot-Fehler bei 4.15.x-Kerneln mit AMDGPU-Treiber
« Reply #9 on: 2018/02/27, 19:58:27 »
Ja, leider ohne Erfolg. Die neue 15.6.x-Kernelreihe zeigt dieselben Symptome. Ich werde wohl einstweilen bei der 4.14.x-Reihe bleiben müssen.

Trotzdem danke.

Axel

Online towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.333
Re: Boot-Fehler bei 4.15.x-Kerneln mit AMDGPU-Treiber
« Reply #10 on: 2018/03/01, 10:47:00 »
CONFIG_AMD_MEM_ENCRYPT


ist in unserem Kernel gar nicht gesetzt.
Daran kann es ergo nicht liegen.


Wie gesagt, ohne dolche Hardware selbst zu haben, ist debugging solcher Probleme ziemlich schwierig für mich.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.