seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/02/21, 02:35:14


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: ATTENTION: Qt 5.10 transition ahead  (Read 5625 times)

0 Members and 1 Guest are viewing this topic.

Offline df8oe

  • User
  • Posts: 106
  • Linux von Innen
    • DF8OE
Re: ATTENTION: Qt 5.10 transition ahead
« Reply #30 on: 2018/04/15, 18:49:53 »
Code: [Select]
apt full-upgrade ??

Offline jaegermeister

  • User
  • Posts: 222
Re: ATTENTION: Qt 5.10 transition ahead
« Reply #31 on: 2018/04/15, 18:56:48 »
Unfortunately same result:

Code: [Select]
# apt full-upgrade
Lettura elenco dei pacchetti...
Generazione albero delle dipendenze...
Lettura informazioni sullo stato...
È utile eseguire "apt --fix-broken install" per correggere ciò.
I seguenti pacchetti hanno dipendenze non soddisfatte:
 gnupg : Dipende: gpgv (= 2.2.5-1)
 libqt5dbus5 : Dipende: libqt5core5a (>= 5.10.0) ma la versione 5.9.2+dfsg-9 è installata
               Dipende: qtbase-abi-5-10-0
 libqt5gui5 : Dipende: libqt5core5a (>= 5.10.0) ma la versione 5.9.2+dfsg-9 è installata
              Dipende: qtbase-abi-5-10-0
 libqt5network5 : Dipende: libqt5core5a (>= 5.10.0) ma la versione 5.9.2+dfsg-9 è installata
                  Dipende: qtbase-abi-5-10-0
 libqt5quick5 : Dipende: libqt5core5a (>= 5.10.0) ma la versione 5.9.2+dfsg-9 è installata
                Dipende: libqt5qml5 (>= 5.10.1) ma la versione 5.9.2-3 è installata
                Dipende: qtbase-abi-5-10-0
                Dipende: qtdeclarative-abi-5-10-1
 libqt5quickcontrols2-5 : Dipende: libqt5core5a (>= 5.10.0) ma la versione 5.9.2+dfsg-9 è installata
                          Dipende: qtbase-abi-5-10-0
                          Dipende: qtdeclarative-abi-5-10-1
 libqt5quicktemplates2-5 : Dipende: libqt5core5a (>= 5.10.0) ma la versione 5.9.2+dfsg-9 è installata
                           Dipende: libqt5qml5 (>= 5.10.1) ma la versione 5.9.2-3 è installata
                           Dipende: qtbase-abi-5-10-0
                           Dipende: qtdeclarative-abi-5-10-1
 libqt5widgets5 : Dipende: libqt5core5a (>= 5.10.0) ma la versione 5.9.2+dfsg-9 è installata
                  Dipende: qtbase-abi-5-10-0
 libqt5x11extras5 : Dipende: libqt5core5a (>= 5.10.1+dfsg~) ma la versione 5.9.2+dfsg-9 è installata
 qml-module-qtgraphicaleffects : Dipende: libqt5qml5 (>= 5.10.1) ma la versione 5.9.2-3 è installata
                                 Dipende: libqt5core5a (>= 5.10.0) ma la versione 5.9.2+dfsg-9 è installata
                                 Dipende: qtdeclarative-abi-5-10-1
 qml-module-qtqml-models2 : Dipende: libqt5core5a (>= 5.10.0) ma la versione 5.9.2+dfsg-9 è installata
                            Dipende: qtdeclarative-abi-5-10-1
 qml-module-qtquick-controls : Dipende: libqt5qml5 (>= 5.10.1) ma la versione 5.9.2-3 è installata
                               Dipende: libqt5core5a (>= 5.10.0) ma la versione 5.9.2+dfsg-9 è installata
                               Dipende: qtbase-abi-5-10-0
                               Dipende: qtdeclarative-abi-5-10-1
 qml-module-qtquick-controls2 : Dipende: libqt5core5a (>= 5.10.0) ma la versione 5.9.2+dfsg-9 è installata
                                Dipende: qtbase-abi-5-10-0
                                Dipende: qtdeclarative-abi-5-10-1
 qml-module-qtquick-dialogs : Dipende: libqt5qml5 (>= 5.10.1) ma la versione 5.9.2-3 è installata
                              Dipende: libqt5core5a (>= 5.10.0) ma la versione 5.9.2+dfsg-9 è installata
                              Dipende: qtbase-abi-5-10-0
                              Dipende: qtdeclarative-abi-5-10-1
 qml-module-qtquick-layouts : Dipende: libqt5core5a (>= 5.10.0) ma la versione 5.9.2+dfsg-9 è installata
                              Dipende: qtbase-abi-5-10-0
                              Dipende: qtdeclarative-abi-5-10-1
 qml-module-qtquick-privatewidgets : Dipende: libqt5core5a (>= 5.10.0) ma la versione 5.9.2+dfsg-9 è installata
                                     Dipende: qtbase-abi-5-10-0
                                     Dipende: qtdeclarative-abi-5-10-1
 qml-module-qtquick-templates2 : Dipende: libqt5core5a (>= 5.10.0) ma la versione 5.9.2+dfsg-9 è installata
                                 Dipende: qtdeclarative-abi-5-10-1
 qml-module-qtquick-window2 : Dipende: libqt5core5a (>= 5.10.0) ma la versione 5.9.2+dfsg-9 è installata
                              Dipende: qtdeclarative-abi-5-10-1
 qml-module-qtquick2 : Dipende: libqt5core5a (>= 5.10.0) ma la versione 5.9.2+dfsg-9 è installata
                       Dipende: qtdeclarative-abi-5-10-1
 qt5-gtk-platformtheme : Dipende: libqt5core5a (>= 5.10.0) ma la versione 5.9.2+dfsg-9 è installata
                         Dipende: qtbase-abi-5-10-0
---------------------------------------
SI VIS PACEM PARA BELLVM
---------------------------------------

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.795
    • g-com.eu
Re: ATTENTION: Qt 5.10 transition ahead
« Reply #32 on: 2018/04/15, 19:02:23 »
For what it is worth - a working mirror could help a lot
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline jaegermeister

  • User
  • Posts: 222
Re: ATTENTION: Qt 5.10 transition ahead
« Reply #33 on: 2018/04/15, 19:05:15 »
Thanks but I am actually looking for advice, do you have some?
---------------------------------------
SI VIS PACEM PARA BELLVM
---------------------------------------

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.795
    • g-com.eu
Re: ATTENTION: Qt 5.10 transition ahead
« Reply #34 on: 2018/04/15, 19:08:18 »
Thanks but I am actually looking for advice, do you have some?

for sure - get a working mirror and resolve the conflicts - it is just that easy.
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline absolut

  • User
  • Posts: 421
Re: ATTENTION: Qt 5.10 transition ahead
« Reply #35 on: 2018/04/15, 19:12:31 »
jaegermeister, there is a suggestion in your post
Code: [Select]
È utile eseguire "apt --fix-broken install" per correggere ciò.
did you try already?

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.728
  • we are the priests ... of the temples of syrinx
Re: ATTENTION: Qt 5.10 transition ahead
« Reply #36 on: 2018/04/15, 19:14:50 »
Yup, a working mirror should give you

Code: [Select]
apt policy gpgv libqt5dbus5 libqt5gui5 libqt5network5 libqt5quick5 libqt5quickcontrols2-5 libqt5quicktemplates2-5 libqt5widgets5 libqt5x11extras5 qml-module-qtgraphicaleffects qml-module-qtqml-models2 qml-module-qtquick-controls qml-module-qtquick-controls2 qml-module-qtquick-dialogs qml-module-qtquick-layouts qml-module-qtquick-privatewidgets qml-module-qtquick-templates2 qml-module-qtquick-window2 qml-module-qtquick2 qt5-gtk-platformtheme
gpgv:
  Installed: 2.2.5-1
  Candidate: 2.2.5-1
  Version table:
 *** 2.2.5-1 500
        500 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
libqt5dbus5:
  Installed: 5.10.1+dfsg-5
  Candidate: 5.10.1+dfsg-5
  Version table:
 *** 5.10.1+dfsg-5 500
        500 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
libqt5gui5:
  Installed: 5.10.1+dfsg-5
  Candidate: 5.10.1+dfsg-5
  Version table:
 *** 5.10.1+dfsg-5 500
        500 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
libqt5network5:
  Installed: 5.10.1+dfsg-5
  Candidate: 5.10.1+dfsg-5
  Version table:
 *** 5.10.1+dfsg-5 500
        500 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
libqt5quick5:
  Installed: 5.10.1-4
  Candidate: 5.10.1-4
  Version table:
 *** 5.10.1-4 500
        500 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
libqt5quickcontrols2-5:
  Installed: 5.10.1-2
  Candidate: 5.10.1-2
  Version table:
 *** 5.10.1-2 500
        500 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
libqt5quicktemplates2-5:
  Installed: 5.10.1-2
  Candidate: 5.10.1-2
  Version table:
 *** 5.10.1-2 500
        500 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
libqt5widgets5:
  Installed: 5.10.1+dfsg-5
  Candidate: 5.10.1+dfsg-5
  Version table:
 *** 5.10.1+dfsg-5 500
        500 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
libqt5x11extras5:
  Installed: 5.10.1-2
  Candidate: 5.10.1-2
  Version table:
 *** 5.10.1-2 500
        500 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
qml-module-qtgraphicaleffects:
  Installed: 5.10.1-2
  Candidate: 5.10.1-2
  Version table:
 *** 5.10.1-2 500
        500 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
qml-module-qtqml-models2:
  Installed: 5.10.1-4
  Candidate: 5.10.1-4
  Version table:
 *** 5.10.1-4 500
        500 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
qml-module-qtquick-controls:
  Installed: 5.10.1-2
  Candidate: 5.10.1-2
  Version table:
 *** 5.10.1-2 500
        500 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
qml-module-qtquick-controls2:
  Installed: 5.10.1-2
  Candidate: 5.10.1-2
  Version table:
 *** 5.10.1-2 500
        500 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
qml-module-qtquick-dialogs:
  Installed: 5.10.1-2
  Candidate: 5.10.1-2
  Version table:
 *** 5.10.1-2 500
        500 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
qml-module-qtquick-layouts:
  Installed: 5.10.1-4
  Candidate: 5.10.1-4
  Version table:
 *** 5.10.1-4 500
        500 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
qml-module-qtquick-privatewidgets:
  Installed: 5.10.1-2
  Candidate: 5.10.1-2
  Version table:
 *** 5.10.1-2 500
        500 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
qml-module-qtquick-templates2:
  Installed: 5.10.1-2
  Candidate: 5.10.1-2
  Version table:
 *** 5.10.1-2 500
        500 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
qml-module-qtquick-window2:
  Installed: 5.10.1-4
  Candidate: 5.10.1-4
  Version table:
 *** 5.10.1-4 500
        500 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
qml-module-qtquick2:
  Installed: 5.10.1-4
  Candidate: 5.10.1-4
  Version table:
 *** 5.10.1-4 500
        500 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
qt5-gtk-platformtheme:
  Installed: (none)
  Candidate: 5.10.1+dfsg-5
  Version table:
     5.10.1+dfsg-5 500
        500 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 Packages
01:10:0401:10 PM [piper@x1 ~]$
I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

Offline jaegermeister

  • User
  • Posts: 222
Re: ATTENTION: Qt 5.10 transition ahead
« Reply #37 on: 2018/04/15, 19:16:43 »
@melmarker
changed mirror in /etc/apt/sources.list.d/debian.list with:
deb http://httpredir.debian.org/debian/ unstable main contrib non-free
same result.

@absolut
in my first post I went even further with the following:
# apt -f --allow-change-held-packages install libqt5core5a libqt5qml5
also "dpkg -a --configure" sorts no result.

---------------------------------------
SI VIS PACEM PARA BELLVM
---------------------------------------

Offline absolut

  • User
  • Posts: 421
Re: ATTENTION: Qt 5.10 transition ahead
« Reply #38 on: 2018/04/15, 19:20:32 »
can you please test with an explicit mirror instead of the httpredir balancer?

e.g.
deb https://ftp-stud.hs-esslingen.de/debian/ unstable main contrib non-free

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.795
    • g-com.eu
Re: ATTENTION: Qt 5.10 transition ahead
« Reply #39 on: 2018/04/15, 19:24:54 »
and if it is a really old kde install with our infamous kdenext - use some swearwords in santas direction and clean up the mess manually

Edit: and maybe it is a good idea (if not yet switched) - switch apt to installation with recommends.
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline jaegermeister

  • User
  • Posts: 222
Re: ATTENTION: Qt 5.10 transition ahead
« Reply #40 on: 2018/04/15, 19:25:16 »
@piper
issuing policy on those packages obtains:
Code: [Select]
gpgv:
  Installato: 2.2.4-2
  Candidato:  2.2.5-1
  Tabella versione:
     2.2.5-1 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
 *** 2.2.4-2 100
        100 /var/lib/dpkg/status
libqt5dbus5:
  Installato: 5.10.1+dfsg-5
  Candidato:  5.10.1+dfsg-5
  Tabella versione:
 *** 5.10.1+dfsg-5 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
libqt5gui5:
  Installato: 5.10.1+dfsg-5
  Candidato:  5.10.1+dfsg-5
  Tabella versione:
 *** 5.10.1+dfsg-5 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
libqt5network5:
  Installato: 5.10.1+dfsg-5
  Candidato:  5.10.1+dfsg-5
  Tabella versione:
 *** 5.10.1+dfsg-5 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
libqt5quick5:
  Installato: 5.10.1-3
  Candidato:  5.10.1-4
  Tabella versione:
     5.10.1-4 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
 *** 5.10.1-3 100
        100 /var/lib/dpkg/status
libqt5quickcontrols2-5:
  Installato: 5.10.1-2
  Candidato:  5.10.1-2
  Tabella versione:
 *** 5.10.1-2 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
libqt5quicktemplates2-5:
  Installato: 5.10.1-2
  Candidato:  5.10.1-2
  Tabella versione:
 *** 5.10.1-2 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
libqt5widgets5:
  Installato: 5.10.1+dfsg-5
  Candidato:  5.10.1+dfsg-5
  Tabella versione:
 *** 5.10.1+dfsg-5 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
libqt5x11extras5:
  Installato: 5.10.1-2
  Candidato:  5.10.1-2
  Tabella versione:
 *** 5.10.1-2 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
qml-module-qtgraphicaleffects:
  Installato: 5.10.1-2
  Candidato:  5.10.1-2
  Tabella versione:
 *** 5.10.1-2 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
qml-module-qtqml-models2:
  Installato: 5.10.1-3
  Candidato:  5.10.1-4
  Tabella versione:
     5.10.1-4 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
 *** 5.10.1-3 100
        100 /var/lib/dpkg/status
qml-module-qtquick-controls:
  Installato: 5.10.1-2
  Candidato:  5.10.1-2
  Tabella versione:
 *** 5.10.1-2 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
qml-module-qtquick-controls2:
  Installato: 5.10.1-2
  Candidato:  5.10.1-2
  Tabella versione:
 *** 5.10.1-2 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
qml-module-qtquick-dialogs:
  Installato: 5.10.1-2
  Candidato:  5.10.1-2
  Tabella versione:
 *** 5.10.1-2 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
qml-module-qtquick-layouts:
  Installato: 5.10.1-3
  Candidato:  5.10.1-4
  Tabella versione:
     5.10.1-4 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
 *** 5.10.1-3 100
        100 /var/lib/dpkg/status
qml-module-qtquick-privatewidgets:
  Installato: 5.10.1-2
  Candidato:  5.10.1-2
  Tabella versione:
 *** 5.10.1-2 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
qml-module-qtquick-templates2:
  Installato: 5.10.1-2
  Candidato:  5.10.1-2
  Tabella versione:
 *** 5.10.1-2 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
qml-module-qtquick-window2:
  Installato: 5.10.1-3
  Candidato:  5.10.1-4
  Tabella versione:
     5.10.1-4 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
 *** 5.10.1-3 100
        100 /var/lib/dpkg/status
qml-module-qtquick2:
  Installato: 5.10.1-3
  Candidato:  5.10.1-4
  Tabella versione:
     5.10.1-4 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
 *** 5.10.1-3 100
        100 /var/lib/dpkg/status
qt5-gtk-platformtheme:
  Installato: 5.10.1+dfsg-5
  Candidato:  5.10.1+dfsg-5
  Tabella versione:
 *** 5.10.1+dfsg-5 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status

@absolut
also with your mirror, same result :(
also, I am not allowed to manaually upgrade any blocking package
---------------------------------------
SI VIS PACEM PARA BELLVM
---------------------------------------

Offline jaegermeister

  • User
  • Posts: 222
Re: ATTENTION: Qt 5.10 transition ahead
« Reply #41 on: 2018/04/15, 19:26:11 »
@melmarker
never went for kdenext mess
not an old install, last du in march
---------------------------------------
SI VIS PACEM PARA BELLVM
---------------------------------------

Offline jaegermeister

  • User
  • Posts: 222
Re: ATTENTION: Qt 5.10 transition ahead
« Reply #42 on: 2018/04/15, 19:32:13 »
Btw recommends already "1"
---------------------------------------
SI VIS PACEM PARA BELLVM
---------------------------------------

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.795
    • g-com.eu
Re: ATTENTION: Qt 5.10 transition ahead
« Reply #43 on: 2018/04/15, 19:36:15 »
please paste the full output. thanks (https://paste.debian.net or https://pb.5id.eu/form might be a good idea)
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline jaegermeister

  • User
  • Posts: 222
Re: ATTENTION: Qt 5.10 transition ahead
« Reply #44 on: 2018/04/15, 19:44:49 »
Here is the paste of fix try:
http://paste.debian.net/1020437/

Clearly the two packages libqt5core5a and libqt5qml5 are the key of this mess.
---------------------------------------
SI VIS PACEM PARA BELLVM
---------------------------------------