seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/01/17, 20:33:57


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Gdm3 and selecting Gnome-classic at Login Issue  (Read 875 times)

0 Members and 1 Guest are viewing this topic.

Offline Kan

  • User
  • Posts: 40
Gdm3 and selecting Gnome-classic at Login Issue
« on: 2018/05/31, 21:36:58 »
Hi there,
I am running Gnome and having issues with multiple monitors and the sddm display manager. The issue is whenever I plug an HDMI monitor into my laptop, upon logging out, anything I touch outside of the login prompt freezes the screen. I have to do a complete reboot. I have dug through several bug reports and user posts. I found one user who thinks it might have to do with the intel driver, but no answers.
I decided to switch to gdm3 since I am running gnome (and I want the lock screen to work, which it doesn't using Gnome under sddm.) The switch to gdm3 worked but it automatically logged me into the Wayland session. I logged out and tried to select all the other 'Classic' or "Xorg options, but it won't log in. It flashes the screen and takes me back to the login prompt. The only option that works is the 'gnome' or Wayland option. Any suggestions on how to use 'gnome-classic' under gdm3?
Thanks,Rodney

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.827
    • Land of the Buckeye
Re: Gdm3 and selecting Gnome-classic at Login Issue
« Reply #1 on: 2018/05/31, 22:04:09 »
Quote from: Kan
... select all the other 'Classic' or "Xorg options, but it won't log in. It flashes the screen and takes me back to the login prompt.

I know nothing whatever about gnome, but this symptom sounds a lot like a problem caused by a root-owned file in the user's home directory.  Check the user's home directory with

Code: [Select]
ls -la
and make sure only the user owns the files and folders.
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline Kan

  • User
  • Posts: 40
Re: Gdm3 and selecting Gnome-classic at Login Issue
« Reply #2 on: 2018/05/31, 23:26:14 »
I ran the command, and I am assigned and have permissions on everything in my home folder, ie no root-owned.

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.556
    • g-com.eu
Re: Gdm3 and selecting Gnome-classic at Login Issue
« Reply #3 on: 2018/06/01, 20:33:01 »
Feel free to try gdm3 8)

Hmm - maybe more verbose - if the problem remains it wasn't the fault of the DM.
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline Kan

  • User
  • Posts: 40
Re: Gdm3 and selecting Gnome-classic at Login Issue
« Reply #4 on: 2018/06/01, 22:07:53 »
I wish I could try gdm3, at least under xorg (gnome-classic.)  :D
I added verbose mode to the gdm config files, but I am not seeing anything reported as errors from the xsession-errors file, which I assume is where I go to read it. 

I have tried everything. From all user reports on the web, I should just be able to select any of the sessions and log in, but not for the xorg sessions.

Offline Kan

  • User
  • Posts: 40
Re: Gdm3 and selecting Gnome-classic at Login Issue
« Reply #5 on: 2018/06/01, 22:52:17 »
Making a little progress here. I found a post where a user suggested switching to gdm3 and at login, select the gnome-classic session, then Ctrl+Alt+F3...then login with password, then 'startx'. That worked, at least i got to my desktop, but...
Immediately, a pop came up saying "Enter password to unlock your login keyring. The login keyring did not get unlocked when you logged into your computer." Wants me to put in my password, which I did. It went away.
I then used the "Lock" which I was never able to do under sddm. That worked, I entered my password, and back to the screen. Then I rebooted....and it was back to not being able to login at the login screen using gnome-classic.

I don't want to keep going out of the shell and typing my password with 'startx' each time. Any suggestions?

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.556
    • g-com.eu
Re: Gdm3 and selecting Gnome-classic at Login Issue
« Reply #6 on: 2018/06/01, 23:11:41 »
/j siduction(-de) and lets talk about in IRC - we can test it live on a KVM machine via spice - sounds complicated but isn't  - the easiest way to figure that out.
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline Kan

  • User
  • Posts: 40
Re: Gdm3 and selecting Gnome-classic at Login Issue
« Reply #7 on: 2018/06/02, 01:13:51 »
Actually, I just ruled out the user as the issue. This must be something not configured in the distro.
You can easily recreate this with a few easy steps;

1. download and install the freshest copy of Siduction Gnome in a Virtualbox.
2. login and install gdm3 (pick gdm3 as your display manager during install or dpkg-reconfigure gdm3 later as root to select it.)
3. reboot
4. change the session to anything other than 'gnome', so gnome-classic would be a good choice and try and login with your password.

It won't let you log in under xorg.

Offline Kan

  • User
  • Posts: 40
Re: Gdm3 and selecting Gnome-classic at Login Issue
« Reply #8 on: 2018/06/09, 20:30:48 »
Doing a follow up to this issue. I finally gave up on Siduction's Gnome build. It obviously has some issues (see my previous post to recreate the xorg issue.) Here are the issues I encountered;
1. GDM and Xorg (see previous post to recreate this issue). Why would you want to switch display mgr to GDM? Because SDDM (Siduction's default) does not allow Gnome to lock your screen. It also has issues with multi-monitor support, ie lots of screen freezes when second monitor connected via HDMI. I am not sure if that is because of Gnome or just in general.
2. Weird Flatpak permissions issues, and doesn't work. This has already been reported by other users under its own post, but no follow up to my knowledge. Again, not sure if this is under their Gnome build or an issue for all.
What I recommend for a solid Gnome experience, which might go against the devs here is to install Debian Testing, switch the repos to Debian Unstable and Siduction (google how to) and what you end up with is a solid Gnome build that corrects all the issues above, including running under Xorg and GDM, and you get Siductions wonderful kernel builds.



Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.827
    • Land of the Buckeye
Re: Gdm3 and selecting Gnome-classic at Login Issue
« Reply #9 on: 2018/06/09, 21:54:00 »
Looks like you found a good-working solution -- congratulations!

Nice thing about the siduction team -- they'll never tell you what you can and can't do with your system.  Although some of them might giggle a little if you share foolish and destructive things .....  ;-)

Also, just FYI in case you never investigated, this team is a contributor to the LXQt desktop development, and if you have some older, slower hardware like this Dell Inspiron laptop that I am typing on at this moment, LXQt is a nice light and very functional DE.  Don't ask me about screen locking, but I'll bet @melmarker knows how to do it.  :)

LXQt screen locking setting is found at main menu > preferences > screensaver.  :)
« Last Edit: 2018/06/09, 22:12:47 by dibl »
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline Kan

  • User
  • Posts: 40
Re: Gdm3 and selecting Gnome-classic at Login Issue
« Reply #10 on: 2018/06/09, 22:55:11 »
Thanks dibl! Actually, it is the opposite, my laptop is about a year old, so more modern.

I have never used LXQt. I would probably be using XFCE, except for one app that I really enjoy and love (silly I know.) GSConnect which links your phone and tablets to your desktop for SMS/File Browsing/Notifications, etc. It is the Gnome version of KDE's Connect. Unfortunately, it doesn't work under XFCE, so I stick with Gnome (not a big fan of KDE.)
I will check out LXQt though.

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.556
    • g-com.eu
Re: Gdm3 and selecting Gnome-classic at Login Issue
« Reply #11 on: 2018/06/09, 23:56:58 »
nope - that's all no solution - but i guess we had an idea about gnome - we will just don't provide it anymore - really, i'm done with.

And please don't choose LXQt - it could take away my fun with LXQt. Thanks. If one think there is to much sarcasm - no, it isn't.

Edit: and no, we will not use testing - if you think flatpak will not work - ok, file a bug in debian. If i sound pissed, i am. You are the second user with the wildest claims about flatpak - and these claims are not true. It might be that there is a missed dependency in the flatpak package. If thats the case file a bug in debian. Nothing we can and will do about.
Re gdm3 - there is a reason why we don't use gdm: it don't play well with live images - therefore gdm is a no go for us. A very big plus about gdm3 is also the fact that this package is a bit sensible and break often (aka with every release iirc - so: it will help here also to file a bug in debian if a pure debian sid installation will fail too. the gnome maintainers will be happy to fix that, because they are really good ones and like it if their packages are working.

EDIT: Anyways - also virtualbox is not a clever idea to test gnome/gdm3 - the keyword is the buggy opengl implementation needed for gdm3. Maybe i'm not right about - but we had massive problems in the last years with this crap. A pointer might be that even Ubuntu use lightdm for their now gnome based main release. They might know why.
« Last Edit: 2018/06/10, 00:22:16 by melmarker »
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.556
    • g-com.eu
Re: Gdm3 and selecting Gnome-classic at Login Issue
« Reply #12 on: 2018/06/10, 01:56:45 »
Some additions:
* tested a live iso - gnome-classic works just fine
* tested gdm3 - really cool, gdm3 start wayland by default, but gnome-classic seems not to work with wayland - indeed,  it doesn't surprise me much - you might ask in #debian-gnome about
* gdm3 has a config option which disable wayland - so xorg should be used - that doesn't work, at least not in a kvm virtual machine - might be the opengl thing - one might ask in #debian-gnome
* sddm and lightdm and i guess even slim should start X+the choosen gnome-session fine - and again - if one encounter problems with, not our problem, we won't change a bit in our setup - take it or not, not really our problem

Same for flatpak -learn to handle it, in case there are bugs - not our problem. I tested it several times and it work just fine - ok, correction, it work as fine as flatpak can work fine - thats a difference
If flatpaks should not be limited to the user (did i mention the --user switch?) it might be that the policykit integration must be installed by the admin of the system. Thats a design decision the flatpak maintainers did intentionally i would guess - so if one don't agree - talk with the flatpak maintainers about or write a bug.

Final note: Damn, i was really surprised and highly excited about the status of wayland in combination with gnome and gdm3 - they did a really awesome job with. One might see this different - but again: not our problem, not our business. In fact - it would be a shame to let go a gnome what is in that good shape.
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline Kan

  • User
  • Posts: 40
Re: Gdm3 and selecting Gnome-classic at Login Issue
« Reply #13 on: 2018/06/10, 08:27:03 »
At no point did I mention anything about Wayland in all my post. In fact, personally, I think Wayland sucks as it stands with Gnome. Not all apps support it, and it always seems slower, laggy. Even Ubuntu moved off Wayland stating publicly it was not ready yet.

What I did state was Gnome Siduction does not work with GDM and Xorg.

To prove that the issues are Siduction related, I installing Debian Testing and made the transition to Unstable and Siduction repos fixes all the issues, including Flatpak. So, the issues are in the Siduction Gnome latest version.

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.556
    • g-com.eu
Re: Gdm3 and selecting Gnome-classic at Login Issue
« Reply #14 on: 2018/06/10, 13:30:16 »
To prove that the issues are Siduction related, I installing Debian Testing and made the transition to Unstable and Siduction repos fixes all the issues, including Flatpak. So, the issues are in the Siduction Gnome latest version.

Come on - read my post again and at least try to understand the things i wrote. And think about Siduction and sid again. Our images are snapshots of sid at a certain point. So if there are bugs in the installed packages at this time - upps, shit happend. If things are not work after an upgrade - upps again. Such things happend. If things are missed - again: upps, shit happend, nothing we can do. And nothing we want to do - if these things are fixed now, fine - the next builds should just work™. If not: Try it with a clean debian and file a bug there. If you are not satisfied with this answer, your options and the way we are handle these things it might be that siduction is not for you. Period.

And you proved nothing - sorry.
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)