seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/10/21, 07:38:18


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Digikam etc.  (Read 1073 times)

0 Members and 1 Guest are viewing this topic.

Offline zash1958

  • User
  • Posts: 83
Digikam etc.
« on: 2018/09/24, 10:56:27 »
Will seit Tagen entfernen:


Code: [Select]

Die folgenden Pakete werden ENTFERNT:
  colord digikam digikam-private-libs kipi-plugins libkf5sane5 libsane1 master-pdf-editor sane sane-utils skanlite xsane


Wo klemmt es denn da noch?

Offline jure

  • User
  • Posts: 520
Re: Digikam etc.
« Reply #1 on: 2018/09/24, 11:44:41 »
ad *sane*

https://forum.siduction.org/index.php?topic=7329.0

Code: [Select]
apt dist-upgrade libsane+
Gruss Juergen

Offline mash

  • User
  • Posts: 29
Re: Digikam etc.
« Reply #2 on: 2018/09/29, 19:15:42 »
zash, versuche es mal hier
https://files.kde.org/digikam/
Die appimages die dort zur Verfueghung gestellt werden, haben keine Abhaengigkeiten. Ich arbeite auch damit.

Cheers
when it was hard to write it should be hard to read

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.367
Re: Digikam etc.
« Reply #3 on: 2018/09/29, 20:47:38 »
Naja, nicht so ganz. AppImages, Snaps und Flatpaks haben keine Abhängigkeiten nach außen. Ein Teil davon wird beispielsweise durch die Laufzeitumgebungen abgedeckt, die etwa Flatpak installiert. Andere Abhängigkeiten werden direkt im Paket mitgeliefert, weswegen diese Art von Paketen so groß sind.

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.922
    • Land of the Buckeye
Re: Digikam etc.
« Reply #4 on: 2018/09/29, 22:15:26 »
@zash1958, just let the d-u remove them and when your system is updated, they are reinstallable with the correct dependencies.  Here is a laptop just updated today:

Code: [Select]
root@dibl-HP350:/# uname -a
Linux dibl-HP350 4.18.11-towo.1-siduction-amd64 #1 SMP siduction 4.18-13 (2018-09-29) x86_64 GNU/Linux
root@dibl-HP350:/# apt policy digikam
digikam:
  Installed: 4:5.9.0-1
  Candidate: 4:5.9.0-1
  Version table:
 *** 4:5.9.0-1 500
        500 http://deb.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
root@dibl-HP350:/# apt policy kipi-plugins
kipi-plugins:
  Installed: 4:5.9.0-1
  Candidate: 4:5.9.0-1
  Version table:
 *** 4:5.9.0-1 500
        500 http://deb.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status

Entschuldigen Sie mich, bitte, für Englisch.
« Last Edit: 2018/09/29, 22:32:21 by dibl »
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline id027102

  • User
  • Posts: 22
Re: Digikam etc.
« Reply #5 on: 2018/10/02, 13:40:41 »
What happens ?
Not the first time :
Update for libsane-common : colord, digikam...,LIBSANE, ..... has to be removed  LIBSANE1 has to be installed and sane-utils  has to be upgraded
It is the third time it happens to me

Last time was the same but LIBSANE1 has to be removed and LIBSANE installed.
So first I had libsane , then libsane1 then back libsane and now again libsane1.What Next time , again libsane or maybe libsane2
libsane-common and sane-utils pinned till next upgrade (if solved)
REMARK :
 libsane-common and sane-utils have both same  installed version and latest version : 1.0.27-2~2 ,
but must be upgraded both ?



Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.367
Re: Digikam etc.
« Reply #6 on: 2018/10/02, 15:03:56 »
Did you do
Code: [Select]
apt dist-upgrade libsane+  ?
The + is not a typo, it belongs there.

Offline id027102

  • User
  • Posts: 22
Re: Digikam etc.
« Reply #7 on: 2018/10/02, 16:49:05 »
did now , repons :libsane is already the newest version
libsane-common , sane-utils have been kept back

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.756
    • g-com.eu
Re: Digikam etc.
« Reply #8 on: 2018/10/02, 19:54:11 »
the next round is just started, so please be patient - did i ever mentioned why we named the latest releases `patience` and didn't changed it?

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=908681
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline ralfi

  • User
  • Posts: 382
Re: Digikam etc.
« Reply #9 on: 2018/10/12, 14:00:56 »
try using AppImage from digikam.org ...


IMHO the best use case

Gruss, ralfi

Niveau sieht von unten oft wie Arroganz aus ...