seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2018/10/19, 00:40:47


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Clementine Upgrade Includes New Library that Has Reported Bug  (Read 200 times)

0 Members and 1 Guest are viewing this topic.

Offline tranquil

  • User
  • Posts: 18
Just distro upgraded a few minutes ago and ended up having to cherry pick the packages to upgrade.  It appears that libprotobuf17 is to replace libprotobuf10, but there's a reported serious bug currently with the new library.  Following is what was left after I cherry picked.


Code: [Select]

The following packages were automatically installed and are no longer required:
  libprotobuf-lite10 libprotobuf10
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed:
  libprotobuf17
The following packages will be upgraded:
  clementine
1 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/5,683 kB of archives.
After this operation, 3,137 kB of additional disk space will be used.

Offline seasons

  • User
  • Posts: 232
See: https://release.debian.org/transitions/html/auto-protobuf.html
I assume the bug you are referring to is: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=910964 which is dealing with cura-engine. As you can see in the transition link, cura-engine is one of the packages that needs updated.
In the future, please give a reference link if you are going to refer to a specific bug.

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.402
    • g-com.eu
libprotobuf17 might need Breaks: libprotobuf10 - if it works, fine, if not - patience

and please apt purge apt-listchanges and similar things
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline tranquil

  • User
  • Posts: 18
I assume the bug you are referring to is: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=910964 which is dealing with cura-engine. As you can see in the transition link, cura-engine is one of the packages that needs updated.
Yes, that's the bug.

... and please apt purge apt-listchanges and similar things
Why?  If that suggestion is specific to the Siduction distro, I don't use it.
« Last Edit: 2018/10/15, 00:09:35 by tranquil »