seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/12/09, 11:19:08


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: update of libasound2 breaks sound on HDA-Intel  (Read 2258 times)

0 Members and 1 Guest are viewing this topic.

Offline t0mte

  • User
  • Posts: 24
update of libasound2 breaks sound on HDA-Intel
« on: 2018/11/03, 11:32:44 »
Hi.
today DU breaks sound on my amd64.
Code: [Select]
libasound2:amd64 (1.1.6-1, 1.1.7-1),
libasound2-data:amd64 (1.1.6-1, 1.1.7-1),
libasound2-dev:amd64 (1.1.6-1, 1.1.7-1),
libasound2-plugins:amd64 (1.1.6-1+b1, 1.1.7-1)
Downgrade to the packages from testing solved that problem.
« Last Edit: 2018/11/03, 11:45:05 by t0mte »

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.931
    • Land of the Buckeye
Re: update of libasound2 breaks sound on HDA-Intel
« Reply #1 on: 2018/11/03, 12:38:56 »
Thank you.  Breakage confirmed, fix works.
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline hsp

  • User
  • Posts: 508
Re: update of libasound2 breaks sound on HDA-Intel
« Reply #2 on: 2018/11/03, 12:39:17 »
same here...


Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.931
    • Land of the Buckeye
Re: update of libasound2 breaks sound on HDA-Intel
« Reply #4 on: 2018/11/03, 13:29:30 »
The problem appears to be caused by the new libasound2-plugins packages.  By chance, I have a laptop that was updated last night and got the new libasound2 and libasound2-data packages, but not the new libasound2-plugins.  Sound is still working.  But this morning, if I run d-u, I see I will get the new libasound2-plugins and that is what will surely break sound.

Code: [Select]
root@n5110:/# apt policy libasound2 libasound2-data libasound2-plugins
libasound2:
  Installed: 1.1.7-1
  Candidate: 1.1.7-1
  Version table:
 *** 1.1.7-1 500
        500 http://deb.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
libasound2-data:
  Installed: 1.1.7-1
  Candidate: 1.1.7-1
  Version table:
 *** 1.1.7-1 500
        500 http://deb.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
libasound2-plugins:
  Installed: 1.1.6-1+b1
  Candidate: 1.1.7-1
  Version table:
     1.1.7-1 500
        500 http://deb.debian.org/debian unstable/main amd64 Packages
 *** 1.1.6-1+b1 100
        100 /var/lib/dpkg/status
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline axt

  • User
  • Posts: 337
    • axebase.net
Re: update of libasound2 breaks sound on HDA-Intel
« Reply #5 on: 2018/11/03, 13:36:23 »
The return isn't necessary.

Code: [Select]
mv /etc/alsa/conf.d{,_bak}
and reboot.

Offline jure

  • User
  • Posts: 520
Re: update of libasound2 breaks sound on HDA-Intel
« Reply #6 on: 2018/11/03, 14:07:03 »
Code: [Select]
mv /etc/alsa/conf.d{,_bak}
thx axt - that works for me ...
Gruss Juergen

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.931
    • Land of the Buckeye
Re: update of libasound2 breaks sound on HDA-Intel
« Reply #7 on: 2018/11/03, 14:22:17 »
Thanks axt!
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline Mte90

  • User
  • Posts: 135
  • KDE & Debian lover
    • http://www.mte90.net
Re: update of libasound2 breaks sound on HDA-Intel
« Reply #8 on: 2018/11/03, 14:23:52 »
thanks axt worked without the reboot on my case :-)
I only done a jump on the chair because on my test I put the volume at maximum  ::)

Offline hsp

  • User
  • Posts: 508
Re: update of libasound2 breaks sound on HDA-Intel
« Reply #9 on: 2018/11/03, 14:25:40 »
That's not the solution, just a workaround until it's fixed.
...

Offline axt

  • User
  • Posts: 337
    • axebase.net
Re: update of libasound2 breaks sound on HDA-Intel
« Reply #10 on: 2018/11/03, 14:36:11 »
hsp, at no point do I claim that's the final solution. You are welcome to bring it. When it's time - undoing the renaming is done in seconds.

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.723
  • we are the priests ... of the temples of syrinx
Re: update of libasound2 breaks sound on HDA-Intel
« Reply #11 on: 2018/11/03, 14:36:24 »
danke axt
I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

Offline hendrikL

  • User
  • Posts: 323
Re: update of libasound2 breaks sound on HDA-Intel
« Reply #12 on: 2018/11/03, 15:05:32 »
and if some one didn't run a full-upgrade, setting libasound2-pluguns on hold should also work.
Code: [Select]
apt-mark hold libasound2-plugins

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.781
    • g-com.eu
Re: update of libasound2 breaks sound on HDA-Intel
« Reply #13 on: 2018/11/03, 18:16:00 »
Is ja alles gut und schön - hat eventuell mal jemand dran gedacht, einen grave-bug gegen libasound2-plugins zu malen?

Code: [Select]
reportbug libasound2-plugins

zeigt auf jeden Fall nix an. Ist überhaupt nicht cool!!  >:(
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline jure

  • User
  • Posts: 520
Re: update of libasound2 breaks sound on HDA-Intel
« Reply #14 on: 2018/11/03, 18:19:40 »
ich denke den gibt es schon https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=912721

Quote
reportbug libasound2-plugins
.....
Bugs with severity grave
   1) #912680  libasound2-plugins: broken symlinks in /etc/alsa/conf.d
   2) #912721  libasound2-plugins: Sound no longer works after latest update
   3) #912726  alsa-lib: update created /etc/alsa/conf.d directory filled with broken symlinks to /usr/share/alsa/alsa.conf.d
   4) #912755  cannot access file /etc/alsa/conf.d/10-rate-lav.conf
Gruss Juergen