seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2018/12/14, 16:14:00


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: (solved) Caution -- sane-related removals (again)  (Read 1799 times)

0 Members and 1 Guest are viewing this topic.

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.816
    • Land of the Buckeye
(solved) Caution -- sane-related removals (again)
« on: 2018/11/06, 12:59:34 »
Watch your d-u messages:

Code: [Select]
The following packages were automatically installed and are no longer required:
  akonadi-contacts-data enblend enfuse hugin hugin-data hugin-tools
  kipi-plugins-common libastro1 libdmtx0a libgdcm2.8 libgps23 libgsl23
  libgslcblas0 libical3 libimage-exiftool-perl libkf5akonadi-data
  libkf5akonadicontact5 libkf5akonadicore5abi2
  libkf5akonadiprivate5abi2 libkf5akonadiwidgets5abi1
  libkf5calendarcore5abi2 libkf5contacteditor5 libkf5contacts-data
  libkf5contacts5 libkf5mediawiki5 libkf5mime-data libkf5mime5abi1
  libkf5notifyconfig-data libkf5notifyconfig5 libkf5prison5
  libkf5sane-data liblensfun-data-v1 liblensfun1 libmarblewidget-qt5-28
  libmime-charset-perl libopencv-highgui3.2 libopencv-imgcodecs3.2
  libopencv-ml3.2 libopencv-objdetect3.2 libopencv-videoio3.2
  libpano13-3 libpano13-bin libposix-strptime-perl libqrencode4
  libqt5designer5 libqt5help5 libqt5serialport5 libqt5xmlpatterns5
  libqtav1 libqtavwidgets1 libshp2 libsocket++1 libsombok3
  libunicode-linebreak-perl libvigraimpex6 libwxbase3.0-0v5
  libwxgtk3.0-0v5 marble-data marble-plugins marble-qt-data minidlna
  python3-dbus.mainloop.pyqt5 python3-pyqt5
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
  digikam-private-libs hplip hplip-gui kipi-plugins libkf5sane5
  libsane1 printer-driver-postscript-hp sane-utils xsane
.
.
.
« Last Edit: 2018/11/15, 14:09:16 by piper »
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.472
  • north of hell south of heaven
Re: Caution -- sane-related removals (again)
« Reply #1 on: 2018/11/06, 13:24:47 »
This is part of an ongoing transition of sane-backends-cleanup


Code: [Select]
The following NEW packages will be installed:
  linux-headers-4.19.1-towo.1-siduction-amd64 linux-image-4.19.1-towo.1-siduction-amd64
The following packages have been kept back:
  libsane-common
The following packages will be upgraded:
  automake bash-completion fontconfig fontconfig-config galternatives ghostscript ghostscript-x libfontconfig1 libfontconfig1:i386 libgs9 libgs9-common
  libmariadbclient18 libmariadbd18 libnm0 libvisual-0.4-0 libvisual-0.4-0:i386 linux-headers-siduction-amd64 linux-image-siduction-amd64 man-db
  network-manager python-pkg-resources python3-pkg-resources sane-utils xsane
24 upgraded, 2 newly installed, 0 to remove and 1 not upgraded.
Need to get 68.9 MB of archives.
After this operation, 275 MB of additional disk space will be used.
Get:1 http://10.10.10.3:3142/incoming.debian.org/debian-buildd buildd-unstable/main amd64 man-db amd64 2.8.4-3 [1,194 kB]
Get:2 http://10.10.10.3:3142/incoming.debian.org/debian-buildd buildd-unstable/main amd64 network-manager amd64 1.14.4-3 [2,368 kB]
Get:3 http://10.10.10.3:3142/incoming.debian.org/debian-buildd buildd-unstable/main amd64 libnm0 amd64 1.14.4-3 [360 kB]
Get:4 http://10.10.10.3:3142/incoming.debian.org/debian-buildd buildd-unstable/main amd64 bash-completion all 1:2.8-2 [207 kB]
Get:5 http://10.10.10.3:3142/incoming.debian.org/debian-buildd buildd-unstable/main amd64 automake all 1:1.16.1-4 [771 kB]
Get:6 http://10.10.10.3:3142/incoming.debian.org/debian-buildd buildd-unstable/main amd64 fontconfig-config all 2.13.1-2 [280 kB]
Get:7 http://10.10.10.3:3142/incoming.debian.org/debian-buildd buildd-unstable/main i386 libfontconfig1 i386 2.13.1-2 [357 kB]
Get:8 http://10.10.10.3:3142/incoming.debian.org/debian-buildd buildd-unstable/main amd64 libfontconfig1 amd64 2.13.1-2 [346 kB]
Get:9 http://10.10.10.3:3142/incoming.debian.org/debian-buildd buildd-unstable/main amd64 fontconfig amd64 2.13.1-2 [405 kB]
Get:10 http://10.10.10.3:3142/incoming.debian.org/debian-buildd buildd-unstable/main amd64 galternatives all 1.0.2 [46.5 kB]
Get:11 http://10.10.10.3:3142/incoming.debian.org/debian-buildd buildd-unstable/main amd64 ghostscript-x amd64 9.25~dfsg-7 [90.0 kB]
Get:12 http://10.10.10.3:3142/incoming.debian.org/debian-buildd buildd-unstable/main amd64 ghostscript amd64 9.25~dfsg-7 [94.1 kB]
Get:13 http://10.10.10.3:3142/incoming.debian.org/debian-buildd buildd-unstable/main amd64 libgs9 amd64 9.25~dfsg-7 [2,184 kB]
Get:14 http://10.10.10.3:3142/incoming.debian.org/debian-buildd buildd-unstable/main amd64 libgs9-common all 9.25~dfsg-7 [5,134 kB]
Get:15 http://10.10.10.3:3142/incoming.debian.org/debian-buildd buildd-unstable/main amd64 libmariadbclient18 amd64 1:10.1.37-1 [737 kB]
Get:16 http://10.10.10.3:3142/incoming.debian.org/debian-buildd buildd-unstable/main amd64 libmariadbd18 amd64 1:10.1.37-1 [3,853 kB]
Get:17 http://10.10.10.3:3142/incoming.debian.org/debian-buildd buildd-unstable/main amd64 libvisual-0.4-0 amd64 0.4.0-13 [133 kB]
Get:18 http://10.10.10.3:3142/incoming.debian.org/debian-buildd buildd-unstable/main i386 libvisual-0.4-0 i386 0.4.0-13 [141 kB]
Get:19 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/siduction/extra unstable/main amd64 linux-headers-4.19.1-towo.1-siduction-amd64 amd64 4.19-8 [8,219 kB]
Get:20 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/siduction/extra unstable/main amd64 linux-image-4.19.1-towo.1-siduction-amd64 amd64 4.19-8 [40.9 MB]
Get:21 http://10.10.10.3:3142/incoming.debian.org/debian-buildd buildd-unstable/main amd64 python-pkg-resources all 40.5.0-1 [180 kB]
Get:22 http://10.10.10.3:3142/incoming.debian.org/debian-buildd buildd-unstable/main amd64 python3-pkg-resources all 40.5.0-1 [151 kB]
Get:23 http://10.10.10.3:3142/incoming.debian.org/debian-buildd buildd-unstable/main amd64 sane-utils amd64 1.0.27-3.1 [261 kB]
Get:24 http://10.10.10.3:3142/incoming.debian.org/debian-buildd buildd-unstable/main amd64 xsane amd64 0.999-6+b1 [370 kB]
Get:25 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/siduction/extra unstable/main amd64 linux-headers-siduction-amd64 amd64 4.19-8 [33.6 kB]
Get:26 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/siduction/extra unstable/main amd64 linux-image-siduction-amd64 amd64 4.19-8 [33.6 kB]
Fetched 68.9 MB in 25s (2,708 kB/s)

Updating sane-backends introduces new bugs: #908681
« Last Edit: 2018/11/06, 13:29:49 by piper »
debian sid  |  apt into it

siduction d-u warnings

Dont Break Debian




we are the priests  ...  of the temples of syrinx  ...

Offline clubex

  • User
  • Posts: 252
Re: Caution -- sane-related removals (again)
« Reply #2 on: 2018/11/06, 13:40:08 »
Piper: +1I let the sane packages be removed and re-installed what I needed ie. colord libkf5sane5 and xsane. No problems so far.

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.472
  • north of hell south of heaven
Re: Caution -- sane-related removals (again)
« Reply #3 on: 2018/11/06, 13:51:22 »
@clubex


I actually don't have a problem, I just posted what my du looked like before I did the du which looks like this after

Code: [Select]
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  libsane-common
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.


I could do this, but, at the moment I won't (different reasons)

Code: [Select]
apt purge libsane-common

The following packages will be REMOVED:
  colord* kolourpaint* kolourpaint4* libkf5sane5* libsane-common* libsane1* libsane1:i386* sane* sane-utils* simple-scan* xsane*

debian sid  |  apt into it

siduction d-u warnings

Dont Break Debian




we are the priests  ...  of the temples of syrinx  ...

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.816
    • Land of the Buckeye
Re: Caution -- sane-related removals (again)
« Reply #4 on: 2018/11/06, 14:12:48 »
Quote from: piper
Updating sane-backends introduces new bugs: #908681

Reading that thread is not encouraging.  I hope "someone" takes some responsibility -- more than I see there.

I'm not in the mood to reinstall printers today, that are currently working just fine.  I think I will wait awhile and see whether the situation gets better.
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.472
  • north of hell south of heaven
Re: Caution -- sane-related removals (again)
« Reply #5 on: 2018/11/06, 14:37:04 »
Quote from:  dibl
Reading that thread is not encouraging.  I hope "someone" takes some responsibility -- more than I see there.

Yeah, a little mess ;)
debian sid  |  apt into it

siduction d-u warnings

Dont Break Debian




we are the priests  ...  of the temples of syrinx  ...

Offline Xaver

  • User
  • Posts: 49
Re: Caution -- sane-related removals (again)
« Reply #6 on: 2018/11/06, 18:29:12 »

On my system (simply openbox) full-upgrade indicated libsane-common to be kept back this morning.
Reinstall of libsane-common showed to me, that libsane1 had to be replaced by libsane.
Then the upgrade of sane/xsane worked fine with no problems.
Could libsane1 be the cause of all your problems too?

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.531
    • g-com.eu
Re: Caution -- sane-related removals (again)
« Reply #7 on: 2018/11/06, 18:34:57 »
libsane1 was just insane :D
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline clubex

  • User
  • Posts: 252
Re: Caution -- sane-related removals (again)
« Reply #8 on: 2018/11/06, 18:44:07 »
melmarker: +1

Offline drb

  • User
  • Posts: 130
Re: Caution -- sane-related removals (again)
« Reply #9 on: 2018/11/07, 10:56:02 »
Quote
On my system (simply openbox) full-upgrade indicated libsane-common to be kept back this morning.
Reinstall of libsane-common showed to me, that libsane1 had to be replaced by libsane.
Then the upgrade of sane/xsane worked fine with no problems.
Could libsane1 be the cause of all your problems too?
Does that mean libsane1 is dead and libsane is back?



Offline jure

  • User
  • Posts: 437
Re: Caution -- sane-related removals (again)
« Reply #10 on: 2018/11/07, 11:38:36 »
changelog for sane-backends
Quote
sane-backends (1.0.27-3.1) unstable; urgency=medium

  * Non-maintainer upload.
  * Rename libsane1 back to libsane, make the renamed package provide libsane1
    (Closes: #908681)

 -- Laurent Bigonville <bigon@debian.org>  Fri, 02 Nov 2018 20:30:06 +0100
Gruss Juergen

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.531
    • g-com.eu
Re: Caution -- sane-related removals (again)
« Reply #11 on: 2018/11/07, 15:02:31 »
Not really the end of the story - so stay tuned.

<  some commercials>

....

8)
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline harley-peter

  • User
  • Posts: 729
Re: Caution -- sane-related removals (again)
« Reply #12 on: 2018/11/08, 19:49:14 »
Today I re-installed libsane and after a du all works fine.

Offline DeepDayze

  • User
  • Posts: 394
Re: Caution -- sane-related removals (again)
« Reply #13 on: 2018/11/09, 04:20:40 »
Hopefully all the sane related packages can be rebuilt against libsane and then things will be "sane" again (pun).

Offline tommy2

  • User
  • Posts: 91
Re: Caution -- sane-related removals (again)
« Reply #14 on: 2018/11/09, 11:58:48 »
Lets just keep our fingers crossed.   :)