seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/11/15, 13:49:36


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: (gelöst) tvbrowser läuft nicht mit systemd 240  (Read 770 times)

0 Members and 1 Guest are viewing this topic.

Offline hsp

  • User
  • Posts: 506
(gelöst) tvbrowser läuft nicht mit systemd 240
« on: 2018/12/23, 10:11:17 »
Alle die Tvbrowser benutzen sollten erstmal auf systemd-240 beim d-u verzichten. Ne Lösung dafür habe ich allerding nicht :)

Code: [Select]
Starting TV-Browser...
Java exec found in PATH. Verifying...
Suitable java version found [java = 1.8.0_191]
Configuring environment...
Loading TV-Browser:
java -Xms16m -Xmx512m -XX:+IgnoreUnrecognizedVMOptions --add-modules=ALL-SYSTEM -Djava.library.path="/usr/share/tvbrowser" -Dpropertiesfile=linux.properties -jar tvbrowser.jar ''
library initialization failed - unable to allocate file descriptor table - out of memory./tvbrowser.sh: Zeile 127:  1965 Abgebrochen             ${JAVA_PROGRAM_DIR}java -Xms16m -Xmx512m -XX:+IgnoreUnrecognizedVMOptions --add-modules=ALL-SYSTEM -Djava.library.path="${PROGRAM_DIR}" -Dpropertiesfile=linux.properties -jar tvbrowser.jar "$@"
TV-Browser TERMINATED.

...
« Last Edit: 2018/12/27, 17:20:49 by hsp »

Offline jure

  • User
  • Posts: 520
Re: tvbrowser läuft nicht mit systemd 240
« Reply #1 on: 2018/12/23, 10:16:08 »
mit TV Browser 4.01 und systemd-240-1 habe ich hier kein Problem

Quote
Version: 4.0.1
Plattform: Linux 4.19.11-towo.2-siduction-amd64
System: amd64

Java-Version: 10.0.2 OpenJDK 64-Bit Server VM Oracle Corporation /usr/lib/jvm/java-10-openjdk-amd64
Gruss Juergen

Offline hsp

  • User
  • Posts: 506
Re: tvbrowser läuft nicht mit systemd 240
« Reply #2 on: 2018/12/23, 10:23:02 »
Du hast auch das nicht mehr existierende 10.0.2 was auch nicht mehr im repo ist. Obsoletes Paket.
Nimm mal java 8 wie es eigentlich sein soll, was auch der Dev empfiehlt. Mit java 11 geht er erst recht nicht, das ist aber ein anderes Problem

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.308
Re: tvbrowser läuft nicht mit systemd 240
« Reply #3 on: 2018/12/23, 10:32:40 »
Nicht nur tvbrowser, ebenso jamaica/hibiscus starten mit gleicher Fehlermeldung nicht.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline jure

  • User
  • Posts: 520
Re: tvbrowser läuft nicht mit systemd 240
« Reply #4 on: 2018/12/23, 12:15:52 »
auch jamaica/hibiscus läuft hier ohne Probleme

Quote
Software-Version: 2.8.6
HBCI4Java-Version: 3.0.22-SNAPSHOT
Datenbank-Version: 65
Build: 369 [Datum 20181101]

Quote
Version: 2.8.2
SWT-Version: 4626 / gtk
Java-Version: 10.0.2 / Linux amd64
Build: 450 [Datum 20180917]
Gruss Juergen

Offline hsp

  • User
  • Posts: 506
Re: tvbrowser läuft nicht mit systemd 240
« Reply #5 on: 2018/12/23, 12:21:04 »
@jure
Jetzt nochmal, du benutzt noch eine nicht mehr existierende Javaverison, java 10 gibt es nicht mehr, schon sehr lange. Auch nicht mehr im Debianrepo. Du hast da noch ein völlig veraltetes Paket drauf. Stable version ist 8 und 11. Du solltest dein System mal aufräumen und alten Ballast entfernen.
...

/edit
es sind alle java-programme betroffen

Offline jure

  • User
  • Posts: 520
Re: tvbrowser läuft nicht mit systemd 240
« Reply #6 on: 2018/12/23, 12:26:56 »
ich habe auch

openjdk-8-jre
openjdk-11-jre

aber mit openjdk-10-jre laufen die progs eben ....
Gruss Juergen

Offline hsp

  • User
  • Posts: 506
Re: tvbrowser läuft nicht mit systemd 240
« Reply #7 on: 2018/12/23, 12:33:31 »
Irgendwann ist dein System nur noch alter Ballast, dann behalte java 10. Irgendwann klingelts oder so...

Offline hsp

  • User
  • Posts: 506
Re: tvbrowser läuft nicht mit systemd 240
« Reply #8 on: 2018/12/27, 17:20:30 »
solved, gelöst ==> systemd 240-2