seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/12/08, 21:53:31


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Update -> some encrypted Volumes not found (not mounted)  (Read 1009 times)

0 Members and 1 Guest are viewing this topic.

Offline tomsiduction

  • User
  • Posts: 108
Hallo
Nach dem letzten Update trat folgendes auf:

Beim Start wurden das Passwort für die Festplattenverschlüsselung abgefragt, aber das System konnte danach nur die verschlüsselte /root-Partition einbinden

meine beiden anderen Devices /dev/mapper/VGsys-LVhome
und
/dev/mapper/VGsys-LVhome können nicht gemounted werden.

Auch ein manueller mount klappt nicht, das system sieht die beiden LVs garnicht.


Trying in English:
Last update gave me following results:
Having 3 encrypted LVs. When the system start I give in my password.
But only one LV (root) is mounted. System says it cannot find the missing volumes.

journalctrl -xb gives me:
Code: [Select]
lvm-config failed
I did make the following update
Packages:

Code: [Select]
dconf-cli (0.30.1-1) to 0.30.1-2
dconf-editor (3.30.0-1) to 3.30.0-2
dconf-gsettings-backend (0.30.1-1) to 0.30.1-2
dconf-service (0.30.1-1) to 0.30.1-2
ffmpeg (7:4.0.3-1) to 7:4.1-1
gcr (3.28.0-2) to 3.28.0-3
gdal-data (2.3.2+dfsg-4) to 2.3.3+dfsg-1
gdisk (1.0.3-1+b1) to 1.0.3-1.1
ghostscript (9.26~dfsg-1) to 9.26~dfsg-2
ghostscript-x (9.26~dfsg-1) to 9.26~dfsg-2
gir1.2-atk-1.0 (2.30.0-1) to 2.30.0-2
gir1.2-freedesktop (1.58.2-1) to 1.58.2-2
gir1.2-gdkpixbuf-2.0 (2.38.0+dfsg-6) to 2.38.0+dfsg-7
gir1.2-glib-2.0 (1.58.2-1) to 1.58.2-2
gir1.2-packagekitglib-1.0 (1.1.11-1) to 1.1.12-1
gnome-desktop3-data (3.30.2-3) to 3.30.2-4
groff-base (1.22.3-10) to 1.22.4-1
libappstream4 (0.12.3-1) to 0.12.4-2
libappstreamqt2 (0.12.3-1) to 0.12.4-2
libarchive13 (3.3.3-1) to 3.3.3-2
libatk1.0-0 (2.30.0-1) to 2.30.0-2
libatk1.0-0:i386 (2.30.0-1) to 2.30.0-2
libatk1.0-data (2.30.0-1) to 2.30.0-2
libavcodec58 (7:4.0.3-1) to 7:4.1-1
libavdevice58 (7:4.0.3-1) to 7:4.1-1
libavfilter7 (7:4.0.3-1) to 7:4.1-1
libavformat58 (7:4.0.3-1) to 7:4.1-1
libavresample4 (7:4.0.3-1) to 7:4.1-1
libavutil56 (7:4.0.3-1) to 7:4.1-1
libbatik-java (1.10-1) to 1.10-2
libcairo-gobject2 (1.16.0-1) to 1.16.0-2
libcairo2 (1.16.0-1) to 1.16.0-2
libcairo2:i386 (1.16.0-1) to 1.16.0-2
libclang1-7 (1:7.0.1-1) to 1:7.0.1-2
libcpupower1 (4.19.9-1) to 4.19.12-1
libdconf1 (0.30.1-1) to 0.30.1-2
libdebconfclient0 (0.245) to 0.246
libgck-1-0 (3.28.0-2) to 3.28.0-3
libgcr-base-3-1 (3.28.0-2) to 3.28.0-3
libgcr-ui-3-1 (3.28.0-2) to 3.28.0-3
libgdal20 (2.3.2+dfsg-4) to 2.3.3+dfsg-1
libgdk-pixbuf2.0-0 (2.38.0+dfsg-6) to 2.38.0+dfsg-7
libgdk-pixbuf2.0-0:i386 (2.38.0+dfsg-6) to 2.38.0+dfsg-7
libgdk-pixbuf2.0-common (2.38.0+dfsg-6) to 2.38.0+dfsg-7
libgirepository-1.0-1 (1.58.2-1) to 1.58.2-2
libgnome-autoar-0-0 (0.2.3-1) to 0.2.3-2
libgnome-desktop-3-17 (3.30.2-3) to 3.30.2-4
libgs9 (9.26~dfsg-1) to 9.26~dfsg-2
libgs9-common (9.26~dfsg-1) to 9.26~dfsg-2
libharfbuzz-icu0 (2.2.0-1) to 2.3.0-1
libharfbuzz0b (2.2.0-1) to 2.3.0-1
libharfbuzz0b:i386 (2.2.0-1) to 2.3.0-1
libkasten3controllers3 (4:17.08.3-1) to 5:0.25.4-2
libkasten3core3 (4:17.08.3-1) to 5:0.25.4-2
libkasten3gui3 (4:17.08.3-1) to 5:0.25.4-2
libkasten3okteta1core1 (4:17.08.3-1) to 5:0.25.4-2
libkasten3okteta1gui1 (4:17.08.3-1) to 5:0.25.4-2
libllvm7 (1:7.0.1-1) to 1:7.0.1-2
libmariadbclient18 (1:10.1.37-3) to 1:10.3.11-1
libnautilus-extension1a (3.30.4-1) to 3.30.5-1
libnet-dns-perl (1.17-1) to 1.19-1
libnss-myhostname (239-15) to 240-1
libnss-winbind (2:4.9.2+dfsg-2) to 2:4.9.4+dfsg-1
libokteta2core2 (4:17.08.3-1) to 5:0.25.4-2
libokteta2gui2 (4:17.08.3-1) to 5:0.25.4-2
libpackagekit-glib2-18 (1.1.11-1) to 1.1.12-1
libpam-systemd (239-15) to 240-1
libpam-winbind (2:4.9.2+dfsg-2) to 2:4.9.4+dfsg-1
libpostproc55 (7:4.0.3-1) to 7:4.1-1
libsmbclient (2:4.9.2+dfsg-2) to 2:4.9.4+dfsg-1
libsoundtouch1 (2.0.0-1) to 2.1.2+ds1-1
libswresample3 (7:4.0.3-1) to 7:4.1-1
libswscale5 (7:4.0.3-1) to 7:4.1-1
libsystemd0 (239-15) to 240-1
libsystemd0:i386 (239-15) to 240-1
libudev1 (239-15) to 240-1
libudev1:i386 (239-15) to 240-1
libwbclient0 (2:4.9.2+dfsg-2) to 2:4.9.4+dfsg-1
libxml2 (2.9.4+dfsg1-7+b2) to 2.9.4+dfsg1-7+b3
libxml2-utils (2.9.4+dfsg1-7+b2) to 2.9.4+dfsg1-7+b3
libxml2:i386 (2.9.4+dfsg1-7+b2) to 2.9.4+dfsg1-7+b3
lintian (2.5.117) to 2.5.118
linux-cpupower (4.19.9-1) to 4.19.12-1
linux-libc-dev (4.19.9-1) to 4.19.12-1
mesa-utils (8.4.0-1) to 8.4.0-1+b1
nautilus (3.30.4-1) to 3.30.5-1
nautilus-data (3.30.4-1) to 3.30.5-1
okteta (4:17.08.3-1) to 5:0.25.4-2
os-prober (1.76) to 1.77
python-libxml2 (2.9.4+dfsg1-7+b2) to 2.9.4+dfsg1-7+b3
python-numpy (1:1.15.4-2) to 1:1.15.4-2+b1
python-pip-whl (18.1-2) to 18.1-3
python-samba (2:4.9.2+dfsg-2) to 2:4.9.4+dfsg-1
python3-dbus (1.2.8-2+b2) to 1.2.8-2+b3
python3-numpy (1:1.15.4-2) to 1:1.15.4-2+b1
python3-pip (18.1-2) to 18.1-3
samba-common (2:4.9.2+dfsg-2) to 2:4.9.4+dfsg-1
samba-common-bin (2:4.9.2+dfsg-2) to 2:4.9.4+dfsg-1
samba-libs (2:4.9.2+dfsg-2) to 2:4.9.4+dfsg-1
seabios (1.11.1-1) to 1.12.0-1
sed (4.5-2) to 4.7-1
systemd (239-15) to 240-1
systemd-container (239-15) to 240-1
systemd-sysv (239-15) to 240-1
udev (239-15) to 240-1
winbind (2:4.9.2+dfsg-2) to 2:4.9.4+dfsg-1
xterm (338-1) to 340-1

Die folgenden Pakete wurden installiert:
libglew2.1 (2.1.0-3)
libkasten3okteta1controllers1abi1 (5:0.25.4-2)
libmariadb3 (1:10.3.11-1)
mariadb-common (1:10.3.11-1)

EDIT:
If entering in recovery-mode the system ends up in a maintenance-console.

If I press Ctrl-D and wait for 5-6 minutes a lock-screen opens and after entering my password everything is fine (both missing volumes are mounted)

Vielen Dank

Regards
« Last Edit: 2018/12/25, 18:36:46 by tomsiduction »

Offline bluelupo

  • Global Moderator
  • User
  • *****
  • Posts: 2.066
    • http://bluelupo.net
Re: Update -> some encrypted Volumes not found (not mounted)
« Reply #1 on: 2018/12/26, 12:14:41 »
Hi tomsiduction,

tritt das Problem mit einen älteren Kernel auch auf? Fehlermeldungen aus dem Journal wären auch interessant.

Offline tomsiduction

  • User
  • Posts: 108
Re: Update -> some encrypted Volumes not found (not mounted)
« Reply #2 on: 2018/12/28, 06:31:42 »
Hallo und vielen Dank

Es hängt nicht mit dem Kernel zusammen.

Sondern

Das Problem scheint nicht neu zu sein:

#917166 - Errors on and after upgrade to 2.03.01-2, swap on lvm not mounted - Debian Bug report logs

Momentan führt jedoch ein upgrade dazu dass über 100 Pakete entfernt werden müssen.
Sowie sich das geklärt hat recherchiere ich weiter.
 

Offline axt

  • User
  • Posts: 337
    • axebase.net
Re: Update -> some encrypted Volumes not found (not mounted)
« Reply #3 on: 2018/12/28, 10:14:28 »
Quote from: tomsiduction
Momentan führt jedoch ein upgrade dazu dass über 100 Pakete entfernt werden müssen.

Die derzeitige qt5-Transition bzw. die bruchstückhafte Aktualisierung jeweiliger Pakete mit unweigerlichen Abhängigjkeitsproblemen lassen sich ja temporär verhindern. Update auf systemd-240-2 läßt sich zudem auch separat durchführen.

Offline tomsiduction

  • User
  • Posts: 108
Re: Update -> some encrypted Volumes not found (not mounted)
« Reply #4 on: 2018/12/28, 16:09:41 »
Vielen Dank

Ich möchte gerne aktualisieren und habe dazu eine Frage:
Quote from: tomsiduction
Momentan führt jedoch ein upgrade dazu dass über 100 Pakete entfernt werden müssen.

Die derzeitige qt5-Transition bzw. die bruchstückhafte Aktualisierung jeweiliger Pakete mit unweigerlichen Abhängigjkeitsproblemen lassen sich ja temporär verhindern. Update auf systemd-240-2 läßt sich zudem auch separat durchführen.


Wie kläre ich bitte, welche Pakete nicht aktualiert werden dürfen, damit ich nicht über 180 Pakete deinstallieren muss.

Vielen Dank

Offline axt

  • User
  • Posts: 337
    • axebase.net
Re: Update -> some encrypted Volumes not found (not mounted)
« Reply #5 on: 2018/12/28, 17:15:24 »
Die andersfarbigen Buchstaben sind ein Link. Desweiteren könnte in Deinem Fall auch dies helfen.

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.780
    • g-com.eu
Re: Update -> some encrypted Volumes not found (not mounted)
« Reply #6 on: 2018/12/28, 17:55:31 »
Erst mal abwarten würd ich vorschlagen - apt upgrade (bitte nicht apt-get upgrade) sollte ebenfalls alles upgraden, was so einigermaßen sicher ist, wenn keine Paketierungsfehler vorliegen.
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)