Welcome, Guest. Please login or register.
Did you miss your activation email?
2021/03/05, 17:49:26


Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Update breaks installs, no graphics, FAILs on boot loading screen  (Read 656 times)

0 Members and 1 Guest are viewing this topic.

Offline geklmintendont

  • User
  • Posts: 39
  • Banned User
I have no idea what it's from or why it happens but the update still causes FAIL on Load Kernel Modules (and a couple other things too)

Also, after the update, it consistently (I've tried to update multiple times) says it has to "recovering journal" when it boots up and I get a bunch of crap about orphaned inodes on the screen.

Also, after updating and before restarting, when shutting down I notice that it says there is a stop job running (I really wish I knew how to force these to stop... I currently unplug my machine)

I first noticed this issue around the start of the year, and it has persisted. I've tried to update about 4 times, and every time it fails.

Does anyone know what the problem is?

Yes, I noticed the "4.2 kernel breaks..." thread, but it seems to be dead, so maybe everyone else is past the issue and I'm stuck on something undiscovered (?)

No, I can't provide screenshots or copy-paste logs here, because the terminal interface doesn't let me copy text (there's no clipboard software running) and I don't actually own any cameras to take pictures of my screen.

I'm banned forever - the Mods had good reasons to do so.

Offline sunrat

  • User
  • Posts: 393
You should be able to select an earlier kernel at the GRUB screen and boot into that to view logs. journalctl can be very informative.
The thread you mentioned does provide solutions for Nvidia and Virtualbox driver fails on kernel 4.20.
The "recovering journal" messages happen because you force an improper shutdown. Search the internet for "magic sysreq keys" to learn a method to cleanly shut down.
« Last Edit: 2019/01/15, 12:13:42 by sunrat »

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.787
  • we are the priests ... of the temples of syrinx
You can *sometimes bypass "stop job running" by using  ctrl+alt+del  7 times or more, then enter root password, then reboot or try to fix.

A "stop job running" is usually but not always a wrong UUID in fstab (most common)

If you unplug your machine, your going to get "recovering journal" and do it enough times you will have no choice but to reinstall.
Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck