seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/04/19, 02:20:59


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Kein Upgrade bei libopenmpi3 und openmpi-common – Kein Display-Manager  (Read 1140 times)

0 Members and 1 Guest are viewing this topic.

Offline toam

  • User
  • Posts: 6

Hallo,


seit meinem letzten Upgrade vor einer Woche, Di. 08.01 oder Mi. 09.01, lädt der Display-Manager nicht mehr. Somit komme ich nicht auf eine Grafische-Oberfläche.


Probleme bereiten seit dem dist-upgrade die Pakete, bzw. Bibliotheken
  • libopenmpi3
  • openmpi-common
Beide bleiben auf der Version 3.1.3-5 hängen, obwohl Version 3.1.3-9 verfügbar ist. Dadurch ergibt sich ein Abhängigkeitsproblem mit anderen Paketen, die die neuere Version voraussetzen.


Code: [Select]
apt-get dist-upgrade
Paketlisten werden gelesen...
Abhängigkeitsbaum wird aufgebaut....
Statusinformationen werden eingelesen....
Probieren Sie »apt --fix-broken install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libopenmpi-dev : Hängt ab von: libopenmpi3 (= 3.1.3-9) aber 3.1.3-5 ist installiert
                  Hängt ab von: openmpi-common (>= 3.1.3-9) aber 3.1.3-5 ist installiert
 openmpi-bin : Hängt ab von: openmpi-common (>= 3.1.3-9) aber 3.1.3-5 ist installiert


Mit dem empfohlenen „apt --fix-broken install”, werden zwar die Pakete in der neuen Version heruntergeladen und versucht zu installieren. Doch dabei gibt es immer den selben Fehler.


Code: [Select]
apt --fix-broken install
Paketlisten werden gelesen...
Abhängigkeitsbaum wird aufgebaut....
Statusinformationen werden eingelesen....
Abhängigkeiten werden korrigiert ... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  libglew2.0 libhttp-parser2.8 libhunspell-1.6-0 libicu-le-hb0 libicu60
  liblouis16 liblvm2app2.2 liblvm2cmd2.02 libntfs-3g88 libopencv-core3.2
  libopencv-imgproc3.2 liborcus-0.13-0 libplacebo6 libtbb2
  libwayland-egl1-mesa node-pseudomap xfce4-mount-plugin
Verwenden Sie »apt autoremove«, um sie zu entfernen.
Die folgenden zusätzlichen Pakete werden installiert:
  libopenmpi3 openmpi-common
Die folgenden Pakete werden aktualisiert (Upgrade):
  libopenmpi3 openmpi-common
2 aktualisiert, 0 neu installiert, 0 zu entfernen und 180 nicht aktualisiert.
651 nicht vollständig installiert oder entfernt.
Es müssen noch 0 B von 2.338 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 16,4 kB Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n]


Genauso wie mit „apt-get dist-upgrade” oder
Code: [Select]
apt-get install openmpi-common=3.1.3-9 libopenmpi3=3.1.3-9


Meiner Meinung nach, ist es genau der gleiche Fehler wie bei dem Debian Bug #916890: https://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg1653733.html


Fehlerausgabe:
Code: [Select]
apt-get install -y openmpi-common=3.1.3-9 libopenmpi3=3.1.3-9
Paketlisten werden gelesen...
Abhängigkeitsbaum wird aufgebaut....
Statusinformationen werden eingelesen....
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  libglew2.0 libhttp-parser2.8 libhunspell-1.6-0 libicu-le-hb0 libicu60
  liblouis16 liblvm2app2.2 liblvm2cmd2.02 libntfs-3g88 libopencv-core3.2
  libopencv-imgproc3.2 liborcus-0.13-0 libplacebo6 libtbb2
  libwayland-egl1-mesa node-pseudomap xfce4-mount-plugin
Verwenden Sie »apt autoremove«, um sie zu entfernen.
Die folgenden Pakete werden aktualisiert (Upgrade):
  libopenmpi3 openmpi-common
2 aktualisiert, 0 neu installiert, 0 zu entfernen und 239 nicht aktualisiert.
651 nicht vollständig installiert oder entfernt.
Es müssen 2.338 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 16,4 kB Plattenplatz freigegeben.
Holen:1 http://ftp2.de.debian.org/debian unstable/main amd64 libopenmpi3 amd64 3.1.3-9 [2.174 kB]
Holen:2 http://ftp2.de.debian.org/debian unstable/main amd64 openmpi-common all 3.1.3-9 [165 kB]
apt-listchanges: Changelogs werden gelesen...
Es wurden 2.338 kB in 9 s geholt (256 kB/s).
(Lese Datenbank ...
(Lese Datenbank ... 5%
(Lese Datenbank ... 10%
(Lese Datenbank ... 15%
(Lese Datenbank ... 20%
(Lese Datenbank ... 25%
(Lese Datenbank ... 30%
(Lese Datenbank ... 35%
(Lese Datenbank ... 40%
(Lese Datenbank ... 45%
(Lese Datenbank ... 50%
(Lese Datenbank ... 55%
(Lese Datenbank ... 60%
(Lese Datenbank ... 65%
(Lese Datenbank ... 70%
(Lese Datenbank ... 75%
(Lese Datenbank ... 80%
(Lese Datenbank ... 85%
(Lese Datenbank ... 90%
(Lese Datenbank ... 95%
(Lese Datenbank ... 100%
(Lese Datenbank ... 385166 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../libopenmpi3_3.1.3-9_amd64.deb ...
Entpacken von libopenmpi3:amd64 (3.1.3-9) über (3.1.3-5) ...
rm: das Entfernen von '/usr/lib/x86_64-linux-gnu/fortran/gfortran-8#' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
rm: das Entfernen von 'End' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
rm: das Entfernen von 'automatically' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
rm: das Entfernen von 'added' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
rm: das Entfernen von 'section' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
dpkg: Warnung: »altes libopenmpi3:amd64-Skript des Paketes post-removal«-Unterprozess gab den Fehlerwert 1 zurück
dpkg: stattdessen wird Skript aus dem neuen Paket probiert ...
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/libopenmpi3_3.1.3-9_amd64.deb (--unpack):
 Es gibt kein Skript in der neuen Version des Paketes - Abbruch
Vorbereitung zum Entpacken von .../openmpi-common_3.1.3-9_all.deb ...
Entpacken von openmpi-common (3.1.3-9) über (3.1.3-5) ...
rm: das Entfernen von '/usr/lib/x86_64-linux-gnu/fortran/gfortran-8#' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
rm: das Entfernen von 'End' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
rm: das Entfernen von 'automatically' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
rm: das Entfernen von 'added' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
rm: das Entfernen von 'section' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
dpkg: Warnung: »altes openmpi-common-Skript des Paketes post-removal«-Unterprozess gab den Fehlerwert 1 zurück
dpkg: stattdessen wird Skript aus dem neuen Paket probiert ...
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/openmpi-common_3.1.3-9_all.deb (--unpack):
 Es gibt kein Skript in der neuen Version des Paketes - Abbruch
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/libopenmpi3_3.1.3-9_amd64.deb
 /var/cache/apt/archives/openmpi-common_3.1.3-9_all.deb


Die Versuche mit
Code: [Select]
apt-get install libopenmpi3=3.1.3-9 openmpi-common=3.1.3-9
und
Code: [Select]
apt-get --reinstall install libopenmpi3=3.1.3-9 openmpi-common=3.1.3-9
scheiterten jedes mal.


Was kann ich tun um dies zu beheben?
Mit Dank im voraus für die Hilfe und Unterstützung.

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.258
Den Output von


Code: [Select]
apt policy

bitte
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline toam

  • User
  • Posts: 6
Code: [Select]
libopenmpi3:
  Installiert:           3.1.3-5
  Installationskandidat: 3.1.3-9
  Versionstabelle:
     3.1.3-9 500
        500 http://ftp2.de.debian.org/debian unstable/main amd64 Packages
 *** 3.1.3-5 100
        100 /var/lib/dpkg/status

Code: [Select]
openmpi-common:
  Installiert:           3.1.3-5
  Installationskandidat: 3.1.3-9
  Versionstabelle:
     3.1.3-9 500
        500 http://ftp2.de.debian.org/debian unstable/main amd64 Packages
 *** 3.1.3-5 100
        100 /var/lib/dpkg/status

Und zusätzlich noch openmpi-bin und libopenmpi-dev:


Code: [Select]
openmpi-bin:
  Installiert:           3.1.3-9
  Installationskandidat: 3.1.3-9
  Versionstabelle:
 *** 3.1.3-9 500
        500 http://ftp2.de.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status

Code: [Select]
libopenmpi-dev:
  Installiert:           3.1.3-9
  Installationskandidat: 3.1.3-9
  Versionstabelle:
 *** 3.1.3-9 500
        500 http://ftp2.de.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.258
Das war nicht, was ich sehen wollte, sondern genau den Output von apt policy, ohne irgendein Paket!
Und weiter,

Quote
651 nicht vollständig installiert oder entfernt.

klingt nach unterprochenem d-u, oder install, mit reboot dazwischen.
Da würde ich erstmal ein dpkg -a empfehlen.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline toam

  • User
  • Posts: 6
Code: [Select]

apt policy
Paketdateien:
 100 /var/lib/dpkg/status
     release a=now
 500 http://ftp.uni-stuttgart.de/siduction/fixes unstable/contrib amd64 Packages
     release o=Siduction,a=unstable,n=unstable,c=contrib,b=amd64
     origin ftp.uni-stuttgart.de
 500 http://ftp.uni-stuttgart.de/siduction/fixes unstable/main amd64 Packages
     release o=Siduction,a=unstable,n=unstable,c=main,b=amd64
     origin ftp.uni-stuttgart.de
 500 http://ftp.uni-stuttgart.de/siduction/extra unstable/main amd64 Packages
     release o=Siduction,n=unstable,c=main,b=amd64
     origin ftp.uni-stuttgart.de
 500 http://ftp2.de.debian.org/debian unstable/non-free amd64 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=non-free,b=amd64
     origin ftp2.de.debian.org
 500 http://ftp2.de.debian.org/debian unstable/contrib amd64 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=contrib,b=amd64
     origin ftp2.de.debian.org
 500 http://ftp2.de.debian.org/debian unstable/main amd64 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=main,b=amd64
     origin ftp2.de.debian.org
Mit Pinning verwaltete Pakete:


Das Upgrade ist bis zum Ende durchgelaufen. Ich war allerdings nicht die ganze ZEit dabei. Nach dem Upgrade im tty1 habe ich einen Neustart gemacht. Seit dem 1. Hochfahren nach dem Upgrade hängt es im tty7 und der Display-Manager wird nicht geladen.


Seitdem probiere ich den Fehler über das tty1 zu lösen.

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.258
Quote
651 nicht vollständig installiert oder entfernt.

Sagt etwas Anderes!

dpkg -a

ist das Mittel der Wahl.

Dann kann auch apt weiter machen, natürlich dann erst nach einem apt update.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline toam

  • User
  • Posts: 6
Ich sehe und habe es auch gesehen, das es 651 nicht vollständig installierte oder entfernte Pakete gibt.
Ich wusste nicht, ob es von dem dist-upgrade kommt, nach dem der Fehler aufgetaucht ist oder von dist-upgrade-Versuchen danach kommt.


dpkg -a gibt zurück, dass weitere Aktionen/Optionen fehlen.

Offline toam

  • User
  • Posts: 6
O.k., mit
Code: [Select]
dpkg --configure -a



konnte ich den Upgradeprozess weiterführen. Vielen Dank für deinen Hinweis. Der Displaymanager lädt nun auch. Ich komme nun also wieder auf die GUI. :)


Dennoch besteht das Problem mit libopenmpi3 und openmpi-common.
Code: [Select]
apt-get --fix-broken install -y

Paketlisten werden gelesen...
Abhängigkeitsbaum wird aufgebaut....
Statusinformationen werden eingelesen....
Abhängigkeiten werden korrigiert ... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  libglew2.0 libhttp-parser2.8 libhunspell-1.6-0 libicu-le-hb0 libicu60
  liblouis16 liblvm2app2.2 liblvm2cmd2.02 libntfs-3g88 libopencv-core3.2
  libopencv-imgproc3.2 liborcus-0.13-0 libplacebo6 libtbb2
  libwayland-egl1-mesa linux-headers-4.19.6-towo.1-siduction-amd64
  linux-image-4.19.6-towo.1-siduction-amd64 node-pseudomap xfce4-mount-plugin
Verwenden Sie »apt autoremove«, um sie zu entfernen.
Die folgenden zusätzlichen Pakete werden installiert:
  libopenmpi3 openmpi-common
Die folgenden Pakete werden aktualisiert (Upgrade):
  libopenmpi3 openmpi-common
2 aktualisiert, 0 neu installiert, 0 zu entfernen und 239 nicht aktualisiert.
2 nicht vollständig installiert oder entfernt.
Es müssen 2.338 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 16,4 kB Plattenplatz freigegeben.
Holen:1 http://ftp2.de.debian.org/debian unstable/main amd64 libopenmpi3 amd64 3.1.3-9 [2.174 kB]
Holen:2 http://ftp2.de.debian.org/debian unstable/main amd64 openmpi-common all 3.1.3-9 [165 kB]
apt-listchanges: Changelogs werden gelesen...
Es wurden 2.338 kB in 6 s geholt (409 kB/s).
(Lese Datenbank ...
(Lese Datenbank ... 5%
(Lese Datenbank ... 10%
(Lese Datenbank ... 15%
(Lese Datenbank ... 20%
(Lese Datenbank ... 25%
(Lese Datenbank ... 30%
(Lese Datenbank ... 35%
(Lese Datenbank ... 40%
(Lese Datenbank ... 45%
(Lese Datenbank ... 50%
(Lese Datenbank ... 55%
(Lese Datenbank ... 60%
(Lese Datenbank ... 65%
(Lese Datenbank ... 70%
(Lese Datenbank ... 75%
(Lese Datenbank ... 80%
(Lese Datenbank ... 85%
(Lese Datenbank ... 90%
(Lese Datenbank ... 95%
(Lese Datenbank ... 100%
(Lese Datenbank ... 385166 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../libopenmpi3_3.1.3-9_amd64.deb ...
Entpacken von libopenmpi3:amd64 (3.1.3-9) über (3.1.3-5) ...
rm: das Entfernen von '/usr/lib/x86_64-linux-gnu/fortran/gfortran-8#' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
rm: das Entfernen von 'End' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
rm: das Entfernen von 'automatically' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
rm: das Entfernen von 'added' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
rm: das Entfernen von 'section' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
dpkg: Warnung: »altes libopenmpi3:amd64-Skript des Paketes post-removal«-Unterprozess gab den Fehlerwert 1 zurück
dpkg: stattdessen wird Skript aus dem neuen Paket probiert ...
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/libopenmpi3_3.1.3-9_amd64.deb (--unpack):
 Es gibt kein Skript in der neuen Version des Paketes - Abbruch
Vorbereitung zum Entpacken von .../openmpi-common_3.1.3-9_all.deb ...
Entpacken von openmpi-common (3.1.3-9) über (3.1.3-5) ...
rm: das Entfernen von '/usr/lib/x86_64-linux-gnu/fortran/gfortran-8#' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
rm: das Entfernen von 'End' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
rm: das Entfernen von 'automatically' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
rm: das Entfernen von 'added' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
rm: das Entfernen von 'section' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
dpkg: Warnung: »altes openmpi-common-Skript des Paketes post-removal«-Unterprozess gab den Fehlerwert 1 zurück
dpkg: stattdessen wird Skript aus dem neuen Paket probiert ...
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/openmpi-common_3.1.3-9_all.deb (--unpack):
 Es gibt kein Skript in der neuen Version des Paketes - Abbruch
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/libopenmpi3_3.1.3-9_amd64.deb
 /var/cache/apt/archives/openmpi-common_3.1.3-9_all.deb
[size=78%]


Ein
[/size]
Code: [Select]
apt-get autoremove
[size=78%]
zum bereinigen geht auch nicht. apt-get geht wieder gar nicht, da die Fehlermeldung mit den unerfüllten Abhänigkeiten apt zum Beenden bringt

[/size]

Code: [Select]
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Probieren Sie »apt --fix-broken install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libopenmpi-dev : Hängt ab von: libopenmpi3 (= 3.1.3-9) aber 3.1.3-5 ist installiert
                  Hängt ab von: openmpi-common (>= 3.1.3-9) aber 3.1.3-5 ist installiert
 openmpi-bin : Hängt ab von: openmpi-common (>= 3.1.3-9) aber 3.1.3-5 ist installiert
E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt --fix-broken install« ohne Angabe eines Pakets (oder geben Sie eine Lösung an).

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.258
Die entsprechend angemeckerten  Scripte in /var/lib/dpkg/info editieren, da ein

exit 0

nach

set -e

reinmalen, abspeichen und

apt -f install

oder den Mist erstmal komplett purgen.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline toam

  • User
  • Posts: 6
Quote
Die entsprechend angemeckerten  Scripte in /var/lib/dpkg/info editieren, da ein

exit 0
nach
set -e
reinmalen, abspeichen und
apt -f install
oder den Mist erstmal komplett purgen.



Danke für den Hinweis, wo ich die Skripte finde und wie ich diese abändern kann. Das hat funktioniert.
Ein purge oder remove sowie autoremove der Pakete ging nicht. Apt hat immer wegen den Abhängigkeitsproblemen gemeckert und nichts ausgeführt.


Jetzt, nach der Änderung der beiden Skripte, sind die beiden Pakete installiert worden.


Ich weiß gar nicht, wozu OpenMPI3 installiert ist. Ist das, zusammen mit bestimmten Abhängigkeiten, standardmäßig bei Debian, bzw. Siduction installiert?


Danke für deine sehr gute und schnelle Hilfe!

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.258
Ich denke nicht, daß siduction openmpi standardmäßig installiert, das Cinnamon Flavour jedenfalls nicht.
Code: [Select]
~
towo:Defiant> apt policy openmpi-bin
openmpi-bin:
  Installiert:           (keine)
  Installationskandidat: 3.1.3-9
  Versionstabelle:
     3.1.3-9 500
        500 http://deb.debian.org/debian unstable/main amd64 Packages
        500 http://deb.debian.org/debian testing/main amd64 Packages
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline rumbarger

  • Newbie
  • Posts: 3
This seems to be a problem with my install as well - translation function is weak here.
Code: [Select]
root@siductionbox:/home/ralph# apt full-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libopenmpi-dev : Depends: libopenmpi3 (= 3.1.3-9) but 3.1.3-5 is installed
                  Depends: openmpi-common (>= 3.1.3-9) but 3.1.3-5 is installed
 openmpi-bin : Depends: openmpi-common (>= 3.1.3-7) but 3.1.3-5 is installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).[code]

of course "apt --fix-broken install"  fails with
[code]Reading database ... 384097 files and directories currently installed.)Preparing to unpack .../libopenmpi3_3.1.3-9_amd64.deb ...
Unpacking libopenmpi3:amd64 (3.1.3-9) over (3.1.3-5) ...
rm: cannot remove '/usr/lib/x86_64-linux-gnu/fortran/gfortran-8#': No such file or directory
rm: cannot remove 'End': No such file or directory
rm: cannot remove 'automatically': No such file or directory
rm: cannot remove 'added': No such file or directory
rm: cannot remove 'section': No such file or directory
dpkg: warning: old libopenmpi3:amd64 package post-removal script subprocess returned error exit status 1
dpkg: trying script from the new package instead ...
dpkg: error processing archive /var/cache/apt/archives/libopenmpi3_3.1.3-9_amd64.deb (--unpack):
 there is no script in the new version of the package - giving up
Preparing to unpack .../openmpi-common_3.1.3-9_all.deb ...
Unpacking openmpi-common (3.1.3-9) over (3.1.3-5) ...
rm: cannot remove '/usr/lib/x86_64-linux-gnu/fortran/gfortran-8#': No such file or directory
rm: cannot remove 'End': No such file or directory
rm: cannot remove 'automatically': No such file or directory
rm: cannot remove 'added': No such file or directory
rm: cannot remove 'section': No such file or directory
dpkg: warning: old openmpi-common package post-removal script subprocess returned error exit status 1
dpkg: trying script from the new package instead ...
dpkg: error processing archive /var/cache/apt/archives/openmpi-common_3.1.3-9_all.deb (--unpack):
 there is no script in the new version of the package - giving up
Errors were encountered while processing:
 /var/cache/apt/archives/libopenmpi3_3.1.3-9_amd64.deb
 /var/cache/apt/archives/openmpi-common_3.1.3-9_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any attempt to 'apt remove' results in a 'missing removal script, trying new removal script - none there either' type of error, eg:
Code: [Select]
rm: cannot remove '/usr/lib/x86_64-linux-gnu/fortran/gfortran-8#': No such file or directoryrm: cannot remove 'End': No such file or directory
rm: cannot remove 'automatically': No such file or directory
rm: cannot remove 'added': No such file or directory
rm: cannot remove 'section': No such file or directory
dpkg: warning: old openmpi-common package post-removal script subprocess returned error exit status 1
dpkg: trying script from the new package instead ...
dpkg: error processing archive /var/cache/apt/archives/openmpi-common_3.1.3-9_all.deb (--unpack):
 there is no script in the new version of the package - giving up
Errors were encountered while processing:
 /var/cache/apt/archives/libopenmpi3_3.1.3-9_amd64.deb
 /var/cache/apt/archives/openmpi-common_3.1.3-9_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

The suggested apt autoremove and apt --fix-broken install fail similarly.

It might be time for a reinstall at any rate, but thought it worth while to check what was said.Heck, 8 years with only upgrades isn't bad.
Thanks,
Ralph
« Last Edit: 2019/01/18, 17:39:42 by rumbarger »

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.629
  • we are the priests ... of the temples of syrinx
I had no problems installing it, I don't use it, so I will purge

Code: [Select]
11:53:00 AM-Fri Jan 18-[piper@x1] $ su
Password:
root@x1:/home/piper# apt install openmpi-bin
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  libcaf-openmpi-3 libcoarrays-openmpi-dev libfabric1 libhwloc-dev libhwloc-plugins libhwloc5 libibverbs-dev libnl-3-dev libnl-route-3-dev libnuma-dev
  libopenmpi-dev libopenmpi3 libpmix2 libpsm-infinipath1 libpsm2-2 librdmacm1 openmpi-common
Suggested packages:
  libhwloc-contrib-plugins openmpi-doc
The following NEW packages will be installed:
  libcaf-openmpi-3 libcoarrays-openmpi-dev libfabric1 libhwloc-dev libhwloc-plugins libhwloc5 libibverbs-dev libnl-3-dev libnl-route-3-dev libnuma-dev
  libopenmpi-dev libopenmpi3 libpmix2 libpsm-infinipath1 libpsm2-2 librdmacm1 openmpi-bin openmpi-common
0 upgraded, 18 newly installed, 0 to remove and 113 not upgraded.
1 not fully installed or removed.
Need to get 5,862 kB of archives.
After this operation, 23.6 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 libpsm-infinipath1 amd64 3.3+20.604758e7-6 [168 kB]
Get:2 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 libpsm2-2 amd64 11.2.68-4 [177 kB]
Get:3 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 librdmacm1 amd64 21.0-1 [65.0 kB]
Get:4 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 libfabric1 amd64 1.6.2-2 [396 kB]
Get:5 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 libhwloc5 amd64 1.11.12-1 [111 kB]
Get:6 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 libhwloc-plugins amd64 1.11.12-1 [17.3 kB]
Get:7 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 libpmix2 amd64 3.1.0~rc4-1 [497 kB]
Get:8 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 libopenmpi3 amd64 3.1.3-9 [2,174 kB]
Get:9 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 libcaf-openmpi-3 amd64 2.4.0-2 [35.6 kB]
Get:10 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 openmpi-common all 3.1.3-9 [165 kB]
Get:11 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 openmpi-bin amd64 3.1.3-9 [200 kB]
Get:12 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 libcoarrays-openmpi-dev amd64 2.4.0-2 [35.2 kB]
Get:13 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 libnuma-dev amd64 2.0.12-1 [39.2 kB]
Get:14 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 libhwloc-dev amd64 1.11.12-1 [175 kB]
Get:15 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 libnl-3-dev amd64 3.4.0-1 [102 kB]
Get:16 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 libnl-route-3-dev amd64 3.4.0-1 [177 kB]
Get:17 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 libibverbs-dev amd64 21.0-1 [355 kB]
Get:18 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable/main amd64 libopenmpi-dev amd64 3.1.3-9 [974 kB]
Fetched 5,862 kB in 1s (5,007 kB/s) 
Selecting previously unselected package libpsm-infinipath1.
(Reading database ... 240845 files and directories currently installed.)
Preparing to unpack .../00-libpsm-infinipath1_3.3+20.604758e7-6_amd64.deb ...
Unpacking libpsm-infinipath1 (3.3+20.604758e7-6) ...
Selecting previously unselected package libpsm2-2.
Preparing to unpack .../01-libpsm2-2_11.2.68-4_amd64.deb ...
Unpacking libpsm2-2 (11.2.68-4) ...
Selecting previously unselected package librdmacm1:amd64.
Preparing to unpack .../02-librdmacm1_21.0-1_amd64.deb ...
Unpacking librdmacm1:amd64 (21.0-1) ...
Selecting previously unselected package libfabric1.
Preparing to unpack .../03-libfabric1_1.6.2-2_amd64.deb ...
Unpacking libfabric1 (1.6.2-2) ...
Selecting previously unselected package libhwloc5:amd64.
Preparing to unpack .../04-libhwloc5_1.11.12-1_amd64.deb ...
Unpacking libhwloc5:amd64 (1.11.12-1) ...
Selecting previously unselected package libhwloc-plugins:amd64.
Preparing to unpack .../05-libhwloc-plugins_1.11.12-1_amd64.deb ...
Unpacking libhwloc-plugins:amd64 (1.11.12-1) ...
Selecting previously unselected package libpmix2:amd64.
Preparing to unpack .../06-libpmix2_3.1.0~rc4-1_amd64.deb ...
Unpacking libpmix2:amd64 (3.1.0~rc4-1) ...
Selecting previously unselected package libopenmpi3:amd64.
Preparing to unpack .../07-libopenmpi3_3.1.3-9_amd64.deb ...
Unpacking libopenmpi3:amd64 (3.1.3-9) ...
Selecting previously unselected package libcaf-openmpi-3:amd64.
Preparing to unpack .../08-libcaf-openmpi-3_2.4.0-2_amd64.deb ...
Unpacking libcaf-openmpi-3:amd64 (2.4.0-2) ...
Selecting previously unselected package openmpi-common.
Preparing to unpack .../09-openmpi-common_3.1.3-9_all.deb ...
Unpacking openmpi-common (3.1.3-9) ...
Selecting previously unselected package openmpi-bin.
Preparing to unpack .../10-openmpi-bin_3.1.3-9_amd64.deb ...
Unpacking openmpi-bin (3.1.3-9) ...
Selecting previously unselected package libcoarrays-openmpi-dev:amd64.
Preparing to unpack .../11-libcoarrays-openmpi-dev_2.4.0-2_amd64.deb ...
Unpacking libcoarrays-openmpi-dev:amd64 (2.4.0-2) ...
Selecting previously unselected package libnuma-dev:amd64.
Preparing to unpack .../12-libnuma-dev_2.0.12-1_amd64.deb ...
Unpacking libnuma-dev:amd64 (2.0.12-1) ...
Selecting previously unselected package libhwloc-dev:amd64.
Preparing to unpack .../13-libhwloc-dev_1.11.12-1_amd64.deb ...
Unpacking libhwloc-dev:amd64 (1.11.12-1) ...
Selecting previously unselected package libnl-3-dev:amd64.
Preparing to unpack .../14-libnl-3-dev_3.4.0-1_amd64.deb ...
Unpacking libnl-3-dev:amd64 (3.4.0-1) ...
Selecting previously unselected package libnl-route-3-dev:amd64.
Preparing to unpack .../15-libnl-route-3-dev_3.4.0-1_amd64.deb ...
Unpacking libnl-route-3-dev:amd64 (3.4.0-1) ...
Selecting previously unselected package libibverbs-dev:amd64.
Preparing to unpack .../16-libibverbs-dev_21.0-1_amd64.deb ...
Unpacking libibverbs-dev:amd64 (21.0-1) ...
Selecting previously unselected package libopenmpi-dev:amd64.
Preparing to unpack .../17-libopenmpi-dev_3.1.3-9_amd64.deb ...
Unpacking libopenmpi-dev:amd64 (3.1.3-9) ...
Setting up libpsm2-2 (11.2.68-4) ...
Setting up libnl-3-dev:amd64 (3.4.0-1) ...
Setting up libnl-route-3-dev:amd64 (3.4.0-1) ...
Setting up librdmacm1:amd64 (21.0-1) ...
Setting up libhwloc5:amd64 (1.11.12-1) ...
Processing triggers for siduction-dynamic-dms (2016.01.31) ...
Setting up libpsm-infinipath1 (3.3+20.604758e7-6) ...
update-alternatives: using /usr/lib/libpsm1/libpsm_infinipath.so.1.16 to provide /usr/lib/x86_64-linux-gnu/libpsm_infinipath.so.1 (libpsm_infinipath.so.1) in auto mode
Setting up libhwloc-plugins:amd64 (1.11.12-1) ...
Setting up openmpi-common (3.1.3-9) ...
Processing triggers for libc-bin (2.28-5) ...
Processing triggers for man-db (2.8.5-1) ...
Setting up libnuma-dev:amd64 (2.0.12-1) ...
Setting up libibverbs-dev:amd64 (21.0-1) ...
Setting up libfabric1 (1.6.2-2) ...
Setting up libhwloc-dev:amd64 (1.11.12-1) ...
Setting up libpmix2:amd64 (3.1.0~rc4-1) ...
Setting up libopenmpi3:amd64 (3.1.3-9) ...
Setting up openmpi-bin (3.1.3-9) ...
update-alternatives: using /usr/bin/mpirun.openmpi to provide /usr/bin/mpirun (mpirun) in auto mode
update-alternatives: using /usr/bin/mpicc.openmpi to provide /usr/bin/mpicc (mpi) in auto mode
Setting up libcaf-openmpi-3:amd64 (2.4.0-2) ...
Setting up libopenmpi-dev:amd64 (3.1.3-9) ...
update-alternatives: using /usr/lib/x86_64-linux-gnu/openmpi/include to provide /usr/include/x86_64-linux-gnu/mpi (mpi-x86_64-linux-gnu) in auto mode
Setting up libcoarrays-openmpi-dev:amd64 (2.4.0-2) ...
Processing triggers for libc-bin (2.28-5) ...
"We're all grown up and don't freak out when a piece of text contains the word 'fuck'. I still don't understand why people think that the word 'fuck' is what would keep certain groups from contributing to the Linux kernel. In all seriousness, it doesn't."

John Paul Adrian Glaubitz

Offline rumbarger

  • Newbie
  • Posts: 3
Howdy Piper:
Perhaps I misspoke - I have no need of that program and did not install it unless perhaps as part of some other thing - Brave or pdfsam perhaps?
The problem is that dist-upgrade is impossible with this broken package in it's current state.  I attempted to purge each package in the list of the ones that were installed for you, and each ended with a similar message to :
Code: [Select]
The following packages have unmet dependencies:
 libfabric1 : Depends: libpsm2-2 (>= 10.3-37) but it is not going to be installed
 libopenmpi-dev : Depends: libopenmpi3 (= 3.1.3-9) but 3.1.3-5 is to be installed
                  Depends: openmpi-common (>= 3.1.3-9) but 3.1.3-5 is to be installed
 libopenmpi3 : Depends: libpsm2-2 (>= 10.3-37) but it is not going to be installed
 openmpi-bin : Depends: openmpi-common (>= 3.1.3-7) but 3.1.3-5 is to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
It seems there is a missing 'uninstall' script in one package with this error:
Code: [Select]
Unpacking openmpi-common (3.1.3-9) over (3.1.3-5) ...
rm: cannot remove '/usr/lib/x86_64-linux-gnu/fortran/gfortran-8#': No such file or directory
rm: cannot remove 'End': No such file or directory
rm: cannot remove 'automatically': No such file or directory
rm: cannot remove 'added': No such file or directory
rm: cannot remove 'section': No such file or directory
dpkg: warning: old openmpi-common package post-removal script subprocess returned error exit status 1
dpkg: trying script from the new package instead ...
dpkg: error processing archive /var/cache/apt/archives/openmpi-common_3.1.3-9_all.deb (--unpack):
 there is no script in the new version of the package - giving up

Truly I only have the roughest idea that openmpi is some sort of coding tool? which I would have No Need Of in this lifetime  :)
Thanis for your response
Ralph

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.629
  • we are the priests ... of the temples of syrinx
"We're all grown up and don't freak out when a piece of text contains the word 'fuck'. I still don't understand why people think that the word 'fuck' is what would keep certain groups from contributing to the Linux kernel. In all seriousness, it doesn't."

John Paul Adrian Glaubitz