seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/07/24, 05:11:41


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [solved] du wants to remove libllvm3.9  (Read 266 times)

0 Members and 1 Guest are viewing this topic.

Offline jyp

  • User
  • Posts: 69
[solved] du wants to remove libllvm3.9
« on: 2019/03/17, 20:54:52 »
Hi everyone
Tried to du today but libllvm3.9 is to be removed. Is it safe fo proceed?I do not compile anything.

Code: [Select]
~$ inxi -v3
System:    Host: omega Kernel: 4.20.13-towo.1-siduction-amd64 x86_64 bits: 64 compiler: gcc v: 8.3.0
           Desktop: KDE Plasma 5.14.5 Distro: siduction 17.1.0 Patience - kde - (201703051755)
           base: Debian GNU/Linux buster/sid
Machine:   Type: Desktop System: ASUS product: All Series v: N/A serial: <root required>
           Mobo: ASUSTeK model: SABERTOOTH Z87 v: Rev 1.xx serial: <root required> BIOS: American Megatrends
           v: 1803 date: 02/17/2014
Battery:   Device-1: hidpp_battery_0 model: Logitech MX Ergo Multi-Device Trackball
           charge: 100% (should be ignored) status: Discharging
CPU:       Topology: Quad Core model: Intel Core i5-4670K bits: 64 type: MCP arch: Haswell rev: 3
           L2 cache: 6144 KiB
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 27184
           Speed: 800 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800
Graphics:  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics vendor: ASUSTeK
           driver: i915 v: kernel bus ID: 00:02.0
           Display: x11 server: X.Org 1.20.3 driver: modesetting unloaded: fbdev,vesa
           resolution: 1920x1080~60Hz, 1920x1200~60Hz
           OpenGL: renderer: Mesa DRI Intel Haswell Desktop v: 4.5 Mesa 18.3.4 direct render: Yes
Network:   Device-1: Intel Ethernet I217-V vendor: ASUSTeK driver: e1000e v: 3.2.6-k port: f080 bus ID: 00:19.0
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: 74:d0:2b:c8:39:c1
Drives:    Local Storage: total: 3.75 TiB used: 1.17 TiB (31.2%)
Info:      Processes: 234 Uptime: 13d 32m Memory: 15.54 GiB used: 8.00 GiB (51.4%) Init: systemd runlevel: 5
           Compilers: gcc: 8.3.0 Shell: bash v: 5.0.2 inxi: 3.0.32
Code: [Select]
~$ apt-rdepends --state-follow=Installed --follow=Depends,PreDepends,Recommends --show=Depends,PreDepends,Recommends --state-show=Installed -r libllvm3.9
Reading package lists... Done
Building dependency tree
Reading state information... Done
libllvm3.9

Thanks
« Last Edit: 2019/03/18, 18:20:31 by jyp »

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.273
Re: du wants to remove libllvm3.9
« Reply #1 on: 2019/03/17, 20:59:38 »
We use llvm8 nowdays.
So yes, let that old lib go.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline jyp

  • User
  • Posts: 69
Re: du wants to remove libllvm3.9
« Reply #2 on: 2019/03/18, 04:44:36 »
@towo

Thanks.
On my system libllvm8 is not installed. So I guess I didn't need it.
Will proceed with the du.