seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/09/21, 02:26:26


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: (solved) PC Startproblem nach du & kein X  (Read 837 times)

0 Members and 1 Guest are viewing this topic.

Offline jure

  • User
  • Posts: 517
(solved) PC Startproblem nach du & kein X
« on: 2019/07/03, 10:57:13 »
Hallo zusammen,

seit dem du von gestern abend startet mein tagesaktueller PC (KDE) nicht mehr, d.h. es kommt kein graphischer login mehr. Es kommen mehrere "failed to start xyz service" Meldungen, als erstes "failed to start wpa supplicant".
Das Netzwerk läuft nicht, div. Aktionen laufen extrem langsam.

Kernel 5.1.12-towo.1-siduction-amd64
Kernel 5.1.15-towo.1-siduction-amd64

Es wurden nur wenige Pakete upgedatet :
dkms
libpng16-16
libwebkit2-gtk
libjavascriptcoregtk
openjdk-11-jre

Ich bin "etwas" ratlos ...... :-[
und schreibe hier vom Tablett und kann Infos nicht vom PC senden, da kein Netzwerk.

Anfang der Ausgabe von journalctl -xb -p err, es folgen noch div. "failed to start...."
« Last Edit: 2019/07/07, 10:09:48 by jure »
Gruss Juergen

Offline unklarer

  • User
  • Posts: 474
Re: PC Startproblem nach du
« Reply #1 on: 2019/07/03, 11:46:44 »
Leider keine Hilfe für dich...   :(

Ich habe eben mein System auf den neuesten Stand gebracht (wöchentlich mehrmals) und habe diesen Fehler nicht.
Code: [Select]
inxi -SGxxx
System:    Host: sidukde Kernel: 5.1.15-towo.1-siduction-amd64 x86_64 bits: 64 compiler: gcc v: 8.3.0
           Desktop: KDE Plasma 5.14.5 tk: Qt 5.11.3 wm: kwin_x11 dm: LightDM 1.26.0
           Distro: siduction 16.1.0 Patience - kde - (201702251051) base: Debian GNU/Linux 10 (buster)
Graphics:  Device-1: AMD Caicos [Radeon HD 6450/7450/8450 / R5 230 OEM] vendor: PC Partner Limited
           driver: radeon v: kernel bus ID: 01:00.0 chip ID: 1002:6779
           Display: x11 server: X.Org 1.20.4 driver: ati,radeon unloaded: fbdev,modesetting,vesa
           compositor: kwin_x11 resolution: 1920x1080~60Hz
           OpenGL: renderer: AMD CAICOS (DRM 2.50.0 / 5.1.15-towo.1-siduction-amd64 LLVM 7.0.1)
           v: 3.3 Mesa 18.3.6 compat-v: 3.1 direct render: Yes

ist ein Desktop-PC. Wenn es sich bei dir um sddm handelt, würde ich zuerst dort ansetzen. Alles Andere sind m.M. Folgefehler.
« Last Edit: 2019/07/03, 12:32:35 by unklarer »

Offline jure

  • User
  • Posts: 517
Re: PC Startproblem nach du
« Reply #2 on: 2019/07/03, 13:03:15 »
Danke für die Infos.

Ich behaupte ja nicht, dass das Problem durch das du verursacht wurde, es trat halt direkt beim booten danach auf.

Ich verwende lightdm 1.26.0-4
systemctl start lightdm.service bringt



bricht dann mit timeout ab

Via ceni (an dem ich aber lange nichts verstellt habe, wie auch sonst nichts verändert wurde) konnte ich eth0 wieder aktivieren, Netz läuft also zZ wieder.

Gruss Juergen

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.298
Re: PC Startproblem nach du
« Reply #3 on: 2019/07/03, 13:08:06 »
Bote mal mit selinux=0 als Kernelparameter.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline jure

  • User
  • Posts: 517
Re: PC Startproblem nach du
« Reply #4 on: 2019/07/03, 13:34:08 »
Im grub menue kernel ausgewählt und über "e" die Parameter unten mit selinux=0 ergänzt und gebootet.
Es rauschen die Meldungen durch "ok started" dann bleibt er hängen und es kommen die Fehler failed bzgl login manager, modem manager etc - siehe Bilder.
Nach ein paar Minuten kommt der login auf der Konsole, bis das login dann durch ist dauert es auch wieder  (unable to get valid context for root),  dann bin ich eingeloggt - hmm
Gruss Juergen

Offline jure

  • User
  • Posts: 517
Re: PC Startproblem nach du
« Reply #5 on: 2019/07/03, 16:39:22 »
Es funktioniert nur die 1te Konsole.

Xorg.o.log endet mit
Quote
Fatal server error:
(EE) SELinux: Failed to open x_contexts mapping in policy
Es ist aber nix von selinux-* installiert...

Hier der lightdm log - welche logs / Infos können noch helfen ?
« Last Edit: 2019/07/03, 16:44:39 by jure »
Gruss Juergen

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.744
    • g-com.eu
Re: PC Startproblem nach du & kein X
« Reply #6 on: 2019/07/04, 13:24:31 »
https://forum.siduction.org/index.php?topic=7674.msg62484#msg62484

Probiers mal damit - aus irgendwelchen Gründen wird selinux mitgeliefert, aber nich konfiguriert.

Edit: Das würde auf jeden Fall das SELINUX-Problem lösen - was Du mit dem bootparameter schon mal gemacht hattest. Zum Thema LightDM - genau aus diesen Gründen benutzen wir durchgängig SDDM, es hatte irgendwie keiner mehr Bock, sich mit den immer neuen Fehlern in LightDM auseinanderzusetzen.
« Last Edit: 2019/07/04, 13:28:15 by melmarker »
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline jure

  • User
  • Posts: 517
Re: PC Startproblem nach du & kein X
« Reply #7 on: 2019/07/04, 14:54:06 »
EDIT !

in /etc/selinux/config  "SELINUX=permissive" auf disabled zu setzen hat es gebracht, der PC bootet und läuft (scheinbar) wieder normal - und ich brauche den ...
Viiielen Dank für deinen Tip !!


Hi Melmarker

danke für den input, es reicht also "SELINUX=permissive" auf disabled zu setzen ?!
Aber als Bootparameter hat SElinux=0 nix gebracht.

Die Kiste braucht ca 10 min bis zum login auf der Konsole. Es wir versucht diverse Dienste zu starten, siehe Bilder oben, was aber letztendlich nicht funzt. Selbst das login braucht dann ca. 1,5 min

Was mich wundert wo der Fehler plötzlich herkommt, wo ich nichts verändert oder installiert habe, außer den wenigen updates der letzten Tage.

Zum Wechsel von lightdm auf sddm reicht ein apt purge lightdm-* und apt install sddm (gibt 9 Pakete) ?
dpkg -l lightdm-* zeigt nur lightdm-kde-greeter als installiert an.

« Last Edit: 2019/07/04, 15:01:57 by jure »
Gruss Juergen

Offline jure

  • User
  • Posts: 517
Re: (solved) PC Startproblem nach du & kein X
« Reply #8 on: 2019/07/04, 16:55:33 »
ja aber ...


was nicht funktioniert, ist das mounten der NAS LW. Auch hier hatte ich nichts geändert, weder am NAS, noch am PC.

hier für "daten-nas, dto für die anderen mounts vom NAS auf den PC
Quote
journalctl -xb -p err

Jul 04 16:44:51 siductionbox NetworkManager[812]: ^[[0;1;39m<error> [1562251491.7890] session-monitor: failed to create systemd-logind monitor: -2
Jul 04 16:45:03 siductionbox sudo[1695]: ^[[0;1;39mpam_unix(sudo:auth): conversation failed
Jul 04 16:45:03 siductionbox sudo[1695]: ^[[0;1;39mpam_unix(sudo:auth): auth could not identify password for [juergen]
Jul 04 16:45:05 siductionbox systemd[1]: ^[[0;1;39mFailed to mount /media/daten-nas.
-- Subject: A start job for unit media-daten\x2dnas.mount has failed
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- A start job for unit media-daten\x2dnas.mount has finished with a failure.
--
-- The job identifier is 1462 and the job result is failed.
Jul 04 16:45:06 siductionbox systemd[1]: ^[[0;1;39mFailed to mount /media/daten-nas.
-- Subject: A start job for unit media-daten\x2dnas.mount has failed
-- Defined-By: systemd
......

die seit langem bestehenden Einträge in fstab sehen so aus

Code: [Select]
192.168.2.60:/volume1/daten     /media/daten-nas        nfs4     noauto,x-systemd.automount,x-systemd.device-timeout=10,timeo=14,x-systemd.idle-timeout=1min 0 0
« Last Edit: 2019/07/04, 18:00:50 by jure »
Gruss Juergen

Offline jure

  • User
  • Posts: 517
Re: (solved) PC Startproblem nach du & kein X
« Reply #9 on: 2019/07/04, 18:22:06 »
auch merkwürdig

z.B.
Code: [Select]
root@siductionbox:/home/juergen# ifconfig
Command 'ifconfig' is available in '/sbin/ifconfig'
The command could not be located because '/sbin' is not included in the PATH environment variable.
This is most likely caused by the lack of administrative privileges associated with your user account.
ifconfig: command not found
Gruss Juergen

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.744
    • g-com.eu
Re: (solved - nicht ganz) PC Startproblem nach du & kein X
« Reply #10 on: 2019/07/04, 23:54:58 »
nö - das ist das neues debian default - dooferweise musst Du die notwenigen Umstellungen auf das alte Verhalten selbst in die Defaults tippen - in den neuen Isos habe ich das mal ganz eigenmächtig gemacht, so gut es ging.

Als das eingeführt wurde, hatten wir glaube ich auch massig Anleitungen hier im Forum wie das ging. Ich habs mittlerweile verdrängt ;)
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline jure

  • User
  • Posts: 517
Re: (solved - nicht ganz) PC Startproblem nach du & kein X
« Reply #11 on: 2019/07/05, 08:40:14 »
ok dann schaue ich mal bzgl der Rechte

aber das ist ja wohl nicht default, wie ich eins weiter oben schrieb
https://forum.siduction.org/index.php?topic=7697.msg62664#msg62664

"..was nicht funktioniert, ist das mounten der NAS LW. Auch hier hatte ich nichts geändert, weder am NAS, noch am PC.."

Gruss Juergen

Offline unklarer

  • User
  • Posts: 474
Re: (solved - nicht ganz) PC Startproblem nach du & kein X
« Reply #12 on: 2019/07/05, 09:36:13 »
Quote from: melmarker
Zum Thema LightDM - genau aus diesen Gründen benutzen wir durchgängig SDDM, es hatte irgendwie keiner mehr Bock, sich mit den immer neuen Fehlern in LightDM auseinanderzusetzen.

Ist bei mir genau "anders herum".   :D  Keinesfalls möchte ich deine Kompetenz in Abrede stellen, im Gegenteil.

Weil mir die Fehler in sddm auf den Sack gingen, habe ich auf lightdm umgestellt. Ist schon länger her und seidem tun vier Siduction und zwei Arch klaglos ihren Dienst, dass ich schon das lightdm vergessen hatte.   ;)

Offline jure

  • User
  • Posts: 517
Re: (solved - nicht ganz) PC Startproblem nach du & kein X
« Reply #13 on: 2019/07/05, 13:24:09 »
Quote from: melmarker
nö - das ist das neues debian default - dooferweise musst Du die notwenigen Umstellungen auf das alte Verhalten selbst in die Defaults tippen - in den neuen Isos habe ich das mal ganz eigenmächtig gemacht, so gut es ging.

Als das eingeführt wurde, hatten wir glaube ich auch massig Anleitungen hier im Forum wie das ging. Ich habs mittlerweile verdrängt

hast du dafür biite mal nen link auf einen alten Faden oder auch gerne EIN Beispiel was wo zu ändern ist. Mein nfs mount Problem https://forum.siduction.org/index.php?topic=7697.msg62664#msg62664 scheint ja auch irgendwie an den Rechten zu liegen
Gruss Juergen

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.744
    • g-com.eu
Re: (solved - nicht ganz) PC Startproblem nach du & kein X
« Reply #14 on: 2019/07/05, 15:31:25 »
Kompetenz hin oder her - wenn lightdm mal funktioniert tut es eigentlich(tm) - leider habe ich in den letzten 10 Jahren zu oft erlebt, dass sich was geändert hat und es auf einmal auf bestehenden Systemen nicht mehr tat.

Zu sddm: Ja, es war mal richtig kacke und konnte nerven - und in großen LDAP-Umgebungen würde ich es heute noch nicht einsetzen wollen - aber an sonsten geht es ganz fein, ansonsten gibt es halt den kleinen Dienstweg zum Upstream.
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)