seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/11/14, 20:01:56


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Transitions?  (Read 1176 times)

0 Members and 1 Guest are viewing this topic.

Offline Taliesin

  • User
  • Posts: 64
Transitions?
« on: 2019/07/21, 03:21:20 »
More a question than a warning.

It seems that there is a transition in place (KDE/QT), would that be correct?

Definitely not a good time to dist-upgrade.

213 upgraded, 1 newly installed, 84 to remove and 2 not upgraded.

Offline jure

  • User
  • Posts: 520
Re: Transitions?
« Reply #1 on: 2019/07/21, 09:26:05 »
here on my kde system

Code: [Select]
126 upgraded, 12 newly installed, 120 to remove and 2 not upgraded.
Gruss Juergen

Offline axt

  • User
  • Posts: 326
    • axebase.net
Re: Transitions?
« Reply #2 on: 2019/07/21, 09:39:58 »
In the last half year it has been very boring. Now that buster has been released, sid becomes sid again, which means a lot of updates all the time.

I update several times a day. Nothing is to be removed here so far (only 6 perl packages were no longer necessary due to new versions). LXQt and other Qt-based software.

If that's the case with you, especially so many packages, you should compare them, especially the versions.

Offline jure

  • User
  • Posts: 520
Re: Transitions?
« Reply #3 on: 2019/07/21, 10:18:24 »
the system ist up to date until Friday
Code: [Select]
inxi -S
System:    Host: siductionbox Kernel: 5.1.18-towo.1-siduction-amd64 x86_64 bits: 64 Desktop: KDE Plasma 5.14.5
           Distro: Debian GNU/Linux bullseye/sid

Code: [Select]
The following packages will be REMOVED:
  akonadi-kde-resource-googledata byzanz console-common digikam-private-libs evince freerdp2-x11 gir1.2-gst-plugins-base-1.0 gir1.2-totem-1.0
  grilo-plugins-0.2 gstreamer1.0-clutter gstreamer1.0-gl gstreamer1.0-libav gstreamer1.0-plugins-bad gstreamer1.0-plugins-base gstreamer1.0-plugins-good
  gstreamer1.0-plugins-ugly gstreamer1.0-pulseaudio gstreamer1.0-x gtkpod jovie k3b k3b-i18n kde-runtime kdebase-runtime kdelibs5-plugins kdenetwork
  kdenlive kdepasswd kinfocenter kipi-plugins knemo kopete kover kppp kprinter4 ksysguard ktimetracker ktorrent ktron kuser libatomicparsley0
  libclutter-gst-2.0-0 libclutter-gst-3.0-0 libdmapsharing-3.0-2 libevview3-3 libfreerdp-client2-2 libgstreamer-gl1.0-0 libgstreamer-plugins-bad1.0-0
  libgstreamer-plugins-base1.0-0 libgtkpod1 libkateinterfaces4 libkdewebkit5 libkf5webkit5 libkgapi2-2 libkleo4 libkvkontakte1 libkworkspace4abi1
  libkworkspace4abi2 libmarblewidget-qt5-28 libmarblewidget13 libmarblewidget15 libmarblewidget16 libmarblewidget17 libmessagecore4 libpimcommon4
  libplasma3 libplasmaclock4abi3 libplasmaclock4abi4 libplasmaclock4abi50 libplasmagenericshell4 libprocessui4a libprocessui7 libqt5multimedia5-plugins
  libqt5multimediagsttools5 libqt5webkit5 libqtgstreamer-1.0-0 libqtgstreamerutils-1.0-0 libqtwebkit4 libreoffice-base-core libreoffice-calc
  libreoffice-core libreoffice-math libreoffice-writer libspice-server1 libtotem0 libweather-ion6 libwebkit2gtk-4.0-37 libwebkitgtk-1.0-0
  libwebkitgtk-3.0-0 libwine lightdm-kde-greeter marble marble-plugins phonon-backend-gstreamer plasma-containments-addons plasma-dataengines-workspace
  plasma-desktop plasma-scriptengine-javascript plasma-scriptengine-superkaramba plasma-widget-cwp plasma-widget-folderview plasma-widget-homerun
  plasma-widget-lancelot plasma-widget-milou plasma-workspace python-gst-1.0 python-pyqt5.qtwebkit python-pyside python-pyside.qtwebkit python3-uno
  qt5-assistant qttools5-dev-tools radiotray recoll recollgui reportbug-ng rocs siduction-settings-lightdm-kde-indiansummer wine64 zenity
The following NEW packages will be installed:
  desktop-base fonts-quicksand gnome-accessibility-themes gnome-themes-extra gnome-themes-extra-data libindicator3-7 libllvm8 libllvm8:i386 libplymouth4
  lightdm-gtk-greeter plymouth plymouth-label
The following packages have been kept back:
  libglib2.0-0 libglib2.0-bin
The following packages will be upgraded:
  ash br2684ctl cpp-9 dash debhelper devscripts dh-strip-nondeterminism file freecad-common freecad-runtime gcc-9 gcc-9-base gcc-9-base:i386
  gir1.2-gstreamer-1.0 gpsbabel gpsbabel-gui gscan2pdf gstreamer1.0-plugins-base:i386 icedtea-netx insserv libaec0 libasan5 libasm-java libatm1
  libatomic1 libatomic1:i386 libcc1-0 libcommons-dbcp2-java libcommons-pool2-java libdevel-stacktrace-perl libegl-mesa0 libegl1-mesa
  libfile-stripnondeterminism-perl libfontbox2-java libfuture-perl libgbm1 libgcc-9-dev libgcc1 libgcc1:i386 libgfortran5 libgl1-mesa-dri
  libgl1-mesa-dri:i386 libgl1-mesa-glx libglapi-mesa libglapi-mesa:i386 libgles2-mesa libglx-mesa0 libglx-mesa0:i386 libgomp1
  libgstreamer-plugins-base1.0-0:i386 libgstreamer1.0-0 libgstreamer1.0-0:i386 libharfbuzz-icu0 libharfbuzz0b libharfbuzz0b:i386 libhawtjni-runtime-java
  libimage-exiftool-perl libio-socket-ssl-perl libitm1 libjboss-logging-java libjide-oss-java liblsan0 liblwp-mediatypes-perl libmagic-mgc libmagic1
  libmaven3-core-java libmovit8 libncurses5 libncurses6 libncurses6:i386 libncursesw5 libncursesw6 libnet-http-perl libnet-ssleay-perl
  libocct-data-exchange-7.3 libocct-foundation-7.3 libocct-modeling-algorithms-7.3 libocct-modeling-data-7.3 libocct-ocaf-7.3 libocct-visualization-7.3
  libosmesa6 libosmesa6:i386 libpam-systemd libplexus-utils2-java libquadmath0 libseccomp2 libstdc++6 libstdc++6:i386 libsub-quote-perl libsystemd0
  libsystemd0:i386 libsz2 libtinfo5 libtinfo5:i386 libtinfo6 libtinfo6:i386 libtsan0 libubsan1 libudev1 libudev1:i386 liburiparser1 libvlc-bin libvlc5
  libvlccore9 libwayland-egl1-mesa libwww-perl libyaml-libyaml-perl linux-libc-dev ncurses-base ncurses-bin openjdk-8-jre openjdk-8-jre-headless
  powermgmt-base systemd systemd-sysv udev usbip vlc-bin vlc-data vlc-l10n vlc-plugin-base vlc-plugin-qt vlc-plugin-samba vlc-plugin-video-output wget
  whois
126 upgraded, 12 newly installed, 120 to remove and 2 not upgraded.
Gruss Juergen

Offline Camelot

  • User
  • Posts: 30
Re: Transitions?
« Reply #4 on: 2019/07/21, 11:27:11 »
Today for me (Xfce):

Code: [Select]
apt-mark showhold
gstreamer1.0-plugins-base:i386
libgstreamer-plugins-base1.0-0:i386
Code: [Select]
The following packages have been kept back:
  gstreamer1.0-alsa gstreamer1.0-gl gstreamer1.0-libav
  gstreamer1.0-plugins-base gstreamer1.0-plugins-base:i386
  gstreamer1.0-plugins-good gstreamer1.0-pulseaudio gstreamer1.0-x
  libglib2.0-0 libglib2.0-bin libgstreamer-plugins-base1.0-0
  libgstreamer-plugins-base1.0-0:i386
0 upgraded, 0 newly installed, 0 to remove and 12 not upgraded.


Offline axt

  • User
  • Posts: 326
    • axebase.net
Re: Transitions?
« Reply #5 on: 2019/07/21, 11:27:46 »
indiansummer? I think, you have "die eine oder andere Leiche im Keller". ;-)

I'd approach it. In this case first not with "apt full-upgrade", but with "apt upgrade".

Offline Camelot

  • User
  • Posts: 30
Re: Transitions?
« Reply #6 on: 2019/07/21, 11:32:26 »
Quote from: axt
indiansummer? I think, you have "die eine oder andere Leiche im Keller". ;-)
Falls du mich meinst, die Leiche habe ich längst entsorgt. ;)
Code: [Select]
inxi -S
System:
  Host: sidzeug Kernel: 5.1.18-towo.1-siduction-amd64 x86_64 bits: 64
  Desktop: Xfce 4.12.4
  Distro: siduction 18.3.0 Patience - xfce - (201805132203)

PS: Danke für die Info wegen "apt upgrade", hatte ich vergessen.
« Last Edit: 2019/07/21, 11:38:12 by Camelot »

Offline der_bud

  • User
  • Posts: 891
  • member
Re: Transitions?
« Reply #7 on: 2019/07/21, 11:43:36 »
Und selbst wenn, warum nicht Indiansummer? Das gibt doch nur die Erstinstallation vom Iso an und hat wenig mit der Aktualität des Systems zu tun, da /etc/siduction-version in der Regel keine Upgrades erfährt. Die Angabe hilft eventuell einigen Supportern aus dem Dev-Team weiter, wenn es um geänderte Defaults in Core-Komponenten geht. Und mein "15.1.0 Paint It Black - kde" z.B ist ziemlich sicher relativ up-to-date ;) - ausser das ich den  derzeitigen KDE-Paketaktualisierungsrutsch noch 1-2 Tage aussitze ...
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline axt

  • User
  • Posts: 326
    • axebase.net
Re: Transitions?
« Reply #8 on: 2019/07/21, 11:45:19 »
Quote from: Camelot
Falls du mich meinst

Nein, jure (auch wenn's bloß das unverfängliche siduction-settings-lightdm-kde-indiansummer ist, daraus kann man's mutmaßen).


Offline jure

  • User
  • Posts: 520
Re: Transitions?
« Reply #9 on: 2019/07/21, 11:58:09 »
ja das ist eine alte Installation, die ist aber bis jetzt immer tagesaktuell ... natürlich gibt es Zeiten, ggf wie jetzt, wo man aufpassen und ein paar Tage warten muss.

ein apt upgrade -d ergibt
Code: [Select]
apt upgrade -d
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
Das folgende Paket wurde automatisch installiert und wird nicht mehr benötigt:
  libllvm7:i386
Verwenden Sie »apt autoremove«, um es zu entfernen.
Die folgenden NEUEN Pakete werden installiert:
  libllvm8 libllvm8:i386
Die folgenden Pakete sind zurückgehalten worden:
  gir1.2-gst-plugins-base-1.0 gstreamer1.0-gl gstreamer1.0-libav gstreamer1.0-plugins-bad gstreamer1.0-plugins-base gstreamer1.0-plugins-base:i386
  gstreamer1.0-plugins-good gstreamer1.0-plugins-ugly gstreamer1.0-pulseaudio gstreamer1.0-x libglib2.0-0 libglib2.0-bin libgstreamer-plugins-bad1.0-0
  libgstreamer-plugins-base1.0-0 libgstreamer-plugins-base1.0-0:i386 python-gst-1.0
Die folgenden Pakete werden aktualisiert (Upgrade):
  ash br2684ctl cpp-9 dash debhelper devscripts dh-strip-nondeterminism file freecad-common freecad-runtime gcc-9 gcc-9-base gcc-9-base:i386
  gir1.2-gstreamer-1.0 gpsbabel gpsbabel-gui gscan2pdf icedtea-netx insserv libaec0 libasan5 libasm-java libatm1 libatomic1 libatomic1:i386 libcc1-0
  libcommons-dbcp2-java libcommons-pool2-java libdevel-stacktrace-perl libegl-mesa0 libegl1-mesa libfile-stripnondeterminism-perl libfontbox2-java
  libfuture-perl libgbm1 libgcc-9-dev libgcc1 libgcc1:i386 libgfortran5 libgl1-mesa-dri libgl1-mesa-dri:i386 libgl1-mesa-glx libglapi-mesa
  libglapi-mesa:i386 libgles2-mesa libglx-mesa0 libglx-mesa0:i386 libgomp1 libgstreamer-gl1.0-0 libgstreamer1.0-0 libgstreamer1.0-0:i386 libharfbuzz-icu0
  libharfbuzz0b libharfbuzz0b:i386 libhawtjni-runtime-java libimage-exiftool-perl libio-socket-ssl-perl libitm1 libjboss-logging-java libjide-oss-java
  liblsan0 liblwp-mediatypes-perl libmagic-mgc libmagic1 libmaven3-core-java libmovit8 libncurses5 libncurses6 libncurses6:i386 libncursesw5 libncursesw6
  libnet-http-perl libnet-ssleay-perl libocct-data-exchange-7.3 libocct-foundation-7.3 libocct-modeling-algorithms-7.3 libocct-modeling-data-7.3
  libocct-ocaf-7.3 libocct-visualization-7.3 libosmesa6 libosmesa6:i386 libpam-systemd libplexus-utils2-java libquadmath0 libseccomp2 libstdc++6
  libstdc++6:i386 libsub-quote-perl libsystemd0 libsystemd0:i386 libsz2 libtinfo5 libtinfo5:i386 libtinfo6 libtinfo6:i386 libtsan0 libubsan1 libudev1
  libudev1:i386 liburiparser1 libvlc-bin libvlc5 libvlccore9 libwayland-egl1-mesa libwww-perl libyaml-libyaml-perl linux-libc-dev ncurses-base
  ncurses-bin openjdk-8-jre openjdk-8-jre-headless powermgmt-base systemd systemd-sysv udev usbip vlc-bin vlc-data vlc-l10n vlc-plugin-base vlc-plugin-qt
  vlc-plugin-samba vlc-plugin-video-output wget whois
125 aktualisiert, 2 neu installiert, 0 zu entfernen und 16 nicht aktualisiert.
Gruss Juergen

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.719
  • we are the priests ... of the temples of syrinx
Re: Transitions?
« Reply #10 on: 2019/07/21, 14:20:24 »
This is my kde du with multiarch & dmo

Code: [Select]
The following packages have been kept back:
  libglib2.0-0 libglib2.0-bin
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

You will have to wait for debian to fix gstreamer

My last du hours ago looked like this

Code: [Select]
The following packages will be upgraded:
  cryptsetup-bin cryptsetup-run ffmpeg gstreamer1.0-plugins-ugly libavcodec58 libavcodec58:i386 libavdevice58 libavfilter7 libavformat58 libavresample4
  libavresample4:i386 libavutil56 libavutil56:i386 libcryptsetup12 libfuture-perl libidn2-0 libidn2-0:i386 libidn2-dev libmyth-30 libmythavcodec58
  libmythavfilter7 libmythavformat58 libmythavutil56 libmythpostproc55 libmythswresample3 libmythswscale5 libmythtv-perl libparted-fs-resize0 libparted2
  libpostproc55 libswresample3 libswresample3:i386 libswscale5 libvlc-dev libvlc5 libvlccore9 mplayer mythtv mythtv-backend mythtv-common mythtv-database
  mythtv-doc mythtv-frontend mythtv-transcode parted php-mythtv powermgmt-base python-mythtv wget
49 upgraded, 3 newly installed, 0 to remove and 2 not upgraded.
I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.925
    • Land of the Buckeye
Re: Transitions?
« Reply #11 on: 2019/07/21, 22:08:15 »
Wow -- let the good times roll!

Code: [Select]
The following NEW packages will be installed:
  libllvm8 libsrt1 libusrsctp1
The following packages will be upgraded:
  apparmor br2684ctl cpp-9 cryptsetup cryptsetup-bin cryptsetup-initramfs cryptsetup-run dash debhelper
  default-jre default-jre-headless devscripts dh-strip-nondeterminism featherpad file firefox fonts-noto-cjk
  fonts-noto-cjk-extra fonts-opensymbol gcc-9 gcc-9-base gir1.2-gst-plugins-base-1.0 gir1.2-gstreamer-1.0
  gir1.2-gtk-3.0 gstreamer1.0-alsa gstreamer1.0-gl gstreamer1.0-gtk3 gstreamer1.0-libav
  gstreamer1.0-plugins-bad gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-ugly
  gstreamer1.0-pulseaudio gstreamer1.0-tools gstreamer1.0-x gtk-update-icon-cache hdparm inxi java-common
  krb5-locales libaec0 libapparmor1 libasan5 libasm-java libassuan0 libatm1 libatomic1 libc-ares2 libcc1-0
  libcgi-fast-perl libcgi-pm-perl libclass-inspector-perl libcpupower1 libcryptsetup-dev libcryptsetup12
  libegl-mesa0 libfile-stripnondeterminism-perl libfuture-perl libgbm1 libgcc-9-dev libgcc1 libgfortran5
  libgl1-mesa-dev libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libglib2.0-0 libglib2.0-bin libglib2.0-data
  libglib2.0-dev libglib2.0-dev-bin libglx-mesa0 libgomp1 libgssapi-krb5-2 libgstreamer-gl1.0-0
  libgstreamer-plugins-bad1.0-0 libgstreamer-plugins-base1.0-0 libgstreamer1.0-0 libgtk-3-0 libgtk-3-bin
  libgtk-3-common libharfbuzz-icu0 libharfbuzz0b libhawtjni-runtime-java libidn2-0 libimage-exiftool-perl
  libio-socket-ssl-perl libitm1 libk5crypto3 libkrb5-3 libkrb5support0 liblsan0 liblwp-mediatypes-perl
  libmagic-mgc libmagic1 libmaven3-core-java libmovit8 libncurses6 libncursesw6 libnet-http-perl
  libnet-ssleay-perl libnftables1 libnss-myhostname libnss-mymachines libnss-systemd libobjc4 libpam-systemd
  libparted-fs-resize0 libparted2 libplexus-utils2-java libpmix2 libquadmath0 libreoffice libreoffice-base
  libreoffice-base-core libreoffice-base-drivers libreoffice-calc libreoffice-common libreoffice-core
  libreoffice-draw libreoffice-gtk3 libreoffice-help-common libreoffice-help-en-us libreoffice-impress
  libreoffice-java-common libreoffice-librelogo libreoffice-math libreoffice-nlpsolver
  libreoffice-report-builder libreoffice-report-builder-bin libreoffice-script-provider-bsh
  libreoffice-script-provider-js libreoffice-script-provider-python libreoffice-sdbc-firebird
  libreoffice-sdbc-hsqldb libreoffice-sdbc-mysql libreoffice-sdbc-postgresql libreoffice-style-breeze
  libreoffice-style-colibre libreoffice-style-tango libreoffice-wiki-publisher libreoffice-writer libseccomp2
  libslang2 libstdc++6 libsub-quote-perl libsystemd0 libsz2 libtinfo6 libtsan0 libubsan1 libudev-dev libudev1
  liburiparser1 libv4l-0 libv4lconvert0 libvlc-bin libvlc5 libvlccore9 libwww-perl libyaml-libyaml-perl
  linux-cpupower linux-libc-dev mesa-common-dev mesa-va-drivers mesa-vdpau-drivers ncurses-base ncurses-bin
  ncurses-term nftables openjdk-11-jre openjdk-11-jre-headless opensc opensc-pkcs11 parted popularity-contest
  powermgmt-base publicsuffix python3-gst-1.0 python3-uno systemd systemd-container systemd-coredump
  systemd-sysv udev uno-libs3 ure vlc vlc-bin vlc-data vlc-l10n vlc-plugin-base vlc-plugin-notify
  vlc-plugin-qt vlc-plugin-samba vlc-plugin-skins2 vlc-plugin-video-output vlc-plugin-video-splitter
  vlc-plugin-visualization wget whois
201 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.719
  • we are the priests ... of the temples of syrinx
Re: Transitions?
« Reply #12 on: 2019/07/21, 23:19:44 »
@jure

knemo is only in backports and jessie (oldoldstable)

Code: [Select]
05:02:50 PM-Sun Jul 21-[piper@x1] $ apt policy knemo
N: Unable to locate package knemo
05:15:23 PM-Sun Jul 21-[piper@x1] $

Exact hits
Package knemo

    jessie (oldoldstable) (kde): network interfaces monitor for KDE's systray
    0.7.6-2: amd64 armel armhf i386
    sid (unstable) (kde): network interfaces monitor for KDE's systray
    0.7.6-2 [debports]: arm64

https://packages.debian.org/search?keywords=knemo

I for sure am not going to go through your list, but, that is where I would start
I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.719
  • we are the priests ... of the temples of syrinx
Re: Transitions?
« Reply #13 on: 2019/07/21, 23:26:19 »
Transitions are also listed on the left hand side of the forums under "Links"

https://release.debian.org/transitions/
I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

Offline Harakiri

  • User
  • Posts: 13
Re: Transitions?
« Reply #14 on: 2019/07/22, 22:03:04 »
indiansummer? I think, you have "die eine oder andere Leiche im Keller". ;-)

I'd approach it. In this case first not with "apt full-upgrade", but with "apt upgrade".
Hehe
Code: [Select]
System:    Host: heisenberg Kernel: 5.1.11.ll10-asus x86_64 bits: 64 Desktop: Xfce 4.13.3
           Distro: siduction 13.1.0 Firestarter - kde - (201305211844)