seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/02/28, 01:21:50


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: qemu-kvm virtmanager keine anzeige der konsole und der einstellungen mehr möglic  (Read 409 times)

0 Members and 1 Guest are viewing this topic.

Offline dieres

  • User
  • Posts: 732
Moin,
Ich steh hier gerade wie Ochs vorm Berg. Habe meine kvm windows systeme bisher immer ohne Probleme über den virt-manager bedienen können. Jetzt kann ich sie zwar noch starten, bekomme aber keine Anzeige des Windows oder der Einstellungen mehr über virtmanager geboten.
kann ich das Windows über die Kommandozeile irgendwie anzeigen? Oder was verhindert das Virt-manager funktioniert?
Ich habe keine Ahnung warum das aufgetreten ist. Mitten in der Arbeit mit der einen Maschiene wurde mir beim wechsel zum fenster der anderen nur noch ein graues Fenster ohne Inhalt gezeigt. Die ander funktionierte noch ne Weile, so das ich über das Netzwerk die Daten wenigstens schon mal auf die Samba Share schaufeln konnte.
Aber jetzt ist guter Rat teuer.
virt-manager removen und neu installieren war nicht erfolgreich.
Ich hab keinen Plan wie ich jetzt weiter vorgehen sollte.
Ich hoffe ihr habt da eine Idee?

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.954
    • Land of the Buckeye
This may be an upgrade issue:

Code: [Select]
root@dibl-patience:/# apt policy virt-manager
virt-manager:
  Installed: 1:2.0.0-3
  Candidate: 1:2.2.1-1
  Version table:
     1:2.2.1-1 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
 *** 1:2.0.0-3 100
        100 /var/lib/dpkg/status

This system was fully up to date yesterday.  As you see, I have not run d-u today, and my kvm is working perfectly.

Entschuldigung sie bitte, für Englisch.
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline dieres

  • User
  • Posts: 732
@dibl:  You are the Greatest. After removing everything qemu kvm libvirt and install new from testing it is working again. But there is one issue left, it prompt me to give the root password if i start the virtual windows machine. ????? that is new and awfull.

Ich war nicht mehr in der Gruppe libvirt. adduser <youruser> libvirt war dafür die Lösung.
Nu ist alles wieder so wie es soll.
« Last Edit: 2019/09/27, 23:01:03 by dieres »

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.954
    • Land of the Buckeye
Thanks @dieres -- glad it helped.

On the root password -- maybe it is going to be the same as ZuluCrypt.  I don't know why Debian ZuluCrypt requires a root password to run.  Now, I guess they will do that for virt-manager.   :'(
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.954
    • Land of the Buckeye
The bug is a missing dependency for the new version of virt-manager:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=941249

I installed gir1.2-gtksource-4, and now virt-manager 1:2.2.1-1 works correctly.

Edit:  No root password needed.   :D
« Last Edit: 2019/10/01, 21:40:46 by dibl »
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline dieres

  • User
  • Posts: 732
Thanks for this information. The root password issue was caused by removing my user from libvirt group when i remoed the whole qemu kvm libvirt packets.