seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/12/15, 10:53:35


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Solved: Qt 5.12 moving in  (Read 1879 times)

0 Members and 1 Guest are viewing this topic.

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.377
Solved: Qt 5.12 moving in
« on: 2019/10/20, 22:20:46 »
The Debian-Qt-KDE team just got a green light for moving in Qt 5.12. There might be some fallout over the next few days or weeks. Just keep an eye on any removals.

Das Debian-Qt-KDE Team hat grünes Licht für den Einzug von Qt 5.12 erhalten. Bitte behaltet in den nächsten Tagen und Wochen zu entfernende Pakete im Auge.
« Last Edit: 2019/10/24, 16:56:28 by melmarker »

Offline GoinEasy9

  • User
  • Posts: 461
Re: Qt 5.12 moving in
« Reply #1 on: 2019/10/21, 00:25:06 »
danke
Linux Counter number 348347

Offline Taliesin

  • User
  • Posts: 64
Re: Qt 5.12 moving in
« Reply #2 on: 2019/10/21, 07:04:55 »
Outstanding.
Thank you for the information Devil.

Offline hendrikL

  • User
  • Posts: 323
Re: Qt 5.12 moving in
« Reply #3 on: 2019/10/21, 08:05:29 »
Time for cleaning your system  8)

Be careful and patient, wait till the storm is over,

Code: [Select]
45 upgraded, 7 newly installed, 348 to remove and 0 not upgraded.
Need to get 0 B/39,0 MB of archives.
After this operation, 1.220 MB disk space will be freed.
Do you want to continue? [Y/n] n
Abort.
« Last Edit: 2019/10/21, 08:09:23 by hendrikL »

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.934
    • Land of the Buckeye
Re: Qt 5.12 moving in
« Reply #4 on: 2019/10/21, 11:56:11 »
Yahoo!

Code: [Select]
82 upgraded, 13 newly installed, 327 to remove and 0 not upgraded.
Need to get 64.6 MB of archives.
After this operation, 945 MB disk space will be freed.
Do you want to continue? [Y/n] n
Abort
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline tranquil

  • User
  • Posts: 58
Re: Qt 5.12 moving in
« Reply #5 on: 2019/10/22, 08:48:42 »
Danke Devil....but argh!   :o
Code: [Select]
The following packages were automatically installed and are no longer required:
  fonts-mathjax kactivities-bin kde-cli-tools-data libchm1 libfakekey0
  libgrantlee-textdocument5 libjs-coffeescript libjs-mathjax libkf5activities5
  libkf5attica5 libkf5auth5 libkf5bookmarks-data libkf5calendarevents5
  libkf5emoticons-bin libkf5emoticons-data libkf5emoticons5 libkf5globalaccel-bin
  libkf5globalaccel-data libkf5globalaccel5 libkf5globalaccelprivate5
  libkf5itemmodels5 libkf5kcmutils-data libkf5kiogui5 libkf5libkleo-data
  libkf5mime-data libkf5mime5abi1 libkf5parts-data libkf5pimtextedit-data
  libkf5pty-data libkf5pty5 libkf5su-bin libkf5su-data libkf5su5
  libkf5syntaxhighlighting-data libkf5syntaxhighlighting5 libkf5xmlgui-bin
  libkf5xmlgui-data libkworkspace5-5 libpodofo0.9.6 libqca-qt5-2
  libqca-qt5-2-plugins libqgpgme7 libqt5designer5 libqt5help5
  libsignon-plugins-common1 libtidy5deb1 libvpx5 libxcb-composite0 libxcb-damage0
  optipng paperkey python-apsw python-asn1crypto python-attr
  python-backports.functools-lru-cache python-bs4 python-cffi-backend
  python-cherrypy3 python-cryptography python-css-parser python-cssselect
  python-cssutils python-dateutil python-dnspython python-enum34 python-feedparser
  python-html2text python-html5-parser python-html5lib python-ipaddress
  python-libxml2 python-lxml python-markdown python-mechanize python-msgpack
  python-netifaces python-olefile python-openssl python-packaging python-pil
  python-pygments python-pyparsing python-regex python-repoze.lru python-routes
  python-sip python-six python-soupsieve python-utidylib python-webencodings
  python-webob python-yaml qml-module-org-kde-kconfig
  qml-module-org-kde-kquickcontrols qml-module-qtqml-models2 signon-plugin-oauth2
  sshfs
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  calibre calibre-bin kaccounts-providers kactivitymanagerd kde-cli-tools
  kdeconnect keditbookmarks kleopatra libkf5bookmarks5 libkf5kcmutils5
  libkf5kiofilewidgets5 libkf5libkleo5 libkf5parts-plugins libkf5parts5
  libkf5pimtextedit-plugins libkf5pimtextedit5abi2 libkf5plasma5
  libkf5plasmaquick5 libkf5xmlgui5 plasma-framework python-pyqt5
  python-pyqt5.qtsvg python-pyqt5.qtwebkit
The following NEW packages will be installed:
  libxcb-xinput0 linux-image-5.3.0-1-amd64
The following packages have been kept back:
  libllvm9
The following packages will be upgraded:
  asunder binutils binutils-common binutils-x86-64-linux-gnu debhelper libbinutils
  libdebhelper-perl libperl5.30 libpopt0 libqt5concurrent5 libqt5core5a
  libqt5dbus5 libqt5designer5 libqt5gui5 libqt5help5 libqt5network5
  libqt5positioning5 libqt5printsupport5 libqt5qml5 libqt5quick5
  libqt5quickcontrols2-5 libqt5quicktemplates2-5 libqt5quickwidgets5 libqt5script5
  libqt5sensors5 libqt5sql5 libqt5sql5-sqlite libqt5svg5 libqt5test5
  libqt5texttospeech5 libqt5waylandclient5 libqt5waylandcompositor5
  libqt5webchannel5 libqt5webengine-data libqt5webengine5 libqt5webenginecore5
  libqt5webenginewidgets5 libqt5webkit5 libqt5widgets5 libqt5x11extras5 libqt5xml5
  libsoxr0 libsoxr0:i386 linux-image-amd64 linux-libc-dev perl perl-base
  perl-modules-5.30 qml-module-qtgraphicaleffects qml-module-qtqml-models2
  qml-module-qtquick-controls qml-module-qtquick-controls2
  qml-module-qtquick-dialogs qml-module-qtquick-layouts
  qml-module-qtquick-privatewidgets qml-module-qtquick-templates2
  qml-module-qtquick-window2 qml-module-qtquick2 qml-module-qtwebengine
  qt5-gtk-platformtheme qttranslations5-l10n qtwayland5
62 upgraded, 2 newly installed, 23 to remove and 1 not upgraded.
Need to get 137 MB of archives.
After this operation, 188 MB of additional disk space will be used.
Dual-booting Debian Stable and Unstable with Openbox window manager and Tint2 panel.

Offline drb

  • User
  • Posts: 156
Re: Qt 5.12 moving in
« Reply #6 on: 2019/10/23, 11:28:39 »
I've still got 11 to remove but there is an oddity.
Code: [Select]
python3-sip (4.19.19+dfsg-1 => 4.19.19+dfsg-2) is showing as an upgrade
but
Code: [Select]
python3-sip (4.19.19+dfsg-2) is showing in autoremove as not required, but it isn't even installed!

Offline NochEinNeuer

  • User
  • Posts: 137
Re: Qt 5.12 moving in
« Reply #7 on: 2019/10/23, 13:13:24 »
So langsam wird es.Nur noch 2 Pakete sollen deinstalliert werden:
Code: [Select]
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  libqt5designer5 libqt5help5 libvpx5 linux-headers-5.3.6-towo.1-siduction-amd64
  linux-image-5.3.6-towo.1-siduction-amd64 python3-sip
Verwenden Sie »sudo apt autoremove«, um sie zu entfernen.
Die folgenden Pakete werden ENTFERNT:
  python3-pyqt5 software-properties-kde
Die folgenden NEUEN Pakete werden installiert:
  libqt5virtualkeyboard5 libxcb-xinput0 linux-headers-5.3.7-towo.2-siduction-amd64
  linux-image-5.3.7-towo.2-siduction-amd64
Die folgenden Pakete werden aktualisiert (Upgrade):
  akonadi-server amd64-microcode aspell binutils binutils-common
  binutils-x86-64-linux-gnu btrfs-progs debhelper execline file kwin-common kwin-x11
  libaspell15 libbinutils libbrotli1 libcpupower2 libdebhelper-perl libexecline2.5
  libgck-1-0 libgcr-base-3-1 libkf5akonadiagentbase5 libkf5akonadicore5abi2
  libkf5akonadiprivate5abi2 libkf5akonadiwidgets5abi1 libkf5xmlgui-bin libkf5xmlgui5
  libkwin4-effect-builtins1 libkwineffects11 libkwinglutils11 libkwinxrenderutils11
  libllvm9 libmagic-mgc libmagic1 libnspr4 libnss3 libperl5.30 libpopt0
  libqt5concurrent5 libqt5core5a libqt5dbus5 libqt5designer5 libqt5gui5 libqt5help5
  libqt5multimedia5 libqt5multimedia5-plugins libqt5multimediagsttools5
  libqt5multimediaquick5 libqt5multimediawidgets5 libqt5network5 libqt5opengl5
  libqt5positioning5 libqt5printsupport5 libqt5qml5 libqt5quick5
  libqt5quickcontrols2-5 libqt5quicktemplates2-5 libqt5quickwidgets5 libqt5script5
  libqt5sensors5 libqt5sql5 libqt5sql5-mysql libqt5sql5-sqlite libqt5svg5 libqt5test5
  libqt5texttospeech5 libqt5waylandclient5 libqt5waylandcompositor5 libqt5webchannel5
  libqt5webengine-data libqt5webengine5 libqt5webenginecore5 libqt5webenginewidgets5
  libqt5webkit5 libqt5widgets5 libqt5x11extras5 libqt5xml5 libqt5xmlpatterns5
  libs6-2.9 libskarnet2.9 libsnmp-base libsnmp35 libsoxr0 libzbar0 linux-cpupower
  linux-headers-siduction-amd64 linux-image-siduction-amd64 linux-libc-dev perl
  perl-base perl-modules-5.30 plasma-integration python3-crypto qdbus-qt5
  qml-module-qt-labs-folderlistmodel qml-module-qt-labs-settings
  qml-module-qtgraphicaleffects qml-module-qtmultimedia qml-module-qtqml-models2
  qml-module-qtquick-controls qml-module-qtquick-controls2 qml-module-qtquick-dialogs
  qml-module-qtquick-layouts qml-module-qtquick-privatewidgets
  qml-module-qtquick-templates2 qml-module-qtquick-virtualkeyboard
  qml-module-qtquick-window2 qml-module-qtquick2 qml-module-qtwebengine
  qml-module-qtwebkit qt5-gtk-platformtheme qt5-image-formats-plugins
  qttranslations5-l10n qtwayland5 s6 sudo xserver-xorg-video-amdgpu
  xserver-xorg-video-ati xserver-xorg-video-radeon
118 aktualisiert, 4 neu installiert, 2 zu entfernen und 0 nicht aktualisiert.
Es müssen 174 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 265 MB Plattenplatz zusätzlich benutzt.

Offline hendrikL

  • User
  • Posts: 323
Re: Qt 5.12 moving in
« Reply #8 on: 2019/10/23, 16:27:15 »
The storm seems to be over

But, always look what apt is telling you

Auch wenn es scheint, dass der Sturm zu einer leichten Brise geworden ist,
achtet immer darauf was apt Euch anzeigt/sagt

Code: [Select]
LANG=C apt full-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


Code: [Select]
apt full-upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.

Offline NochEinNeuer

  • User
  • Posts: 137
Re: Qt 5.12 moving in
« Reply #9 on: 2019/10/23, 17:50:48 »
Bei mir soll mittlerweile auch kein Paket mehr gelöscht werden.

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.781
    • g-com.eu
Re: Qt 5.12 moving in
« Reply #10 on: 2019/10/23, 18:24:05 »
Nü, langsam isses durch, aber es ist noch genau einen Tag zu früh für ne generelle Entwarnung. Dass irgendwas mit neuem Qt baut bedeutet noch lange nicht, dass alles funktioniert. Bevor Einwände kommen: Ja, ich weiss sehr genau, wovon ich rede. Leider. Aber Qt 5.12.5 ist alt genug, so dass sich die Überraschungen in sehr eng definierten Grenzen halten dürften.
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline NochEinNeuer

  • User
  • Posts: 137
Re: Qt 5.12 moving in
« Reply #11 on: 2019/10/23, 19:22:28 »
Vielen Dank für die Info.
Dann warte ich noch bis Donnerstag Abend und dann las ich das dist-upgrade durchlaufen falls sich bis dahin nichts negativ verändert.

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.781
    • g-com.eu
Re: Qt 5.12 moving in
« Reply #12 on: 2019/10/23, 22:13:32 »
so und jetzt butter bei die fische für meine meinung:
* some crashes in plasma: maybe this would be the solutioon - https://phabricator.kde.org/D24654 - we workin on this
* dat hüpsche daran ist - plasma startet bei ungewöhnlichen Anforderungen nur neu, aber es gehen keine Daten verloren
* ich fühle mich beschissen, weil ich den Patch zwar ansehen, aber nicht herunterladen kann :) ok - man kann an allem arbeiten
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.781
    • g-com.eu
Solved: Qt 5.12 moving in
« Reply #13 on: 2019/10/24, 16:55:51 »
ein gefixtes plasma-workspace paket ist gestern hochgeladen worden - ich rufe mal die allgemeine Entwarnung aus. Und noch ne Neuigkeit: KDE Pim kann wieder drucken - und auch die Druckvorschau funktioniert wieder.
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.934
    • Land of the Buckeye
Re: Solved: Qt 5.12 moving in
« Reply #14 on: 2019/10/24, 21:53:12 »
Confirmed, on 2 KDE desktops.  Items checked out OK:

- Nvidia graphics
- zulucrypt/cryptsetup
- qemu/KVM
- chrome and firefox browsers
- konsole, kate, and dolphin

Code: [Select]
202 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 307 MB of archives.
After this operation, 285 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS