seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/07/02, 12:15:23


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: problem upgrading ure to version 6.4.0~rc1-5 -- FIXED  (Read 1168 times)

0 Members and 1 Guest are viewing this topic.

Offline mdmarmer

  • User
  • Posts: 19
after trying d-u I receive this message
dpkg: error processing archive /var/cache/apt/archives/ure_6.4.0~rc1-5_amd64.deb (--unpack):
 trying to overwrite '/usr/share/java/juh.jar', which is also in package libjuh-java 1:6.4.0~rc1-5
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/ure_6.4.0~rc1-5_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


FIX: this command
apt-get -o Dpkg::Options::="--force-overwrite" install ure


follow with
apt install -f
to make sure all is ok.

Online samoht

  • User
  • Posts: 359
Re: problem upgrading ure to version 6.4.0~rc1-5 -- FIXED
« Reply #1 on: 2020/01/01, 23:20:05 »
I confirm this error when updating libreoffice packages.
Another fix, working here:

Code: [Select]
# apt purge libreoffice-nlpsolver libreoffice-wiki-publisher libreoffice-java-common
Of course, if these packages are not necessary.


Offline tranquil

  • User
  • Posts: 81
Re: problem upgrading ure to version 6.4.0~rc1-5 -- FIXED
« Reply #3 on: 2020/01/03, 12:37:35 »
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=947907


Interesting...I wonder why apt-listbugs doesn't show this bug. I just performed a full-upgrade, thinking that apt-listbugs would show the bug and allow me to cancel the upgrade...NOT!!!


I tried samoht's workaround, but that doesn't work. I'm hesitant to try mdmarmer's workaround because that would seem to allow ure to overwrite /usr/share/java/juh.jar.


I'll attempt to downgrade LibreOffice to the prior version using the Debian Snapshot site.
Dual-booting Debian Stable and Unstable with Openbox window manager and Tint2 panel.

Offline tranquil

  • User
  • Posts: 81
Re: problem upgrading ure to version 6.4.0~rc1-5 -- FIXED
« Reply #4 on: 2020/01/03, 13:02:59 »
...I'm hesitant to try mdmarmer's workaround because that would seem to allow ure to overwrite /usr/share/java/juh.jar.
...


I retrieved the info about libjuh-java and it is a recommended package for ure, so I used mdmarmer's workaround and things are fine now.  Thank you mdmarmer!  ;)
Dual-booting Debian Stable and Unstable with Openbox window manager and Tint2 panel.

Offline vilde

  • User
  • Posts: 671
Re: problem upgrading ure to version 6.4.0~rc1-5 -- FIXED
« Reply #5 on: 2020/01/03, 22:53:13 »
This is just for information, I have no idea if this is a good thing to do and don't do it before somebody here who knows about this things has told you it's ok.

I have been stuck in this a half day, not been able to come into xfce, tried all fixes mentioned here but not working. I cleared up the computer, did necessary back ups of home and so on to prepare for a new install, I don't have time to wait, must have the computer working.

Just before starting a new install i remember that I have experimental repo enabled so I invented a desperate command that I didin't have no idea if it is possible to do but
Code: [Select]
apt -t experimental full-upgrade 
apt -t experimental -f install
really did it. Maybe I have done something that will hit me later but for now I have my computer up working again without re-installation.
« Last Edit: 2020/01/03, 23:01:22 by vilde »

Offline tranquil

  • User
  • Posts: 81
Re: problem upgrading ure to version 6.4.0~rc1-5 -- FIXED
« Reply #6 on: 2020/01/04, 03:43:36 »
@vilde...

Thank you for sharing. I knew about the Experimental repo, but I've never toyed with it. Your comment reminded me about it.

I have been stuck in this half a day... You've been stuck in what, the ure upgrade issue?


I think what you have done may come back to bite you later. You've basically upgraded a number, or all, of your Unstable packages with Experimental packages. So now the Experimental packages you have will quite possibly continue to get upgrades from the Experimental repo. Probably not a big deal as long as there are no bugs.

I believe the Experimental repo is only meant to be cherry picked from as a last resort. You haven't cherry picked, you've cut down the whole tree.
Dual-booting Debian Stable and Unstable with Openbox window manager and Tint2 panel.

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.415
Re: problem upgrading ure to version 6.4.0~rc1-5 -- FIXED
« Reply #7 on: 2020/01/04, 06:46:53 »
Kids, please don't do this at home :)

Offline vilde

  • User
  • Posts: 671
Re: problem upgrading ure to version 6.4.0~rc1-5 -- FIXED
« Reply #8 on: 2020/01/04, 09:57:34 »
@vilde...

Thank you for sharing. I knew about the Experimental repo, but I've never toyed with it. Your comment reminded me about it.

I have been stuck in this half a day... You've been stuck in what, the ure upgrade issue?


I think what you have done may come back to bite you later. You've basically upgraded a number, or all, of your Unstable packages with Experimental packages. So now the Experimental packages you have will quite possibly continue to get upgrades from the Experimental repo. Probably not a big deal as long as there are no bugs.

I believe the Experimental repo is only meant to be cherry picked from as a last resort. You haven't cherry picked, you've cut down the whole tree.
Kids, please don't do this at home :)
Yes it was the ure thing I didn't read about it until it apparently was to late with the fixes, after trying to du I was stuck.

Didn't know that the packages will continue to update from experimental, but maybe they have to to fit with others, this is far over my knowledge.


But so what for now, I've already done my backups and prepared for a new installation so why not live on the wild side for a while ;)
« Last Edit: 2020/01/04, 10:02:10 by vilde »

Offline hsp

  • User
  • Posts: 515
Re: problem upgrading ure to version 6.4.0~rc1-5 -- FIXED
« Reply #9 on: 2020/01/04, 10:28:10 »
fixed version

libreoffice 1:6.4.0~rc1-6 uploaded by Rene Engelhard (rene) (Closes: #947909) https://tracker.debian.org/libreoffice
« Last Edit: 2020/01/04, 12:23:26 by hsp »