seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/02/29, 14:02:34


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: nvidia broken [solved]  (Read 1105 times)

0 Members and 1 Guest are viewing this topic.

Offline sotnik

  • User
  • Posts: 48
nvidia broken [solved]
« on: 2020/01/29, 09:00:04 »
Today DU resulted in a broken system (I could not login into X)
The error was the following:

Code: [Select]
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n]
Setting up nvidia-kernel-dkms (435.21-3) ...
Removing old nvidia-current-435.21 DKMS files...

------------------------------
Deleting module version: 435.21
completely from the DKMS tree.
------------------------------
Done.
Loading new nvidia-current-435.21 DKMS files...
Building for 5.4.8-towo.1-siduction-amd64
Building initial module for 5.4.8-towo.1-siduction-amd64
Error! Bad return status for module build on kernel: 5.4.8-towo.1-siduction-amd64 (x86_64)
Consult /var/lib/dkms/nvidia-current/435.21/build/make.log for more information.
dpkg: error processing package nvidia-kernel-dkms (--configure):
 installed nvidia-kernel-dkms package post-installation script subprocess returned error exit status 10
dpkg: dependency problems prevent configuration of nvidia-driver:
 nvidia-driver depends on nvidia-kernel-dkms (= 435.21-3) | nvidia-kernel-435.21; however:
  Package nvidia-kernel-dkms is not configured yet.
  Package nvidia-kernel-435.21 is not installed.
  Package nvidia-kernel-dkms which provides nvidia-kernel-435.21 is not configured yet.

dpkg: error processing package nvidia-driver (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 nvidia-kernel-dkms
 nvidia-driver
E: Sub-process /usr/bin/dpkg returned an error code (1)

I removed nouveau from black list. I removed 20-nvidia.conf from /etc/X11/xorg.conf.d and eventually I manage to login into my system.
Therefore I think, for the time being to avoid upgrading or put nvidia in hold.

EDITThe content of /var/lib/dkms/nvidia-current/435.21/build/make.log is
Code: [Select]
DKMS make.log for nvidia-current-435.21 for kernel 5.4.8-towo.1-siduction-amd64 (x86_64)
Wed 29 Jan 2020 09:53:15 AM EET
make  V=1 -C /lib/modules/5.4.8-towo.1-siduction-amd64/build M=/var/lib/dkms/nvidia-current/435.21/build ARCH=x86_64 NV_KERNEL_SOURCES=/lib/modules/5.4.8-towo.1-siduction-amd64/build NV_KERNEL_OUTPUT=/lib/modules/5.4.8-towo.1-siduction-a>
make[1]: Entering directory '/usr/src/linux-headers-5.4.8-towo.1-siduction-amd64'
test -e include/generated/autoconf.h -a -e include/config/auto.conf || (                \
echo >&2;                                                       \
echo >&2 "  ERROR: Kernel configuration is invalid.";           \
echo >&2 "         include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo >&2 "         Run 'make oldconfig && make prepare' on kernel src to fix it.";      \
echo >&2 ;                                                      \
/bin/false)
make -f ./scripts/Makefile.build obj=/var/lib/dkms/nvidia-current/435.21/build single-build= need-builtin=1 need-modorder=1
NV_CONFTEST_CMD=/bin/sh /var/lib/dkms/nvidia-current/435.21/build/conftest.sh " gcc-9" x86_64 /lib/modules/5.4.8-towo.1-siduction-amd64/build /lib/modules/5.4.8-towo.1-siduction-amd64/build
NV_CONFTEST_CFLAGS=-O2 -D__KERNEL__ -DKBUILD_BASENAME="#conftest31581" -DKBUILD_MODNAME="#conftest31581" -nostdinc -isystem /usr/lib/gcc/x86_64-linux-gnu/9/include -I/lib/modules/5.4.8-towo.1-siduction-amd64/build/arch/x86/include/asm/ma>
KBUILD_CFLAGS=-Wall -Wundef -Werror=strict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -fshort-wchar -fno-PIE -Werror=implicit-function-declaration -Werror=implicit-int -Wno-format-security -std=gnu89 -mno-sse -mno-mmx -mn>
LINUXINCLUDE=-I./arch/x86/include -I./arch/x86/include/generated  -I./include -I./arch/x86/include/uapi -I./arch/x86/include/generated/uapi -I./include/uapi -I./include/generated/uapi -include ./include/linux/kconfig.h
LDFLAGS=
  ln -sf /var/lib/dkms/nvidia-current/435.21/build/nvidia/nv-kernel-amd64.o_binary /var/lib/dkms/nvidia-current/435.21/build/nvidia/nv-kernel.o
KBUILD_LDFLAGS=-m elf_x86_64  -z max-page-size=0x200000
  ln -sf /var/lib/dkms/nvidia-current/435.21/build/nvidia-modeset/nv-modeset-kernel-amd64.o_binary /var/lib/dkms/nvidia-current/435.21/build/nvidia-modeset/nv-modeset-kernel.o
The Module.symvers file is missing, or does not contain any
symbols exported from the kernel. This could cause the NVIDIA
kernel modules to be built against a configuration that does
not accurately reflect the actual target kernel.
The Module.symvers file check can be disabled by setting the
environment variable IGNORE_MISSING_MODULE_SYMVERS to 1.
make[2]: *** [/var/lib/dkms/nvidia-current/435.21/build/Kbuild:198: module_symvers_sanity_check] Error 1
make[2]: *** Waiting for unfinished jobs....
ARCH=x86_64
make[1]: *** [Makefile:1665: /var/lib/dkms/nvidia-current/435.21/build] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-5.4.8-towo.1-siduction-amd64'
make: *** [Makefile:81: modules] Error 2
EDIT
Installing nvidia-driver from experimental solves the problem (see last post)
« Last Edit: 2020/01/29, 14:26:22 by sotnik »

Offline hsp

  • User
  • Posts: 513
Re: nvidia broken
« Reply #1 on: 2020/01/29, 10:15:49 »
same problem here.
...

/edit
a bug report does not seem to exist yet, at least I have not found one.
« Last Edit: 2020/01/29, 10:45:38 by hsp »

Offline sunrat

  • User
  • Posts: 321
Re: nvidia broken
« Reply #2 on: 2020/01/29, 12:30:54 »
Did you try the 440.44-1 driver from Debian experimental?

Offline charlyheinz

  • User
  • Posts: 5
Re: nvidia broken
« Reply #3 on: 2020/01/29, 12:54:51 »
same here. The 440.44-1 has a lot of broken dependencies. Is it possible to downgrade to the last 430.65-4 (5)

Offline charlyheinz

  • User
  • Posts: 5
Re: nvidia broken
« Reply #4 on: 2020/01/29, 12:58:16 »
Sorry- I mean 430.64-4 (5).

Offline dsat

  • User
  • Posts: 99
Re: nvidia broken
« Reply #5 on: 2020/01/29, 13:01:43 »
nvidia-driver from experimental works for my system.
Code: [Select]
System:    Host: ekkehard Kernel: 5.4.0-3-amd64 x86_64 bits: 64 Console: tty 3 Distro: Debian GNU/Linux bullseye/sid
Graphics:  Device-1: NVIDIA GK208B [GeForce GT 720] driver: nvidia v: 440.44
           Display: server: X.Org 1.20.7 driver: nvidia unloaded: fbdev,modesetting,nouveau,vesa resolution: 1920x1080~60Hz
           OpenGL: renderer: GeForce GT 720/PCIe/SSE2 v: 4.6.0 NVIDIA 440.44

Offline hsp

  • User
  • Posts: 513

Offline charlyheinz

  • User
  • Posts: 5
Re: nvidia broken [solved]
« Reply #7 on: 2020/01/29, 15:51:55 »
nvidia-driver 440.44-1 von experimental läuft.
Ich musste  deb http://deb.debian.org/debian/ experimental main contrib non-free  in der debian.list zusätzlich eintragen.

nvidia-driver 440.44-1 from experimental works.
I had to add  deb http://deb.debian.org/debian/ experimental main contrib non-free  in addition into the debian.list.

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.954
    • Land of the Buckeye
Re: nvidia broken [solved]
« Reply #8 on: 2020/01/29, 23:24:13 »

nvidia-driver 440.44-1 from experimental works.


Thanks for posting this tip -- saved me some time today!   ;D
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline Geier0815

  • User
  • Posts: 486
Re: nvidia broken [solved]
« Reply #9 on: 2020/01/30, 07:45:45 »
Sehr merkwürdig, gestern morgen um 7 wurde mir 440.44-1 in unstable per "apt policy nvidia-kernel-dkms" angezeigt, um kurz vor 11 zwar als installiert aber keine Quelle mehr angegeben. Daher hatte ich die Meldung das es in unstable angekommen ist wieder gelöscht. Gegen 13 Uhr nochmals geguckt und da war 440.44-2 in unstable.

Yesterday morning at 7 o'clock 44.0.44-1 was shown in unstable via "apt policy nvidia-kernel-dkms". At 11 it was shown as installed but without a source. I deleted then the message that it is in unstable. At 13 o'clock I saw 440.44-2 in unstable.
« Last Edit: 2020/01/31, 08:13:27 by Geier0815 »
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?