seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/02/29, 14:57:31


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Caution -- KDE/Plasma Users  (Read 2019 times)

0 Members and 1 Guest are viewing this topic.

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.954
    • Land of the Buckeye
Caution -- KDE/Plasma Users
« on: 2020/01/31, 21:24:37 »
It would appear there is a disturbance -- possibly starting the new KDE version:

Code: [Select]
The following packages were automatically installed and are no longer required:
  kde-style-qtcurve-qt5 libdlrestrictions1 libqtcurve-utils2 qtcore4-l10n
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  kde-l10n-de kde-style-qtcurve-qt4 libdbusmenu-qt2 libkdecore5 libqt4-dbus libqt4-declarative
  libqt4-designer libqt4-help libqt4-network libqt4-script libqt4-scripttools libqt4-sql libqt4-sql-mysql
  libqt4-sql-sqlite libqt4-svg libqt4-test libqt4-xml libqt4-xmlpatterns libqtassistantclient4 libqtcore4
  libqtdbus4 libqtgui4 python3-dbus.mainloop.qt python3-pyqt4 qdbus qt-at-spi sni-qt
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline tranquil

  • User
  • Posts: 75
Re: Caution -- KDE/Plasma Users
« Reply #1 on: 2020/02/01, 01:30:40 »
Thank you dibl.
Dual-booting Debian Stable and Unstable with Openbox window manager and Tint2 panel.

Offline drb

  • User
  • Posts: 160
Re: Caution -- KDE/Plasma Users
« Reply #2 on: 2020/02/01, 11:18:50 »
Code: [Select]
akonadi-kde-resource-googledata (1.2.0-1+b2)
   jovie (4:17.08.3-1)
   kaccessible (4:17.08.3-1)
   katepart (4:4.14.3-5)
   kde-config-baloo-advanced (1.00.00-1)
   kde-runtime (4:17.08.3-2.1)
   kdelibs-bin (4:4.14.38-4)
   kdelibs5-plugins (4:4.14.38-4)
   kdepasswd (4:16.08.3-3)
   kdesudo (3.4.2.4-2+b1)
   kdoctools (4:4.14.38-4)
   konqueror-nsplugins (4:16.08.3-1)
   konsole4-kpart (4:4.14.2-4)
   kopete (4:17.08.3-2.1)
   kppp (4:17.08.3-1)
   kremotecontrol (4:17.08.3-1)
   kscd (4:17.08.3-1)
   ktimetracker (4:4.14.10-7+b3)
   kuser (4:16.08.0-1+b1)
   libakonadi-calendar4 (4:4.14.10-11)
   libakonadi-contact4 (4:4.14.10-11)
   libakonadi-kcal4 (4:4.14.10-11)
   libakonadi-kde4 (4:4.14.10-11)
   libakonadi-kmime4 (4:4.14.10-11)
   libakonadi-notes4 (4:4.14.10-11)
   libakonadiprotocolinternals1 (1.13.0-12)
   libattica0.4 (0.4.2-2+b11)
   libbaloopim4 (4:4.14.3-3+b4)
   libcalendarsupport4 (4:4.14.10-7+b3)
   libcomposereditorng4 (4:4.14.10-2)
   libdbusmenu-qt2 (0.9.3+16.04.20160218-1+b1)
   libfcitx-qt0 (1:4.2.9.6-5+b1)
   libfollowupreminder4 (4:4.14.10-2)
   libgrantlee-core0 (0.4.0-4+b1)
   libgrantlee-gui0 (0.4.0-4+b1)
   libincidenceeditorsng4 (4:4.14.10-7+b3)
   libk3b6 (1:2.0.3a-dmo3)
   libk3b6-extracodecs (1:2.0.3a-dmo3)
   libkabc4 (4:4.14.10-11)
   libkactivities6 (4:4.13.3-2+b1)
   libkalarmcal2 (4:4.14.10-11)
   libkasten2controllers2 (4:4.14.2-3)
   libkasten2core2 (4:4.14.2-3)
   libkasten2gui2 (4:4.14.2-3)
   libkasten2okteta1controllers1abi1 (4:4.14.2-3)
   libkasten2okteta1core1 (4:4.14.2-3)
   libkasten2okteta1gui1 (4:4.14.2-3)
   libkatepartinterfaces4 (4:4.14.3-5)
   libkblog4 (4:4.14.10-11)
   libkcal4 (4:4.14.10-11)
   libkcalcore4 (4:4.14.10-11)
   libkcalutils4 (4:4.14.10-11)
   libkcddb4 (4:16.08.3-1)
   libkcmutils4 (4:4.14.38-4)
   libkcompactdisc4 (4:16.04.0-2)
   libkdcraw23 (4:15.08.0-1.1)
   libkde3support4 (4:4.14.38-4)
   libkdeclarative5 (4:4.14.38-4)
   libkdecore5 (4:4.14.38-4)
   libkdepim4 (4:4.14.10-7+b3)
   libkdepimdbusinterfaces4 (4:4.14.10-7+b3)
   libkdesu5 (4:4.14.38-4)
   libkdeui5 (4:4.14.38-4)
   libkdewebkit5 (4:4.14.38-4)
   libkdgantt2-0 (4:4.14.10-7+b3)
   libkdnssd4 (4:4.14.38-4)
   libkemoticons4 (4:4.14.38-4)
   libkexiv2-11 (4:15.04.3-1)
   libkfile4 (4:4.14.38-4)
   libkgapi2-2 (2.2.0-2)
   libkholidays4 (4:4.14.10-11)
   libkhtml5 (4:4.14.38-4)
   libkimap4 (4:4.14.10-11)
   libkio5 (4:4.14.38-4)
   libkjsapi4 (4:4.14.38-4)
   libkjsembed4 (4:4.14.38-4)
   libkldap4 (4:4.14.10-11)
   libkleo4 (4:4.14.10-7+b3)
   libkmanagesieve4 (4:4.14.10-2)
   libkmbox4 (4:4.14.10-11)
   libkmediaplayer4 (4:4.14.38-4)
   libkmime4 (4:4.14.10-11)
   libknewstuff2-4 (4:4.14.38-4)
   libknewstuff3-4 (4:4.14.38-4)
   libknotifyconfig4 (4:4.14.38-4)
   libkntlm4 (4:4.14.38-4)
   libkonq-common (4:16.08.3-3)
   libkonq5abi1 (4:16.08.3-3)
   libkonqsidebarplugin4a (4:16.08.3-1)
   libkontactinterface4a (4:4.14.10-11)
   libkopete4 (4:17.08.3-2.1)
   libkparts4 (4:4.14.38-4)
   libkpeople4 (0.3.0-2)
   libkpgp4 (4:4.14.10-7+b3)
   libkpimidentities4 (4:4.14.10-11)
   libkpimtextedit4 (4:4.14.10-11)
   libkpimutils4 (4:4.14.10-11)
   libkprintutils4 (4:4.14.38-4)
   libkpty4 (4:4.14.38-4)
   libkresources4 (4:4.14.10-11)
   libkrosscore4 (4:4.14.38-4)
   libksieve4 (4:4.14.10-2)
   libktexteditor4 (4:4.14.38-4)
   libktnef4 (4:4.14.10-11)
   libktorrent5 (1.3.1-5)
   libktpcommoninternalsprivate8 (0.9.0-2)
   libktpmodelsprivate8 (0.9.0-2)
   libktpwidgetsprivate8 (0.9.0-2)
   libkxmlrpcclient4 (4:4.14.10-11)
   libmailtransport4 (4:4.14.10-11)
   libmessagecore4 (4:4.14.10-7+b3)
   libmicroblog4 (4:4.14.10-11)
   libntrack-qt4-1 (016-1.4)
   libokteta1core1 (4:4.14.2-3)
   libokteta1gui1 (4:4.14.2-3)
   libokularcore6 (4:15.08.3-1)
   libphonon4 (4:4.10.3-2)
   libpimcommon4 (4:4.14.10-7+b3)
   libplasma3 (4:4.14.38-4)
   libpolkit-qt-1-1 (0.112.0-6)
   libpoppler-qt4-4 (0.61.1-2)
   libqca2 (2.2.1-1)
   libqgpgme1 (4:4.14.10-11)
   libqimageblitz4 (1:0.0.6-5)
   libqjson0 (0.8.1-3+b1)
   libqmobipocket1 (4:16.08.0-1)
   libqt4-dbus (4:4.8.7+dfsg-19)
   libqt4-declarative (4:4.8.7+dfsg-19)
   libqt4-designer (4:4.8.7+dfsg-19)
   libqt4-help (4:4.8.7+dfsg-19)
   libqt4-network (4:4.8.7+dfsg-19)
   libqt4-opengl (4:4.8.7+dfsg-19)
   libqt4-qt3support (4:4.8.7+dfsg-19)
   libqt4-script (4:4.8.7+dfsg-19)
   libqt4-scripttools (4:4.8.7+dfsg-19)
   libqt4-sql (4:4.8.7+dfsg-19)
   libqt4-sql-sqlite (4:4.8.7+dfsg-19)
   libqt4-svg (4:4.8.7+dfsg-19)
   libqt4-test (4:4.8.7+dfsg-19)
   libqt4-xml (4:4.8.7+dfsg-19)
   libqt4-xmlpatterns (4:4.8.7+dfsg-19)
   libqtassistantclient4 (4.6.3-7+b1)
   libqtcore4 (4:4.8.7+dfsg-19)
   libqtdbus4 (4:4.8.7+dfsg-19)
   libqtglib-2.0-0 (1.2.0-4)
   libqtgstreamer-1.0-0 (1.2.0-4)
   libqtgstreamerui-1.0-0 (1.2.0-4)
   libqtgui4 (4:4.8.7+dfsg-19)
   libqtwebkit4 (2.3.4.dfsg-10)
   libsendlater4 (4:4.14.10-7+b3)
   libsolid4 (4:4.14.38-4)
   libsoprano4 (2.9.4+dfsg-5)
   libsyndication4 (4:4.14.10-11)
   libtelepathy-logger-qt4-1 (0.8.0-3)
   libtelepathy-qt4-2 (0.9.7-1)
   libthreadweaver4 (4:4.14.38-4)
   mplayerthumbs (4:15.08.3-2)
   phonon (4:4.10.3-2)
   phonon-backend-vlc (1:0.10.3-dmo1)
   plasma-scriptengine-javascript (4:17.08.3-2.1)
   plasma-widget-folderview (4:16.04.1-1)
   python-qt4 (4.12.1+dfsg-3+b1)
   qdbus (4:4.8.7+dfsg-19)
   sni-qt (0.2.7+15.10.20150729-2+b1)
   soprano-daemon (2.9.4+dfsg-5)
165 packages to be removed here.

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.954
    • Land of the Buckeye
Re: Caution -- KDE/Plasma Users
« Reply #3 on: 2020/02/01, 21:29:41 »
On a "spare" system that I could afford to trash, I ran this d-u just now:

Code: [Select]
Calculating upgrade...
The following packages were automatically installed and are no longer required:
  kde-style-qtcurve-qt5 libdlrestrictions1 libqtcurve-utils2 qtcore4-l10n
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
  kde-l10n-de kde-style-qtcurve-qt4 libdbusmenu-qt2 libkdecore5 libqt4-dbus
  libqt4-declarative libqt4-designer libqt4-help libqt4-network libqt4-script
  libqt4-scripttools libqt4-sql libqt4-sql-mysql libqt4-sql-sqlite libqt4-svg
  libqt4-test libqt4-xml libqt4-xmlpatterns libqtassistantclient4 libqtcore4
  libqtdbus4 libqtgui4 python3-dbus.mainloop.qt python3-pyqt4 qdbus qt-at-spi
  sni-qt
The following NEW packages will be installed:
  gparted-common
The following packages have been kept back:
  gdal-data
The following packages will be upgraded:
  cups cups-browsed cups-bsd cups-client cups-common cups-core-drivers
  cups-daemon cups-filters cups-filters-core-drivers cups-ipp-utils cups-ppdc
  cups-server-common ethtool gparted haveged hpijs-ppds hplip hplip-data
  hplip-gui iputils-ping libcups2 libcups2-dev libcupsfilters-dev
  libcupsfilters1 libcupsimage2 libcupsimage2-dev libdebconfclient0
  liberror-perl libfontembed1 libgmp10 libgpgme11 libgpgmepp6 libgps26
  libhavege2 libhpmud0 liblensfun-data-v1 liblensfun1 libnm0 libnss-myhostname
  libnss-mymachines libnss-systemd libp11-kit0 libpam-systemd
  libpulse-mainloop-glib0 libpulse0 libpulsedsp libqgpgme7 libqt5concurrent5
  libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5 libqt5opengl5
  libqt5opengl5-dev libqt5printsupport5 libqt5sql5 libqt5sql5-mysql
  libqt5sql5-sqlite libqt5test5 libqt5widgets5 libqt5xml5 libsane-hpaio
  libsqlite3-0 libsystemd0 libudev-dev libudev1 libuv1 nano network-manager
  opencv-data p11-kit p11-kit-modules printer-driver-foo2zjs
  printer-driver-foo2zjs-common printer-driver-hpcups printer-driver-hpijs
  printer-driver-m2300w printer-driver-postscript-hp pulseaudio
  pulseaudio-module-bluetooth pulseaudio-module-gsettings
  pulseaudio-module-zeroconf pulseaudio-utils python3-cryptography python3-gpg
  python3-sip qt5-gtk-platformtheme qt5-qmake qt5-qmake-bin qtbase5-dev
  qtbase5-dev-tools systemd systemd-container systemd-coredump systemd-sysv
  udev wireless-regdb youtube-dl
98 upgraded, 1 newly installed, 27 to remove and 1 not upgraded.

I have been testing and checking for 10 minutes, and everything is working as expected.  YMMV.
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline sunrat

  • User
  • Posts: 321
Re: Caution -- KDE/Plasma Users
« Reply #4 on: 2020/02/02, 10:18:08 »
I guess that's Qt4 packages being replaced by Qt5 packages.
Recommend a full system backup image before upgrading, which is a good idea to do anyway.

Offline NochEinNeuer

  • User
  • Posts: 144
Re: Caution -- KDE/Plasma Users
« Reply #5 on: 2020/02/02, 10:55:25 »
Ich verwende zwar Plasma, aber irgendwie wird bei mir kein Update dafür angezeigt....

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.396
Re: Caution -- KDE/Plasma Users
« Reply #6 on: 2020/02/03, 00:13:09 »
Zeig doch mal ein
Code: [Select]
apt update && apt dist-upgrade

Offline NochEinNeuer

  • User
  • Posts: 144
Re: Caution -- KDE/Plasma Users
« Reply #7 on: 2020/02/03, 04:16:54 »
Komisch:
Code: [Select]
jf@jf-pc:~$ sudo apt update && apt dist-upgrade
OK:1 http://packages.siduction.org/extra unstable InRelease
OK:2 http://deb.debian.org/debian sid InRelease                                       
OK:3 http://ftp.spline.de/pub/siduction/extra unstable InRelease                       
OK:4 http://deb.debian.org/debian unstable InRelease                                   
OK:5 https://packages.siduction.org/fixes unstable InRelease                           
OK:6 https://deb.opera.com/opera-stable stable InRelease
Paketlisten werden gelesen... Fertig               
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Aktualisierung für 21 Pakete verfügbar. Führen Sie »apt list --upgradable« aus, um sie anzuzeigen.
E: Sperrdatei /var/lib/dpkg/lock-frontend konnte nicht geöffnet werden. - open (13: Keine Berechtigung)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are you root?
allerdings funktioniert es so:
Code: [Select]
jf@jf-pc:~$ sudo apt update                   
OK:1 http://deb.debian.org/debian sid InRelease
OK:2 http://deb.debian.org/debian unstable InRelease                                   
OK:3 http://packages.siduction.org/extra unstable InRelease                           
OK:4 http://ftp.spline.de/pub/siduction/extra unstable InRelease                       
OK:5 https://deb.opera.com/opera-stable stable InRelease                               
OK:6 https://packages.siduction.org/fixes unstable InRelease
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Aktualisierung für 21 Pakete verfügbar. Führen Sie »apt list --upgradable« aus, um sie anzuzeigen.
jf@jf-pc:~$ sudo apt -d dist-upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  linux-headers-5.4.0-1-common linux-headers-5.4.0-2-common
  linux-headers-5.4.13-towo.2-siduction-amd64
  linux-headers-5.4.14-towo.1-siduction-amd64
  linux-image-5.4.13-towo.2-siduction-amd64 linux-image-5.4.14-towo.1-siduction-amd64
Verwenden Sie »sudo apt autoremove«, um sie zu entfernen.
Die folgenden NEUEN Pakete werden installiert:
  gcc-10-base libgcc-s1
Die folgenden Pakete werden aktualisiert (Upgrade):
  cmake cmake-data debian-keyring lib32z1 libatomic1 libcc1-0 libcdr-0.1-1 libgcc1
  libgfortran5 libgomp1 libical3 libitm1 liblilv-0-0 liblsan0 libobjc4 libquadmath0
  libstdc++6 libtsan0 libubsan1 zlib1g zlib1g-dev
21 aktualisiert, 2 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Es müssen 40,9 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 2.018 kB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n] n
Abbruch.
jf@jf-pc:~$


Offline sunrat

  • User
  • Posts: 321
Re: Caution -- KDE/Plasma Users
« Reply #8 on: 2020/02/03, 07:23:42 »
@NochEinNeuer - that happens because you used sudo and didn't use sudo for the dist-upgrade command. sudo only works for a single command.
I didn't realise anyone uses sudo in siduction. Normally we switch to a root terminal with su - .

Gtranslate - Dies geschieht, weil Sie sudo verwendet haben und sudo nicht für den Befehl dist-upgrade verwendet haben. sudo funktioniert nur für einen einzelnen Befehl.
Ich habe nicht bemerkt, dass irgendjemand sudo in siduction benutzt. Normalerweise wechseln wir mit su -  zu einem Root-Terminal.
Code: [Select]
su -
<enter root password>
apt update && apt dist-upgrade

Offline NochEinNeuer

  • User
  • Posts: 144
Re: Caution -- KDE/Plasma Users
« Reply #9 on: 2020/02/03, 15:14:24 »
Trotzdem nix neues bezüglich kde dabei:
Code: [Select]
root@jf-pc:/home/jf# apt update && apt dist-upgrade
OK:1 http://packages.siduction.org/extra unstable InRelease
OK:2 http://deb.debian.org/debian sid InRelease                                       
OK:3 http://ftp.spline.de/pub/siduction/extra unstable InRelease                       
OK:4 https://deb.opera.com/opera-stable stable InRelease                               
OK:5 http://deb.debian.org/debian unstable InRelease                                   
OK:6 https://packages.siduction.org/fixes unstable InRelease                     
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Aktualisierung für 36 Pakete verfügbar. Führen Sie »apt list --upgradable« aus, um sie anzuzeigen.
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  libexiv2-14 linux-headers-5.4.0-1-common linux-headers-5.4.0-2-common
  linux-headers-5.4.13-towo.2-siduction-amd64
  linux-headers-5.4.14-towo.1-siduction-amd64
  linux-image-5.4.13-towo.2-siduction-amd64 linux-image-5.4.14-towo.1-siduction-amd64
Verwenden Sie »apt autoremove«, um sie zu entfernen.
Die folgenden NEUEN Pakete werden installiert:
  gcc-10-base libgcc-s1 linux-headers-5.4.17-towo.1-siduction-amd64
  linux-image-5.4.17-towo.1-siduction-amd64
Die folgenden Pakete werden aktualisiert (Upgrade):
  binutils binutils-common binutils-x86-64-linux-gnu cmake cmake-data debian-keyring
  firmware-linux-free gir1.2-gexiv2-0.10 lib32z1 libatomic1 libbinutils libcc1-0
  libcdr-0.1-1 libctf-nobfd0 libctf0 libgcc1 libgexiv2-2 libgfortran5 libgomp1
  libical3 libitm1 libjpeg-progs libjpeg9 liblilv-0-0 liblsan0 libobjc4 libquadmath0
  libsdl2-2.0-0 libstdc++6 libtsan0 libubsan1 libzbar0 linux-headers-siduction-amd64
  linux-image-siduction-amd64 zlib1g zlib1g-dev
36 aktualisiert, 4 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Es müssen 97,3 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 270 MB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n]

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.795
    • g-com.eu
Re: Caution -- KDE/Plasma Users
« Reply #10 on: 2020/02/03, 17:37:02 »
Und warum sollte da was neues dabei sein?
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline gnasch

  • User
  • Posts: 27
Re: Caution -- KDE/Plasma Users
« Reply #11 on: 2020/02/03, 18:30:41 »
Bei mir soll digikam und kde-l10n-de gekillt werden:  :-\

Code: [Select]
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  digikam-data digikam-private-libs enblend enchant enfuse gdal-data guile-2.0-libs hugin hugin-data hugin-tools
  kde-style-qtcurve-qt5 kipi-plugins-common libaec0 libarchive-zip-perl libarmadillo9 libarpack2 libastro1 libc6-i386 libcharls2
  libdap25 libdapclient6v5 libdlrestrictions1 libdns-export1104 libenchant1c2a libepsilon1 libexiv2-14 libfreexl1 libfyba0
  libgdal20 libgdcm2.8 libgeos-3.8.0 libgeos-c1v5 libgeotiff5 libhdf4-0-alt libhdf5-103 libimage-exiftool-perl libiptc0
  libisc-export1100 libkf5mediawiki5 libkmlbase1 libkmldom1 libkmlengine1 liblensfun-data-v1 liblensfun1 liblivemedia68
  libmarblewidget-qt5-28 libmime-charset-perl libnetcdf13 libogdi4.1 libopencv-core3.2 libopencv-highgui3.2
  libopencv-imgcodecs3.2 libopencv-imgproc3.2 libopencv-ml3.2 libopencv-objdetect3.2 libopencv-videoio3.2 libpano13-3
  libpano13-bin libposix-strptime-perl libproj15 libqhull7 libqt5serialport5 libqtav1 libqtavwidgets1 libqtcurve-utils2 libshp2
  libsocket++1 libsombok3 libspatialite7 libsuperlu5 libsz2 libtbb2 libunicode-linebreak-perl liburiparser1 libvigraimpex11
  linux-headers-5.4.12-towo.1-siduction-amd64 linux-image-5.4.12-towo.1-siduction-amd64 marble-plugins marble-qt-data odbcinst
  odbcinst1debian2 opencv-data proj-bin proj-data python-asn1crypto python-cffi-backend python-cryptography python-enum34
  python-ipaddress python-secretstorage qtcore4-l10n syslinux syslinux-common
Verwenden Sie »sudo apt autoremove«, um sie zu entfernen.
Die folgenden Pakete werden ENTFERNT:
  digikam kde-l10n-de kde-style-qtcurve-qt4 kipi-plugins libkdecore5 libphonon4 libqt4-dbus libqt4-network libqt4-svg libqt4-xml
  libqtcore4 libqtdbus4 libqtgui4 qdbus qt-at-spi qt4-qtconfig tuxboot
Die folgenden NEUEN Pakete werden installiert:
  gcc-10-base gparted-common libexiv2-27 libgcc-s1 linux-headers-5.4.17-towo.1-siduction-amd64
  linux-image-5.4.17-towo.1-siduction-amd64
Die folgenden Pakete sind zurückgehalten worden:
  digikam-private-libs gdal-data
Die folgenden Pakete werden aktualisiert (Upgrade):
  bash-completion binutils binutils-common binutils-x86-64-linux-gnu cpio cpp-9 cups cups-browsed cups-bsd cups-client
  cups-common cups-core-drivers cups-daemon cups-filters cups-filters-core-drivers cups-ipp-utils cups-ppdc cups-server-common
  digikam-data ethtool ffmpeg firmware-linux-free fonts-lyx fonts-opensymbol fonts-wine g++-9 gcc-9 gcc-9-base
  gir1.2-freedesktop gir1.2-glib-2.0 gnome-orca gparted grep guile-2.0-libs gwenview haveged hpijs-ppds hplip hplip-data
  hplip-gui hugin hugin-tools inetutils-telnet iputils-ping krename libasan5 libasm-java libatomic1 libavcodec58 libavdevice58
  libavfilter7 libavformat58 libavresample4 libavutil56 libbinutils libcc1-0 libcdr-0.1-1 libcommons-codec-java
  libcommons-compress-java libctf-nobfd0 libctf0 libcups2 libcupsfilters1 libcupsimage2 libdebconfclient0 libegl-mesa0
  liberror-perl libfontembed1 libgbm1 libgcc-9-dev libgcc1 libgexiv2-2 libgfortran5 libgirepository-1.0-1 libgl1-mesa-dri
  libgl1-mesa-glx libglapi-mesa libglib-object-introspection-perl libglx-mesa0 libgmp10 libgomp1 libgpgme11 libgpgmepp6 libgps26
  libhavege2 libhpmud0 libhttpclient-java libhttpcore-java libical3 libimage-exiftool-perl libipc-system-simple-perl libitm1
  libjpeg-progs libjpeg9 libjuh-java libjurt-java libkf5filemetadata-bin libkf5filemetadata3 libkf5kexiv2-15.0.0 libldb2
  liblensfun-data-v1 liblensfun1 liblilv-0-0 liblsan0 libmariadb3 libmaven3-core-java libmbedcrypto3 libmbedtls12 libmbedx509-0
  libneon27-gnutls libnm0 libnss-myhostname libnss-mymachines libnss-systemd libobjc4 libopenmpt-modplug1 libopenmpt0 libosmesa6
  libp11-kit0 libpam-systemd libpci3 libpcsclite1 libplexus-component-annotations-java libplexus-utils2-java libpostproc55
  libqgpgme7 libqpdf26 libqt5concurrent5 libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5 libqt5opengl5 libqt5printsupport5
  libqt5sql5 libqt5sql5-mysql libqt5sql5-sqlite libqt5test5 libqt5widgets5 libqt5xml5 libquadmath0 libreoffice libreoffice-base
  libreoffice-base-core libreoffice-base-drivers libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw
  libreoffice-gtk3 libreoffice-help-common libreoffice-help-en-us libreoffice-impress libreoffice-java-common libreoffice-kde5
  libreoffice-kf5 libreoffice-librelogo libreoffice-math libreoffice-nlpsolver libreoffice-plasma libreoffice-qt5
  libreoffice-report-builder libreoffice-report-builder-bin libreoffice-script-provider-bsh libreoffice-script-provider-js
  libreoffice-script-provider-python libreoffice-sdbc-hsqldb libreoffice-sdbc-mysql libreoffice-sdbc-postgresql
  libreoffice-style-breeze libreoffice-style-colibre libreoffice-style-tango libreoffice-wiki-publisher libreoffice-writer
  libridl-java libsane-hpaio libsdl2-2.0-0 libsmbclient libsnappy-java libsnappy-jni libsnappy1v5 libsqlite3-0 libstdc++-9-dev
  libstdc++6 libswresample3 libswscale5 libsystemd0 libtsan0 libubsan1 libudev1 libuno-cppu3 libuno-cppuhelpergcc3-3
  libuno-purpenvhelpergcc3-3 libuno-sal3 libuno-salhelpergcc3-3 libunoil-java libunoloader-java libuv1 libvkd3d1 libvncclient1
  libvncserver1 libwagon-http-java libwagon-provider-api-java libwbclient0 libwine libxerces2-java libzbar0 lightning
  linux-headers-siduction-amd64 linux-image-siduction-amd64 mariadb-client-core-10.3 mariadb-common mariadb-server-core-10.3
  mawk mc mc-data mesa-va-drivers mesa-vdpau-drivers mesa-vulkan-drivers mkvtoolnix mpv nano network-manager ocl-icd-libopencl1
  opencv-data opensc opensc-pkcs11 orca p11-kit p11-kit-modules pci.ids pciutils pcscd perl-openssl-defaults
  printer-driver-foo2zjs printer-driver-foo2zjs-common printer-driver-hpcups printer-driver-hpijs printer-driver-m2300w
  printer-driver-postscript-hp python-cryptography python-gi python-keyring python3-gi python3-gpg python3-ldb python3-pil
  python3-renderpm python3-reportlab python3-reportlab-accel python3-samba python3-sip python3-uno qt5-gtk-platformtheme
  samba-common samba-common-bin samba-dsdb-modules samba-libs sudo systemd systemd-container systemd-coredump systemd-sysv
  thunderbird thunderbird-l10n-de torbrowser-launcher udev uno-libs-private ure wine wine64 wireless-regdb youtube-dl zlib1g
  zlib1g-dev
275 aktualisiert, 6 neu installiert, 17 zu entfernen und 2 nicht aktualisiert.
Es müssen noch 0 B von 538 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 281 MB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n]

Offline brutor

  • User
  • Posts: 6
Re: Caution -- KDE/Plasma Users
« Reply #12 on: 2020/02/04, 18:34:16 »
123 packages to be removed here.

Is this safe to let them go ?
Code: [Select]
The following packages will be REMOVED:
  digikam dolphin4 jovie kaccessible katepart kde-runtime kdelibs-bin
  kdelibs5-plugins kdepasswd kdesudo kdoctools kio-mtp kipi-plugins
  konqueror-nsplugins kopete kpartsplugin kremotecontrol kscd kuser
  libakonadi-contact4 libakonadi-kde4 libakonadiprotocolinternals1
  libattica0.4 libdbusmenu-qt2 libgcc1:i386 libk3b6 libk3b6-extracodecs
  libkabc4 libkactivities6 libkatepartinterfaces4 libkcalcore4 libkcddb4
  libkcmutils4 libkcompactdisc4 libkde3support4 libkdeclarative5 libkdecore5
  libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4 libkexiv2-11
  libkfile4 libkhtml5 libkio5 libkjsapi4 libkjsembed4 libkldap4
  libkmediaplayer4 libkmime4 libknewstuff2-4 libknewstuff3-4 libknotifyconfig4
  libkntlm4 libkonq-common libkonq5abi1 libkonqsidebarplugin4a libkopete4
  libkparts4 libkpimidentities4 libkpimtextedit4 libkpimutils4 libkprintutils4
  libkpty4 libkresources4 libkrosscore4 libktexteditor4 libktorrent5
  libkxmlrpcclient4 libntrack-qt4-1 libokularcore7 libphonon4 libplasma3
  libpolkit-qt-1-1 libpoppler-qt4-4 libpyside1.2 libqaccessibilityclient0
  libqca2 libqca2-plugin-ossl libqca2-plugins libqimageblitz4 libqjson0
  libqmobipocket1 libqt4-dbus libqt4-declarative libqt4-designer libqt4-help
  libqt4-network libqt4-opengl libqt4-qt3support libqt4-script
  libqt4-scripttools libqt4-sql libqt4-sql-sqlite libqt4-svg libqt4-test
  libqt4-xml libqt4-xmlpatterns libqtassistantclient4 libqtcore4 libqtdbus4
  libqtgui4 libqtwebkit4 libsolid4 libsoprano4 libsoqt4-20 libsyndication4
  libthreadweaver4 phonon phonon-backend-gstreamer
  plasma-scriptengine-javascript python-pyside.qtcore python-pyside.qtgui
  python-pyside.qtsvg python-pyside.qtuitools python-pyside.qtxml python-qt4
  python-qt4-gl qdbus qucs-s sni-qt soprano-daemon
The following NEW packages will be installed:
  gcc-10-base gcc-10-base:i386 gparted-common libexiv2-27 libgcc-s1
  libgcc-s1:i386 liblimesuite20.01-1 libnetcdf15
  linux-headers-5.4.17-towo.1-siduction-amd64
  linux-image-5.4.17-towo.1-siduction-amd64 python3-jeepney
The following packages have been kept back:
  digikam-private-libs gdal-bin gdal-data libpdal-base9 libpdal-plugin-sqlite
  libvtk7.1p paraview python3-gdal qmapshack sshfs





Offline drb

  • User
  • Posts: 160
Re: Caution -- KDE/Plasma Users
« Reply #13 on: 2020/02/05, 10:54:39 »
Definitely not.
Although I have gone from 165 to remove to 0 to remove overnight.

Offline ruebe99

  • Newbie
  • Posts: 4
Re: Caution -- KDE/Plasma Users
« Reply #14 on: 2020/02/05, 13:59:41 »
A d-u is by now no longer removing any package.