seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/02/29, 13:30:00


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Upgrade of libqt5core5a causes packages to be removed  (Read 492 times)

0 Members and 1 Guest are viewing this topic.

Offline mdmarmer

  • User
  • Posts: 19

Here is the list of packages that would be removed on my system if i allow full-upgrade to upgrade libqt5core5a 


libpoppler-qt4-4 libqt4-dbus libqt4-declarative libqt4-designer libqt4-help
  libqt4-network libqt4-script libqt4-scripttools libqt4-sql libqt4-sql-sqlite
  libqt4-svg libqt4-test libqt4-xml libqt4-xmlpatterns libqtassistantclient4
  libqtcore4 libqtdbus4 libqtgui4 pdfviewer python-qt4 python-qt4-dbus


So for now I'm not doing full-upgrade 


And I have still not allowed libsqlite3-0 to upgrade as I think this will break firefox.  Appears the fix for this is in progress, but not completed.




Offline Camelot

  • User
  • Posts: 36
Re: Upgrade of libqt5core5a causes packages to be removed
« Reply #1 on: 2020/02/01, 10:57:44 »
Current Firefox works with current libsqlite3-0
Code: [Select]
apt-cache policy firefox libsqlite3-0
firefox:
  Installed: 72.0.2-1
  Candidate: 72.0.2-1
  Version table:
 *** 72.0.2-1 500
        500 http://deb.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
libsqlite3-0:
  Installed: 3.31.0+really3.30.1+fossil191229-1
  Candidate: 3.31.0+really3.30.1+fossil191229-1
  Version table:
 *** 3.31.0+really3.30.1+fossil191229-1 500
        500 http://deb.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status

Offline mdmarmer

  • User
  • Posts: 19
Re: Upgrade of libqt5core5a causes packages to be removed
« Reply #2 on: 2020/02/03, 00:13:21 »
I did the upgrades of libqt5core5a and libsqlite3-0 .  It appears that everything is working normally.  I have lxqt system
Looks like pdfviewer was not a current package anyway there are lots of application to read a pdf file.  As Camelolt said, firefox is working ok now with upgraded libsqlite3-0