seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/02/29, 14:55:35


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [solved] du wants to remove cups  (Read 407 times)

0 Members and 1 Guest are viewing this topic.

Offline harley-peter

  • User
  • Posts: 815
[solved] du wants to remove cups
« on: 2020/02/07, 22:29:29 »
A du this evening wants to remove some cups files:
Code: [Select]
Die folgenden Pakete werden ENTFERNT:
  configure-cups cups cups-bsd cups-client hplip hplip-gui printer-driver-cups-pdf printer-driver-gutenprint printer-driver-hpcups
  printer-driver-splix
« Last Edit: 2020/02/09, 16:30:03 by harley-peter »

Offline tranquil

  • User
  • Posts: 75
Re: du wants to remove cups
« Reply #1 on: 2020/02/08, 06:51:09 »
Has something to do with the installation of the following new packages: gcc-10-base, libgcc-s1. Based on my experience cherry picking some other package upgrades earlier in the evening, I don't currently recommend allowing the aforementioned new packages to be installed.

Code: [Select]
The following packages were automatically installed and are no longer required:
  cups-browsed cups-core-drivers cups-daemon cups-ppdc cups-server-common
  libgutenprint-common libgutenprint9 ssl-cert
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  cups-core-drivers cups-daemon gcc-10-base libcups2 libcups2:i386 libgcc-s1
Suggested packages:
  cups cups-bsd cups-common cups-server-common cups-client
  foomatic-db-compressed-ppds | foomatic-db cups-pdf smbclient
The following packages will be REMOVED:
  cups cups-client printer-driver-gutenprint
The following NEW packages will be installed:
  gcc-10-base libgcc-s1
The following packages will be upgraded:
  cups-core-drivers cups-daemon cups-ipp-utils libcups2 libcups2:i386
5 upgraded, 2 newly installed, 3 to remove and 199 not upgraded.
Need to get 1,532 kB/1,769 kB of archives.
After this operation, 2,245 kB disk space will be freed.
« Last Edit: 2020/02/08, 08:24:29 by tranquil »
Dual-booting Debian Stable and Unstable with Openbox window manager and Tint2 panel.

Offline Camelot

  • User
  • Posts: 36
Re: du wants to remove cups
« Reply #2 on: 2020/02/08, 11:29:18 »
For this moment use apt upgrade, not full-upgrade:
Code: [Select]
#apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  cups-core-drivers cups-daemon cups-ipp-utils libcups2 libcups2:i386
0 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.

Code: [Select]
#apt full-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  cups-browsed cups-core-drivers cups-daemon cups-server-common hplip-data
  libgutenprint-common libgutenprint9 libsane-hpaio python3-renderpm
  python3-reportlab python3-reportlab-accel ssl-cert
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
  cups cups-bsd cups-client hplip printer-driver-cups-pdf
  printer-driver-gutenprint printer-driver-hpcups
The following packages will be upgraded:
  cups-core-drivers cups-daemon cups-ipp-utils libcups2 libcups2:i386
5 upgraded, 0 newly installed, 7 to remove and 0 not upgraded.
« Last Edit: 2020/02/08, 11:54:45 by Camelot »

Offline drb

  • User
  • Posts: 160
Re: du wants to remove cups
« Reply #3 on: 2020/02/08, 11:35:41 »
I don't have any new packages wanting to be installed but 10 removals:
Code: [Select]
The following packages will be REMOVED:
   configure-cups (0.8.20)
   cups (2.3.1-4)
   cups-bsd (2.3.1-4)
   cups-client (2.3.1-4)
   hplip (3.19.12+dfsg0-4)
   hplip-gui (3.19.12+dfsg0-4)
   printer-driver-cups-pdf (3.0.1-6)
   printer-driver-gutenprint (5.3.3-3)
   printer-driver-hpcups (3.19.12+dfsg0-4)
   printer-driver-splix (2.0.0+svn315-7)
The following packages will be upgraded:
   coinor-libcoinutils3v5 (2.11.3+repack1-1 => 2.11.4+repack1-1)
   cups-core-drivers (2.3.1-4 => 2.3.1-5)
   cups-daemon (2.3.1-4 => 2.3.1-5)
   cups-ipp-utils (2.3.1-4 => 2.3.1-5)
   fonts-opensymbol (2:102.11+LibO6.4.1~rc1-1 => 2:102.11+LibO6.4.1~rc1-2)
   libcups2 (2.3.1-4 => 2.3.1-5)
   libcupsimage2 (2.3.1-4 => 2.3.1-5)

Offline harley-peter

  • User
  • Posts: 815
Re: [solved] du wants to remove cups
« Reply #4 on: 2020/02/09, 16:30:53 »
Today the du goes without problems. :)