seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/02/29, 14:05:05


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [SOLVED] Careful Upgrading - cpp-9 Upgrade Removes libgcc-s1:i386  (Read 559 times)

0 Members and 1 Guest are viewing this topic.

Offline tranquil

  • User
  • Posts: 75
I was cherry picking packages to upgrade a few minutes ago because there were a number of cups related packages to be removed. When I upgraded the cpp-9 pacakage, I failed to note that the libgcc-s1:i386 package would be removed. Upgrading the cpp-9 package results in the proposed actions:
Code: [Select]
The following packages will be REMOVED:
  libgcc1:i386
The following NEW packages will be installed:
  gcc-10-base:i386 libgcc-s1:i386
The following packages will be upgraded:
  cpp-9 g++-9 gcc-9 gcc-9-base gcc-9-base:i386 libasan5 libatomic1 libatomic1:i386
  libcc1-0 libgcc-9-dev libgcc1 libgfortran5 libgomp1 libgomp1:i386 libitm1
  liblsan0 libquadmath0 libstdc++-9-dev libstdc++6 libstdc++6:i386 libtsan0
  libubsan1
22 upgraded, 2 newly installed, 1 to remove and 184 not upgraded.
Need to get 0 B/38.2 MB of archives.
After this operation, 864 kB of additional disk space will be used.

Following are the dpkg statements caused by the removal of the libgcc-s1:i386 package:

Code: [Select]
dpkg: libgcc1:i386: dependency problems, but removing anyway as you requested:
 mesa-vulkan-drivers:i386 depends on libgcc1 (>= 1:4.2); however:
  Package libgcc1:i386 is to be removed.
  Package libgcc-s1:i386 which provides libgcc1 is not configured yet.
 mesa-vdpau-drivers:i386 depends on libgcc1 (>= 1:4.2); however:
  Package libgcc1:i386 is to be removed.
  Package libgcc-s1:i386 which provides libgcc1 is not configured yet.
 mesa-va-drivers:i386 depends on libgcc1 (>= 1:4.2); however:
  Package libgcc1:i386 is to be removed.
  Package libgcc-s1:i386 which provides libgcc1 is not configured yet.
 libz3-4:i386 depends on libgcc1 (>= 1:7); however:
  Package libgcc1:i386 is to be removed.
  Package libgcc-s1:i386 which provides libgcc1 is not configured yet.
 libx265-179:i386 depends on libgcc1 (>= 1:4.2); however:
  Package libgcc1:i386 is to be removed.
  Package libgcc-s1:i386 which provides libgcc1 is not configured yet.
 libvpx6:i386 depends on libgcc1 (>= 1:4.2); however:
  Package libgcc1:i386 is to be removed.
  Package libgcc-s1:i386 which provides libgcc1 is not configured yet.
 libvdpau-va-gl1:i386 depends on libgcc1 (>= 1:4.2); however:
  Package libgcc1:i386 is to be removed.
  Package libgcc-s1:i386 which provides libgcc1 is not configured yet.
 libtag1v5-vanilla:i386 depends on libgcc1 (>= 1:3.0); however:
  Package libgcc1:i386 is to be removed.
  Package libgcc-s1:i386 which provides libgcc1 is not configured yet.
 libstdc++6:i386 depends on libgcc1 (>= 1:4.2); however:
  Package libgcc1:i386 is to be removed.
  Package libgcc-s1:i386 which provides libgcc1 is not configured yet.
 libsnappy1v5:i386 depends on libgcc1 (>= 1:3.0); however:
  Package libgcc1:i386 is to be removed.
  Package libgcc-s1:i386 which provides libgcc1 is not configured yet.
 librsvg2-2:i386 depends on libgcc1 (>= 1:4.2); however:
  Package libgcc1:i386 is to be removed.
  Package libgcc-s1:i386 which provides libgcc1 is not configured yet.
 libproxy1v5:i386 depends on libgcc1 (>= 1:3.0); however:
  Package libgcc1:i386 is to be removed.
  Package libgcc-s1:i386 which provides libgcc1 is not configured yet.
 libosmesa6:i386 depends on libgcc1 (>= 1:4.2); however:
  Package libgcc1:i386 is to be removed.
  Package libgcc-s1:i386 which provides libgcc1 is not configured yet.
 libllvm9:i386 depends on libgcc1 (>= 1:4.2); however:
  Package libgcc1:i386 is to be removed.
  Package libgcc-s1:i386 which provides libgcc1 is not configured yet.
 libjack-jackd2-0:i386 depends on libgcc1 (>= 1:4.2); however:
  Package libgcc1:i386 is to be removed.
  Package libgcc-s1:i386 which provides libgcc1 is not configured yet.
 libigdgmm11:i386 depends on libgcc1 (>= 1:4.2); however:
  Package libgcc1:i386 is to be removed.
  Package libgcc-s1:i386 which provides libgcc1 is not configured yet.
 libicu63:i386 depends on libgcc1 (>= 1:7); however:
  Package libgcc1:i386 is to be removed.
  Package libgcc-s1:i386 which provides libgcc1 is not configured yet.
 libglu1-mesa:i386 depends on libgcc1 (>= 1:3.0); however:
  Package libgcc1:i386 is to be removed.
  Package libgcc-s1:i386 which provides libgcc1 is not configured yet.
 libgl1-mesa-dri:i386 depends on libgcc1 (>= 1:4.2); however:
  Package libgcc1:i386 is to be removed.
  Package libgcc-s1:i386 which provides libgcc1 is not configured yet.
 libcaca0:i386 depends on libgcc1 (>= 1:3.0); however:
  Package libgcc1:i386 is to be removed.
  Package libgcc-s1:i386 which provides libgcc1 is not configured yet.
 libc6:i386 depends on libgcc1; however:
  Package libgcc1:i386 is to be removed.
  Package libgcc-s1:i386 which provides libgcc1 is not configured yet.
 intel-media-va-driver:i386 depends on libgcc1 (>= 1:4.2); however:
  Package libgcc1:i386 is to be removed.
  Package libgcc-s1:i386 which provides libgcc1 is not configured yet.
 gstreamer1.0-plugins-good:i386 depends on libgcc1 (>= 1:3.0); however:
  Package libgcc1:i386 is to be removed.
  Package libgcc-s1:i386 which provides libgcc1 is not configured yet.

So I'm thinking a distro/full upgrade will cause the same results. Now I have to go through the arduous process of downgrading all of those packages.
« Last Edit: 2020/02/10, 08:11:16 by tranquil »
Dual-booting Debian Stable and Unstable with Openbox window manager and Tint2 panel.

Offline tranquil

  • User
  • Posts: 75
Re: Careful Upgrading - cpp-9 Upgrade Removes libgcc-s1:i386
« Reply #1 on: 2020/02/08, 06:55:24 »
Okay...I've downgraded everything. There's a bigger issue going on. I guess there's an ongoing transition as a number of package upgrades will install the following new packages: gcc-10-base, libgcc-s1. I currently don't recommend allowing the installation of the new packages.

Installation of libgcc-s1:i386 results in the removal of libgcc-1:i386.

What a mess!!
« Last Edit: 2020/02/08, 06:59:03 by tranquil »
Dual-booting Debian Stable and Unstable with Openbox window manager and Tint2 panel.

Offline unklarer

  • User
  • Posts: 493
Re: Careful Upgrading - cpp-9 Upgrade Removes libgcc-s1:i386
« Reply #2 on: 2020/02/08, 10:10:16 »
I think you caused this "mess" yourself.   ;)

Who or what causes you to work in siduction with dpkg, or to do "the crosscheck"?


@devil has pointed out in this forum not only once: dpkg does not resolve dependencies, but apt does!


I do not have your problems. Here is my log from 2020-02-04
Code: [Select]
Start-Date: 2020-02-04  14:47:33
Commandline: apt dist-upgrade
Install: gcc-10-base:i386 (10-20200202-1, automatic), libgcc-s1:i386 (10-20200202-1, automatic), libexiv2-27:i386 (0.27.2-8, automatic)
Upgrade: libgcc-7-dev:i386 (7.5.0-3, 7.5.0-4), libmpx2:i386 (8.3.0-26, 8.3.0-27), exim4-base:i386 (4.93-9, 4.93-10), gcc-9-base:i386 (9.2.1-25, 9.2.1-28), libctf-nobfd0:i386 (2.33.90.20200122-2, 2.34-2), libsystemd0:i386 (244.1-2, 244.1-3), ruby-gtk2:i386 (3.4.1-1, 3.4.1-2), cpp-7:i386 (7.5.0-3, 7.5.0-4), cpp-8:i386 (8.3.0-26, 8.3.0-27), cpp-9:i386 (9.2.1-25, 9.2.1-28), python-gi:i386 (3.34.0-5, 3.34.0-6), gcc-8-base:i386 (8.3.0-26, 8.3.0-27), libsqlite3-0:i386 (3.31.0+really3.30.1+fossil191229-1, 3.31.1-1), binutils:i386 (2.33.90.20200122-2, 2.34-2), ruby-atk:i386 (3.4.1-1, 3.4.1-2), zlib1g:i386 (1:1.2.11.dfsg-1+b1, 1:1.2.11.dfsg-1.2), libitm1:i386 (9.2.1-25, 10-20200202-1), liblilv-0-0:i386 (0.24.4~dfsg0-2, 0.24.6-1), python3-gi-cairo:i386 (3.34.0-5, 3.34.0-6), libgspell-1-common:i386 (1.8.2-2, 1.8.3-1), sudo:i386 (1.8.29-1, 1.8.31-1), gcc-7-base:i386 (7.5.0-3, 7.5.0-4), exim4-daemon-light:i386 (4.93-9, 4.93-10), libzbar0:i386 (0.23-1.2, 0.23-1.3), udev:i386 (244.1-2, 244.1-3), libcilkrts5:i386 (7.5.0-3, 7.5.0-4), ruby-cairo-gobject:i386 (3.4.1-1, 3.4.1-2), zlib1g-dev:i386 (1:1.2.11.dfsg-1+b1, 1:1.2.11.dfsg-1.2), libasan4:i386 (7.5.0-3, 7.5.0-4), libasan5:i386 (9.2.1-25, 9.2.1-28), libquadmath0:i386 (9.2.1-25, 10-20200202-1), libgexiv2-2:i386 (0.12.0-1, 0.12.0-2), ruby-gobject-introspection:i386 (3.4.1-1, 3.4.1-2), libudev1:i386 (244.1-2, 244.1-3), libstdc++-9-dev:i386 (9.2.1-25, 9.2.1-28), libgcc1:i386 (1:9.2.1-25, 1:10-20200202-1), firmware-linux-free:i386 (3.4, 20200122-1), libgcc-8-dev:i386 (8.3.0-26, 8.3.0-27), libunbound8:i386 (1.9.6-1, 1.9.6-2), libglib2.0-dev-bin:i386 (2.62.4-1+b1, 2.62.4-2), python3-future:i386 (0.16.0-1, 0.18.2-1), libubsan0:i386 (7.5.0-3, 7.5.0-4), libubsan1:i386 (9.2.1-25, 10-20200202-1), g++-9:i386 (9.2.1-25, 9.2.1-28), exim4-config:i386 (4.93-9, 4.93-10), libnss-myhostname:i386 (244.1-2, 244.1-3), guile-2.0-libs:i386 (2.0.13+1-5.3+b1, 2.0.13+1-5.4), libgfortran5:i386 (9.2.1-25, 10-20200202-1), ruby-pango:i386 (3.4.1-1, 3.4.1-2), systemd-sysv:i386 (244.1-2, 244.1-3), gcc-7:i386 (7.5.0-3, 7.5.0-4), gcc-8:i386 (8.3.0-26, 8.3.0-27), gcc-9:i386 (9.2.1-25, 9.2.1-28), libglib2.0-bin:i386 (2.62.4-1+b1, 2.62.4-2), perl-openssl-defaults:i386 (3, 4), libpam-systemd:i386 (244.1-2, 244.1-3), libglib2.0-dev:i386 (2.62.4-1+b1, 2.62.4-2), systemd:i386 (244.1-2, 244.1-3), libgomp1:i386 (9.2.1-25, 10-20200202-1), libgspell-1-2:i386 (1.8.2-2, 1.8.3-1), libsdl2-2.0-0:i386 (2.0.10+dfsg1-1, 2.0.10+dfsg1-2), ruby-gdk-pixbuf2:i386 (3.4.1-1, 3.4.1-2), binutils-common:i386 (2.33.90.20200122-2, 2.34-2), libglib2.0-data:i386 (2.62.4-1, 2.62.4-2), python3-gi:i386 (3.34.0-5, 3.34.0-6), binutils-i686-linux-gnu:i386 (2.33.90.20200122-2, 2.34-2), libbinutils:i386 (2.33.90.20200122-2, 2.34-2), cpio:i386 (2.13+dfsg-1, 2.13+dfsg-2), python-gi-cairo:i386 (3.34.0-5, 3.34.0-6), libatomic1:i386 (9.2.1-25, 10-20200202-1), libcc1-0:i386 (9.2.1-25, 10-20200202-1), libstdc++6:i386 (9.2.1-25, 10-20200202-1), libglib2.0-0:i386 (2.62.4-1+b1, 2.62.4-2), lightdm:i386 (1.26.0-6+b1, 1.26.0-7), ruby-gio2:i386 (3.4.1-1, 3.4.1-2), ruby-glib2:i386 (3.4.1-1, 3.4.1-2), liblightdm-gobject-1-0:i386 (1.26.0-6+b1, 1.26.0-7), libctf0:i386 (2.33.90.20200122-2, 2.34-2), libgcc-9-dev:i386 (9.2.1-25, 9.2.1-28), xterm:i386 (352-1, 353-1)
End-Date: 2020-02-04  14:51:24

Offline tranquil

  • User
  • Posts: 75
Re: Careful Upgrading - cpp-9 Upgrade Removes libgcc-s1:i386
« Reply #3 on: 2020/02/09, 09:01:31 »
I think it's pretty clear from my OP that I caused the mess myself.

Why do you think I was working with dpkg? The dpkg statements resulted when I cherry picked the cpp-9 upgrade. I also don't use Siduction. I use Debian Unstable. I come here for knowledge and help in using Debian Unstable.

For the record, using dpkg can be useful for downgrading a package(s) using a deb, even under Debian Unstable or Siduction.

Code: [Select]
sudo dpkg -i <package.deb>
Dual-booting Debian Stable and Unstable with Openbox window manager and Tint2 panel.

Offline unklarer

  • User
  • Posts: 493
Re: Careful Upgrading - cpp-9 Upgrade Removes libgcc-s1:i386
« Reply #4 on: 2020/02/09, 11:52:30 »
Quote from: tranquil
I also don't use Siduction. I use Debian Unstable.

Sorry, I hadn't thought of such nonsense...

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.795
    • g-com.eu
Re: Careful Upgrading - cpp-9 Upgrade Removes libgcc-s1:i386
« Reply #5 on: 2020/02/09, 11:56:15 »
@tranquil - dpkg is the last resort, like GOTO 99 (Nikolas Wirth), a brothel (in RL) and so on.

In other words: It's the plumbing part of apt, so one should avoid it if possible. But if there are no better bets left - just use it and make sure that apt is happy afterwards.
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline tranquil

  • User
  • Posts: 75
Re: Careful Upgrading - cpp-9 Upgrade Removes libgcc-s1:i386
« Reply #6 on: 2020/02/10, 08:09:20 »
Just performed a full-upgrade and things are fine now.
Dual-booting Debian Stable and Unstable with Openbox window manager and Tint2 panel.