seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/12/01, 07:22:55


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: libpango1.0-0 is going to be removed  (Read 778 times)

0 Members and 1 Guest are viewing this topic.

Offline hendrikL

  • User
  • Posts: 450
libpango1.0-0 is going to be removed
« on: 2020/04/03, 09:30:51 »
libpango1.0-0 will be removed on a full-upgrade/dist-upgrade

Be careful if you need it!

Reading the bug report

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=954217#10

It will never come back, but some applications still depends on it as you can read.

I my case it was a third party app, anydesk.

I filled a bug report upstream anydesk, because of ...

I managed to reinstall it by first installing libpango-1.0-0 (it was already installed)
and then using dpkg, not "apt install ./<app>",

 dpkg -i --ignore-depends=libpango1.0-0 anydesk_5.5.4-1_amd64.deb, installation went fine  8), but if it works correctly?

Time will tell.

edit: don't try this at home, you will get a bit trouble.
Now apt is complaining about missing libpango1.0-0 ;)

So before i want to do something with apt I have to "apt -f install", this removes anydesk, after doing my things with apt like full-upgrade I can install anydesk again, 8)

« Last Edit: 2020/04/03, 17:38:57 by hendrikL »

Offline tranquil

  • User
  • Posts: 85
Re: libpango1.0-0 is going to be removed
« Reply #1 on: 2020/04/03, 12:36:09 »
Same here:

Code: [Select]
The following packages were automatically installed and are no longer required:
  libcroco3:i386 libpangox-1.0-0 libre2-5 python-notify python-scandir
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  libhdf5-103 libpango1.0-0 slimjet

In my case, Slimjet browser depends on it, so I cherry picked packages to be upgraded and ended up with the following:

Code: [Select]
The following package was automatically installed and is no longer required:
  libpangox-1.0-0
Use 'sudo apt autoremove' to remove it.
The following packages will be REMOVED:
  libpango1.0-0 slimjet
The following packages have been kept back:
  cpp-9 g++-9 gcc-9 gcc-9-base libasan5 libgcc-9-dev libstdc++-9-dev sshfs
The following packages will be upgraded:
  gir1.2-pango-1.0 libpango-1.0-0 libpango-1.0-0:i386 libpangocairo-1.0-0
  libpangocairo-1.0-0:i386 libpangoft2-1.0-0 libpangoft2-1.0-0:i386
  libpangoxft-1.0-0
8 upgraded, 0 newly installed, 2 to remove and 8 not upgraded.
Need to get 683 kB of archives.
After this operation, 261 MB disk space will be freed.
Dual-booting Debian Stable and Unstable with Openbox window manager and Tint2 panel.