seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/05/31, 01:03:12


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: KDE; Systemsettings crash after entering "Compositor"  (Read 291 times)

0 Members and 1 Guest are viewing this topic.

Offline tomsiduction

  • User
  • Posts: 134
Hello
I am using KDE Plasma 5.17.5 with Frameworks 5.62.0 and QT Version 5.12.5 (64 bit)

In "Systemsettings" I cannot open "Compositor". If I select "Compositor" systemsettings crashes.

Any idea what to do?


Regards

Offline der_bud

  • User
  • Posts: 920
  • member
Re: KDE; Systemsettings crash after entering "Compositor"
« Reply #1 on: 2020/04/08, 10:29:54 »
No idea what to do, but a short "me too" ;). Other settings than those under display work well, but on entering submenu 'compositor' or 'gamma', systemsettings immediately crash.

--

EDIT:  When I go to a terminal and enter
Code: [Select]
kcmshell5 kwincompositingthe compositor settings dialog opens, and changes can be made and applied. (kcmshell5 --list gives an overview of all systemsetting modules).
« Last Edit: 2020/04/08, 10:59:08 by der_bud »
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline tomsiduction

  • User
  • Posts: 134
Re: KDE; Systemsettings crash after entering "Compositor"
« Reply #2 on: 2020/04/08, 19:27:04 »
Hello
Thank you very much for your help

Regards

Offline der_bud

  • User
  • Posts: 920
  • member
Re: KDE; Systemsettings crash after entering "Compositor"
« Reply #3 on: 2020/04/10, 19:56:37 »
Update/Workarounds (kind of) to this:

I found this forum entry about a similar bug, https://www.linuxquestions.org/questions/slackware-14/%5Bktown%5D-selecting-regional-settings-crashes-system-settings-4175671456/ ,and when I do as mentioned there in a terminal
Code: [Select]
$ QT_QUICK_CONTROLS_STYLE=Base systemsettings5Systenmsettings work without error. So seems to be a bug that has to do with themes/styles.

Then there is KDE Bug #419625, https://bugs.kde.org/show_bug.cgi?id=419625#c2 , and there
Code: [Select]
...the problem appears when upgrading kscreen from 5.16.5 to 5.17.0

I've done further investigation and found the following:
in kcm/package/contents/ui/Output.qml:231, when I remove maskSource from OpacityMask item, the problem vanishes (tag v5.17.0)
Problem appears after commit 6309d33
and yes, I commented the said line in the file /usr/share/kpackage/kcms/kcm_kscreen/contents/ui/Output.qml and no more segfaults. At least more people noticed and working at it...
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline hendrikL

  • User
  • Posts: 403
Re: KDE; Systemsettings crash after entering "Compositor"
« Reply #4 on: 2020/05/04, 11:05:38 »
[...]