seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/05/30, 23:56:41


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Probleme mit intel-microcode  (Read 873 times)

0 Members and 1 Guest are viewing this topic.

Offline knorki

  • User
  • Posts: 20
Probleme mit intel-microcode
« on: 2020/04/09, 07:33:26 »
Seit dem letztem update intel-microcode 3.20191115.5 vor ca. 1 Woche gibt es Probleme mit einem 2. Bildschim am Laptop: rote Pixel streuen zeilenweise durchs Bild. Jedoch nur auf dem 2. Monitor.
Die Darstellung auf dem Laptop ist sauber.


inxi -G macht folgende Ausgabe
Graphics:  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics driver: i915 v: kernel
           Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa
           resolution: 1366x768~60Hz, 1920x1200~60Hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 405 (BSW) v: 4.6 Mesa 20.0.4

1920x1200~60Hz ist der zweite Monitor


 
Since the last update intel-microcode 3.20191115.5 about 1 week ago there are problems with a 2nd screen on the laptop: red pixels scatter line by line through the image. But only on the 2nd monitor.
The display on the laptop is ok.

inxi -G produces the following output
Graphics: Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics driver: i915 v: kernel
           Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa
           resolution: 1366x768~60Hz, 1920x1200~60Hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 405 (BSW) v: 4.6 Mesa 20.0.4

1920x1200~60Hz is the second monitor

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.407
Re: Probleme mit intel-microcode
« Reply #1 on: 2020/04/13, 23:51:19 »
Wie kommst du darauf, dass intel-microcode damit zu tun haben könnte? Das ist eher unwahrscheinlich.

Offline knorki

  • User
  • Posts: 20
Re: Probleme mit intel-microcode
« Reply #2 on: 2020/04/14, 06:59:03 »
Nun, weil nach der Installation des Intel-microcode und Neustart das Problem auftrat. Die Bildstörungen auf den 2. Monitor sind auch bis heute noch so, trotz neuem Update mit dem neusten Kernel Linux sidu06 5.6.4-towo.1-siduction-amd64.

Hast Du eine Idee woran es sonst liegen könnte?

Hier noch mal die Ausgabe mit lspci zum Grafik-controller
00:02.0 VGA compatible controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller (rev 21) (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller
   Flags: bus master, fast devsel, latency 0, IRQ 124
   Memory at 90000000 (64-bit, non-prefetchable) [size=16M]
   Memory at 80000000 (64-bit, prefetchable) [size=256M]
   I/O ports at 2000 [size=64]
   Expansion ROM at 000c0000 [virtual] [disabled] [size=128K]
   Capabilities: <access denied>
   Kernel driver in use: i915
   Kernel modules: i915

Offline axt

  • User
  • Posts: 378
    • axebase.net
Re: Probleme mit intel-microcode
« Reply #3 on: 2020/04/14, 19:01:43 »
Quote from: devil
Das ist eher unwahrscheinlich.

Ich glaube das auch nicht, aber vor allem, weil in debian (übergreifend, nicht nur in sid) die derzeit höchste Version 3.20191115.2 vom 2019-12-11 ist. Also auch nichts mit einem solchem Update vor einer Woche (so man nicht gerade eine alte siduction-Version neu installiert und das erste d-u gefahren hat).

Nun kann auch mal eine Version zurückgezogen werden (hier wären's dann aber schon drei), aber irgendwo würde man sie noch finden.

Nun, wenn Du, knorki, glaubst, intel-microcode in bestimmter Version wäre ursächlich, wäre das ja wohl eine leichte Ubung, das Paket testweise zu deinstallieren oder durch eine Vorversion zu ersetzen.

Hast Du dann festgestellt, ui, das ist's gar nicht gewesen, könntest Du bspw. statt i915 modesetting testen, sprich den GPU-Treiber wechseln.

Oder auch mal einen vorherigen Kernel (das wäre gar nicht unwahrscheinlich), 5.5.irgendwas. 5.6(.3) hat towo erst als regulären Kernel in siduction freigegeben gehabt.

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.352
Re: Probleme mit intel-microcode
« Reply #4 on: 2020/04/14, 21:32:09 »
Bitte boote das System mal mit intel_iommu=igfx_off als Bootparameter.
Alternativ kannst Du auch härter mit intel_iommu=off agieren.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline knorki

  • User
  • Posts: 20
Re: Probleme mit intel-microcode
« Reply #5 on: 2020/04/16, 08:07:56 »
Hallo,
Ja, ich denke ihr habt Recht und es nicht der Intel Microcode. Wenn ich es richtig verstehe wirkt ist der Code nur für den intel-Prozessor und nicht für die intel-Grafikeinheit.

Die Versuche mit
intel_iommu=igfx_off als Bootparameter
oder mit intel_iommu=off bringen keinen Erfolg.

Zur Zeit behelfe ich mich in dem ich die Bildschirm Auflösung  des 2. Monitor von 19200x1200 auf 1680x1050 reduziere, dann ist das Bild streifenfrei.

Anlage: Photo von Problem


Offline axt

  • User
  • Posts: 378
    • axebase.net
Re: Probleme mit intel-microcode
« Reply #6 on: 2020/04/17, 06:35:27 »
Quote from: knorki
nur für den intel-Prozessor und nicht für die intel-Grafikeinheit.

Wobei der IGP in Deiner Atom-CPU enthalten ist.

Und damit bleibt Du jetzt stehen?!

Ich wiederhole:

Quote from: axt
statt i915 modesetting testen, sprich den GPU-Treiber wechseln.

Oder auch mal einen vorherigen Kernel (das wäre gar nicht unwahrscheinlich), 5.5.irgendwas. 5.6(.3) hat towo erst als regulären Kernel in siduction freigegeben gehabt.

Code: [Select]
mkdir -p ~/Downloads/5.5.14-towo.1/
cd ~/Downloads/5.5.14-towo.1/
wget https://packages.siduction.org/extra/pool/main/l/linux-siduction/linux-headers-5.5.14-towo.1-siduction-amd64_5.5-14_amd64.deb
wget https://packages.siduction.org/extra/pool/main/l/linux-siduction/linux-image-5.5.14-towo.1-siduction-amd64_5.5-14_amd64.deb
sudo dpkg -i *.deb


Nach Reboot mußt Du natürlich im Grub manuell diesen Kernel wählen, da der 5.6.4er höher ist.


Offline knorki

  • User
  • Posts: 20
Re: Probleme mit intel-microcode
« Reply #7 on: 2020/04/20, 07:33:23 »
Problem gelöst.
Ein simples Kontaktproblem am DVI-Stecker war die Ursache. Ein paarmal Ein-Aus-gesteckt und alles ist gut.
Sorry für die Zeitverschwendung

Offline drooghead

  • User
  • Posts: 20
Re: Probleme mit intel-microcode
« Reply #8 on: 2020/04/20, 09:41:44 »
It's not a waste of time. Even if I don't have problems, when I read these forums I always learn something. I'm also picking up a bit of German.  ;)