seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/05/31, 00:58:53


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: (Solved) Latest kernel headers/dkms won't install  (Read 502 times)

0 Members and 1 Guest are viewing this topic.

Offline vayu

  • User
  • Posts: 214
(Solved) Latest kernel headers/dkms won't install
« on: 2020/05/18, 00:30:05 »
The kernel module I use for my camera to work as a webcam for Zoom isn't working. DKMS usually does it automatically.
The module is video for linux: v4l2loopback
The kernel is: 5.6.13-towo.1-siduction-amd64
Code: [Select]
apt-cache policy linux-headers-5.6.13-towo.1-siduction-amd64linux-headers-5.6.13-towo.1-siduction-amd64:
  Installed: (none)
  Candidate: 5.6-13
Code: [Select]
apt install linux-headers-5.6.13-towo.1-siduction-amd64..The following packages have unmet dependencies:
 cpp-10 : Depends: gcc-10-base (= 10.1.0-1) but 10-20200502-1 is to be installed
 gcc-10 : Depends: gcc-10-base (= 10.1.0-1) but 10-20200502-1 is to be installed
          Depends: libcc1-0 (>= 10.1.0-1) but 10-20200502-1 is to be installed
          Depends: libgcc-10-dev (= 10.1.0-1) but it is not going to be installed
It seems cpp-10 and gcc-10 is interfering with compiling my linux-headers.
Does anyone know what I could do?
« Last Edit: 2020/05/18, 14:27:33 by vayu »

Offline hendrikL

  • User
  • Posts: 403
Re: Latest kernel headers/dkms won't install
« Reply #1 on: 2020/05/18, 07:43:07 »
mh,
Code: [Select]
:~$ inxi -Sxx
System:    Host: hhl Kernel: 5.6.13-towo.1-siduction-amd64 x86_64 bits: 64 compiler: gcc v: 10.1.0 Desktop: KDE Plasma 5.18.5
           tk: Qt 5.12.5 wm: kwin_x11 dm: SDDM Distro: siduction 18.3.0 Patience - kde - (201809172151)
           base: Debian GNU/Linux bullseye/sid

maybe it is worth a try
Code: [Select]
apt install linux-headers-5.6.13-towo.1-siduction-amd64 libgcc-10-dev+

Offline der_bud

  • User
  • Posts: 920
  • member
Re: Latest kernel headers/dkms won't install
« Reply #2 on: 2020/05/18, 12:01:36 »
I wonder where your "...but 10-20200502-1 is to be installed" comes from, because:
Code: [Select]
$ LANG=C apt-cache policy gcc-10-base
gcc-10-base:
  Installed: 10.1.0-1
  Candidate: 10.1.0-1
  Version table:
 *** 10.1.0-1 500
        500 http://ftp.plusline.net/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
Do you have some uncommon repos active?
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline vayu

  • User
  • Posts: 214
Re: Latest kernel headers/dkms won't install
« Reply #3 on: 2020/05/18, 13:41:10 »
It must have something to do with wine or steam. When I manually list all the packages needed to complete gcc-10-base then it proposes to remove a huge list of :i386 packages as well as wine-stable.  I'm not sure what to do. 
« Last Edit: 2020/05/18, 14:25:10 by vayu »

Offline vayu

  • User
  • Posts: 214
Re: Latest kernel headers/dkms won't install
« Reply #4 on: 2020/05/18, 14:26:18 »
Thanks for helping. I resolved it by letting go of wine and steam, now all is good with my kernel modules.  I'll play with steam another time.

Offline dpanter

  • Newbie
  • Posts: 1
Re: (Solved) Latest kernel headers/dkms won't install
« Reply #5 on: 2020/05/18, 17:19:11 »
Removing Steam and Wine is not a satisfactory solution!  :o


I ran into this as well. These packages had different amd64/i386 versions available for upgrade. APT can't figure out what to do in these situations.
Code: [Select]
gcc-10-base gcc-10-base:i386 libatomic1 libatomic1:i386 libgcc-s1 libgcc-s1:i386 libgomp1 libgomp1:i386 libstdc++6 libstdc++6:i386

Looked like this:
Code: [Select]
gcc-10-base/now 10-20200502-1 amd64 [installed,upgradable to: 10.1.0-1]
gcc-10-base/now 10-20200502-1 i386 [installed,upgradable to: 10.1.0-2]


Specifying the correct version solves the issue, kernel headers can then be updated and virtualbox-dkms will build module properly.
Code: [Select]
sudo apt install {gcc-10-base,gcc-10-base:i386,libatomic1,libatomic1:i386,libgcc-s1,libgcc-s1:i386,libgomp1,libgomp1:i386,libstdc++6,libstdc++6:i386}=10.1.0-1

Offline hendrikL

  • User
  • Posts: 403
Re: (Solved) Latest kernel headers/dkms won't install
« Reply #6 on: 2020/05/19, 10:11:30 »
mh, gcc-10=10.1.0-2 on amd64 is waiting to be buildd

https://buildd.debian.org/status/package.php?p=gcc-10&suite=sid

If this happens, then the problem is maybe solved!?

Offline DeepDayze

  • User
  • Posts: 412
Re: (Solved) Latest kernel headers/dkms won't install
« Reply #7 on: 2020/05/20, 03:43:42 »
Quote
If If this happens, then the problem is maybe solved!?
It should be OK hopefully if someone else tested it.

Offline vayu

  • User
  • Posts: 214
Re: (Solved) Latest kernel headers/dkms won't install
« Reply #8 on: 2020/05/22, 02:10:20 »
A couple days later and I've been able to reinstall wine, steam and the :i386 packages that I had to let go in order to compile my dkms modules.