seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/10/29, 05:17:22


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Policykit-1 Update Issue  (Read 725 times)

0 Members and 1 Guest are viewing this topic.


Offline pjnsmb

  • User
  • Posts: 70
Re: Policykit-1 Update Issue
« Reply #1 on: 2020/07/17, 06:13:04 »
@seasons


thanks for the warning
regards
pjnsmb

Offline seasons

  • User
  • Posts: 258
Re: Policykit-1 Update Issue
« Reply #2 on: 2020/07/17, 08:42:29 »
Being somewhat of an impatient masochist, I created this symlink to allow the package to finish installing:
Code: [Select]
/usr/lib/policykit-1/polkit-agent-helper-1 -> /usr/libexec/polkit-agent-helper-1Then I rebooted and found a lot of stuff not working or working really slowly and systemd complaining it couldn't find polkitd. So I made another symlink and rebooted:
Code: [Select]
/usr/lib/policykit-1/polkitd -> /usr/libexec/polkitdOh, and in case it's unclear or something gets lost in translation, I highly recommend against the symlink hacking unless you've already upgraded and have a dysfunctional system.

Offline campitosai

  • User
  • Posts: 6
Re: Policykit-1 Update Issue
« Reply #3 on: 2020/07/17, 10:32:58 »
@seasons,
works fine, thank you

Offline id027102

  • User
  • Posts: 31
Re: Policykit-1 Update Issue
« Reply #4 on: 2020/07/17, 10:34:06 »
Already upgraded , and found :
set S bit for pkexec and polkit-agent-helper-1 solved the problem for me
chmod +s /usr/libexec/polkit-agent-helper-1
[/color][/size]chmod +s /usr/bin/pkexec[/font]

Offline ajavibp

  • User
  • Posts: 102
    • The website of the association where I collaborate.
Re: Policykit-1 Update Issue
« Reply #5 on: 2020/07/17, 10:49:14 »
Thank you very much for your help, you have saved my day.

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.042
    • Land of the Buckeye
Re: Policykit-1 Update Issue
« Reply #6 on: 2020/07/17, 10:54:23 »
@seasons, THANKS for the warning!  I will wait and not d-u today -- hopefully the fix will come soon.
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline seasons

  • User
  • Posts: 258
Re: Policykit-1 Update Issue
« Reply #7 on: 2020/07/17, 11:19:10 »
@seasons, THANKS for the warning!  I will wait and not d-u today -- hopefully the fix will come soon.
You (and others) are welcome. I'm glad you folks saw it before jumping in. The maintainer said he was working on the fix, so it should come later today.

Offline hschn

  • User
  • Posts: 96
Re: Policykit-1 Update Issue
« Reply #8 on: 2020/07/17, 12:54:56 »
Hello,

fix is in

http://incoming.debian.org/debian-buildd buildd-unstable/main amd64 Packages

and should be soon in sid.

No problems here

Greetings
Mögen hätt' ich schon wollen, aber dürfen habe ich mich nicht getraut (Karl Valentin)

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.042
    • Land of the Buckeye
Re: Policykit-1 Update Issue
« Reply #9 on: 2020/07/17, 18:01:23 »
Confirmed -- the fixed package is now available to North American users. I just completed full-upgrade on two systems and had no problems of any kind.
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline ajavibp

  • User
  • Posts: 102
    • The website of the association where I collaborate.
Re: Policykit-1 Update Issue
« Reply #10 on: 2020/07/17, 18:04:15 »
A question, if we who made the links and chmod, do we have to undo them, or is it enough to update?

Offline seasons

  • User
  • Posts: 258
Re: Policykit-1 Update Issue
« Reply #11 on: 2020/07/17, 20:32:14 »
I removed my links when the new version came out. I recommend you do the same. They shouldn't hurt anything, but they're not compliant with Debian Filesystem Hierarchy, and it's the type of thing that can cause strange issues in the future after you've long forgotten about it.
As for chmod/permissions, make sure they look like the following. The fixed version of policykit should take have taken care of it for you:
Code: [Select]
# ls -l /usr/libexec/polkit-agent-helper-1
-rwsr-xr-x 1 root root 19040 Jul 17 04:49 /usr/libexec/polkit-agent-helper-1

Offline ajavibp

  • User
  • Posts: 102
    • The website of the association where I collaborate.
Re: Policykit-1 Update Issue
« Reply #12 on: 2020/07/17, 21:05:01 »
Thank you very much!