seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/10/25, 23:31:05


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [solved] bash misbehaviour  (Read 225 times)

0 Members and 1 Guest are viewing this topic.

Offline jyp

  • User
  • Posts: 86
[solved] bash misbehaviour
« on: 2020/09/08, 19:07:38 »
I recently installed siduction on an iMac (2012,1); everything perfect.
Code: [Select]
System:    Host: mu Kernel: 5.8.7-towo.2-siduction-amd64 x86_64 bits: 64 Desktop: KDE Plasma 5.17.5
           Distro: siduction 18.3.0 Patience - kde - (202007152027)
Machine:   Type: Desktop System: Apple product: iMac12,1 v: 1.0 serial: <superuser/root required>
           Mobo: Apple model: Mac-942B5BF58194151B serial: <superuser/root required> UEFI: Apple
           v: IM121.88Z.0047.B21.1506101610 date: 06/10/15
CPU:       Info: Quad Core model: Intel Core i5-2400S bits: 64 type: MCP L2 cache: 6144 KiB
           Speed: 1596 MHz min/max: 1600/3300 MHz Core speeds (MHz): 1: 1683 2: 1711 3: 1702 4: 1716
Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics driver: i915 v: kernel
           Device-2: Advanced Micro Devices [AMD/ATI] Whistler [Radeon HD 6630M/6650M/6750M/7670M/7690M] driver: radeon
           v: kernel
           Device-3: Apple FaceTime HD Camera (Built-in) type: USB driver: uvcvideo
           Display: x11 server: X.Org 1.20.9 driver: modesetting,radeon FAILED: ati unloaded: fbdev,vesa
           resolution: 1920x1080~60Hz
           OpenGL: renderer: AMD TURKS (DRM 2.50.0 / 5.8.7-towo.2-siduction-amd64 LLVM 10.0.1) v: 3.3 Mesa 20.1.7
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio driver: snd_hda_intel
           Device-2: AMD Turks HDMI Audio [Radeon HD 6500/6600 / 6700M Series] driver: snd_hda_intel
           Sound Server: ALSA v: k5.8.7-towo.2-siduction-amd64
Network:   Device-1: Broadcom and subsidiaries NetXtreme BCM57765 Gigabit Ethernet PCIe driver: tg3
           IF: enp2s0 state: down mac: a8:20:66:05:85:3d
           Device-2: Qualcomm Atheros AR93xx Wireless Network Adapter driver: ath9k
           IF: wlp3s0 state: up mac: 20:c9:d0:32:bf:cc
Drives:    Local Storage: total: 931.51 GiB used: 36.12 GiB (3.9%)
           ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 1TB size: 931.51 GiB
Partition: ID-1: / size: 128.77 GiB used: 9.70 GiB (7.5%) fs: ext4 dev: /dev/sda1
Swap:      Alert: No Swap data was found.
Sensors:   System Temperatures: cpu: 49.0 C mobo: N/A
           Fan Speeds (RPM): cpu: 1198
Info:      Processes: 220 Uptime: 1h 17m Memory: 15.62 GiB used: 2.74 GiB (17.6%) Shell: Bash inxi: 3.1.06


Then after upgrading the system a few days ago, bash started to misbehave:
bash displays a wrong hostname (m:) as user and the proper hostname (mu) as root
jyp@m:~$
root@mu:/home/jyp#
Code: [Select]
jyp@m:~$ cat /etc/hostname
mu
Code: [Select]
jyp@mu:~$ echo $PS1
\[\e]0;\u@\h: \w\a\]${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\

But the worst is that bash inserts a space (see _ ) after a character (cursor in position x) when I trried to type a command:
for instance (trying to type rsync)
jyp@m:~$ r_x
jyp@m:~$ rsync_x
It becomes quite a nightmare!

The alignment is also scrambled
Code: [Select]
jyp@m:~$ df -hT
Filesystem     Type      Size  Used Avail Use% Mounted on
udev           devtmpfs  7.8G     0  7.8G   0% /dev
tmpfs          tmpfs     1.6G  1.6M  1.6G   1% /run
/dev/sda1      ext4      129G  9.8G  113G   8% /
tmpfs          tmpfs     7.9G  202M  7.7G   3% /dev/shm
tmpfs          tmpfs     5.0M  4.0K  5.0M   1% /run/lock
tmpfs          tmpfs     4.0M     0  4.0M   0% /...

These glitches do not occur in tty; everything is normal there.
Finally, another weird behaviour is that after login I get the alternate keyboard layout (ca_fr) instead of the system locale (us)

I tried to google that a lot but came out empty handed as to where to look to correct that; I hope not to be cornered into reinstalling my system!!
Thank you for your attention.


« Last Edit: 2020/09/08, 23:50:42 by jyp »

Offline der_bud

  • User
  • Posts: 948
  • member
Re: bash misbehaviour
« Reply #1 on: 2020/09/08, 21:04:59 »
I've seen that earlier with KDE Konsole, the culprit was faulty set fonts (proportional when fixed was needed). So please check:
1. apt install fonts-hack (if not already installed)
2. KDE Systemsettings -> Fonts -> Fixed Fonts <<-- set to Hack
3. Konsole current profile settings, set font to Hack
http://pb.5id.eu/Zqg4.jpg
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline jyp

  • User
  • Posts: 86
Re: bash misbehaviour
« Reply #2 on: 2020/09/08, 23:49:43 »
A thousand thanks
Back to normal except for Yakuake but I suspect it will be ok after a reboot.

I did indeed change fonts in system settings but could not imagine that the problem could come frrom there.
Again, thanks